Aplikační rozhraní systému CallChange: Hlavní stránka

Aplikační rozhraní systému CallChange Dokumentace

Úvod do programování CallChange

Úvod do programování CallChange

Jak funguje CallChange

Základ CallChange tvoří server, který spravuje relace (sessions) jednotlivých komponent systému. Těmto komponentám umožňuje zejména:

  • přihlásit a odhlásit se od systému,
  • odesílat a přijímat zprávy od ostatních komponent,
  • získat informace o konfiguraci,
  • přístup do databáze,
  • přístup do sdíleného paměťového úložiště.

Server je tvořen těmito komponentami:

Komponenta | Popis
UMS Object Share | Object Share je služba systému Windows, která umožňuje komponentám najít komponenty běžící na jiných počítačích v síti.
UMS Task Manager | Task Manager je služba systému Windows, která se stará o spuštění a běh komponent systému UMS.
CX Server | Základní komponenta systému CallChange. Spravuje klientské sesisons a umožňuje klientům přístup ke konfiguraci, do databáze a do sdíleného paměťového úložiště.
CX Line Monitor | Komunikuje s pobočkovou ústřednou. Získává informace o hovorech a umožňuje je ovládat.
CX Message Routing | Rozesílá nové zprávy vhodným příjemcům.
CX Archiver | Přesouvá staré záznamy z paměťového úložiště do databáze.

Klient může být tvořen těmito komponentami (pouze L1 klient je nutnou komponentou):

Komponenta | Popis
L1 klient | Zajišťuje komunikaci s CX servrem. Poskytuje L1 API pro monitorování a ovládání hovorů.
L2 klient | Jakákoliv aplikace, která využívá L1 API pro monitorování a/nebo ovládání hovorů.
L2CC klient | L2CC je konkrétní příklad L2 klienta. Umožňuje ovládat hovory CX Call Centra.
L3 klient pro L2CC | Klientská aplikace, která spolupracuje s L2CC na zpracování hovorů CX Call Centra.

Programování CallChange

Příklady najdete na instalačním CD v adresáři "/support/Callchange/samples".

Programování L2 aplikací

L2 aplikace je klientská aplikace, která využívá aplikačního rozhraní L1 klienta. L1 klient posílá L2 aplikaci události týkající se hovorů na monitorovaných linkách a L2 aplikace má možnost prostřednictvím L1 API tyto hovory ovládat, případně vytočit hovor nový. L2 aplikace je možné vyvíjet v libovolném programovacím jazyce podporujícím COM.

L2 aplikace musí:

  1. Vytvořit COM objekt pro L1 klienta (CXCLIENT2Lib.level1)
  2. Inicializovat klienta metodou Init.
  3. Připojit se k linkám, které je chce ovládat funkcí ConnectLine.
  4. Zpracovávat události a ovládat hovory prostřednictvím rozhraní L1 API.

Programování L3 aplikací pro Call Centrum

L3 aplikace pro CC je aplikace, která využívá rozhraní L2CC pro ovládání call centrových hovorů. L3CC aplikace je možné vyvíjet v libovolném programovacím jazyce podporujícím COM.

Pokud je L3 aplikace využívána současně s implicitní aplikací, nemusí dělat vůbec nic, nebo může například jen zpracovávat informace. Pokud je L3 aplikace jediným rozhraním pro agenta, musí umožnit minimálně uzavřít CC hovor.

L3CC aplikace musí:

  1. Vytvořit COM objekt pro komunikaci s L2CC (ILevel2CCLib.Core). L2CC aplikace zprostředkovává i přístup k L1 prostřednictvím funkce GetSession.
  2. Zaregistrovat se u L2CC zavoláním metody Init. Součástí registrace je jméno L2 aplikace.
  3. Reagovat na zprávy zasílané L2CC aplikací a ovládat CC hovory prostřednictvím L2CC a L2 API.

Programování VoiceChange modulů pro Call Centrum

CC skript umožňuje přesměrovat hovor do VX. CC hovor je ve VX obsloužen modulem uvedeným v CC skriptu. Jedná se o běžné moduly pro VX ScriptRedirector (viz reference VX skriptu).

Pro zjišťování či nastavování atributů CC hovoru je možné použít modul cc_helper. Následující příklad (viz "VXScripting.CCTest.wsc") přehraje WAV, jehož jméno je uloženo v atributu CC hovoru s názvem VX_WAV, počká na stisk klávesy na telefonu a její hodnotu uloží do atributu CC hovoru s názvem VX_KEY.

WAV = cc_helper.GetCallParam("VX_WAV")
Key = Line.AskChar(WAV, Empty)
cc_helper.SetCallParam "VX_KEY", Key


Aplikační rozhraní systému CallChange: Rejstřík souborů

Aplikační rozhraní systému CallChange Seznam souborů

Zde naleznete seznam všech dokumentovaných souborů se stručnými popisy:
callchange.dcm [zdrojový text]
cx_xml_stub.idl [zdrojový text]
CxClient2.idl [zdrojový text]
cxglueline.idl [zdrojový text]
CxL2CC.idl [zdrojový text]
CXServer2.idl [zdrojový text]
delegate.idl [zdrojový text]
DSAppActivator.idl [zdrojový text]
CXServer2/head/current/DsCssSrv.idl [zdrojový text]
ConSrchSrv/head/current/DsCssSrv.idl [zdrojový text]
CXServer2/head/current/DSMQueue.idl [zdrojový text]
DSMQueue/head/current/DSMQueue.idl [zdrojový text]
DSServMngr.idl [zdrojový text]
CXServer2/head/current/DSShareObj.idl [zdrojový text]
DSShareObj/head/current/DSShareObj.idl [zdrojový text]
fxExtObj.idl [zdrojový text]
PhoneNormalizer.idl [zdrojový text]


Aplikační rozhraní systému CallChange: Seznam tříd

Následující seznam obsahuje především identifikace tříd, ale nacházejí se zde i další netriviální prvky, jako jsou struktury (struct), unie (union) a rozhraní (interface). V seznamu jsou uvedeny jejich stručné popisy:
_Ilevel1Events | Události, které zasílá klient Level1 aplikacím Level2
_ILevel2CCEvents | Události, které zasílá CallCenter klient Level2 aplikacím Level3
IAppActivator | Objekt slouží k aktivování (spouštění, otevírání) aplikací
ICore | Rozhraní pro práci s vyhledávacím serverem
ICXArchive | Rozhraní pro práci s archivem hovorů
ICXGlueLine |
ICXRouter | Rozhraní routeru
ICXServer | Hlavní objekt CallChange
ICXSession | Identifikované připojení k CX serveru
ICXXMLRPCPlugin | Server XML-RPC
IDSInprocQI | Pomocné rozhraní
IDSMQStorage | Jednoduché paměťové úložište
IDSVariantCol | Pomocný objekt - implementace kolekce
IDSXMLRPCClient | Klient XML-RPC
IFxExt | Pomocný objekt - utility
IFxFile | Pomocný objekt - souborové funkce
Ilevel1 | Rozhraní pro práci s L1 calchange klienta
ILevel2CC |
IPhNormalizer | Rozhraní pro manipulaci s telefonními čísly
IShareObj | Objekt pro sdílení COM objektů v počítačové síti
ISMngr | Main interface of Ums Task Manager
ISysDbConn | Objekt zprostředkující přístup do systémové databáze
SMngr |


Aplikační rozhraní systému CallChange: Dokumentace rozhraní _Ilevel1Events

CXCLIENT2Lib::_Ilevel1Events

Dokumentace rozhraní _Ilevel1Events

Události, které zasílá klient Level1 aplikacím Level2. ...

Seznam všech členů.

Veřejné metody

HRESULT | Busy ([in] BSTR CallID)
Protistrana je zaneprázdněna, nemůže hovor přijmout.
HRESULT | CallCreated (BSTR CallID, BSTR LineID, BSTR Number, BSTR Cause)
První zpráva při každém hovoru - handle hovoru a linky, číslo linky a důvod vytvoření ("line_event" nebo "message").
HRESULT | CallInfo (BSTR CallID, BSTR LocalNumber, BSTR RemoteNumber, BSTR Direction, BSTR State, BSTR OtherParams)
Je poslána vždy, pokud se změní nebo upřesní základní informace o hovoru (volající číslo, volané číslo, směr hovoru, stav hovoru).
HRESULT | Connected ([in] BSTR CallID)
Došlo ke spojení.
HRESULT | Disabled ()
Aplikace L2 je zakázána (z menu L1).
HRESULT | Enabled ()
Aplikace L2 je povolena (z menu L1).
HRESULT | EndCall ([in] BSTR CallID)
Konec hovoru - po EndCall již L2 aplikace nesmí volat žádnou funkci vázanou na hovor.
HRESULT | InComingCall ([in] BSTR CallID)
Příchozí hovor s identifikátorem CallID.
HRESULT | LineError ([in] BSTR CallID,[in] BSTR ErrCode,[in] BSTR OtherParams)
Došlo k chybě při zpracování příkazu.
HRESULT | Notify ([in] BSTR msgType,[in] BSTR msgData)
Předáva level 2 aplikaci notifikační zprávy (NTF_* a RM_*).
HRESULT | OutGoingCall ([in] BSTR CallID)
Odchozí hovor s identifikátorem CallID.
HRESULT | PhoneUp ([in] BSTR CallID)
Zvednutý telefon.
HRESULT | Ringing ([in] BSTR CallID)
Myšleno 'zvoní na druhé straně'.
HRESULT | ServerConnection ([in] BSTR Connected)
Informuje o stavu připojení k CX serveru. Je-li Connected="1", došlo k navázání spojení s CX serverem. Je-li Connected="0", CX server není dostupný.
HRESULT | Terminate ()
Uživatel požádal o ukončení klientské aplikace. Aplikace L2 by měla uložit data a přestat používat rozhraní CX vrstvy 1.

Detailní popis

Události, které zasílá klient Level1 aplikacím Level2.

Definice je uvedena na řádku 180 v souboru CxClient2.idl.

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • CxClient2.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní _ILevel2CCEvents

ILevel2CCLib::_ILevel2CCEvents

Dokumentace rozhraní _ILevel2CCEvents

Události, které zasílá CallCenter klient Level2 aplikacím Level3. ...

Seznam všech členů.

Veřejné metody

HRESULT | ActivateOnCall ([in] BSTR LineName,[in] BSTR callid,[in] BSTR cccall,[in] BSTR Params)
Aktivace aplikace za běhu na daném hovoru.
HRESULT | OnCall ([in] BSTR LineName,[in] BSTR callid,[in] BSTR cccall,[in] BSTR Params)
Nový hovor ke zpracování, všechny další zprávy pro hovor se posílají přes OnMessage.
HRESULT | OnDial ([in] BSTR LineName)
Je třeba vytočit hovor - v aktuální verzi není podporována.
HRESULT | OnMessage ([in] BSTR LineName,[in] BSTR callid,[in] BSTR cccall,[in] BSTR MessageType,[in] BSTR Params)
Zpráva pro daný hovor.
HRESULT | Terminate ()
Požadavek na ukončení klientské aplikace Level3. Aplikace Level3 by měla uložit data a přestat používat rozhraní CallCenter Level2.

Detailní popis

Události, které zasílá CallCenter klient Level2 aplikacím Level3.

Definice je uvedena na řádku 141 v souboru CxL2CC.idl.

Dokumentace k metodám

HRESULT ActivateOnCall | ( | [in] BSTR | LineName,
 |  | [in] BSTR | callid,
 |  | [in] BSTR | cccall,
 |  | [in] BSTR | Params
 | ) |

Aktivace aplikace za běhu na daném hovoru.

Parametry:
LineName | linka
callid | handle (ID) fyzického hovoru
cccall | handle (ID) callcenter hovoru
Params | seznam parametrů oddělených znakem '|'

HRESULT OnCall | ( | [in] BSTR | LineName,
 |  | [in] BSTR | callid,
 |  | [in] BSTR | cccall,
 |  | [in] BSTR | Params
 | ) |

Nový hovor ke zpracování, všechny další zprávy pro hovor se posílají přes OnMessage.

Parametry:
LineName | linka
callid | handle (ID) fyzického hovoru
cccall | handle (ID) callcenter hovoru
Params | seznam parametrů oddělených znakem '|' od CX serveru vztahující se k danému fyzickému hovoru

HRESULT OnDial ( [in] BSTR LineName )

Je třeba vytočit hovor - v aktuální verzi není podporována.

Parametry:
LineName linka

HRESULT OnMessage | ( | [in] BSTR | LineName,
 |  | [in] BSTR | callid,
 |  | [in] BSTR | cccall,
 |  | [in] BSTR | MessageType,
 |  | [in] BSTR | Params
 | ) |

Zpráva pro daný hovor.

Parametry:
LineName | linka
callid | handle (ID) fyzického hovoru
cccall | handle (ID) callcenter hovoru
MessageType | typ zpravy - CS_CONNECTED, CS_IDLE atd.
Params | seznam parametrů oddělených znakem '|' od CX serveru vztahující se k danému fyzickému hovoru

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • CxL2CC.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní IAppActivator

Dokumentace rozhraní IAppActivator

Objekt slouží k aktivování (spouštění, otevírání) aplikací. ...

Seznam všech členů.

Veřejné metody

HRESULT | Activate ([in] BSTR parameters,[in] BSTR envVariables,[out, retval] BSTR *retStat)
Aktivuje aplikaci způsobem dle aktivačních parametrů.
HRESULT | Notify ([in] BSTR event,[in] VARIANT params,[out, retval] BSTR *retStat)
Oznámí aktivované aplikaci změnu stavu hovoru.

Detailní popis

Objekt slouží k aktivování (spouštění, otevírání) aplikací.

Definice je uvedena na řádku 17 v souboru DSAppActivator.idl.

Dokumentace k metodám

HRESULT Activate | ( | [in] BSTR | parameters,
 |  | [in] BSTR | envVariables,
 |  | [out, retval] BSTR * | retStat
 | ) |

Aktivuje aplikaci způsobem dle aktivačních parametrů.

Parametry:
parameters | parametry ve tvaru "parametr1=abc|parametr2=efg..."
envVariables | proměnné prostředí, ve tvaru: "evv1=abc|cid=efg..." kterými budou nahrazeny parametry

HRESULT Notify | ( | [in] BSTR | event,
 |  | [in] VARIANT | params,
 |  | [out, retval] BSTR * | retStat
 | ) |

Oznámí aktivované aplikaci změnu stavu hovoru.

Parametry:
event | Druh události jménem shodný se jmény metod _ILevel2CCEvents
params | Parametry metod rozhraní _ILevel2CCEvents naskládané do pole variantů v opačném pořadí
retStat | Stav vykonání

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • DSAppActivator.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ICore

Dokumentace rozhraní ICore

Rozhraní pro práci s vyhledávacím serverem. ...

Seznam všech členů.

Veřejné metody

HRESULT | GetStorePF ([out, retval] VARIANT *retVal)
Vrátí Public Folders message store entry ID.
HRESULT | GetStorePF ([out, retval] VARIANT *retVal)
Vrátí Public Folders message store entry ID.
HRESULT | Search ([in] BSTR SetName,[in] BSTR NormTelNum,[in] BSTR EntrTelNum,[out, retval] VARIANT *retVal)
HRESULT | Search ([in] BSTR SetName,[in] BSTR NormTelNum,[in] BSTR EntrTelNum,[out, retval] VARIANT *retVal)
HRESULT | SearchEx ([in] BSTR SetName,[in] BSTR NormTelNum,[in] BSTR EntrTelNum,[out, retval] VARIANT *retVal)
HRESULT | SearchEx ([in] BSTR SetName,[in] BSTR NormTelNum,[in] BSTR EntrTelNum,[out, retval] VARIANT *retVal)
HRESULT | SearchSQL ([in] BSTR SetName,[in] BSTR AttrFormula,[in, out] VARIANT *retVal,[in, defaultvalue(1)] long maxcount,[out, retval] long *retCount)
Vyhledá a vrátí pole kontaktů určených výběrovým kriteriem.
HRESULT | SearchSQL ([in] BSTR SetName,[in] BSTR AttrFormula,[out] VARIANT *retVal,[in, defaultvalue(1)] long maxcount,[out, retval] long *retCount)
Vyhledá a vrátí pole kontaktů určených výběrovým kriteriem.

Detailní popis

Rozhraní pro práci s vyhledávacím serverem.

Definice je uvedena na řádku 19 v souboru CXServer2/head/current/DsCssSrv.idl.

Dokumentace k metodám

HRESULT Search | ( | [in] BSTR | SetName,
 |  | [in] BSTR | NormTelNum,
 |  | [in] BSTR | EntrTelNum,
 |  | [out, retval] VARIANT * | retVal
 | ) |

Vyhledá a vrátí entry ID kontaktu podle zadaného telefonního čísla. Prohledávají se tato tel. čísla: PR_BUSINESS_TELEPHONE_NUMBER, PR_BUSINESS2_TELEPHONE_NUMBER, PR_HOME_TELEPHONE_NUMBER, PR_HOME2_TELEPHONE_NUMBER, PR_MOBILE_TELEPHONE_NUMBER, PR_ISDN_NUMBER, PR_ASSISTANT_TELEPHONE_NUMBER, PR_CAR_TELEPHONE_NUMBER, PR_OTHER_TELEPHONE_NUMBER, PR_PRIMARY_TELEPHONE_NUMBER, PR_RADIO_TELEPHONE_NUMBER. V případě neúspěchu vrátí hodnotu "NOT_FOUND". V případě chyby vrátí hodnotu "ERROR".

Parametry:
SetName | Název sady folderu, ve které se má hledat. Chcete-li hledat v globálním adresáři, zadejte hodnotu "GAL". Je možné také zadat libovolnou sadu definovanou v registrech v klíči: HKLM\SOFTWARE\Datasys\UMS\ContactSearch\UserSet
NormTelNum | Telefonní číslo ve znormalizovaném tvaru.
EntrTelNum | Telefonní číslo v původním tvaru.

HRESULT Search | ( | [in] BSTR | SetName,
 |  | [in] BSTR | NormTelNum,
 |  | [in] BSTR | EntrTelNum,
 |  | [out, retval] VARIANT * | retVal
 | ) |

Vyhledá a vrátí entry ID kontaktu podle zadaného telefonního čísla. Prohledávají se tato tel. čísla: PR_BUSINESS_TELEPHONE_NUMBER, PR_BUSINESS2_TELEPHONE_NUMBER, PR_HOME_TELEPHONE_NUMBER, PR_HOME2_TELEPHONE_NUMBER, PR_MOBILE_TELEPHONE_NUMBER, PR_ISDN_NUMBER, PR_ASSISTANT_TELEPHONE_NUMBER, PR_CAR_TELEPHONE_NUMBER, PR_OTHER_TELEPHONE_NUMBER, PR_PRIMARY_TELEPHONE_NUMBER, PR_RADIO_TELEPHONE_NUMBER. V případě neúspěchu vrátí hodnotu "NOT_FOUND". V případě chyby vrátí hodnotu "ERROR".

Parametry:
SetName | Název sady folderu, ve které se má hledat. Chcete-li hledat v globálním adresáři, zadejte hodnotu "GAL". Je možné také zadat libovolnou sadu definovanou v registrech v klíči: HKLM\SOFTWARE\Datasys\UMS\ContactSearch\UserSet
NormTelNum | Telefonní číslo ve znormalizovaném tvaru.
EntrTelNum | Telefonní číslo v původním tvaru.

HRESULT SearchEx | ( | [in] BSTR | SetName,
 |  | [in] BSTR | NormTelNum,
 |  | [in] BSTR | EntrTelNum,
 |  | [out, retval] VARIANT * | retVal
 | ) |

Vyhledá a vrátí entry ID a jméno kontaktu podle zadaného telefonního čísla. Prohledávají se tato tel. čísla: PR_BUSINESS_TELEPHONE_NUMBER, PR_BUSINESS2_TELEPHONE_NUMBER, PR_HOME_TELEPHONE_NUMBER, PR_HOME2_TELEPHONE_NUMBER, PR_MOBILE_TELEPHONE_NUMBER, PR_ISDN_NUMBER, PR_ASSISTANT_TELEPHONE_NUMBER, PR_CAR_TELEPHONE_NUMBER, PR_OTHER_TELEPHONE_NUMBER, PR_PRIMARY_TELEPHONE_NUMBER, PR_RADIO_TELEPHONE_NUMBER.

Parametry:
SetName | Název sady folderu, ve které se má hledat. Chcete-li hledat v globálním adresáři, zadejte hodnotu "GAL". Je možné také zadat libovolnou sadu definovanou v registrech v klíči: HKLM\SOFTWARE\Datasys\UMS\ContactSearch\UserSet
NormTelNum | Telefonní číslo ve znormalizovaném tvaru.
EntrTelNum | Telefonní číslo v původním tvaru.
retVal | Návratová hodnota je ve tvaru řetězce: par1=val1|par2=val2|par3=val3|... . Entry ID je vráceno jako parametr se jménem EID, jméno jako NAME a stav jako STATUS - v případě úspěchu se STATE = OK.

HRESULT SearchEx | ( | [in] BSTR | SetName,
 |  | [in] BSTR | NormTelNum,
 |  | [in] BSTR | EntrTelNum,
 |  | [out, retval] VARIANT * | retVal
 | ) |

Vyhledá a vrátí entry ID a jméno kontaktu podle zadaného telefonního čísla. Prohledávají se tato tel. čísla: PR_BUSINESS_TELEPHONE_NUMBER, PR_BUSINESS2_TELEPHONE_NUMBER, PR_HOME_TELEPHONE_NUMBER, PR_HOME2_TELEPHONE_NUMBER, PR_MOBILE_TELEPHONE_NUMBER, PR_ISDN_NUMBER, PR_ASSISTANT_TELEPHONE_NUMBER, PR_CAR_TELEPHONE_NUMBER, PR_OTHER_TELEPHONE_NUMBER, PR_PRIMARY_TELEPHONE_NUMBER, PR_RADIO_TELEPHONE_NUMBER.

Parametry:
SetName | Název sady folderu, ve které se má hledat. Chcete-li hledat v globálním adresáři, zadejte hodnotu "GAL". Je možné také zadat libovolnou sadu definovanou v registrech v klíči: HKLM\SOFTWARE\Datasys\UMS\ContactSearch\UserSet
NormTelNum | Telefonní číslo ve znormalizovaném tvaru.
EntrTelNum | Telefonní číslo v původním tvaru.
retVal | Návratová hodnota je ve tvaru řetězce: par1=val1|par2=val2|par3=val3|... . Entry ID je vráceno jako parametr se jménem EID, jméno jako NAME a stav jako STATUS - v případě úspěchu se STATE = OK.

HRESULT SearchSQL | ( | [in] BSTR | SetName,
 |  | [in] BSTR | AttrFormula,
 |  | [in, out] VARIANT * | retVal,
 |  | [in, defaultvalue(1)] long | maxcount,
 |  | [out, retval] long * | retCount
 | ) |

Vyhledá a vrátí pole kontaktů určených výběrovým kriteriem.

Parametry:
SetName | Název sady folderu, ve které se má hledat. Chcete-li hledat v globálním adresáři, zadejte hodnotu "GAL". Je možné také zadat libovolnou sadu definovanou v registrech v klíči: HKLM\SOFTWARE\Datasys\UMS\ContactSearch\UserSet
AttrFormula | Výběrové kriterium (WHERE část SQL dotazu). Ve výrazu lze použít tato standardní pole: EID, NAME (display name), ORIGNUM (původní číslo), NORMNUM (číslo ve znormalizovaném tvaru) a všechny custom properties s podtržítkem před názvem. Příklad: "(NAME='Jan') And (_EMAIL='jan@xy.cz')"
retVal | Pole navrácených kontaktů, každý kontakt je ve tvaru řetězce: par1=val1|par2=val2|par3=val3|... .
maxcount | Omezení počtu navrácených záznamů
retCount | Počet navrácených záznamů

HRESULT SearchSQL | ( | [in] BSTR | SetName,
 |  | [in] BSTR | AttrFormula,
 |  | [out] VARIANT * | retVal,
 |  | [in, defaultvalue(1)] long | maxcount,
 |  | [out, retval] long * | retCount
 | ) |

Vyhledá a vrátí pole kontaktů určených výběrovým kriteriem.

Parametry:
SetName | Název sady folderu, ve které se má hledat. Chcete-li hledat v globálním adresáři, zadejte hodnotu "GAL". Je možné také zadat libovolnou sadu definovanou v registrech v klíči: HKLM\SOFTWARE\Datasys\UMS\ContactSearch\UserSet
AttrFormula | Výběrové kriterium (WHERE část SQL dotazu). Ve výrazu lze použít tato standardní pole: EID, NAME (display name), ORIGNUM (původní číslo), NORMNUM (číslo ve znormalizovaném tvaru) a všechny custom properties s podtržítkem před názvem. Příklad: "(NAME='Jan') And (_EMAIL='jan@xy.cz')"
retVal | Pole navrácených kontaktů, každý kontakt je ve tvaru řetězce: par1=val1|par2=val2|par3=val3|... .
maxcount | Omezení počtu navrácených záznamů
retCount | Počet navrácených záznamů

Dokumentace pro toto rozhraní byla generována z následujících souborů:
  • CXServer2/head/current/DsCssSrv.idl
  • ConSrchSrv/head/current/DsCssSrv.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ICXArchive

Dokumentace rozhraní ICXArchive

Rozhraní pro práci s archivem hovorů. ...

Seznam všech členů.

Veřejné metody

HRESULT | GetArchiveCalls ([in] BSTR lines,[in] BSTR extraItemList,[in] BSTR selection,[in] BSTR orderBy,[in] long rowMax,[in, out] VARIANT *records,[out, retval] BSTR *retStat)
Načte z databáze údaje o proběhlém hovoru.
HRESULT | GetCallEvents ([in] BSTR callID,[in, out] VARIANT *records,[out, retval] BSTR *retstat)
Průběh volání.
HRESULT | StoreArchiveCallAttributes ([in] BSTR callID,[in] BSTR attributeList,[out, retval] BSTR *retStat)
Uložení dodatečné informace k volání.

Detailní popis

Rozhraní pro práci s archivem hovorů.

Definice je uvedena na řádku 23 v souboru CXServer2.idl.

Dokumentace k metodám

HRESULT GetArchiveCalls | ( | [in] BSTR | lines,
 |  | [in] BSTR | extraItemList,
 |  | [in] BSTR | selection,
 |  | [in] BSTR | orderBy,
 |  | [in] long | rowMax,
 |  | [in, out] VARIANT * | records,
 |  | [out, retval] BSTR * | retStat
 | ) |

Načte z databáze údaje o proběhlém hovoru.

Parametry:
lines | Seznam jmen linek, oddělených '|'
extraItemList Seznam jmen dalších (nestandardních) položek, které se mají načíst z provázané tabulky CC_OBJ_ATR.
Položky jsou odděleny znakem '|'
selection Výběrové kriterium (SQL syntaxe) např:
TIM_ACT > '20040602'
orderBy Třídit podle (SQL syntaxe)
rowMax | Maximální počet navrácených záznamů
records | Seznam navrácených záznamů jako pole VARIANTů obsahujících řetězce

HRESULT GetCallEvents | ( | [in] BSTR | callID,
 |  | [in, out] VARIANT * | records,
 |  | [out, retval] BSTR * | retstat
 | ) |

Průběh volání.

Parametry:
callID Identifikátor volání
records Seznam navrácených záznamů jako pole VARIANTů obsahujících řetězce
obsahujících položky:
  • OBJ_ID - identifikátor volání (callID)
  • EV_TIME - čas události
  • EV_TYPE - druh události
  • EV_VAL - hodnota
  • EV_DESCR - popis, nebo další informace

HRESULT StoreArchiveCallAttributes | ( | [in] BSTR | callID,
 |  | [in] BSTR | attributeList,
 |  | [out, retval] BSTR * | retStat
 | ) |

Uložení dodatečné informace k volání.

Parametry:
callID Identifikátor volání
attributeList Seznam polozek-hodnot, ktere maji byt ulozeny do archivni databaze
tyto položky se ukládají do databázové tabulky CC_CALLS:
  • ID
  • LINE
  • CONNECTED
  • DIRECTION
  • REMNUM
  • STATE
  • TIM_ACT
  • TIM_CN
  • TIM_DC
    Ostatní položky (volitelných jmen) se ukládají do tabulky CC_OBJ_ATR, co položka to jeden záznam v databázi

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • CXServer2.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ICXGlueLine

Dokumentace rozhraní ICXGlueLine

Seznam všech členů.

Veřejné metody

HRESULT | CreateNewCall ([in] BSTR lineName,[in, out] VARIANT *id,[out, retval] BSTR *retStat)
Vytvoří nové ID volání.
HRESULT | GetCfgItem ([in] BSTR itemName,[out, retval] VARIANT *itemValue)
Získání konfigurační položky ovladače. Tč. z registry.
HRESULT | GetLineFromStand ([in] BSTR stand,[out, retval] BSTR *line)
Získá lokální jméno linky z kompletního jména linky.
HRESULT | GetLinesConfig ([in, out] VARIANT *linesCfg,[out, retval] BSTR *retStat)
Získání seznamu linek povolených v konfiguraci CX serveru.
HRESULT | GetOperationRequest ([in] long timeout,[in, out] VARIANT *line,[in, out] VARIANT *action,[in, out] VARIANT *attrs,[in, out] VARIANT *data,[out, retval] BSTR *retStat)
Získá další požadavek na operaci na lince z CX serveru.
HRESULT | GetSession ([in, out] VARIANT *session,[out, retval] BSTR *retStat)
Vrací rozhraní ICXSession.
HRESULT | GetStandFromLine ([in] BSTR line,[out, retval] BSTR *stand)
Získá kompletního jméno linky z lokálního jména linky.
HRESULT | Init ([in] BSTR instanceNumber,[out, retval] BSTR *retStat)
Inicializace knihovny. Musí být voláno před voláním ostatních metod.
HRESULT | RegisterLine ([in] BSTR lineName,[in] BSTR enabled,[in] BSTR attStat,[out, retval] BSTR *retStat)
HRESULT | SendLineEvent ([in] BSTR lineName,[in] BSTR driverCallid,[in] BSTR mtype,[in] BSTR params,[out, retval] BSTR *retStat)
Informuje CX server o události na lince.

Detailní popis

Objekt zprostředkovává spojení mezi CX serverem a vlastním ovladačem PBX. Řeší mj. automatické navazování spojení s CX serverem. Pokus o navázání spojení je prováděn v rámci volání všech metod které pro svoji činnost vyžadují spojení s CX serverem. Po navázaní nového spojení je tento stav signalizován ve výstupní hodnotě metody GetOperationRequest(). Pokud ovladač PBX obdrží informaci o nově vzníklém spojení je třeba aby provedl registraci svých linek voláním metody RegisterLine().

Definice je uvedena na řádku 27 v souboru cxglueline.idl.

Dokumentace k metodám

HRESULT CreateNewCall | ( | [in] BSTR | lineName,
 |  | [in, out] VARIANT * | id,
 |  | [out, retval] BSTR * | retStat
 | ) |

Vytvoří nové ID volání.

Parametry:
lineName | jmeno linky (namespace driveru)
id | ID nově vytvořeného volání
retStat Návratový kód
  • "OK" - úspěšné provedení metody
  • "NO_SRV_CONNECTION" -není spojení na server

HRESULT GetLineFromStand | ( | [in] BSTR | stand,
 |  | [out, retval] BSTR * | line
 | ) |

Získá lokální jméno linky z kompletního jména linky.

Parametry:
stand | kompletní jméno linky
line | lokální jméno linky

HRESULT GetLinesConfig | ( | [in, out] VARIANT * | linesCfg,
 |  | [out, retval] BSTR * | retStat
 | ) |

Získání seznamu linek povolených v konfiguraci CX serveru.

Parametry:
linesCfg Pole obsahující pro každou linku řetězec ve tvaru položka1=hodnota1|... obsahující tyto položky:
  • LINE_NAME - jméno linky (pouze lokální část plného jména linky)
  • LINE_NUMBER - číslo přiřazené lince v konfigurační DB
  • LINE_TYPE - typ linky
retStat Návratový kód
  • "OK" - úspěch
  • "NO_SRV_CONNECTION" -není spojení na server

HRESULT GetOperationRequest | ( | [in] long | timeout,
 |  | [in, out] VARIANT * | line,
 |  | [in, out] VARIANT * | action,
 |  | [in, out] VARIANT * | attrs,
 |  | [in, out] VARIANT * | data,
 |  | [out, retval] BSTR * | retStat
 | ) |

Získá další požadavek na operaci na lince z CX serveru.

Parametry:
timeout | timeout v ms
line | jméno linky (pojmenování driveru)
action | typ operace
attrs | atributy zprávy
data | data zprávy
retStat Návratový kód
  • "OK" - úspěšné provedení metody
  • "OK_NEW_SESSION" - úspěšné provedení metody, pro komunikaci s CX se nyní používá nová session
  • "NO_DATA" - žádný požadavek není k dispozici
  • "NO_DATA_NEW_SESSION" - žádný požadavek není k dispozici, pro komunikaci s CX se nyní používá nová session
  • "NO_SRV_CONNECTION" -není spojení na server
  • libovolný jiný text vysvětlující chybu

HRESULT GetSession | ( | [in, out] VARIANT * | session,
 |  | [out, retval] BSTR * | retStat
 | ) |

Vrací rozhraní ICXSession.

Parametry:
session Návratová hodnota
retStat Návratový kód
  • "OK" - úspěšné provedení metody
  • "NO_SRV_CONNECTION" -není spojení na server

HRESULT GetStandFromLine | ( | [in] BSTR | line,
 |  | [out, retval] BSTR * | stand
 | ) |

Získá kompletního jméno linky z lokálního jména linky.

Parametry:
line | lokální jméno linky
stand | kompletní jméno linky

HRESULT Init | ( | [in] BSTR | instanceNumber,
 |  | [out, retval] BSTR * | retStat
 | ) |

Inicializace knihovny. Musí být voláno před voláním ostatních metod.

Parametry:
instanceNumber | Číslo instance ovladače na daném počítači. Slouží pro upřesnění adresace ovladače a určení konfigurace
retStat | Návratový kód "OK" - úspěch

HRESULT RegisterLine | ( | [in] BSTR | lineName,
 |  | [in] BSTR | enabled,
 |  | [in] BSTR | attStat,
 |  | [out, retval] BSTR * | retStat
 | ) |

Registruje linku v CX serveru.
Pokud je ovladač schopen získat seznam linek PBX vlastními prostředky:
Provede registraci všech svých linek. Avšak připojuje (aktivuje) pouze ty linky které jsou přítomny v seznamu získanem voláním GetLinesConfig().

Pokud ovladač není schopen získat seznam linek vlastními prostředky:
Seznam linek získá voláním metody GetLinesConfig().

Parametry:
lineName | Jméno linky
enabled Má být linka povolena? V běžném provozu s povolením linky manipuluje administrátor, nikoliv ovladač linky.
  • 0 NE
  • 1 ANO
  • prázdný řetězec - ponechá původní stav
attStat Úspěšnost připojení linky
  • OK - linka úspěšně připojena
  • ERR - chyba
retStat | Návratový kód "OK" - úspěch

HRESULT SendLineEvent | ( | [in] BSTR | lineName,
 |  | [in] BSTR | driverCallid,
 |  | [in] BSTR | mtype,
 |  | [in] BSTR | params,
 |  | [out, retval] BSTR * | retStat
 | ) |

Informuje CX server o události na lince.

Parametry:
lineName | Jméno linky
driverCallid | Identifikátor hovoru (soukromá řada ve správě driveru)
mtype | Typ zprávy
params | parametry zprávy
retStat Návratový kód
  • "OK" - úspěšné provedení metody
  • "NO_SRV_CONNECTION" -není spojení na server

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • cxglueline.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ICXRouter

Dokumentace rozhraní ICXRouter

Rozhraní routeru. ...

Seznam všech členů.

Veřejné metody

HRESULT | AddNumberToBL ([in] BSTR lname,[in] BSTR phnumber,[in] double expirationDays,[in, defaultvalue("")] BSTR agentID,[in, defaultvalue("")] BSTR description,[out, retval] BSTR *retStat)
Přidá záznam do blacklistu.
HRESULT | CheckNumberInBL ([in] BSTR phoneNum,[in] BSTR listName,[in, out] VARIANT *blStat,[out, retval] BSTR *retStat)
Zjistí, zda je telefonní číslo uloženo v black/white listu.
HRESULT | DeleteNumberFromBL ([in] BSTR phoneNumber,[in] BSTR listName,[out, retval] BSTR *retStat)
Odstraní telefonní číslo ze zeznamu.
HRESULT | GetListBlNames ([in, out] VARIANT *listNames,[out, retval] BSTR *retStat)
Vrátí seznam dostupných blacklistů.

Detailní popis

Rozhraní routeru.

Definice je uvedena na řádku 90 v souboru CXServer2.idl.

Dokumentace k metodám

HRESULT AddNumberToBL | ( | [in] BSTR | lname,
 |  | [in] BSTR | phnumber,
 |  | [in] double | expirationDays,
 |  | [in, defaultvalue("")] BSTR | agentID,
 |  | [in, defaultvalue("")] BSTR | description,
 |  | [out, retval] BSTR * | retStat
 | ) |

Přidá záznam do blacklistu.

Parametry:
lname | Jméno seznamu
phnumber | Telefonní číslo pro přidání
expirationDays | Doba expirace ve dnech. Pro neexpiraci nastavit 0
agentID | ID adenta, který provedl zápis (volitelné)
description | Důvod zápisu (volitelné)

HRESULT CheckNumberInBL | ( | [in] BSTR | phoneNum,
 |  | [in] BSTR | listName,
 |  | [in, out] VARIANT * | blStat,
 |  | [out, retval] BSTR * | retStat
 | ) |

Zjistí, zda je telefonní číslo uloženo v black/white listu.

Parametry:
phoneNum | telefonní číslo
listName | Jméno seznamu
blStat Atributy záznamu v seznamu
  • ID - ID záznamu
  • LNAME - Jméno blacklistu. Defaultně jen "BLACK" a "WHITE".
  • PHNUMBER - Normalizované telefonní číslo
  • TMS_INSERT - Timestamp zápisu
  • TMS_EXPIRY - Timestamp expirace; pokud nemá expirovat, dejte 9.9.9999 00:00
  • AGENT_ID - ID agenta, který zapsal záznam
  • DESCRIPTION - Poznámka - např. důvod zařazení
retStat Návratová hodnota
  • YES byl-li odpovídající záznam nalezen
  • NO nebyl-li odpovídající záznam nalezen
  • Jiný text jako chybové hlášení

HRESULT GetListBlNames | ( | [in, out] VARIANT * | listNames,
 |  | [out, retval] BSTR * | retStat
 | ) |

Vrátí seznam dostupných blacklistů.

Parametry:
listNames Návratová hodnota, seznam jmen seznamů. Je předáno jako safearray obsahující tyto informace:
  • LNAME - Jméno blacklistu.
  • DESCRIPTION - Poznámka - popis seznamu.

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • CXServer2.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ICXServer

Dokumentace rozhraní ICXServer

Hlavní objekt CallChange. ...

Seznam všech členů.

Veřejné metody

HRESULT | Done ()
Je volán jako signál k ukončení, během této metody cxserver zruší všechny vlastněné objekty.
HRESULT | GetSession ([in] BSTR sessID,[out, retval] ICXSession **session)
HRESULT | Init ()
Je volán ihned po vytvoření.
HRESULT | MakeNewSession ([in, defaultvalue("")] BSTR options,[out, retval] ICXSession **session)
Vytvoří novou session. Pro všechny operace s CX Serverem je session nutná.

Detailní popis

Hlavní objekt CallChange.

Je vytvořen v jedné instanci a zveřejněn v DsShareObject pod jménem "CallChangeServer"

Definice je uvedena na řádku 988 v souboru CXServer2.idl.

Dokumentace k metodám

HRESULT GetSession | ( | [in] BSTR | sessID,
 |  | [out, retval] ICXSession ** | session
 | ) |

Vrátí objekt existující session. Funkce je určena zejména pro podporu vlasní funkcionality serveru

HRESULT MakeNewSession | ( | [in, defaultvalue("")] BSTR | options,
 |  | [out, retval] ICXSession ** | session
 | ) |

Vytvoří novou session. Pro všechny operace s CX Serverem je session nutná.

Parametry:
options | rezerva
session | návratová hodnota

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • CXServer2.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ICXSession

Dokumentace rozhraní ICXSession

Identifikované připojení k CX serveru. ...

Seznam všech členů.

Veřejné typy

enum LogLevel {
LOG_UNIVERSE_END = 0, LOG_ERROR = 1, LOG_WARNING = 2, LOG_INFO = 3,
LOG_DEBUG = 4, LOG_TRACE = 5, LOG_DATA = 6, LOG_FETCH = 7
}
Úroveň závažnosti logované události. ...

Veřejné metody

HRESULT | AgentAssignGroup ([in] BSTR groupID,[in, defaultvalue("")] BSTR options,[out, retval] BSTR *retStat)
Přihlášování a připojování agentů do uživatelských skupin.
HRESULT | AgentCheckRight ([in] BSTR role,[in, out] VARIANT *enabled,[out, retval] BSTR *stat)
Kontrola, zda má agent určité oprávnění.
HRESULT | AgentGetApplicationParams ([in] BSTR appName,[in, out] VARIANT *appData,[out, retval] BSTR *retStat)
Získá definici (parametry) agentské aplikace.
HRESULT | AgentGetGroups ([in] BOOL enrol,[in, out] VARIANT *groupInfo,[out, retval] BSTR *retStat)
Vrátí seznam skupin do kterých je agent přihlášen.
HRESULT | AgentGetRequisiteApps ([in, defaultvalue("")] BSTR options,[in, out] VARIANT *appList,[out, retval] BSTR *retStat)
Získá seznam aplikací, které musí agentská session (L2CC) obsluhovat.
HRESULT | AgentLogoff ([out, retval] BSTR *retStat)
Odhlášení agenta call centra ze session.
HRESULT | AgentLogon ([in] BSTR loginName,[in] BSTR password,[in, defaultvalue("")] BSTR options,[in, out] VARIANT *userID,[out, retval] BSTR *retStat)
Přihlášení agenta callcentra.
HRESULT | AgentStoreStatus ([in] BSTR actionCode,[in] BSTR actionSubcode,[out, retval] BSTR *retStat)
HRESULT | AgentStoreStatusEx ([in] BSTR actionCode,[in] BSTR actionSubcode,[in, defaultvalue("")] BSTR agentSession,[out, retval] BSTR *retStat)
HRESULT | AllocID ([in, defaultvalue("")] BSTR specChar,[out, retval] BSTR *newID)
Vytvoří v rámci CallChange unikátní identifikátor, použitelný k obecné identifikaci. Je vytvořeno 64-bitové číslo v textové podobě zleva doplněné nulami.
HRESULT | CheckLicence ([in] long licenceBit,[out, retval] BSTR *retStat)
Kontrola, zda je k dispozici licence určeného typu.
HRESULT | ConnectLine ([in] BSTR lineName,[out, retval] BSTR *retStat)
Připojí linku do aktuální session. Linka může být současně připojena do více session.
HRESULT | CreateNewCall ([in] BSTR lineName,[in, out] VARIANT *callID,[out, retval] BSTR *retStat)
Vytvoření nového volání.
HRESULT | DisconnectLine ([in] BSTR lineName,[out, retval] BSTR *retStat)
Odpojí linku z aktuální session.
HRESULT | Done ()
Tuto metodu je třeba volat při ukončení session.
HRESULT | ExecuteSQL ([in] BSTR sqlCommand,[in] BSTR options,[in] BSTR lockKey,[in, out] VARIANT *numRec,[out, retval] BSTR *retStat)
Vykoná v databázi SQL příkaz.
HRESULT | GetActualLineCalls ([in] BSTR lineName,[in, out] VARIANT *callList,[out, retval] BSTR *retStat)
Podá seznam aktuálních hovorů, které právě na lince probíhají.
HRESULT | GetArchive ([out, retval] ICXArchive **pVal)
Objekt archivu proběhlých volání, interně pracuje s databází.
HRESULT | GetCallEvents ([in] BSTR callID,[in, out] VARIANT *eventList,[out, retval] BSTR *retStat)
Seznam udalostí proběhlých během hovoru.
HRESULT | GetCallState ([in] BSTR callID,[in, out] VARIANT *callAttributes,[out, retval] BSTR *retStat)
Informace o aktuálním stavu hovoru.
HRESULT | GetCallStateEx ([in] BSTR callID,[in] BSTR options,[in, out] VARIANT *callAttributes,[out, retval] BSTR *retStat)
HRESULT | GetConfigItems ([in] BSTR itemNameList,[in, out] VARIANT *resultList,[out, retval] BSTR *retStat)
Získání hodnot z globální konfigurace.
HRESULT | GetCXMessage ([in] long waitTimeout,[in, out] VARIANT *msgAttributes,[in, out] VARIANT *msgData,[out, retval] BSTR *retStat)
Vyzvednutí zprávy z CX serveru.
HRESULT | GetCXMessageEx ([in] long waitTimeout,[in] long flags,[in, defaultvalue("")] BSTR selection,[in, out] VARIANT *msgAttributes,[in, out] VARIANT *msgData,[out, retval] BSTR *retStat)
HRESULT | GetDatabase ([out, retval] ISysDbConn **db)
Vrátí vlastní databázové připojení.
HRESULT | GetDatabaseData ([in] BSTR sqlQuery,[in] long rowMax,[in, out] VARIANT *records,[out, retval] BSTR *retStat)
Čtení údajů z databáze s použitím společného databázového připojení.
HRESULT | GetDeviceCaps ([in] BSTR deviceType,[in] BSTR deviceName,[in, defaultvalue("")] BSTR caps,[in, out] VARIANT *capsList,[out, retval] BSTR *retStat)
Zjištění, jaké služby zařízení poskytujue.
HRESULT | GetLineFeature ([in] BSTR lineName,[in] BSTR feature,[out, retval] BSTR *retStat)
Vyzvednutí vlastností linky.
HRESULT | GetLineInfo ([in] BSTR lineName,[in, out] VARIANT *lineInfo,[out, retval] BSTR *retStat)
Podá informace o lince kromě stavu aktuálních volání.
HRESULT | GetLineList ([out, retval] BSTR *lineList)
Seznam všech linek v CallChange.
HRESULT | GetLocalLines ([out, retval] BSTR *localLines)
Seznam linek které má uživatelská session právo obsluhovat.
HRESULT | GetRouter ([out, retval] ICXRouter **pVal)
rozhraní routeru
HRESULT | GetServerTime ([out, retval] VARIANT *_time)
Jednotný serverový čas ve formě VariantTime (číslo v plovocí čárce, jednomu dni odpovídá 1.0).
HRESULT | GetServerTimeString ([out, retval] BSTR *time)
Jednotný serverový čas ve formě yyyymmddHHMMSSsss.
HRESULT | GetSessionAttributes ([in, out] VARIANT *attributes,[in, defaultvalue("")] BSTR sessionID,[out, retval] BSTR *retStat)
Aktuální informace o typu a stavu session.
HRESULT | GetSessionID ([out, retval] BSTR *retV)
Identifikátor vlastní session.
HRESULT | GetStorage ([out, retval] IDSMQStorage **pVal)
HRESULT | Init ([out, retval] BSTR *sessionID)
HRESULT | Log ([in] long level,[in] BSTR category,[in] BSTR value,[in] BSTR text)
HRESULT | LoginService ([in] BSTR serviceName,[in] BSTR machineName,[out, retval] BSTR *retStat)
Přihlášení systémové služby do session.
HRESULT | LoginUser ([in] BSTR userName,[in] BSTR machineName,[out, retval] BSTR *retStat)
Přihlášení uživatele (agenta) do session. Před voláním této funkce je třeba volat metodu Init(). V rámci jedné session není možné vícenásobné volání této metody.
HRESULT | OperateCall ([in] BSTR parameters,[out, retval] BSTR *retStat)
Manipulace s hovorem. Volba, ukončení hovoru, přesměrování, konferenční funkce atd.
HRESULT | OperateCallEx ([in] BSTR parameters,[in, defaultvalue("")] BSTR queueName,[in, out, defaultvalue("")] VARIANT *requestID,[out, retval] BSTR *retStat)
HRESULT | OperateCallVX ([in] BSTR operateParams,[in] BSTR vxAppName,[in] BSTR vxAction,[in] BSTR vxAppParams,[in, defaultvalue("")] BSTR options,[out, retval] BSTR *retStat)
HRESULT | PostCXMessage ([in] BSTR messageType,[in] BSTR recipients,[in] VARIANT msgData,[in, defaultvalue("")] BSTR options,[out, retval] BSTR *retStat)
Poslání zprávy jednomu nebo několika příjemcům.
HRESULT | RegisterAsOperateChainMember ([in] BSTR msgFilterFormulas,[out, retval] BSTR *retStat)
HRESULT | SetCallState ([in] BSTR callID,[in] BSTR attributes,[in, defaultvalue("")] BSTR options,[out, retval] BSTR *retStat)
Nastavení položky záznamu aktuálního stavu hovoru
.
HRESULT | SetDatabaseData ([in] BSTR tableName,[in] BSTR selCrit,[in] BSTR data,[in] StoreDataOptions options,[in, out] VARIANT *numAffRec,[out, retval] BSTR *retStat)
Zápis údajů (aktualizace) do databáze.
HRESULT | SetLineFeature ([in] BSTR lineName,[in] BSTR operation,[out, retval] BSTR *retStat)
Nastavení vlastností linky.
HRESULT | SetLineInfo ([in] BSTR lineName,[in] BSTR lineInfo,[out, retval] BSTR *retstat)
Nastavení informací linky.
HRESULT | SetSessionAttributes ([in] BSTR attributes,[in, defaultvalue("")] BSTR sessionID,[out, retval] BSTR *retStat)
HRESULT | SimpleLock ([in] BSTR lockName,[in] long waitTimeout,[in] long lockTimeout,[in, out] VARIANT *retStat,[out, retval] BSTR *lockHandle)
Obecný zámek (Mutex) v rozsahu CallChange.
HRESULT | SimpleUnlock ([in] BSTR lockHandle,[out, retval] BSTR *retStat)
Odemčení zamknutého zámku.
HRESULT | StoreEvent ([in] BSTR obj_id,[in] BSTR ev_type,[in] BSTR ev_val,[in] BSTR ev_descr,[out, retval] BSTR *retStat)
HRESULT | SubscribeNotification ([in] BSTR NotifyType,[out, retval] BSTR *retStat)

Detailní popis

Identifikované připojení k CX serveru.

Tento objekt je využíván jak klientskými aplikacemi, tak i drivery linek, a pluginy serveru.

Pokud není u metod uvedeno jinak, tak textová navratová hodnota retStat indikuje úspěšnost provedení operace

  • "OK" - úspěšné provedení metody
  • "NO_DATA" - poŽadované údaje nejsou k dispozici
  • libovolný jiný text vysvětlující chybu

Definice je uvedena na řádku 248 v souboru CXServer2.idl.

Dokumentace k členským výčtům

enum LogLevel

Úroveň závažnosti logované události.

Hodnoty výčtu:
LOG_UNIVERSE_END | nepocitame ze nastane
LOG_ERROR | chyba
LOG_WARNING | varování
LOG_INFO | zakladni informace o behu
LOG_DEBUG | ladící informace
LOG_TRACE | trasovací informace
LOG_DATA | data
LOG_FETCH | emptydata

Definice je uvedena na řádku 251 v souboru CXServer2.idl.

00252                 {
00254                 LOG_UNIVERSE_END=0,
00256                 LOG_ERROR=1,
00258                 LOG_WARNING=2,
00260                 LOG_INFO=3,
00262                 LOG_DEBUG=4,
00264                 LOG_TRACE=5,
00266                 LOG_DATA=6,
00268                 LOG_FETCH=7
00269                 } LogLevel;

Dokumentace k metodám

HRESULT AgentAssignGroup | ( | [in] BSTR | groupID,
 |  | [in, defaultvalue("")] BSTR | options,
 |  | [out, retval] BSTR * | retStat
 | ) |

Přihlášování a připojování agentů do uživatelských skupin.

Parametry:
groupID | Identifikátor skupiny
options Provést přihlášení/odhlášení či připojení/odpojení. např. "ENROL=1|CONNECT=0"
  • ENROL je požadováno přihlášení/odhlášení
    • "0" - odhlášení ze skupiny - promítne se do databáze
    • "1" - přihlášení ke skupině - promítne se do databáze
  • CONNECT je požadováno připojení/odpojení
    • "0" - odpojení ze skupiny - platí pouze pro aktuální session
    • "1" - připojení - platí pouze pro aktuální session
      Příklad "CONNECT=1|ENROL=1" provede změny jak v databázi tak i v aktuální session
retStat | Návratový kód buď "OK", nebo popis chyby

HRESULT AgentCheckRight | ( | [in] BSTR | role,
 |  | [in, out] VARIANT * | enabled,
 |  | [out, retval] BSTR * | stat
 | ) |

Kontrola, zda má agent určité oprávnění.

Parametry:
role Jméno oprávnění:
  • "AGENT"
  • "SUPERAGENT"
  • "AGENTADMIN"
  • "CCADMIN"
  • "STATS"
enabled Návratová hodnota VARIANT_BOOL

HRESULT AgentGetApplicationParams | ( | [in] BSTR | appName,
 |  | [in, out] VARIANT * | appData,
 |  | [out, retval] BSTR * | retStat
 | ) |

Získá definici (parametry) agentské aplikace.

Parametry:
appName | Krátké jméno aplikace
appData Parametry aplikace jako řetězec ve tvaru:
"TYPE=<typ aplikace>|PAR0=<prvni parametr aplikace>|PAR1=<druhý parametr aplikace>...."
Kde TYPE má tento význam:
  • 1 - Příkazový řádek
  • 2 - URL
  • 3 - COM komunikace prostřednictvím GetObject
    Toto je jen prvotní návrh bude potřeba upřesnit-rozšířit
retStat | Návratový kód

HRESULT AgentGetGroups | ( | [in] BOOL | enrol,
 |  | [in, out] VARIANT * | groupInfo,
 |  | [out, retval] BSTR * | retStat
 | ) |

Vrátí seznam skupin do kterých je agent přihlášen.

Parametry:
enrol Volba, jaké skupiny hledat
  • enrol=0 hledat nepřihlášené skupiny
  • enrol=1 hledat přihlášené skupiny
groupInfo | Návratová hodnota - pole záznamů obsahující informace z databázové tabulky CC_USERS (záznamy skupin) doplněné o položku CONNECTED nabývající hodnot "1"/"0".
retStat | Návratový kód buď "OK", nebo popis chyby

HRESULT AgentGetRequisiteApps | ( | [in, defaultvalue("")] BSTR | options,
 |  | [in, out] VARIANT * | appList,
 |  | [out, retval] BSTR * | retStat
 | ) |

Získá seznam aplikací, které musí agentská session (L2CC) obsluhovat.

Parametry:
options | Reservováno pro budoucí užití
appList Seznam aplikací, jako pole obsahující řetězce, které jsou ve tvaru:
"GROUP_ID=<ID ACD skupiny>|NAME=<krátké jméno aplikace>|TITLE=<titulek aplikace>|GROUP_IDENT=<krátké jméno ACD skupiny>|GROUP_DISPLAYNAME=<displayname ACD skupiny>"
retStat | Navratový kód

HRESULT AgentLogon | ( | [in] BSTR | loginName,
 |  | [in] BSTR | password,
 |  | [in, defaultvalue("")] BSTR | options,
 |  | [in, out] VARIANT * | userID,
 |  | [out, retval] BSTR * | retStat
 | ) |

Přihlášení agenta callcentra.

Parametry:
options Možnosti přihlášení jako řetězec tvaru položka=hodnota|položka2=hodnota2....
  • FORCE=1 Umožňuje přihlášení, přestože je agent již přihlášen v jiné session. V tom případě je v původní session agent odhlášen.
  • AGENT_STATE - Stav agenta po přihlášení
    • READY (default) - agent je připraven zpracovávat hovory
    • NOT_READY - agent není připraven zpracovávat hovory
  • AGENT_SUBSTATE - příčina neaktivního stavu agenta
  • AGENT_LINE - jmeno linky, ke které se agent přihlašuje
userID Identifikátor agenta - návratová hodnota
retStat Vrací:
  • "OK" - úspěšné přihlášení
  • "BAD_LOGIN" - neznámé jméno uživatele nebo chybné heslo
  • "ALREADY_LOGGED" - agent je již přihlášen v jiné session
  • "OTHER_SESS_USE_LINE=<identifikátor session> linka ke které se agent přihlašuje je již připojena pro jiného agenta

HRESULT AgentStoreStatus | ( | [in] BSTR | actionCode,
 |  | [in] BSTR | actionSubcode,
 |  | [out, retval] BSTR * | retStat
 | ) |

Informuje systém o aktuálním stavu agenta.
Provádí následující akce:

  • uloží stav do tabulky "s" viz: "s" - Tabulka stavu session
  • pošle notifikační zprávu NTF_AGENT_CHANGED viz: SubscribeNotification()
  • zapíše záznam do CC_OPHISTORY
Parametry:
actionCode Kód prováděníé akce
  • "LOGON" - přihlášení agenta. Je voláno implicitně v metodě AgentLogon()
  • "LOGOFF" - přihlášení agenta. Je voláno implicitně v metodě AgentLogoff()
  • "SLEEP" - agent si dává pauzu
  • "AWAKE" - agent se opět zapojil do procesu
actionSubcode Subkód akce - má smysl u SLEEP (z jakého důvodu si agent dává pauzu)

HRESULT AgentStoreStatusEx | ( | [in] BSTR | actionCode,
 |  | [in] BSTR | actionSubcode,
 |  | [in, defaultvalue("")] BSTR | agentSession,
 |  | [out, retval] BSTR * | retStat
 | ) |

Parametry:
actionCode Kód prováděníé akce
  • "LOGON" - přihlášení agenta. Je voláno implicitně v metodě AgentLogon()
  • "LOGOFF" - přihlášení agenta. Je voláno implicitně v metodě AgentLogoff()
  • "SLEEP" - agent si dává pauzu
  • "AWAKE" - agent se opět zapojil do procesu
actionSubcode | Subkód akce - má smysl u SLEEP (z jakého důvodu si agent dává pauzu)
agentSession | ID agentské session pro kterou má být status uložen

HRESULT CheckLicence | ( | [in] long | licenceBit,
 |  | [out, retval] BSTR * | retStat
 | ) |

Kontrola, zda je k dispozici licence určeného typu.

Parametry:
licenceBit Číslo bitu licenčního klíče
retStat Vrací:
  • OK - licence je platná
  • LIC_NOT_VALID - licence není platná
  • LIC_EXPIRED - licence již expirovala
  • LIC_EXCEED - překročen počet licencí

HRESULT ConnectLine | ( | [in] BSTR | lineName,
 |  | [out, retval] BSTR * | retStat
 | ) |

Připojí linku do aktuální session. Linka může být současně připojena do více session.

Parametry:
lineName jméno linky (nikoliv číslo linky)

HRESULT CreateNewCall | ( | [in] BSTR | lineName,
 |  | [in, out] VARIANT * | callID,
 |  | [out, retval] BSTR * | retStat
 | ) |

Vytvoření nového volání.

Parametry:
lineName | Jméno linky pro volání
callID | Návratová hodnota - ID nového hovoru

HRESULT DisconnectLine | ( | [in] BSTR | lineName,
 |  | [out, retval] BSTR * | retStat
 | ) |

Odpojí linku z aktuální session.

Parametry:
lineName jméno linky (nikoliv číslo linky)

HRESULT ExecuteSQL | ( | [in] BSTR | sqlCommand,
 |  | [in] BSTR | options,
 |  | [in] BSTR | lockKey,
 |  | [in, out] VARIANT * | numRec,
 |  | [out, retval] BSTR * | retStat
 | ) |

Vykoná v databázi SQL příkaz.

Parametry:
sqlCommand | Příkaz v jazyce SQL
options | Reservováno pro budoucí užití
lockKey | Jméno klíče pro exlusivní přístup
numRec | Počet modifikovaných záznamů
retStat | Výsledek operace

HRESULT GetActualLineCalls | ( | [in] BSTR | lineName,
 |  | [in, out] VARIANT * | callList,
 |  | [out, retval] BSTR * | retStat
 | ) |

Podá seznam aktuálních hovorů, které právě na lince probíhají.

Parametry:
lineName | jméno linky (nikoliv číslo linky)
callList | VARIANT obsahující pole řetězců. Každý řetězec odpovídá jednomu na lince právě probíhajícímu hovoru. Obsah řetězců je stejný jako u parametru callAttributes metody GetCallState()

HRESULT GetCallEvents | ( | [in] BSTR | callID,
 |  | [in, out] VARIANT * | eventList,
 |  | [out, retval] BSTR * | retStat
 | ) |

Seznam udalostí proběhlých během hovoru.

Parametry:
callID | ID hovoru
eventList | VARIANT obsahující pole řetězců representujících události. Jejich formát odpovídá parametru eventAttributes metody StoreCallEvent()

HRESULT GetCallState | ( | [in] BSTR | callID,
 |  | [in, out] VARIANT * | callAttributes,
 |  | [out, retval] BSTR * | retStat
 | ) |

Informace o aktuálním stavu hovoru.

Parametry:
callID ID hovoru
callAttributes Seznam položek ve tvaru:
"<jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>...."
Význam položek:

HRESULT GetCallStateEx | ( | [in] BSTR | callID,
 |  | [in] BSTR | options,
 |  | [in, out] VARIANT * | callAttributes,
 |  | [out, retval] BSTR * | retStat
 | ) |

Údaje o hovoru, získané buď z paměťového úložiště nebo z archivu hovoru
Je-li v options povolen přístup do archivu, pak je tato metoda synchonizována zámkem s metodou SetCallState

Parametry:
callID Identifikátor hovoru
options Rozšiřující volby jako seznam parametrů:
  • USE_ARCHIVE=1 - pokud hovor již není v paměťovém úložišti, je hledán v archivu
  • EXTRA_ATTRIBUTTES=0 - z archivu se získávají pouze základní atributy hovoru
callAttributes Získaný seznam položek ve tvaru:
"<jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>...."
Význam položek:
retStat Status operace:
  • OK - data jsou získána z paměťového úložiště
  • NO_DATA - data nenalezena
  • ARCHIVE_DATA - data nalezena v archivu hovorů

HRESULT GetConfigItems | ( | [in] BSTR | itemNameList,
 |  | [in, out] VARIANT * | resultList,
 |  | [out, retval] BSTR * | retStat
 | ) |

Získání hodnot z globální konfigurace.

Parametry:
itemNameList seznam jmen požadovaných hodnot oddělených znakem "|"
resultList textový seznam položek ve tvaru
"<jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>...."
jméno položky může mít tvar "//sect:<sekce konfigurace>" v tom případě jsou vráceny všechny položky příslušné sekce.
Jména položek a hodnoty jsou "escapovány"

HRESULT GetCXMessage | ( | [in] long | waitTimeout,
 |  | [in, out] VARIANT * | msgAttributes,
 |  | [in, out] VARIANT * | msgData,
 |  | [out, retval] BSTR * | retStat
 | ) |

Vyzvednutí zprávy z CX serveru.

Parametry:
waitTimeout Doba čekání ve funkci na zprávu v ms. Je-li:
  • 0 - na zprávu se nečeká
  • 0xffffffff - na zprávu se čeká neomezeně dlouho Pro dlouhotrvající session je vhodné na zprávu čekat neomezeně dlouho ve zvláštním vlákně. Ukončení čekání ve funkci při ukončování session se v takovém případě provede na základě zprávy SM_DONE, která je zaslána v rámci metody Done()
msgAttributes Atributy zprávy jako řetězec.
Obsahuje položky: "m" - Tabulka předávání zpráv
msgData Vlastní data zprávy. Jejich obsah závisí na typu zprávy

HRESULT GetCXMessageEx | ( | [in] long | waitTimeout,
 |  | [in] long | flags,
 |  | [in, defaultvalue("")] BSTR | selection,
 |  | [in, out] VARIANT * | msgAttributes,
 |  | [in, out] VARIANT * | msgData,
 |  | [out, retval] BSTR * | retStat
 | ) |

Parametry:
waitTimeout Doba čekání ve funkci na zprávu v ms. Je-li:
  • 0 - na zprávu se nečeká
  • 0xffffffff - na zprávu se čeká neomezeně dlouho Pro dlouhotrvající session je vhodné na zprávu čekat neomezeně dlouho ve zvláštním vlákně. Ukončení čekání ve funkci při ukončování session se v takovém případě provede na základě zprávy SM_DONE, která je zaslána v rámci metody Done()
flags | Volby IDSMQStorage::DSMQStorageFlags
selection | výběrové kriterium pro paměťové úložiště tabulka "m", není-li zadáno zprávy se odebírají z aktuální session
msgAttributes Atributy zprávy jako řetězec.
Obsahuje položky: "m" - Tabulka předávání zpráv

HRESULT GetDatabaseData | ( | [in] BSTR | sqlQuery,
 |  | [in] long | rowMax,
 |  | [in, out] VARIANT * | records,
 |  | [out, retval] BSTR * | retStat
 | ) |

Čtení údajů z databáze s použitím společného databázového připojení.

Parametry:
sqlQuery | SQL dotaz
rowMax | Maximální počet záznamů, které mají být přečteny.
records Údaje z databáze.
  • pokud je rowMax = 1 pak records obsahuje jeden záznam jako řetězec ve formě
    "<jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>...."
  • pokud je rowMax > 1 pak records obsahuje pole VARIANTů odpovídajících jednotlivým řádkům formátovaných obdobně jako v případě rowMax = 1.

HRESULT GetDeviceCaps | ( | [in] BSTR | deviceType,
 |  | [in] BSTR | deviceName,
 |  | [in, defaultvalue("")] BSTR | caps,
 |  | [in, out] VARIANT * | capsList,
 |  | [out, retval] BSTR * | retStat
 | ) |

Zjištění, jaké služby zařízení poskytujue.

Parametry:
deviceType | Typ zařízení, pro telefonní linku "LINE" Jméno konkrétního zařízení (linky)
deviceName | Seznam požadovaných položek, je-li prázdný metoda vrátí všechny dostupné údaje
caps | Navrácené vlastnosti zařízení jako řetězec <jméno položky>=<hodnota>|....
capsList | Chybový kód

HRESULT GetLineFeature | ( | [in] BSTR | lineName,
 |  | [in] BSTR | feature,
 |  | [out, retval] BSTR * | retStat
 | ) |

Vyzvednutí vlastností linky.

Parametry:
lineName | Jméno linky
feature | Jméno požadované funkce je závislé na příslušné ústředně

HRESULT GetLineInfo | ( | [in] BSTR | lineName,
 |  | [in, out] VARIANT * | lineInfo,
 |  | [out, retval] BSTR * | retStat
 | ) |

Podá informace o lince kromě stavu aktuálních volání.

Parametry:
lineName jméno linky (nikoliv číslo linky)
lineInfo Obdrží řetezec ve tvaru:
"<jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>...."
Význam položek:

HRESULT GetLineList ( [out, retval] BSTR * lineList )

Seznam všech linek v CallChange.

Parametry:
lineList řetězec obsahující seznam všech linek ve formátu:
<jméno linky1>=<číslo linky1>|<jméno linky2>=<číslo linky2>.....

HRESULT GetLocalLines ( [out, retval] BSTR * localLines )

Seznam linek které má uživatelská session právo obsluhovat.

Parametry:
localLines
<jméno linky1>=<číslo linky1>|<jméno linky2>=<číslo linky2>.....

HRESULT GetSessionAttributes | ( | [in, out] VARIANT * | attributes,
 |  | [in, defaultvalue("")] BSTR | sessionID,
 |  | [out, retval] BSTR * | retStat
 | ) |

Aktuální informace o typu a stavu session.

Parametry:
attributes Obdrží řetezec ve tvaru:
"<jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>...."
sessionID ID session

HRESULT GetStorage ( [out, retval] IDSMQStorage ** pVal )

Hlavní datové úložiště CX serveru, volání provedená přes získané rozhraní je zpracováno zprostředkovaně objektem CXSession z důvodu logování a předzpracování.

HRESULT Init ( [out, retval] BSTR * sessionID )

Inicializace session, po jejím zavolání je session zaregistrována v systému. Může přijímat a odesílat zprávy

Parametry:
sessionID Nově přiřazené ID session. ID jsou přidělována z "nekonečné řady čísel"

HRESULT Log | ( | [in] long | level,
 |  | [in] BSTR | category,
 |  | [in] BSTR | value,
 |  | [in] BSTR | text
 | ) |

Zápis do sytémového logu CallChange. Při zápisu je do záznamu doplněn čas a identita session

Parametry:
level | úroveň logované události viz: LogLevel
category | Formalizované jméno události použitelné např. pro filtrování při monitoringu
value | Formalizovaná hodnota, nebo bližší určení nastalé události
text | Textový popis události

HRESULT LoginService | ( | [in] BSTR | serviceName,
 |  | [in] BSTR | machineName,
 |  | [out, retval] BSTR * | retStat
 | ) |

Přihlášení systémové služby do session.

Parametry:
serviceName Jméno služby, která se hlásí.
machineName Windows jméno počítače kde služba běží, preferovaně v doménovém tvaru <doména>\<jméno počítače>.

HRESULT LoginUser | ( | [in] BSTR | userName,
 |  | [in] BSTR | machineName,
 |  | [out, retval] BSTR * | retStat
 | ) |

Přihlášení uživatele (agenta) do session. Před voláním této funkce je třeba volat metodu Init(). V rámci jedné session není možné vícenásobné volání této metody.

Parametry:
userName | Windows uživatelské jméno agenta, preferovaně v doménovém tvaru <doména>\<jméno uživatele>
machineName | Windows jméno klientského počítače, preferovaně v doménovém tvaru <doména>\<jméno počítače>

HRESULT OperateCall | ( | [in] BSTR | parameters,
 |  | [out, retval] BSTR * | retStat
 | ) |

Manipulace s hovorem. Volba, ukončení hovoru, přesměrování, konferenční funkce atd.

Parametry:
parameters Informace o požadované akci ve formě seznamu "<jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>...."
Význam položek:
  • CID - ID hovoru
  • ACTION - požadovaná akce viz: Dokumentace rozhraní ústředny MD110
    • DIAL - volba telefonního čísla
      další požadované položky:
      • NUMBER - číslo volaného
    • TRANSWER - přesměrování hovoru
      další požadované položky:
      • NUMBER - číslo pobočky kam přesměrovat
    • ANSWER - zvednout příchozí hovor
    • HANGUP - zavěsit, ukončit hovor
    • HOLD - přidržet hovor
    • UNHOLD - přidržený hovor aktivovat

HRESULT OperateCallEx | ( | [in] BSTR | parameters,
 |  | [in, defaultvalue("")] BSTR | queueName,
 |  | [in, out, defaultvalue("")] VARIANT * | requestID,
 |  | [out, retval] BSTR * | retStat
 | ) |

Manipulace s hovorem. Volba, ukončení hovoru, přesměrování, konferenční funkce atd. Rozšířená verze metody OperateCall, obsahuje však navíc parametr requestID

Parametry:
parameters | Parametry operace, kterou je t5eba vykonat viz. Události a operace nad CX linkami
queueName | Jméono fronty zpráv která zpracuje požadavek. Není-li uvedeno použije se _CX. Pro "komponenty řetězu" zadejte _CX_CHAIN
requestID | Výstupní parametr. Obsahuje jednoznačný identifikátor požadavku
retStat | Návratový kód

HRESULT OperateCallVX | ( | [in] BSTR | operateParams,
 |  | [in] BSTR | vxAppName,
 |  | [in] BSTR | vxAction,
 |  | [in] BSTR | vxAppParams,
 |  | [in, defaultvalue("")] BSTR | options,
 |  | [out, retval] BSTR * | retStat
 | ) |

Manipulace s hovorem ve spolupráci s voicechange (přesměrování na IVR, zřízení konference s VX linkou..). Funkčnost zahrnuje funkcionalitu metody OperateCall(), s tím že telefonní číslo je, pokud není určeno, přiděleno.
Před provedením vlastní operace s hovorem je skriptu VoiceChange linky na adresu Q:VX_LINE_<číslo_linky> poslána zpráva typu vxAppMessage obsahující parametry:

  • APP_NAME jméno VX aplikace (parametr vxAppName)
  • APP_ARGS parametr vxAppParams rozšířený o tyto položky:
    • CX_CLIENT_SESSION identifikátor CX session, která operaci požaduje (této session je možno posílat notifikace o průběhu VX aplikace)
    • VX_LINE_TRG číslo linky, na kterou byla operace směrována
    • VX_ACTION hodnota parametru vxAction
Parametry:
operateParams | Parametry pro manipulaci s hovorem viz OperateCall()
vxAppName | Jméno VX alikace, která má hovor zpracovat
vxAction | Typ požadované akce např. RUN_APP
vxAppParams | Parametry předané vxAplikaci
options Paramety specifikující vyhledání vhodné VX linky a zacházení s ní.
Možné parametry:
  • VX_LINE - Číslo VX linky (tak jak jej předá VX ovladač) která má přijmout hovor. Pokud je tento parametr uveden, je třeba uvést i parametr NUMBER v operateParms, protože nebude použito automatické cyklické užívání čísel VX linek.
retStat | Návratový kód

HRESULT PostCXMessage | ( | [in] BSTR | messageType,
 |  | [in] BSTR | recipients,
 |  | [in] VARIANT | msgData,
 |  | [in, defaultvalue("")] BSTR | options,
 |  | [out, retval] BSTR * | retStat
 | ) |

Poslání zprávy jednomu nebo několika příjemcům.

Parametry:
messageType | Jméno typu zprávy. viz: Jména zpráv zasílaných v systému
recipients Seznam příjemců zprávy, kde jednotliví přijemci jsou odděleni znakem "|". Pro vyhodnocení příjemce platí tyto pravidla:
  • pokud jméno příjemce je "_CX" je zpráva adresována CallChange ke zpracování
  • pokud jméno příjemce začíná 's' je zpráva adresována session, odpovídajícího ID. Za číselnou částí může následovat oddělovač "." k oddělení části adresy, kterou interpretuje klient (vrstva 1)
  • pokud jméno příjemce začíná:
    • U: - je zpráva adresována uživateli nebo službě daného jména
    • C: - (neimplementovano) je zpráva adresována session, která momentálně zpracovává hovor jehož ID je uvedeno jako pokračování adresy
    • O: - (neimplementovano) je zpráva adresována driveru linky, který momentálně zpracovává hovor jehož ID je uvedeno jako pokračování adresy
    • G: - (neimplementovano) je zpráva adresována skupině příjemců daného jména
msgData | Kontextově závislá data. Není vhodné zprávou posílat rozhraní objektu.
options | Rezerva
retStat Status odeslání:
  • OK - úspěšné odeslání
  • RCP_UNKNOWN: - někteří přijemci nebyli rozpoznáni. Jejich "|" oddělený seznam následuje
  • Nějaký chybový stav

HRESULT RegisterAsOperateChainMember | ( | [in] BSTR | msgFilterFormulas,
 |  | [out, retval] BSTR * | retStat
 | ) |

Session se může zaregistrovat do "řetězu zpracování zpráv". V tom případě sesion zachytí zprávy nakonfigurovaných typů jestě před doručením ovladači linky, nebo v opačném směru zachytí události linky před doručením agentům.

Parametry:
msgFilterFormulas Filtr zachytávání a způsob zpracování zachycených zpráv Formát je tento:
msgFilterFormulas::=escape(msgFilterFormula)[\|escape(msgFilterFormula)]* msgFilterFormula::=escape(formulaName)=escape(singleFilter) singleFilter::=BEHAVIOUR=[MONITOR|ROUTE] \| ATTR_FILTER=escape(simpleFilters) \| DATA_FILTER=escape(simpleFilters) simpleFilters::=[escape(simpleFilter)\|]* simpleFilter::=escape(fieldName)=escape(regExpPattern) fieldName::=<jmeno polozky atributu nebo dat zpravy>

Vyznam BEHAVIOUR: -li MONITOR - pokud zprava vyhovuje zadanému filtru je poslána dané session a následuje nezměněné zpracování dalších členů řetezu -li ROUTE - pokud zprava vyhovuje zadanému filtru je poslána dané session, ta je zodpovědná za další zpracování zprávy
retStat Návratový kód

HRESULT SetCallState | ( | [in] BSTR | callID,
 |  | [in] BSTR | attributes,
 |  | [in, defaultvalue("")] BSTR | options,
 |  | [out, retval] BSTR * | retStat
 | ) |

Nastavení položky záznamu aktuálního stavu hovoru
.

Parametry:
callID ID hovoru
attributes Seznam položek ve tvaru:
"<jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>...."
Význam položek:
options Dodatečné volby ve tvaru <jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>....
  • PENETRATE_ARC=
    • 0 - běžná funkce, data jsou uložena pouze do paměťového úložiště, pokud hovor s odpovídajícím callID existuje
    • 1 - pokud hovor již není v paměťovém úložišti, jsou změny uloženy do archivu hovorů
  • LOCK_RECORD=
    • 0 - běžná funkce
    • 1 - během zápisu je uzamčen zámek prostřenictvím funkce SimpleLock() se jmenem zámku "MODIFY_CALL_STATE:<callID>"

HRESULT SetDatabaseData | ( | [in] BSTR | tableName,
 |  | [in] BSTR | selCrit,
 |  | [in] BSTR | data,
 |  | [in] StoreDataOptions | options,
 |  | [in, out] VARIANT * | numAffRec,
 |  | [out, retval] BSTR * | retStat
 | ) |

Zápis údajů (aktualizace) do databáze.

Parametry:
tableName Jméno databázové tabulky
CC_LINES - seznam telefonních linek
selCrit | Výběrové kriterium podle SQL syntaxe
data Řetězec ve tvaru:
"<jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>...."
options | Možnosti zpracování viz: enum StoreDataOptions
numAffRec | Počet aktualizovaných záznamů

HRESULT SetLineFeature | ( | [in] BSTR | lineName,
 |  | [in] BSTR | operation,
 |  | [out, retval] BSTR * | retStat
 | ) |

Nastavení vlastností linky.

Parametry:
lineName | Jméno linky
operation | Parametry dle dokumentace ustredny

HRESULT SetLineInfo | ( | [in] BSTR | lineName,
 |  | [in] BSTR | lineInfo,
 |  | [out, retval] BSTR * | retstat
 | ) |

Nastavení informací linky.

Parametry:
lineName Jméno linky
lineInfo Řetězec ve tvaru:
"<jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>...."
Význam položek:

HRESULT SetSessionAttributes | ( | [in] BSTR | attributes,
 |  | [in, defaultvalue("")] BSTR | sessionID,
 |  | [out, retval] BSTR * | retStat
 | ) |

Nastavení parametrů session, pro operatorske session například stav operátora
Metoda oznamuje změnu přihlášeným přijemcům prostřednictvím zprávy NTF_SESSION_STATE viz: SubscribeNotification() a "n" - Tabulka přihlášek k notifikacím Jako data zprávy je předán parametr attributes

Parametry:
attributes Sezbnam položek ve tvaru:
"<jmeno položky>=<hodnota>|<jmeno položky>=<hodnota>...."
Doposud jsou známy tyto položky:
  • AGENT_STATE - stav operátora:
    • READY - agent je připraven zpracovávat hovory
    • NOT_READY - agent není připraven zpracovávat hovory
  • AGENT_SUBSTATE - příčina neaktivního stavu agenta
sessionID ID session, pokud není zadáno, nebo je "", tak se použije ID vlastní session

HRESULT SimpleLock | ( | [in] BSTR | lockName,
 |  | [in] long | waitTimeout,
 |  | [in] long | lockTimeout,
 |  | [in, out] VARIANT * | retStat,
 |  | [out, retval] BSTR * | lockHandle
 | ) |

Obecný zámek (Mutex) v rozsahu CallChange.

Parametry:
lockName | jméno zámku
waitTimeout | doba, jak maximálně dlouho čekat na uvolnění již zamčeného zámku v ms
lockTimeout | doba, za jak dlouho má být zámek automaticky odemknut v ms, není-li odemknut explicitně
retStat chybové stavy:
  • OK - úspěšně uzamčeno
  • TIMEOUT - vyprsel timeout
  • FAIL - ostatní chyby
lockHandle handle který je potřebný pro funkci SimpleUnlock()

HRESULT SimpleUnlock | ( | [in] BSTR | lockHandle,
 |  | [out, retval] BSTR * | retStat
 | ) |

Odemčení zamknutého zámku.

Parametry:
lockHandle handle získaný funkcí SimpleLock()

HRESULT StoreEvent | ( | [in] BSTR | obj_id,
 |  | [in] BSTR | ev_type,
 |  | [in] BSTR | ev_val,
 |  | [in] BSTR | ev_descr,
 |  | [out, retval] BSTR * | retStat
 | ) |

Uloží jednotlivý záznam o události týkající se objektu obj_id. Identifikátorem objektu může být:

  • identifikátor volání
  • ID session
  • ID linky
    Čas události do záznamu doplní server během volání.
    viz: "e" - Tabulka událostí
Parametry:
obj_id | Identifikátor objektu, k němuž se událost vztahuje
ev_type | Typ události
ev_val | Nepovinné. Kvantifikace události (např. tel číslo které vytáčíme)
ev_descr | Nepovinné. Textový popis události.

HRESULT SubscribeNotification | ( | [in] BSTR | NotifyType,
 |  | [out, retval] BSTR * | retStat
 | ) |

Přihlášení session k příjmu oznamovacích zpráv.
Tuto funkci je třeba volat požadovanou notifikaci zvlášt. Oznamovací zprávu je možno odeslat pomocí metody PostCxMessage(), kde jako příjemce je uveden "_CX". Aby byla zpráva považována za oznamovaci (server ji distribuoval), je třeba, aby typ odesílané zprávy začínal NTF_

Parametry:
NotifyType | Typ oznámení viz "n" - Tabulka přihlášek k notifikacím
retStat | Návratová hodnota

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • CXServer2.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ICXXMLRPCPlugin

Dokumentace rozhraní ICXXMLRPCPlugin

Server XML-RPC. ...

Seznam všech členů.

Veřejné metody

HRESULT | AddProgID ([in] BSTR ProgID,[in] BSTR options)
Přidá typ COM objektů, které smí být na požádání instancovány.
HRESULT | AddService ([in] BSTR serviceName,[in] IDispatch *service)
Přidá instanci COM objektu pro publikování.
HRESULT | Done ()
Ukončí činnost http serveru.
HRESULT | Init ([in] long port)
Spustí HTTP server.

Detailní popis

Server XML-RPC.

Umožňuje přistupovat k COM objektům prostřednictvím protokolu XML-RPC http://www.xml-rpc.com
Podmínkou je, aby COM objekt poskytoval IDispatch rozhraní včetně typových informací. Tuto podmínku splňuje většina objektů vytvořených v ATL,VisualBasicu a VBS. Jsou podporovány všechny datové typy, které je možno uložit do proměnné typu VARIANT včetně polí a objektů. Textové řetězce jsou v XML kódovány v UTF-8 (kompatibilita s XMLRPC knihovnami pro .NET a PHP).
Objekt se chová jako HTTP server, který sídlí v procesu, který objekt inicializoval. Je vytvořen ve vícevláknoveém apartmentu. Tzn. přístup k objektům, které jsou vytvořeny ve hostitelském procesu nevyžaduje marshaling a je rychlý bez nadbytečného požírání výkonu. Není prováděn žádný druh impersonalizace, server pracuje s oprávněními hostitelského procesu.
Metody publikovaných COM objektů jsou volány ve více vláknech. Pro volání metod se používá pool threadů.

Parametry XMLRPC metod

Jméno funkce | popis funkce | první prametr | druhý parametr | třetí prametr | návratová hodnota
CreateCOMSession | Vytvoří klientskou session pro zástupné COM objekty. Tato funkce musí být klientem volána právě jednou | string - "" | string - jméno, které idetifikuje klienta. Pro vlastní činnost není podstatné, slouží zejména pro ladění a správu běhu serveru. |  | string - identifikátor vytvořené session
FreeCOMSession | Zruší klientskou session a všechny COM objekty v této session vytvořené. | string - "" | string - identifikátor session |  | boolean-úpěšnost operace
GetStaticObject | Vytvoří zástupný COM objekt. | string - "" | string - jméno registrovaného existujícího COM objektu, nebo registrované ProgID COM objektu pro vytvoření | string - identifikátor session | string - identifikátor objektu
FreeCOMObject | Zruší zástupný COM objekt | string - "" | string - identifikátor objektu |  | boolean-úpěšnost operace
HeartBeat | Klient oznamuje serveru, že jeho session je stále živá. Pokud není tato metoda ani metoda COM objektu patřícho session, volána časteji, než jedenkrát za 4min, je session zrušena. | string - "" | string - identifikátor session |  | boolean-úpěšnost operace
GetIDsOfNames | Seznam jmen a DispID metod objektu | string - "" | string - identifikátor objektu |  | array( array(jménametod) ,array(dispid_metod) )
GetDispInfo | Vrátí popis rozhraní objektu včetně typů prametrů a návratové hodnoty | string - "" | string - identifikátor objektu |  | array ( ProgID, jméno_metody, typvolání, typ návratové hodnoty, array(typy parametrů) )
<Jméno metody COM objektu> | Zavolá metodu zástupného COM objektu s předanými parametry. | string - identifikátor objektu | parametry metody COM objektu (není zde omezení na pouze 2 parametry) |  | Do návratové hodnoty XMLRPC funkce je uložena [out, retval] návratová hodnota metody COM objektu a případné [in,out] parametry metody. Pokud metoda vrací pouze jednu hodnotu, je tato hodnota návratovou hodnotou XMLRPC volání. Pokud metoda vrací více hodnot (vystupní parametry a návratová hodnota metody COM objektu), tak je navratová hodnota XMLRPC metody pole, které obsahuje hodnoty vrácené metodou COM objektu. Například parametry metody M podle deklarace: M([in] a, [in,out] b, [in]c,[in,out]d,[out,retval]e) budou navráceny v poli v tomto pořadí: array(e,b,d) Pokud COM objekt vrací jako výsledek operace COM objekt, pak je tento objekt transformován na identifikátor COM objektu. Tento identifikátor je možné používat ve voláních jeho metod.

Definice je uvedena na řádku 34 v souboru cx_xml_stub.idl.

Dokumentace k metodám

HRESULT AddProgID | ( | [in] BSTR | ProgID,
 |  | [in] BSTR | options
 | ) |

Přidá typ COM objektů, které smí být na požádání instancovány.

Parametry:
ProgID | Prog id. Je možno vytvářet jak in-process, tak i out-of process COM objekty
options | Rezerva pro možné budoucí použití

HRESULT AddService | ( | [in] BSTR | serviceName,
 |  | [in] IDispatch * | service
 | ) |

Přidá instanci COM objektu pro publikování.

Parametry:
serviceName | Jméno pod kterým je objekt zpřístupněn
service | Rozhraní objektu

HRESULT Init ( [in] long port )

Spustí HTTP server.

Parametry:
port Port na kterém jsou očekávána spojení

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • cx_xml_stub.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní IDSInprocQI

Dokumentace rozhraní IDSInprocQI

Pomocné rozhraní. ...

Seznam všech členů.

Veřejné metody

HRESULT | InprocQueryInterface ([in] BSTR iidQ,[out, retval] long *inprocItfc)
HRESULT | InprocQueryInterface ([in] BSTR iidQ,[out, retval] long *inprocItfc)

Detailní popis

Pomocné rozhraní.

Vrací fyzickou adresu rozhraní. Lze použít v podobných situacích jako CoCreateFreeThreadedMarshaler k obejití proxy-stub. Použití je v noha případech nebezpečné.

Definice je uvedena na řádku 25 v souboru CXServer2/head/current/DSMQueue.idl.

Dokumentace k metodám

HRESULT InprocQueryInterface | ( | [in] BSTR | iidQ,
 |  | [out, retval] long * | inprocItfc
 | ) |

Parametry:
iidQ | IID of interface as string
inprocItfc | resulting direct pointer

HRESULT InprocQueryInterface | ( | [in] BSTR | iidQ,
 |  | [out, retval] long * | inprocItfc
 | ) |

Parametry:
iidQ | IID of interface as string
inprocItfc | resulting direct pointer

Dokumentace pro toto rozhraní byla generována z následujících souborů:
  • CXServer2/head/current/DSMQueue.idl
  • DSMQueue/head/current/DSMQueue.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní IDSMQStorage

Dokumentace rozhraní IDSMQStorage

Jednoduché paměťové úložište. ...

Seznam všech členů.

Veřejné typy

enum DSMQStorageFlags {
DSMQS_MULTIPLE = 1, DSMQS_PERSISTENT = 2, DSMQS_PUT_FRONT = 4, DSMQS_NOREMOVE = 8,
DSMQS_NODATA = 16, DSMQS_LOCK = 32, DSMQS_ENABLE_NEW = 64, DSMQS_WAIT_50 = 128,
DSMQS_LIFO = 256, DSMQS_DELETETABLE = 512, DSMQS_FLAG_BND
}
Možnosti ukládání datového úložiště. ...
enum DSMQStorageFlags {
DSMQS_MULTIPLE = 1, DSMQS_PERSISTENT = 2, DSMQS_PUT_FRONT = 4, DSMQS_NOREMOVE = 8,
DSMQS_NODATA = 16, DSMQS_LOCK = 32, DSMQS_ENABLE_NEW = 64, DSMQS_WAIT_50 = 128,
DSMQS_LIFO = 256, DSMQS_DELETETABLE = 512, DSMQS_FLAG_BND
}
Možnosti ukládání datového úložiště. ...

Veřejné metody

HRESULT | DeleteRecords ([in] BSTR tableName,[in] BSTR attrFormula,[out, retval] long *retCount)
Smaže záznamy.
HRESULT | DeleteRecords ([in] BSTR tableName,[in] BSTR attrFormula,[out, retval] long *retCount)
Smaže záznamy.
HRESULT | GetLastFlagImplemented ([out, retval] DSMQStorageFlags *flg)
HRESULT | GetLastFlagImplemented ([out, retval] DSMQStorageFlags *flg)
HRESULT | GetNextID ([out, retval] BSTR *retID)
Vytvoří nový unikátní identifikátor.
HRESULT | GetNextID ([out, retval] BSTR *retID)
Vytvoří nový unikátní identifikátor.
HRESULT | GetRecords ([in] BSTR tableName,[in] BSTR attrFormula,[in, out] VARIANT *recordAttr,[in, out] VARIANT *data,[in, defaultvalue(0)] long flags,[in, defaultvalue(0)] long timeout,[in, defaultvalue(1)] long maxcount,[out, retval] long *retCount)
HRESULT | GetRecords ([in] BSTR tableName,[in] BSTR attrFormula,[in, out] VARIANT *recordAttr,[in, out] VARIANT *data,[in, defaultvalue(0)] long flags,[in, defaultvalue(0)] long timeout,[in, defaultvalue(1)] long maxcount,[out, retval] long *retCount)
HRESULT | PutRecords ([in] BSTR tableName,[in] VARIANT recordAttr,[in] VARIANT *data,[in, defaultvalue(0)] long flags,[out, retval] VARIANT *recordID)
HRESULT | PutRecords ([in] BSTR tableName,[in] VARIANT recordAttr,[in] VARIANT *data,[in, defaultvalue(0)] long flags,[out, retval] VARIANT *recordID)
HRESULT | SetAttr ([in] BSTR tableName,[in] BSTR attrFormula,[in] BSTR newAttr,[in, defaultvalue(0)] long flags,[in, optional] VARIANT *data,[out, retval] long *retCount)
Uložení udajů do uložiště.
HRESULT | SetAttr ([in] BSTR tableName,[in] BSTR attrFormula,[in] BSTR newAttr,[in, defaultvalue(0)] long flags,[in, optional] VARIANT *data,[out, retval] long *retCount)
Uložení udajů do uložiště.
HRESULT | SetIDPersist ([in] BSTR regValName)
HRESULT | SetIDPersist ([in] BSTR regValName)
HRESULT | SetWorkDirectory ([in] BSTR fileDir)
Nastavení pracovního adresáře, je potřebné volat pokud bude využíváno persistence záznamů.
HRESULT | SetWorkDirectory ([in] BSTR fileDir)
Nastavení pracovního adresáře, je potřebné volat pokud bude využíváno persistence záznamů.

Detailní popis

Jednoduché paměťové úložište.

Implementovaná rozhraní
  • IDSMQStorage
  • IDSInprocQI
Program ID
DSMQueue.Storage
Hlavní vlastnosti úložistě
Data jsou uložena v operační paměti. Pokud je při založení záznamu použit atribut DSMQS_PERSISTENT a úložiště je konfigurováno pro persistentní provoz, jsou udaje současně ukládány do souborového systému ve formě "co záznam to soubor". CallChange se tato možnost nevyužívá
Záznamy jsou organizovány do tabulek, přičemž tabulky ani sloupce tebulek není třeba explicitně zakládat, vytvoří (doplní) se automaticky při prvním použití.
Jednolivé záznamy obsahují jednak pole nazývaná atributy, podle kterých je možno vyhledávat a dále jedno datové pole, které může obsahovat data jakéhokoliv typu, které lze vložit do proměnné typu VARIANT, například texty, pole, čísla.
Uložiště je navrženo pro vícevláknový provoz. Jeho užitečnou vlastností je, že je možno v operacích, které získávají data z paměťového úložiště, stanovit timeout. Pokud v době zavolání operace odpovídající záznamy nejsou v úložišti přítomny, zařadí se volající vlákno do seznamu žadatelů. Požadavky žadatelů jsou postupně s příchodem odpovídajících dat uspokojovány. Tento mechanismus je využit např. pro posílání zpráv mezi komponenty.
Operace modifikující data jsou atomické, není implementována žádná forma zamykání záznamů.
Každý záznam v úložišti je identifikován jednoznačným identifikátorem ID. Tyto identifikátory jsou automaticky generovány při zakládání záznamu.

Záznamy je možno v datovém úložišti vyhledávat užitím výrazů.
Jako příklad: "NAME>E&NAME<G|INLOVE=Jack"

Jsou podporovány tyto operátory
- "=" test na shodnost (záleží na velikosti písmen)
- "<" lexikografické porovnání
- ">" lexikografické porovnání
- "&" logický součin
- "|" logický součet

Priorita operátorů je následulící (sestupně podle priority)
"=","<",">","&","|"

Poznámka k vyhledávání

Prohledávání je velmi rychlé pro první podvýraz logického součinu (s použitím indexu), další části se vyhodnocují sekvenčeně v množině vybrané prvním podvýrazem.
Pokud je ve vyhledávacích operacích požadován vetší počet záznamů než 1, pak jsou návratové hodnoty (položky attributy a data) navráceny jako pole obsahující proměnné typu VARIANT.
Viz také:
Prohlížeč datového úložiště

Definice je uvedena na řádku 104 v souboru CXServer2/head/current/DSMQueue.idl.

Dokumentace k členským výčtům

enum DSMQStorageFlags

Možnosti ukládání datového úložiště.

Hodnoty výčtu:
DSMQS_MULTIPLE | přenos více řádků najednou
DSMQS_PERSISTENT | uložit záznam trvale
DSMQS_PUT_FRONT | uložit záznam před ostatní záznamy
DSMQS_NOREMOVE | neodstraňovat záznam z tabulky
DSMQS_NODATA | vrátit pouze aributy záznamu, data nevracet
DSMQS_LOCK | neimplementováno
DSMQS_ENABLE_NEW | v metodě SetAttr povolit vytvoření nového záznamu pokud neexistuje vyhovující záznam
DSMQS_WAIT_50 | čekat ješte 50ms před vyzvednutím záznamů po detekci prvního vyhovujícího záznamu. Použití je vhodné při dotazu na více záznamů v situaci, kdy je rychle za sebou vloženo do paměťového uložište více záznamů vyhovujících výběrovému kriteriu. V takovém případě je možné jejich vyzvednutí najednou.
DSMQS_LIFO | při vyhledávání na základě rovnosti vrátí jako první v sadě naposledy uložený záznam
DSMQS_DELETETABLE | před uložením záznamů pomocí PutRecords() nejprve smaže všechny existující záznamy v tabulce

Definice je uvedena na řádku 107 v souboru DSMQueue/head/current/DSMQueue.idl.

00108                 {
00110                 DSMQS_MULTIPLE=1,
00112                 DSMQS_PERSISTENT=2,
00114                 DSMQS_PUT_FRONT=4,
00116                 DSMQS_NOREMOVE=8,
00118                 DSMQS_NODATA=16,
00120                 DSMQS_LOCK=32,
00122                 DSMQS_ENABLE_NEW=64,
00124                 DSMQS_WAIT_50=128,
00126                 DSMQS_LIFO=256,
00128                 DSMQS_DELETETABLE=512,
00129                 DSMQS_FLAG_BND
00130                 } DSMQStorageFlags;

enum DSMQStorageFlags

Možnosti ukládání datového úložiště.

Hodnoty výčtu:
DSMQS_MULTIPLE | přenos více řádků najednou
DSMQS_PERSISTENT | uložit záznam trvale
DSMQS_PUT_FRONT | uložit záznam před ostatní záznamy
DSMQS_NOREMOVE | neodstraňovat záznam z tabulky
DSMQS_NODATA | vrátit pouze aributy záznamu, data nevracet
DSMQS_LOCK | neimplementováno
DSMQS_ENABLE_NEW | v metodě SetAttr povolit vytvoření nového záznamu pokud neexistuje vyhovující záznam
DSMQS_WAIT_50 | čekat ješte 50ms před vyzvednutím záznamů po detekci prvního vyhovujícího záznamu. Použití je vhodné při dotazu na více záznamů v situaci, kdy je rychle za sebou vloženo do paměťového uložište více záznamů vyhovujících výběrovému kriteriu. V takovém případě je možné jejich vyzvednutí najednou.
DSMQS_LIFO | při vyhledávání na základě rovnosti vrátí jako první v sadě naposledy uložený záznam
DSMQS_DELETETABLE | před uložením záznamů pomocí PutRecords() nejprve smaže všechny existující záznamy v tabulce

Definice je uvedena na řádku 107 v souboru CXServer2/head/current/DSMQueue.idl.

00108                 {
00110                 DSMQS_MULTIPLE=1,
00112                 DSMQS_PERSISTENT=2,
00114                 DSMQS_PUT_FRONT=4,
00116                 DSMQS_NOREMOVE=8,
00118                 DSMQS_NODATA=16,
00120                 DSMQS_LOCK=32,
00122                 DSMQS_ENABLE_NEW=64,
00124                 DSMQS_WAIT_50=128,
00126                 DSMQS_LIFO=256,
00128                 DSMQS_DELETETABLE=512,
00129                 DSMQS_FLAG_BND
00130                 } DSMQStorageFlags;

Dokumentace k metodám

HRESULT DeleteRecords | ( | [in] BSTR | tableName,
 |  | [in] BSTR | attrFormula,
 |  | [out, retval] long * | retCount
 | ) |

Smaže záznamy.

Parametry:
tableName | jméno tabulky
attrFormula | výběrové kriterium
retCount | počet smazaných záznamů

HRESULT DeleteRecords | ( | [in] BSTR | tableName,
 |  | [in] BSTR | attrFormula,
 |  | [out, retval] long * | retCount
 | ) |

Smaže záznamy.

Parametry:
tableName | jméno tabulky
attrFormula | výběrové kriterium
retCount | počet smazaných záznamů

HRESULT GetRecords | ( | [in] BSTR | tableName,
 |  | [in] BSTR | attrFormula,
 |  | [in, out] VARIANT * | recordAttr,
 |  | [in, out] VARIANT * | data,
 |  | [in, defaultvalue(0)] long | flags,
 |  | [in, defaultvalue(0)] long | timeout,
 |  | [in, defaultvalue(1)] long | maxcount,
 |  | [out, retval] long * | retCount
 | ) |

Získání záznamů určených výběrovým kriteriem

Parametry:
tableName | jméno tabulky
attrFormula | výběrové kriterium
flags | kombinace DSMQStorageFlags
timeout | čas, jak dlouho čekat na odpovídající záznamy v ms
maxcount | omezení počtu navrácených záznamů
Vracené hodnoty:
recordAttr | atributové položky záznamu
data | datová položka záznamu
retCount | počet navrácených záznamů
Poznámka:
Poznámka k vyhledávání

HRESULT GetRecords | ( | [in] BSTR | tableName,
 |  | [in] BSTR | attrFormula,
 |  | [in, out] VARIANT * | recordAttr,
 |  | [in, out] VARIANT * | data,
 |  | [in, defaultvalue(0)] long | flags,
 |  | [in, defaultvalue(0)] long | timeout,
 |  | [in, defaultvalue(1)] long | maxcount,
 |  | [out, retval] long * | retCount
 | ) |

Získání záznamů určených výběrovým kriteriem

Parametry:
tableName | jméno tabulky
attrFormula | výběrové kriterium
flags | kombinace DSMQStorageFlags
timeout | čas, jak dlouho čekat na odpovídající záznamy v ms
maxcount | omezení počtu navrácených záznamů
Vracené hodnoty:
recordAttr | atributové položky záznamu
data | datová položka záznamu
retCount | počet navrácených záznamů
Poznámka:
Poznámka k vyhledávání

HRESULT PutRecords | ( | [in] BSTR | tableName,
 |  | [in] VARIANT | recordAttr,
 |  | [in] VARIANT * | data,
 |  | [in, defaultvalue(0)] long | flags,
 |  | [out, retval] VARIANT * | recordID
 | ) |

Uložení zaznam(ů) do tabulky

Parametry:
tableName | jméno tabulky do které ukládat
recordAttr atributy (položky) záznamu. Dle těchto položek je možno vyhledávat.
AGE=9|SEX=F|NAME=Lisa Simpson
data | data záznamu. Dle této požky není možno vyhledávat, ale může obsahovat jakýkoliv datový typ, ktreý je možno uložit do proměnné typu VARIANT
flags | kombinace voleb DSMQStorageFlags
Vracené hodnoty:
recordID návratová hodnota, identifikátor uloženého záznamu
Poznámka:
položky recordAttr a data mohou být řetezce uložené ve variantu nebo pole variantů obsahujících řetězce uložené ve variantu

HRESULT PutRecords | ( | [in] BSTR | tableName,
 |  | [in] VARIANT | recordAttr,
 |  | [in] VARIANT * | data,
 |  | [in, defaultvalue(0)] long | flags,
 |  | [out, retval] VARIANT * | recordID
 | ) |

Uložení zaznam(ů) do tabulky

Parametry:
tableName | jméno tabulky do které ukládat
recordAttr atributy (položky) záznamu. Dle těchto položek je možno vyhledávat.
AGE=9|SEX=F|NAME=Lisa Simpson
data | data záznamu. Dle této požky není možno vyhledávat, ale může obsahovat jakýkoliv datový typ, ktreý je možno uložit do proměnné typu VARIANT
flags | kombinace voleb DSMQStorageFlags
Vracené hodnoty:
recordID návratová hodnota, identifikátor uloženého záznamu
Poznámka:
položky recordAttr a data mohou být řetezce uložené ve variantu nebo pole variantů obsahujících řetězce uložené ve variantu

HRESULT SetAttr | ( | [in] BSTR | tableName,
 |  | [in] BSTR | attrFormula,
 |  | [in] BSTR | newAttr,
 |  | [in, defaultvalue(0)] long | flags,
 |  | [in, optional] VARIANT * | data,
 |  | [out, retval] long * | retCount
 | ) |

Uložení udajů do uložiště.

Parametry:
tableName | jméno tabulky
attrFormula | výběrové kriterium
newAttr | ukládané atributy záznamu (indexované položky)
flags | kombinace DSMQStorageFlags
data | volitelná datová položka záznamu
retCount | počet aktualizovaných záznamů

HRESULT SetAttr | ( | [in] BSTR | tableName,
 |  | [in] BSTR | attrFormula,
 |  | [in] BSTR | newAttr,
 |  | [in, defaultvalue(0)] long | flags,
 |  | [in, optional] VARIANT * | data,
 |  | [out, retval] long * | retCount
 | ) |

Uložení udajů do uložiště.

Parametry:
tableName | jméno tabulky
attrFormula | výběrové kriterium
newAttr | ukládané atributy záznamu (indexované položky)
flags | kombinace DSMQStorageFlags
data | volitelná datová položka záznamu
retCount | počet aktualizovaných záznamů

HRESULT SetIDPersist ( [in] BSTR regValName )

Nastaví místo v registry kde bude ukládáno počítadlo ID. Tuto metoduje třeba zavolat pokud je požadováno aby se po znovuspuštění ID neopakovaly v situaci, kdy se nevyužívá persistence záznamů

Parametry:
regValName Kompletní cesta k hodnotě počítadla ID v registry.
Pokud je prázné, alokovaná ID budou vždy po spuštění začínat od začáatku řady

HRESULT SetIDPersist ( [in] BSTR regValName )

Nastaví místo v registry kde bude ukládáno počítadlo ID. Tuto metoduje třeba zavolat pokud je požadováno aby se po znovuspuštění ID neopakovaly v situaci, kdy se nevyužívá persistence záznamů

Parametry:
regValName Kompletní cesta k hodnotě počítadla ID v registry.
Pokud je prázné, alokovaná ID budou vždy po spuštění začínat od začáatku řady

HRESULT SetWorkDirectory ( [in] BSTR fileDir )

Nastavení pracovního adresáře, je potřebné volat pokud bude využíváno persistence záznamů.

Parametry:
fileDir cesta ke složce v systému souborů

HRESULT SetWorkDirectory ( [in] BSTR fileDir )

Nastavení pracovního adresáře, je potřebné volat pokud bude využíváno persistence záznamů.

Parametry:
fileDir cesta ke složce v systému souborů

Dokumentace pro toto rozhraní byla generována z následujících souborů:
  • CXServer2/head/current/DSMQueue.idl
  • DSMQueue/head/current/DSMQueue.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní IDSVariantCol

Dokumentace rozhraní IDSVariantCol

Pomocný objekt - implementace kolekce. ...

Seznam všech členů.

Veřejné metody

HRESULT | _NewEnum ([out, retval] IUnknown **pVal)
HRESULT | Add ([in] BSTR valueName,[in] VARIANT val,[out, retval] long *idx)
HRESULT | AddFromString ([in]BSTR String,[in, defaultvalue("")] BSTR Delimiter,[out, retval] long *idx)
HRESULT | AddParamList ([in] BSTR String)
HRESULT | AsParamList ([out, retval] BSTR *pVal)
HRESULT | AsString ([in, defaultvalue("")] BSTR Delimiter,[in] BSTR newVal)
HRESULT | AsString ([in, defaultvalue("")] BSTR Delimiter,[out, retval] BSTR *pVal)
HRESULT | AutoAdd ([in] BOOL newVal)
HRESULT | AutoAdd ([out, retval] BOOL *pVal)
HRESULT | Clear ()
HRESULT | Count ([in] long size)
HRESULT | Count ([out, retval] long *pVal)
HRESULT | CreateNew ([out, retval] IDSVariantCol **retVal)
HRESULT | Delete ([in] VARIANT Index,[out, retval] long *cnt)
HRESULT | Find ([in] BSTR Key,[out, retval] long *idx)
HRESULT | Item ([in] VARIANT Index,[in] VARIANT val)
HRESULT | Item ([in] VARIANT Index,[out, retval] VARIANT *val)
HRESULT | Key ([in] long Idx,[out, retval] BSTR *Key)
HRESULT | ReadVXIni ([in] BSTR iniFile,[out, retval] BOOL *retVal)
HRESULT | Sort ([in, defaultvalue(0)] BOOL onValue)
HRESULT | uniq ([in] BOOL newVal)
HRESULT | uniq ([out, retval] BOOL *pVal)
HRESULT | WriteVXIni ([in] BSTR iniFile,[out, retval] BOOL *retVal)

Detailní popis

Pomocný objekt - implementace kolekce.

Definice je uvedena na řádku 134 v souboru fxExtObj.idl.

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • fxExtObj.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní IDSXMLRPCClient

Dokumentace rozhraní IDSXMLRPCClient

Klient XML-RPC. ...

Seznam všech členů.

Veřejné metody

HRESULT | CallXMLRPC ([in] BSTR methodName,[in] VARIANT paramArray,[in, out] VARIANT *result,[in, out] VARIANT *errMsg,[out, retval] long *errCode)
Volání funkce obecného XMLRPC serveru.
HRESULT | COMSessionID ([out, retval] BSTR *pVal)
V režimu spolupráce s DSXMLRPC serverem vrátí identifikátor COM session.
HRESULT | CreateCOMSession ([in] BSTR sessionName)
V režimu spolupráce s DSXMLRPC serverem vytvoří klientskou session. Je třeba volat práve jedenkrát.
HRESULT | GetProxyObject ([in] BSTR objectName,[out, retval] IDispatch **obj)
HRESULT | Init ([in] BSTR url,[in] BSTR options,[out, retval] BSTR *retStat)
Nastavení parametrů pro připojení.

Detailní popis

Klient XML-RPC.

Definice je uvedena na řádku 73 v souboru cx_xml_stub.idl.

Dokumentace k metodám

HRESULT CallXMLRPC | ( | [in] BSTR | methodName,
 |  | [in] VARIANT | paramArray,
 |  | [in, out] VARIANT * | result,
 |  | [in, out] VARIANT * | errMsg,
 |  | [out, retval] long * | errCode
 | ) |

Volání funkce obecného XMLRPC serveru.

Parametry:
methodName | Jméno metody
paramArray | Parametry metody uložené ve VARIANT obsahující pole VARIANTů, nebo pouze jeden parametr jako VARIANT
result | Návratová hodnota
errMsg | Popis chyby
errCode | Chybový kód 0-úspěšné vykonání

HRESULT GetProxyObject | ( | [in] BSTR | objectName,
 |  | [out, retval] IDispatch ** | obj
 | ) |

V režimu spolupráce s DSXMLRPC serverem vrátí COM objekt, který slouží jako klientský zástupce serverového COM objektu

Parametry:
objectName | Jméno zveřeněného COM objektu, nebo povolené ProgID
obj | Návratová hodnota - objekt-zástupce

HRESULT Init | ( | [in] BSTR | url,
 |  | [in] BSTR | options,
 |  | [out, retval] BSTR * | retStat
 | ) |

Nastavení parametrů pro připojení.

Parametry:
url | URL XMLRPC serveru
options | Dodatečné parametry implementováno "PROXY=<server>:<port>"
retStat | Návratová hodnota "OK, nebo popis chyby"

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • cx_xml_stub.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní IFxExt

Dokumentace rozhraní IFxExt

Pomocný objekt - utility. ...

Seznam všech členů.

Veřejné metody

HRESULT | CloseWin32Handle ([in] long handle)
HRESULT | CopyFile ([in] BSTR existingFile,[in] BSTR newName,[out, retval] BOOL *result)
HRESULT | CreateConsole ()
HRESULT | CreateGUID ([out, retval] BSTR *retVal)
HRESULT | CreateMutex ([in] BSTR NameOfObject,[out, retval] long *handle)
HRESULT | CreateSemaphore ([in] BSTR NameOfObject,[in, out] VARIANT *handle,[out, retval] BOOL *firstInstance)
HRESULT | CreateTemporaryFilePath ([in] BSTR ext,[out, retval] BSTR *FilePath)
HRESULT | DeleteFile ([in]BSTR file,[out, retval] long *pRet)
HRESULT | GetCurrentProcessId ([out, retval] long *id)
HRESULT | GetItemFromList ([in] BSTR itemName,[in] BSTR itemList,[in, defaultvalue("=")] BSTR ass,[in, defaultvalue("|")] BSTR sep,[in, defaultvalue("\\")] BSTR esc,[out, retval] VARIANT *itemValue)
HRESULT | GetItemNames ([in] BSTR itemList,[in, defaultvalue("=")] BSTR ass,[in, defaultvalue("|")] BSTR sep,[in, defaultvalue("\\")] BSTR esc,[out, retval] VARIANT *itemNames)
HRESULT | GetLocalTime ([out, retval] long *locT)
HRESULT | GetShortPathName ([in] BSTR LongPathName,[out, retval] BSTR *result)
HRESULT | GetTempFileName ([in] BSTR dir,[out, retval] BSTR *fileName)
HRESULT | GetTempPath ([out, retval] BSTR *path)
HRESULT | InitializeSecurity ([in, defaultvalue("")] BSTR params)
HRESULT | Loc ([in] BSTR refStr,[out, optional] VARIANT *accl,[out, retval] BSTR *local)
HRESULT | Localize2 ([in] BSTR refStr,[in] BSTR LocFile,[in, out, optional] VARIANT *accl,[out, retval] BSTR *local)
HRESULT | MergeLists ([in] BSTR firstList,[in] BSTR secondList,[in, defaultvalue("=")] BSTR ass,[in, defaultvalue("|")] BSTR sep,[out, retval] BSTR *newList)
HRESULT | MoveFile ([in] BSTR existingFile,[in] BSTR newName,[out, retval] BOOL *result)
HRESULT | PutItemToList ([in] BSTR itemName,[in] BSTR itemValue,[in] BSTR oldParamList,[in, defaultvalue("=")] BSTR ass,[in, defaultvalue("|")] BSTR sep,[in, defaultvalue("\\")] BSTR esc,[out, retval] BSTR *newList)
HRESULT | ReleaseMutex ([in] long handle,[out, retval] BOOL *result)
HRESULT | RemoveItemFromList ([in] BSTR itemName,[in] BSTR paramList,[in, defaultvalue("=")] BSTR ass,[in, defaultvalue("|")] BSTR sep,[in, defaultvalue("\\")] BSTR esc,[out, retval] BSTR *newList)
HRESULT | RunCmd ([in] BSTR cmdLine, long mode,[out, retval] long *pVal)
HRESULT | SyncFolders ([in] BSTR srcFld,[in] BSTR dstFld,[in] BOOL updateOpenedFiles,[in] BOOL deleteExtraFiles,[in] BOOL doRegistrations,[in] BOOL overwriteNew,[in, out] VARIANT *restartRq,[out, retval] BSTR *errState)
HRESULT | WaitForSingleObject ([in] long handle,[in, defaultvalue(0xffffffff)] long timeout,[in, defaultvalue(0)] BOOL prosessWinMsgs,[out, retval] long *retCode)

Detailní popis

Pomocný objekt - utility.

Definice je uvedena na řádku 21 v souboru fxExtObj.idl.

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • fxExtObj.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní IFxFile

Dokumentace rozhraní IFxFile

Pomocný objekt - souborové funkce. ...

Seznam všech členů.

Veřejné metody

HRESULT | Close ()
HRESULT | Flush ()
HRESULT | fscanf ([in] BSTR format,[out, retval] BSTR *str)
HRESULT | Open ([in] BSTR filename,[in] BSTR flags)
HRESULT | ReadBase64 ([out, retval] BSTR *dataEncoded)
HRESULT | Write ([in]BSTR str,[out, retval] int *cnt)

Detailní popis

Pomocný objekt - souborové funkce.

Definice je uvedena na řádku 116 v souboru fxExtObj.idl.

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • fxExtObj.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní Ilevel1

Dokumentace rozhraní Ilevel1

Rozhraní pro práci s L1 calchange klienta. ...

Seznam všech členů.

Veřejné metody

HRESULT | Answer ([in] BSTR CallID,[out, retval] BSTR *retStat)
Operace Answer.
HRESULT | CloseCallSession ([in] BSTR CallID)
Zavírá call session.
HRESULT | ConnectLine ([in] BSTR lineName,[out, retval] BSTR *retStat)
Připojí linku.
HRESULT | Consultation ([in] BSTR CallID,[in] BSTR number,[in, out] VARIANT *consultCallID,[out, retval] BSTR *retStat)
Podržení aktivního hovoru a vytočení konzultačního hovoru. Slučuje funkce HOLD a DIAL do jedné.
HRESULT | Dial ([in] BSTR LineName,[in] BSTR Number,[out, retval] BSTR *retStat)
Operace vytočení čísla přes danou linku.
HRESULT | DisconnectLine ([in] BSTR lineName,[out, retval] BSTR *retStat)
Odpojí linku.
HRESULT | GetArchive ([out, retval] VARIANT *pVal)
Vrátí rozhraní pro práci s archivem hovorů (ICXArchive).
HRESULT | GetConfigItem ([in] BSTR ItemName,[out, retval] BSTR *Value)
Vrátí hodnotu z globální konfigurace na serveru.
HRESULT | GetContactSearchServer ([out, retval] VARIANT *pVar)
HRESULT | GetLineInfo ([in] BSTR LineName,[out, retval] BSTR *retInfo)
Vrátí informace o lince kromě stavu aktuálních volání.
HRESULT | GetLineState ([in] BSTR LineName,[out, retval] BSTR *State)
Vrátí stav konkrétní linky.
HRESULT | GetLocalLines ([out, retval] VARIANT *LineNames)
Vrátí pole standů linek dostupných přihlášenému uživateli.
HRESULT | GetSession ([out, retval] VARIANT *pVal)
Vrátí rozhraní ICXSession.
HRESULT | GetStandList ([out] VARIANT *LineNames,[out] VARIANT *Numbers)
Vrátí pole standů linek v systému + pole čísel na nich dostupných.
HRESULT | GetStorage ([out, retval] VARIANT *pVal)
Vrátí rozhraní pro práci s hlavním datovým úložištěm (IDSMQStorage).
HRESULT | HangUp ([in] BSTR CallID,[out, retval] BSTR *retStat)
Operace HangUp.
HRESULT | Init ([in] BSTR AppName,[in] long AppLicenseBit)
HRESULT | OperateCall ([in] BSTR CallID,[in] BSTR OperationName,[in] BSTR Params,[out, retval] BSTR *retStat)
Ostatní operace (hold, unhold).
HRESULT | Redirect ([in] BSTR CallID,[in] BSTR Number,[out, retval] BSTR *retStat)
Operace přesměrování hovoru na dané číslo.

Detailní popis

Rozhraní pro práci s L1 calchange klienta.

Definice je uvedena na řádku 19 v souboru CxClient2.idl.

Dokumentace k metodám

HRESULT Answer | ( | [in] BSTR | CallID,
 |  | [out, retval] BSTR * | retStat
 | ) |

Operace Answer.

Parametry:
CallID | Stand hovoru
retStat | Vrátí "OK" v případě úspěchu, jinak chyba

HRESULT CloseCallSession ( [in] BSTR CallID )

Zavírá call session.

Parametry:
CallID Stand hovoru

HRESULT ConnectLine | ( | [in] BSTR | lineName,
 |  | [out, retval] BSTR * | retStat
 | ) |

Připojí linku.

Parametry:
lineName | Stand linky
retStat | Vrátí "OK" v případě úspěchu, jinak chyba

HRESULT Consultation | ( | [in] BSTR | CallID,
 |  | [in] BSTR | number,
 |  | [in, out] VARIANT * | consultCallID,
 |  | [out, retval] BSTR * | retStat
 | ) |

Podržení aktivního hovoru a vytočení konzultačního hovoru. Slučuje funkce HOLD a DIAL do jedné.

Parametry:
CallID | id aktivního spojeného hovoru
number | číslo se kterým je vytvářen konzultační hovor
consultCallID | návratová hodnota - id nově vzniklého konzultačního hovoru
retStat | OK nebo popis chyby

HRESULT Dial | ( | [in] BSTR | LineName,
 |  | [in] BSTR | Number,
 |  | [out, retval] BSTR * | retStat
 | ) |

Operace vytočení čísla přes danou linku.

Parametry:
LineName | Stand linky; je-li rovno "", vytáčí se přes implicitní linku L1
Number | Telefonní číslo
retStat | Vrátí stand hovoru v případě úspěchu, jinak chyba

HRESULT DisconnectLine | ( | [in] BSTR | lineName,
 |  | [out, retval] BSTR * | retStat
 | ) |

Odpojí linku.

Parametry:
lineName | Stand linky
retStat | Vrátí "OK" v případě úspěchu, jinak chyba

HRESULT GetConfigItem | ( | [in] BSTR | ItemName,
 |  | [out, retval] BSTR * | Value
 | ) |

Vrátí hodnotu z globální konfigurace na serveru.

Parametry:
ItemName | Název položky. Zadáme-li hodnotu "L1DialLine", obdržíme stand implicitní linky L1 pro vytáčení
Value | Hodnota položky

HRESULT GetLineInfo | ( | [in] BSTR | LineName,
 |  | [out, retval] BSTR * | retInfo
 | ) |

Vrátí informace o lince kromě stavu aktuálních volání.

Parametry:
LineName Stand linky

HRESULT GetLineState | ( | [in] BSTR | LineName,
 |  | [out, retval] BSTR * | State
 | ) |

Vrátí stav konkrétní linky.

Parametry:
LineName Stand linky

HRESULT GetLocalLines ( [out, retval] VARIANT * LineNames )

Vrátí pole standů linek dostupných přihlášenému uživateli.

Parametry:
LineNames Pole standů linek

HRESULT GetStandList | ( | [out] VARIANT * | LineNames,
 |  | [out] VARIANT * | Numbers
 | ) |

Vrátí pole standů linek v systému + pole čísel na nich dostupných.

Parametry:
LineNames | Pole standů linek
Numbers | Pole čísel linek

HRESULT HangUp | ( | [in] BSTR | CallID,
 |  | [out, retval] BSTR * | retStat
 | ) |

Operace HangUp.

Parametry:
CallID | Stand hovoru
retStat | Vrátí "OK" v případě úspěchu, jinak chyba

HRESULT Init | ( | [in] BSTR | AppName,
 |  | [in] long | AppLicenseBit
 | ) |

Inicializace, zahájení komunikace aplikace s 1. vrstvou cx klienta Metoda se snaží o získání ICXSession, v případě neúspěchu je vrácena chyba. K serveru se přihlašuje pod volajícím uživatelem (zjištěn přes UMS.ExchangeSearch).

Parametry:
AppName | Název aplikace
AppLicenseBit | Číslo bitu, který musí být na serveru nastaven v klíči, aby aplikace šla spustit

HRESULT OperateCall | ( | [in] BSTR | CallID,
 |  | [in] BSTR | OperationName,
 |  | [in] BSTR | Params,
 |  | [out, retval] BSTR * | retStat
 | ) |

Ostatní operace (hold, unhold).

Parametry:
CallID | Stand hovoru
OperationName | Název operace (viz ICXSession::OperateCall)
Params | Parametry operace ve formátu Par1=Val1|Par2=Val2
retStat | Vrátí "OK" v případě úspěchu, jinak chyba

HRESULT Redirect | ( | [in] BSTR | CallID,
 |  | [in] BSTR | Number,
 |  | [out, retval] BSTR * | retStat
 | ) |

Operace přesměrování hovoru na dané číslo.

Parametry:
CallID | Stand hovoru
Number | Telefonní číslo
retStat | Vrátí "OK" v případě úspěchu, jinak chyba

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • CxClient2.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ILevel2CC

Dokumentace rozhraní ILevel2CC

Seznam všech členů.

Veřejné metody

HRESULT | CloseCall ([in] BSTR CCID,[out, retval] VARIANT *retVal)
HRESULT | Dial ([in] BSTR GroupID,[in] BSTR NumList,[out, retval] VARIANT *retVal)
Umožňuje zadat seznam čísel pro automatické vytáčení odchozích hovorů.
HRESULT | GetSession ([out, retval] VARIANT *retVal)
Vrátí rozhraní Level1, aby klientská aplikace L3 mohla pracovat nad hovorem.
HRESULT | Init ([in] BSTR AppName,[out, retval] BOOLEAN *retVal)
Zaregistrování CallCenter klientské aplikace Level3.
HRESULT | LogWrite ([in] BSTR Text,)
Umožňuje L3 klientským aplikacím zápis do logu Callchange Center Level2.
HRESULT | Record ([out, retval] VARIANT *retVal)
Záznam hovoru je realizován jako konferenční hovor na linku zadanou v konfiguraci CX serveru (cc.record.line hodnota). Zavolání metody je ekvivalentní stisku tlačítka na L2CC aplikaci.
HRESULT | SetCallRc ([in] BSTR CCID,[in] BSTR Rc,[in] BSTR Rc2,[in] BSTR Description,[out, retval] VARIANT *retVal)
Nastaví hovoru atributy RC, RC2 a DESC - tím klientská aplikace Level3 říká, jak hovor zpracovala.
HRESULT | TransferCall ([in] BSTR callid,[in] BSTR LineName,[in] BSTR LineNumber,[out, retval] VARIANT *retVal)
Operace předání hovoru na dalšího operátora s předáním informací o hovoru.

Detailní popis

Rozhraní Callchange Center ILevel2

Parametry p?edávané L3 aplikacím jsou: CID = ID fyzického hovoru CCID = ID CC hovoru LINE = telefonní linka DIRECTION = p?íchozí/odchozí hovor (in/out) NUMBER = telefonní ?íslo AGENTID = ID agenta GROUPID = ID ACD skupiny

Definice je uvedena na řádku 28 v souboru CxL2CC.idl.

Dokumentace k metodám

HRESULT CloseCall | ( | [in] BSTR | CCID,
 |  | [out, retval] VARIANT * | retVal
 | ) |

Uzavře práci s CallCenter (ne-fyzickým) hovorem - nastaví mu STATE=CS_IDLE (a následně server tento hovor uloží do archivu)

Parametry:
CCID | handle (ID) callcenter hovoru
retVal | návratová hodnota je ERROR v případě chyby, jinak OK

HRESULT Dial | ( | [in] BSTR | GroupID,
 |  | [in] BSTR | NumList,
 |  | [out, retval] VARIANT * | retVal
 | ) |

Umožňuje zadat seznam čísel pro automatické vytáčení odchozích hovorů.

Parametry:
GroupID | ID ACD skupiny, za kterou se bude vytáčet
NumList | seznam telefonních čísel oddělených znakem |
retVal | návratová hodnota (OK v případě úspěchu)

HRESULT GetSession ( [out, retval] VARIANT * retVal )

Vrátí rozhraní Level1, aby klientská aplikace L3 mohla pracovat nad hovorem.

Parametry:
retVal návratovou hodnotou je rozhraní (cx.level1)

HRESULT Init | ( | [in] BSTR | AppName,
 |  | [out, retval] BOOLEAN * | retVal
 | ) |

Zaregistrování CallCenter klientské aplikace Level3.

Parametry:
AppName | název aplikace Level3
retVal | návratová hodnota je TRUE pokud se aplikace úspěšně zaregistrovala nebo FALSE v případě chyby

HRESULT LogWrite ( [in] BSTR Text )

Umožňuje L3 klientským aplikacím zápis do logu Callchange Center Level2.

Parametry:
Text text k zalogování

HRESULT Record ( [out, retval] VARIANT * retVal )

Záznam hovoru je realizován jako konferenční hovor na linku zadanou v konfiguraci CX serveru (cc.record.line hodnota). Zavolání metody je ekvivalentní stisku tlačítka na L2CC aplikaci.

Parametry:
retVal návratová hodnota (OK v případě úspěchu)

HRESULT SetCallRc | ( | [in] BSTR | CCID,
 |  | [in] BSTR | Rc,
 |  | [in] BSTR | Rc2,
 |  | [in] BSTR | Description,
 |  | [out, retval] VARIANT * | retVal
 | ) |

Nastaví hovoru atributy RC, RC2 a DESC - tím klientská aplikace Level3 říká, jak hovor zpracovala.

Parametry:
CCID | handle (ID) callcenter hovoru
Rc | atribut RC - výsledek hovoru (0=neúspěch, 1=úspěch)
Rc2 atribut RC2 - kód konce hovoru. Pro zpracovaný hovor (RC=1) může být: CONNECTED (hovor byl spojen operátorovi. Tento stav je nastaven automaticky; aplikace L3 jej může následně změnit podle potřeby),
  • OK (doporučený stav, kterým L3 aplikace říká, že hovor v pořádku zpracovala).
    Pro nezpracovaný hovor (RC=0) může být: ERR_SCRIPT (chyba v routovacím skriptu),
  • ERR_ENDSCRIPT (konec routovacího skriptu aniž by bylo zjevné, co se má s hovorem stát (Tato chyba by neměla nastávat, neb routovací skript bdue generován WWW aplikací),
  • NPROC (hovor nebyl zpracován / volající zavěsil, zatímco čekal ve frontě routeru),
  • NANSW (hovor přepojen na operátora, nicméně nezvednut operátorem / volající zavěsil než to operátor zvednul),
  • ERR_NAPP (hovor byl přepojen na operátora, ale není zde aplikace, která by ho mohla obsloužit),
  • R_HANGUP (routerový skript dorazil na příkaz HANGUP a nebylo uvedeno, jaká se má nastavit hodnota k hovoru),
  • R_BLACKLIST (číslo je na blacklistu), R_WHITELIST (číslo není na whitelistu) a případně další uživatelsky definované stavové kódy.
Description | detailní popis k ukončení hovoru (může být prázdný řetězec)
retVal | návratová hodnota je ERROR v případě chyby, jinak OK

HRESULT TransferCall | ( | [in] BSTR | callid,
 |  | [in] BSTR | LineName,
 |  | [in] BSTR | LineNumber,
 |  | [out, retval] VARIANT * | retVal
 | ) |

Operace předání hovoru na dalšího operátora s předáním informací o hovoru.

Parametry:
callid | handle (ID) fyzického (ne callcenter) hovoru
LineName | linka
LineNumber | tel. číslo
retVal | návratová hodnota je ERROR v případě chyby, NOT_FOUND=hovor nenalezen,jinak OK

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • CxL2CC.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní IPhNormalizer

Dokumentace rozhraní IPhNormalizer

Rozhraní pro manipulaci s telefonními čísly. ...

Seznam všech členů.

Veřejné typy

enum | PhoneNormalizerOptions { NORMALIZER_NUMBER_FROM_PBX = 1, NORMALIZER_INTERNAL_SHORT = 2, NORMALIZER_FORMAT_DIAL = 4, NORMALIZER_FORMAT_SHORTEST = 8 }
Možnosti normalizace a formátování telefonních čísel. ...

Veřejné metody

HRESULT | AreaCode ([in] BSTR newVal)
HRESULT | AreaCode ([out, retval] BSTR *pVal)
HRESULT | AreaCodeEscape ([in] BSTR newVal)
HRESULT | AreaCodeEscape ([out, retval] BSTR *pVal)
HRESULT | Format ([in] BSTR num,[in] long options,[out, retval] BSTR *result)
Konverze telefonního čísla.
HRESULT | Init ([in] BSTR paramList)
Inicializace objektu na základě konfiguračního řetězce.
HRESULT | InitFromRegistry ([in] BSTR regKeyName,[out, retval] BSTR *retStat)
Inicializuje objekt na základě údajů uložených v registry.
HRESULT | InternationalAccessCode ([in] BSTR newVal)
HRESULT | InternationalAccessCode ([out, retval] BSTR *pVal)
HRESULT | IsNumberInternal ([in] BSTR num,[out, retval] VARIANT_BOOL *result)
Rozlišení, zda telefonní číslo je interní.
HRESULT | LocalCountryCode ([in] BSTR newVal)
HRESULT | LocalCountryCode ([out, retval] BSTR *pVal)
HRESULT | MakeVariations ([in] BSTR phoneNum,[in] long options,[out, retval] BSTR *result)
Vytvoří platné variace telefonního čísla.
HRESULT | Normalize ([in] BSTR phoneNum,[in] long options,[out, retval] BSTR *result)
HRESULT | PBXCommonPart ([in] BSTR newVal)
HRESULT | PBXCommonPart ([out, retval] BSTR *pVal)
HRESULT | PBXdigits ([in] long newVal)
HRESULT | PBXdigits ([out, retval] long *pVal)
HRESULT | PBXIncommingPrefix ([in] BSTR newVal)
HRESULT | PBXIncommingPrefix ([out, retval] BSTR *pVal)
HRESULT | PBXOutsideAccessCode ([in] BSTR newVal)
HRESULT | PBXOutsideAccessCode ([out, retval] BSTR *pVal)
HRESULT | TrunkWildcard ([in] BSTR newVal)
HRESULT | TrunkWildcard ([out, retval] BSTR *pVal)

Detailní popis

Rozhraní pro manipulaci s telefonními čísly.

Definice je uvedena na řádku 18 v souboru PhoneNormalizer.idl.

Dokumentace k členským výčtům

enum PhoneNormalizerOptions

Možnosti normalizace a formátování telefonních čísel.

Hodnoty výčtu:
NORMALIZER_NUMBER_FROM_PBX | Telefonní číslo je předáno ústřednou, počátek čísla PBXIncommingPrefix je pro externí volání odstraněn.
NORMALIZER_INTERNAL_SHORT | Při normalizaci jsou interní čísla navrácena v nejkratší formě (bez mezinárodní atd. části).
NORMALIZER_FORMAT_DIAL | Funkci Format() převádí číslo na formu vhodnou pro vytáčení.
NORMALIZER_FORMAT_SHORTEST | Funkci Format() převádí číslo na nejkratší formu (nikoliv pro vytáčení).

Definice je uvedena na řádku 21 v souboru PhoneNormalizer.idl.

00022                         {
00024                         NORMALIZER_NUMBER_FROM_PBX=1,
00026                         NORMALIZER_INTERNAL_SHORT=2,
00028                         NORMALIZER_FORMAT_DIAL=4,
00030                         NORMALIZER_FORMAT_SHORTEST=8
00031                         } PhoneNormalizerOptions;

Dokumentace k metodám

HRESULT Format | ( | [in] BSTR | num,
 |  | [in] long | options,
 |  | [out, retval] BSTR * | result
 | ) |

Konverze telefonního čísla.

Parametry:
num Telefonní číslo, ktreé je třeba konvertovat
options Pro konverzi do vytočitelného tvaru je třeba použít volbu NORMALIZER_FORMAT_DIAL volitelně v kombinaci s NORMALIZER_NUMBER_FROM_PBX viz: PhoneNormalizerOptions
Pokud prvním znakem tohoto parametru je "!", pak je pouze odstraněn tento znak. Tuto možnost lze využít pokud je třeba vytočit číslo, které nemá být normalizací atd. měněno.

HRESULT Init ( [in] BSTR paramList )

Inicializace objektu na základě konfiguračního řetězce.

Parametry:
paramList Řetězec ve formě "položka=hodnota|..."
Rětězec musí obsahovat tyto položky
  • PHONE.InternationalAccessCode - Kód pro zahraniční volání. V ČR je 00
  • PHONE.LocalCountryCode - Místní národní kód. Pro ČR je 420
  • PHONE.AreaCodeEscape - Kód pro meziměstská volání. V ČR je prazdný, před přečíslováním byl 0
  • PHONE.AreaCode - Místní kód oblasti. V ČR se nyní nepoužívá, před přečíslováním pro Prahu býval 2
  • PHONE.PBXdigits - Počet číslic interních telefonních čísel. Obvykle 2 až 4
  • PHONE.PBXCommonPart - Společná část (začátek) všech telefonních čísel. Pro Datasys je +420225308.
  • PHONE.PBXOutsideAccessCode - Kód pro přechod z interní sítě do státní. Často bývá 0 nebo 9
  • PHONE.PBXIncommingPrefix - Číslice, jež vkládá telefonní ústředna na začátek čísla volajícího při přichozím hovoru ze státní sítě. Tyto číslice mohou být při normalizaci odstraněny je-li v parametru options použito NORMALIZER_NUMBER_FROM_PBX viz. PhoneNormalizerOptions
  • PHONE.TrunkWildcard - Maska udentifikující telefonní čísla příček ústředny. Povolené znaky jsou _*,

HRESULT InitFromRegistry | ( | [in] BSTR | regKeyName,
 |  | [out, retval] BSTR * | retStat
 | ) |

Inicializuje objekt na základě údajů uložených v registry.

Parametry:
regKeyName Jméno klíče s uloženou konfigurací.
Je-li prázdné, pak se konfigurace očekává v "HKEY_LOCAL_MACHINE\SOFTWARE\Datasys\UMS\ContactSearch\PhoneNormalizer"
Jména hodnot uložených v registry jsou obdobná jako u metody Init(), avšak bez předpony "PHONE.". Tedy "InternationalAccessCode" atd.

HRESULT MakeVariations | ( | [in] BSTR | phoneNum,
 |  | [in] long | options,
 |  | [out, retval] BSTR * | result
 | ) |

Vytvoří platné variace telefonního čísla.

Parametry:
phoneNum | Vstupní číslo, nemusí být normalizované
options | Může mít hodnotu NORMALIZER_NUMBER_FROM_PBX viz. PhoneNormalizerOptions
result | Řetězec obsahující jednotlivé varianty telefonního čísla oddělené znakem "|"

HRESULT Normalize | ( | [in] BSTR | phoneNum,
 |  | [in] long | options,
 |  | [out, retval] BSTR * | result
 | ) |

Převede telefonní číslo do normalizovaného tvaru. Normalizovaný tvar je plné vyjadření telefonního čísla začínající "+"
Pokud options obsahuje NORMALIZER_INTERNAL_SHORT pak jsou interní čísla ústředny navrácena v interní (nejratší) podobě bez úvodního znaku "+".
Pokud prvním znakem phoneNum je "!", pak toto číslo není metodou Normalize modifikováno.

Parametry:
phoneNum | Číslo, které je třeba normalizovat
options | Kombinace z hodnot NORMALIZER_NUMBER_FROM_PBX, NORMALIZER_INTERNAL_SHORT viz. PhoneNormalizerOptions

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • PhoneNormalizer.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní IShareObj

Dokumentace rozhraní IShareObj

Objekt pro sdílení COM objektů v počítačové síti. ...

Seznam všech členů.

Veřejné metody

HRESULT | DisconnectAll ([in, defaultvalue("")] BSTR typeID)
Disconnect all clients of specified type.
HRESULT | DisconnectAll ([in, defaultvalue("")] BSTR typeID)
Disconnect all clients of specified type.
HRESULT | GetObject ([in] BSTR typeID,[in] long timeout,[in] long processTimeout,[in, defaultvalue(0)] long taskID,[in, out, optional] VARIANT *param,[out, retval] IDispatch **obj)
Get offered object from manager.
HRESULT | GetObject ([in] BSTR typeID,[in] long timeout,[in] long processTimeout,[in, defaultvalue(0)] long taskID,[in, out, optional] VARIANT *param,[out, retval] IDispatch **obj)
Get offered object from manager.
HRESULT | GetPublicObject ([in] BSTR pubName,[in, out] VARIANT *pubObj,[out, retval] BOOL *found)
GetPublicObject.
HRESULT | GetPublicObject ([in] BSTR pubName,[in, out] VARIANT *pubObj,[out, retval] BOOL *found)
GetPublicObject.
HRESULT | OfferObject ([in] IDispatch *obj,[in] BSTR typeID,[in, defaultvalue(0)] long timeout,[in, optional] VARIANT param,[out, retval] BOOL *used)
Offer local object to others. Name of offered service type is identified by typeID string.
HRESULT | OfferObject ([in] IDispatch *obj,[in] BSTR typeID,[in, defaultvalue(0)] long timeout,[in, optional] VARIANT param,[out, retval] BOOL *used)
Offer local object to others. Name of offered service type is identified by typeID string.
HRESULT | Register ([in] BSTR pubName,[in] IDispatch *obj)
Publish.
HRESULT | Register ([in] BSTR pubName,[in] IDispatch *obj)
Publish.
HRESULT | Revoke ([in] BSTR pubName)
Revoke.
HRESULT | Revoke ([in] BSTR pubName)
Revoke.

Detailní popis

Objekt pro sdílení COM objektů v počítačové síti.

Definice je uvedena na řádku 19 v souboru CXServer2/head/current/DSShareObj.idl.

Dokumentace k metodám

HRESULT GetObject | ( | [in] BSTR | typeID,
 |  | [in] long | timeout,
 |  | [in] long | processTimeout,
 |  | [in, defaultvalue(0)] long | taskID,
 |  | [in, out, optional] VARIANT * | param,
 |  | [out, retval] IDispatch ** | obj
 | ) |

Get offered object from manager.

Parametry:
typeID | type of requested service (used for finding appropriate client)
timeout | time to wait for free server
processTimeout | client is disconnected from server if client does no call to server
taskID | id of client task. Used for fast client crach detection (can be used on local computer only)
param | optional information from server

HRESULT GetObject | ( | [in] BSTR | typeID,
 |  | [in] long | timeout,
 |  | [in] long | processTimeout,
 |  | [in, defaultvalue(0)] long | taskID,
 |  | [in, out, optional] VARIANT * | param,
 |  | [out, retval] IDispatch ** | obj
 | ) |

Get offered object from manager.

Parametry:
typeID | type of requested service (used for finding appropriate client)
timeout | time to wait for free server
processTimeout | client is disconnected from server if client does no call to server
taskID | id of client task. Used for fast client crach detection (can be used on local computer only)
param | optional information from server

HRESULT OfferObject | ( | [in] IDispatch * | obj,
 |  | [in] BSTR | typeID,
 |  | [in, defaultvalue(0)] long | timeout,
 |  | [in, optional] VARIANT | param,
 |  | [out, retval] BOOL * | used
 | ) |

Offer local object to others. Name of offered service type is identified by typeID string.

Parametry:
obj | Offered object
typeID | type of offered service
timeout | time to wait for a client
param | optional information for client

HRESULT OfferObject | ( | [in] IDispatch * | obj,
 |  | [in] BSTR | typeID,
 |  | [in, defaultvalue(0)] long | timeout,
 |  | [in, optional] VARIANT | param,
 |  | [out, retval] BOOL * | used
 | ) |

Offer local object to others. Name of offered service type is identified by typeID string.

Parametry:
obj | Offered object
typeID | type of offered service
timeout | time to wait for a client
param | optional information for client

Dokumentace pro toto rozhraní byla generována z následujících souborů:
  • CXServer2/head/current/DSShareObj.idl
  • DSShareObj/head/current/DSShareObj.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ISMngr

Dokumentace rozhraní ISMngr

Main interface of Ums Task Manager. ...

Seznam všech členů.

Veřejné metody

HRESULT | GetTaskStatus ([in] long taskID,[in] BSTR cmdLine,[out, retval] TaskStatus *status)
HRESULT | QueryLicence ([in] long cls,[in] long ProcessID,[in] long instNum,[out, retval] BOOL *retVal)
Question if available licences are there.
HRESULT | RunCmd ([in] BSTR CmdLine,[in, defaultvalue(0)] BSTR WorkDir,[in, defaultvalue(0)] long StopTimeout,[out, retval] BOOL *status)
Start new task in window station of Ums Task Manager.
HRESULT | StopAll ([out, retval] BOOL *result)
Stop all managed tasks.
HRESULT | StopTaskByID ([in] long taskID,[out, retval] BOOL *result)
StopTask identifyed by Task ID.
HRESULT | StopTaskByName ([in] BSTR taskName,[out, retval] BOOL *status)

Detailní popis

Main interface of Ums Task Manager.

Definice je uvedena na řádku 32 v souboru DSServMngr.idl.

Dokumentace k metodám

HRESULT GetTaskStatus | ( | [in] long | taskID,
 |  | [in] BSTR | cmdLine,
 |  | [out, retval] TaskStatus * | status
 | ) |

Question for new task state

Managed tasks should periodicaly call this method to obtain requested TaskStatus. Task should exit if they get TaskStatus different than TSRunning. This is the only way, by which Task Manager can notify a task to quit.
Poznámka:
If task does not respect (or doesnt call this method) request to stop than it will be hardly terminated.
Parametry:
taskID | Task ID of task querying his status
cmdLine | optional command line of task querying his status
status
Návratová hodnota:
Requested task state

HRESULT QueryLicence | ( | [in] long | cls,
 |  | [in] long | ProcessID,
 |  | [in] long | instNum,
 |  | [out, retval] BOOL * | retVal
 | ) |

Question if available licences are there.

Parametry:
cls | class of licence (application type)
ProcessID | Task ID of task requeting licence
instNum | Number of consuming licences
retVal
Vracené hodnoty:
Nozero for success

HRESULT RunCmd | ( | [in] BSTR | CmdLine,
 |  | [in, defaultvalue(0)] BSTR | WorkDir,
 |  | [in, defaultvalue(0)] long | StopTimeout,
 |  | [out, retval] BOOL * | status
 | ) |

Start new task in window station of Ums Task Manager.

Parametry:
CmdLine | command line
WorkDir | startup directory
StopTimeout | Maximal period of calls GetTaskStatus
status
Vracené hodnoty:
Succes=TRUE

HRESULT StopAll ( [out, retval] BOOL * result )

Stop all managed tasks.

Parametry:
result
Vracené hodnoty:
Succes=TRUE

HRESULT StopTaskByID | ( | [in] long | taskID,
 |  | [out, retval] BOOL * | result
 | ) |

StopTask identifyed by Task ID.

Parametry:
result
Vracené hodnoty:
Succes=TRUE

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • DSServMngr.idl


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ISysDbConn

Dokumentace rozhraní ISysDbConn

Objekt zprostředkující přístup do systémové databáze. ...

Seznam všech členů.

Veřejné typy

enum | GOB_SpecType { GOB_MQ_LIKE = 0, GOB_SQL_FULL = 1, GOB_SQL_WHERE = 2 }
enum | StoreDataOptions { SDO_ADD_NEW = 0, SDO_UPDATE = 1, SDO_UPDATE_OR_ADD = 2, SDO_ERR_NOREPORT = 4 }
Možnosti úkládání dat do databáze. ...

Veřejné metody

HRESULT | ExecuteSQL ([in] BSTR sqlCommand,[in] BSTR options,[in] BSTR lockKey,[in, out]VARIANT *numRec,[out, retval] BSTR *retStat)
HRESULT | GetData ([in] BSTR sqlQuery,[in] long rowMax,[in, out] VARIANT *records,[out, retval] BSTR *retStat)
Vrati data z databáze.
HRESULT | GetObjData ([in] BSTR spec,[in] GOB_SpecType spectype,[in] BSTR options,[in] long rowMax,[in, out] VARIANT *records,[out, retval] BSTR *retStat)
HRESULT | SetData ([in] BSTR tableName,[in] BSTR selCrit,[in] BSTR data,[in] StoreDataOptions options,[in] BSTR lockKey,[in, out] VARIANT *numAffRec,[out, retval] BSTR *retStat)
Uloží data do databáze.

Detailní popis

Objekt zprostředkující přístup do systémové databáze.

Definice je uvedena na řádku 152 v souboru CXServer2.idl.

Dokumentace k členským výčtům

enum GOB_SpecType

Hodnoty výčtu:
GOB_MQ_LIKE | Spec je výraz v syntaxi DSMQueue.
GOB_SQL_FULL | Spec je kompletní SQL dotaz.
GOB_SQL_WHERE | Spec je WHERE část SQL dotazu.

Definice je uvedena na řádku 167 v souboru CXServer2.idl.

00168                 {
00170                 GOB_MQ_LIKE=0,
00172                 GOB_SQL_FULL=1,
00174                 GOB_SQL_WHERE=2
00175                 } GOB_SpecType;

enum StoreDataOptions

Možnosti úkládání dat do databáze.

Hodnoty výčtu:
SDO_ADD_NEW | Vždy přidá nový záznam.
SDO_UPDATE | Provede update.
SDO_UPDATE_OR_ADD | Pokud existuje vyhovující záznam(y) provede update, pokud neexituje, tak vloží nový záznam.
SDO_ERR_NOREPORT | Nereportovat chyby datbázové operace.

Definice je uvedena na řádku 155 v souboru CXServer2.idl.

00156                 {
00158                 SDO_ADD_NEW=0,
00160                 SDO_UPDATE=1,
00162                 SDO_UPDATE_OR_ADD=2,
00164                 SDO_ERR_NOREPORT=4
00165                 } StoreDataOptions;

Dokumentace k metodám

HRESULT GetData | ( | [in] BSTR | sqlQuery,
 |  | [in] long | rowMax,
 |  | [in, out] VARIANT * | records,
 |  | [out, retval] BSTR * | retStat
 | ) |

Vrati data z databáze.

Parametry:
sqlQuery | SQL dotaz
rowMax | Maximální počet navrácených záznamů
records | Jednotlivé záznamy jsou vráceny v poli variantů obsahujících řetezce

HRESULT GetObjData | ( | [in] BSTR | spec,
 |  | [in] GOB_SpecType | spectype,
 |  | [in] BSTR | options,
 |  | [in] long | rowMax,
 |  | [in, out] VARIANT * | records,
 |  | [out, retval] BSTR * | retStat
 | ) |

Vrátí údaje z tabulky CC_OBJ_ATR, přičemž údaje příslušné jednomu objektu jsou z více databázových řádků sloučeny do jednoho záznamu

Parametry:
spec | Specifikace výběru, interpretováno na základě spectype
spectype | Jak interpretovat spec
options Seznam parametrů
  • OBJ_TYPE Jméno typu objektu, který má být vybrán
    • "c" data volání
    • "l" atributy linky
    • "s" atributy session
rowMax | Omezení počtu vrácených řádků
records Navrácená data jako pole variantů obsahujících řetezce
Pokud je rowMax=1 pak navrácená hodnota je přímo záznam (není v poli)

HRESULT SetData | ( | [in] BSTR | tableName,
 |  | [in] BSTR | selCrit,
 |  | [in] BSTR | data,
 |  | [in] StoreDataOptions | options,
 |  | [in] BSTR | lockKey,
 |  | [in, out] VARIANT * | numAffRec,
 |  | [out, retval] BSTR * | retStat
 | ) |

Uloží data do databáze.

Parametry:
tableName | Jméno tabulky
selCrit | Výběrové kriterum, nemá při přidávání zaznamů
data | Data datab8zov0ho zaznamu
lockKey | Pomocny klic pro zamykani pri update

Dokumentace pro toto rozhraní byla generována z následujícího souboru:
  • CXServer2.idl


Aplikační rozhraní systému CallChange: Dokumentace třídy SMngr

DSSERVMNGRLib::SMngr

Dokumentace třídy SMngr

Detailní popis

Ums Task Manager
Implemented interfaces
  • [default] interface ISMngr;
Program ID
  • 8A5A6312-BD0E-11D2-830A-00105A2F4B4E
  • DSServMngr.SMngr

Definice je uvedena na řádku 104 v souboru DSServMngr.idl.

Dokumentace pro tuto třídu byla generována z následujícího souboru:
  • DSServMngr.idl


Aplikační rozhraní systému CallChange: Seznam členů tříd

Zde naleznete seznam všech dokumentovaných členů tříd s odkazy na třídy, ke kterým příslušejí:

- a -

  • Activate() : IAppActivator
  • ActivateOnCall() : _ILevel2CCEvents
  • AddNumberToBL() : ICXRouter
  • AddProgID() : ICXXMLRPCPlugin
  • AddService() : ICXXMLRPCPlugin
  • AgentAssignGroup() : ICXSession
  • AgentCheckRight() : ICXSession
  • AgentGetApplicationParams() : ICXSession
  • AgentGetGroups() : ICXSession
  • AgentGetRequisiteApps() : ICXSession
  • AgentLogoff() : ICXSession
  • AgentLogon() : ICXSession
  • AgentStoreStatus() : ICXSession
  • AgentStoreStatusEx() : ICXSession
  • AllocID() : ICXSession
  • Answer() : Ilevel1

- b -

  • Busy() : _Ilevel1Events

- c -

  • CallCreated() : _Ilevel1Events
  • CallInfo() : _Ilevel1Events
  • CallXMLRPC() : IDSXMLRPCClient
  • CheckLicence() : ICXSession
  • CheckNumberInBL() : ICXRouter
  • CloseCall() : ILevel2CC
  • CloseCallSession() : Ilevel1
  • COMSessionID() : IDSXMLRPCClient
  • Connected() : _Ilevel1Events
  • ConnectLine() : Ilevel1, ICXSession
  • Consultation() : Ilevel1
  • CreateCOMSession() : IDSXMLRPCClient
  • CreateNewCall() : ICXGlueLine, ICXSession

- d -

  • DeleteNumberFromBL() : ICXRouter
  • DeleteRecords() : IDSMQStorage
  • Dial() : ILevel2CC, Ilevel1
  • Disabled() : _Ilevel1Events
  • DisconnectAll() : IShareObj
  • DisconnectLine() : Ilevel1, ICXSession
  • Done() : ICXXMLRPCPlugin, ICXServer, ICXSession
  • DSMQS_DELETETABLE : IDSMQStorage
  • DSMQS_ENABLE_NEW : IDSMQStorage
  • DSMQS_LIFO : IDSMQStorage
  • DSMQS_LOCK : IDSMQStorage
  • DSMQS_MULTIPLE : IDSMQStorage
  • DSMQS_NODATA : IDSMQStorage
  • DSMQS_NOREMOVE : IDSMQStorage
  • DSMQS_PERSISTENT : IDSMQStorage
  • DSMQS_PUT_FRONT : IDSMQStorage
  • DSMQS_WAIT_50 : IDSMQStorage
  • DSMQStorageFlags : IDSMQStorage

- e -

  • Enabled() : _Ilevel1Events
  • EndCall() : _Ilevel1Events
  • ExecuteSQL() : ICXSession

- f -

  • Format() : IPhNormalizer

- g -

  • GetActualLineCalls() : ICXSession
  • GetArchive() : Ilevel1, ICXSession
  • GetArchiveCalls() : ICXArchive
  • GetCallEvents() : ICXSession, ICXArchive
  • GetCallState() : ICXSession
  • GetCallStateEx() : ICXSession
  • GetCfgItem() : ICXGlueLine
  • GetConfigItem() : Ilevel1
  • GetConfigItems() : ICXSession
  • GetCXMessage() : ICXSession
  • GetCXMessageEx() : ICXSession
  • GetData() : ISysDbConn
  • GetDatabase() : ICXSession
  • GetDatabaseData() : ICXSession
  • GetDeviceCaps() : ICXSession
  • GetLineFeature() : ICXSession
  • GetLineFromStand() : ICXGlueLine
  • GetLineInfo() : Ilevel1, ICXSession
  • GetLineList() : ICXSession
  • GetLinesConfig() : ICXGlueLine
  • GetLineState() : Ilevel1
  • GetListBlNames() : ICXRouter
  • GetLocalLines() : Ilevel1, ICXSession
  • GetNextID() : IDSMQStorage
  • GetObjData() : ISysDbConn
  • GetObject() : IShareObj
  • GetOperationRequest() : ICXGlueLine
  • GetProxyObject() : IDSXMLRPCClient
  • GetPublicObject() : IShareObj
  • GetRecords() : IDSMQStorage
  • GetRouter() : ICXSession
  • GetServerTime() : ICXSession
  • GetServerTimeString() : ICXSession
  • GetSession() : ICXGlueLine, ILevel2CC, Ilevel1, ICXServer
  • GetSessionAttributes() : ICXSession
  • GetSessionID() : ICXSession
  • GetStandFromLine() : ICXGlueLine
  • GetStandList() : Ilevel1
  • GetStorage() : Ilevel1, ICXSession
  • GetStorePF() : ICore
  • GetTaskStatus() : ISMngr
  • GOB_MQ_LIKE : ISysDbConn
  • GOB_SpecType : ISysDbConn
  • GOB_SQL_FULL : ISysDbConn
  • GOB_SQL_WHERE : ISysDbConn

- h -

  • HangUp() : Ilevel1

- i -

  • InComingCall() : _Ilevel1Events
  • Init() : ICXGlueLine, IDSXMLRPCClient, ICXXMLRPCPlugin, ILevel2CC, Ilevel1, IPhNormalizer, ICXServer, ICXSession
  • InitFromRegistry() : IPhNormalizer
  • InprocQueryInterface() : IDSInprocQI
  • IsNumberInternal() : IPhNormalizer

- l -

  • LineError() : _Ilevel1Events
  • Log() : ICXSession
  • LOG_DATA : ICXSession
  • LOG_DEBUG : ICXSession
  • LOG_ERROR : ICXSession
  • LOG_FETCH : ICXSession
  • LOG_INFO : ICXSession
  • LOG_TRACE : ICXSession
  • LOG_UNIVERSE_END : ICXSession
  • LOG_WARNING : ICXSession
  • LoginService() : ICXSession
  • LoginUser() : ICXSession
  • LogLevel : ICXSession
  • LogWrite() : ILevel2CC

- m -

  • MakeNewSession() : ICXServer
  • MakeVariations() : IPhNormalizer

- n -

  • Normalize() : IPhNormalizer
  • NORMALIZER_FORMAT_DIAL : IPhNormalizer
  • NORMALIZER_FORMAT_SHORTEST : IPhNormalizer
  • NORMALIZER_INTERNAL_SHORT : IPhNormalizer
  • NORMALIZER_NUMBER_FROM_PBX : IPhNormalizer
  • Notify() : IAppActivator, _Ilevel1Events

- o -

  • OfferObject() : IShareObj
  • OnCall() : _ILevel2CCEvents
  • OnDial() : _ILevel2CCEvents
  • OnMessage() : _ILevel2CCEvents
  • OperateCall() : Ilevel1, ICXSession
  • OperateCallEx() : ICXSession
  • OperateCallVX() : ICXSession
  • OutGoingCall() : _Ilevel1Events

- p -

  • PhoneNormalizerOptions : IPhNormalizer
  • PhoneUp() : _Ilevel1Events
  • PostCXMessage() : ICXSession
  • PutRecords() : IDSMQStorage

- q -

  • QueryLicence() : ISMngr

- r -

  • Record() : ILevel2CC
  • Redirect() : Ilevel1
  • Register() : IShareObj
  • RegisterAsOperateChainMember() : ICXSession
  • RegisterLine() : ICXGlueLine
  • Revoke() : IShareObj
  • Ringing() : _Ilevel1Events
  • RunCmd() : ISMngr

- s -

  • SDO_ADD_NEW : ISysDbConn
  • SDO_ERR_NOREPORT : ISysDbConn
  • SDO_UPDATE : ISysDbConn
  • SDO_UPDATE_OR_ADD : ISysDbConn
  • Search() : ICore
  • SearchEx() : ICore
  • SearchSQL() : ICore
  • SendLineEvent() : ICXGlueLine
  • ServerConnection() : _Ilevel1Events
  • SetAttr() : IDSMQStorage
  • SetCallRc() : ILevel2CC
  • SetCallState() : ICXSession
  • SetData() : ISysDbConn
  • SetDatabaseData() : ICXSession
  • SetIDPersist() : IDSMQStorage
  • SetLineFeature() : ICXSession
  • SetLineInfo() : ICXSession
  • SetSessionAttributes() : ICXSession
  • SetWorkDirectory() : IDSMQStorage
  • SimpleLock() : ICXSession
  • SimpleUnlock() : ICXSession
  • StopAll() : ISMngr
  • StopTaskByID() : ISMngr
  • StoreArchiveCallAttributes() : ICXArchive
  • StoreDataOptions : ISysDbConn
  • StoreEvent() : ICXSession
  • SubscribeNotification() : ICXSession

- t -

  • Terminate() : _ILevel2CCEvents, _Ilevel1Events
  • TransferCall() : ILevel2CC


Aplikační rozhraní systému CallChange: Rejstřík stránek

Aplikační rozhraní systému CallChange Ostatní stránky

Následující seznam odkazuje na další stránky projektu:
  • Přehled tabulek paměťového úložiště
  • Položky tabulek datového úložiště
  • Jména zpráv zasílaných v systému
  • Komunikace s nahrávačem hovorů
  • Dokumentace rozhraní ústředny MD110
  • Dokumentace rozhraní ústředen připojených přes Business Link
  • Dokumentace rozhraní ústředen Siemens Hicom
  • Dokumentace rozhraní ústředen Siemens Cap
  • Dokumentace rozhraní ústředen OmniPCX4400
  • Příklady použití rozhraní ústředen
  • Prohlížeč datového úložiště
  • Popis konfigurace monitoru CX
  • Popis routeru zpráv
  • Události a operace nad CX linkami
  • LineMonitor - tabulka ovladačů


Aplikační rozhraní systému CallChange: Přehled tabulek paměťového úložiště

Přehled tabulek paměťového úložiště

Položky tabulek datového úložiště
  • "a" - Tabulka linek připojených k session
  • "c" - Tabulka stavu hovorů
  • "e" - Tabulka událostí
  • "g" - Tabulka členů ACD skupin
  • "k" - Tabulka registrací členů řetězu zpracování zpráv
  • "l" - Tabulka linek
  • "m" - Tabulka předávání zpráv
  • "n" - Tabulka přihlášek k notifikacím
  • "q" - Tabulka front
  • "r" - Tabulka nahrávek
  • "s" - Tabulka stavu session
  • "x" - Tabulka simulatoru PBX
  • "z" - Tabulka klientských session, které zpracovávají volání


Aplikační rozhraní systému CallChange: Položky tabulek datového úložiště

Položky tabulek datového úložiště

"a" - Tabulka linek připojených k session

  • ID_SESS - ID session
  • LINE_NAME - Jméno připojené linky

"c" - Tabulka stavu hovorů

  • ID - Call ID hovoru
  • LINE - jméno linky, na které hovor probíhá
  • STATE - stav volání:
    • CS_CREATE_CALL - hovor byl založen
    • CS_IDLE - žádný hovor neprobíhá
    • CS_BLOCKED - hovor ukončen ostatními účastníky
    • CS_CONNECTED - hovor je spojen
    • CS_BUSY - volaná protistrana je obsazena
    • CS_NEWCALL - nové odchozí volání
    • CS_RINGBACK - vyzvánění na vzdálené straně
    • CS_OFFERING - příchozí nespojené volání
    • CS_ONHOLD - hovor je přidržen - není aktivní
    • CS_FAILED - nějaká chyba
    • CS_ERROR - nějaká chyba
  • DIRECTION - směr volání:
    • IN - příchozí volání
    • OUT - odchozí volání
  • REM_NUM - poslední telefonní číslo protistrany
  • TIM_ACT - čas poslední aktualizace záznamu
  • TIM_CN - čas navázání spojení
  • TIM_DCN - čas ukončení spojení
  • CID_ORG - původní ID hovoru, z něhož hovor přesměrováním nebo založením konference vznikl
  • PBX_CALL_ID - interní identifikátor hovoru dle ústředny
  • CC_SCRIPT_NAME - jméno skriptu
  • CC_SCRIPT_VERSION - verze skriptu
  • CC_SCRIPT_STEP - aktuální krok skriptu
  • CC_SCRIPT_TIMEOUT - čas, příští činnosti skriptu
  • CC_QUEUE_TIMEOUT - čas ukončení čekání na volného operátora
  • CC_VX_LINE - číslo obsluhující linky VX
  • CC_VX_ARGS - argumenty pro VX
  • AGENT_ID - číslo obsluhujícího agenta
  • GROUP_ID - číslo obsluhující ACD skupiny

"e" - Tabulka událostí

  • OBJ_ID - Identifikátor objektu, k němuž se událost vztahuje
  • EV_TIME - Čas události
  • EV_TYPE - Typ události
  • EV_VAL - Nepovinné. Kvantifikace události (např. tel číslo které vytáčíme)
  • EV_DESCR - Nepovinné. Textový popis události.

"g" - Tabulka členů ACD skupin

  • Prozatím nedokumentováno ale tabulka je pouzivána

"k" - Tabulka registrací členů řetězu zpracování zpráv

  • Prozatím nedokumentováno ale tabulka je pouzivána

"m" - Tabulka předávání zpráv

  • MTP - typ zprávy viz: Jména zpráv zasílaných v systému
  • STM - čas, kdy byla zpráva odeslána
  • SND - adresa odesílatele zprávy - jeho session ID
  • MQ - ID session pro kterou je zpráva určena
  • LA - nepovinná položka - obsahuje lokální adresu v rámci klienta - zpracuje level1

"l" - Tabulka linek

  • LINE_NAME - Jméno linky
  • LINE_NUMBER - Lokální telefonní číslo
  • SESS_ID - ID session, která provádí monitorování linky

"n" - Tabulka přihlášek k notifikacím

  • TYPE - Typ notifikace viz: NTF_ - Ohlašovací zprávy o změně stavu agenta, session ...
  • ID_SESS - identifikátor session, která chce zprávy přijímat

"q" - Tabulka front

  • CCID - ID CC hovoru
  • GROUP_ID - ID ACD skupiny
  • KNOWLEDGES - požadované znalosti agenta
  • TIME_QUEUED - čas zařazení do fronty
  • PRIORITY - priorita hovoru
  • STATE - stav hovoru:
    • CS_QUEUED_OP - čeká na volného agenta
    • CS_DIVERTING_OP - čeká na přijetí hovoru agentem
    • CS_QUEUED_VX - čeká na volnou linku VX
    • CS_DIVERTING_VX - čaká na přijetí hovoru VX

"r" - Tabulka nahrávek

  • Prozatím nedokumentováno ale tabulka je pouzivána

"s" - Tabulka stavu session

  • ID - ID session, totožné s ID řádku tabulky
  • TIME_INIT - Čas, kdy byla session inicializována
  • TYPE - Druh session
    • SERVICE pro služby cx
    • USER pro uživatelská připojení
  • MACHINE - Jméno počítače, ze kterého je připojení realizováno
  • NAME - Jméno služby, nebo uživatele
  • AGENT_STATE - stav operátora:
    • READY - agent je připraven zpracovávat hovory
    • NOT_READY - agent není připraven zpracovávat hovory
  • AGENT_SUBSTATE - příčina neaktivního stavu agenta (oběd,toaleta...)
  • AGENT_LOGGED - stav přihlášení agenta
    • 0 - agent není přihlášen
    • 1 - agent je přihlášen
  • CCID - ID uživatele v databázové tabulce CC_USERS
  • CC_CALL - id právě zpracovávaného CallCenter hovoru
  • CCNAME - Callcenterové jméno uživatele
  • LASTLOGON - Čas posledního přihlášení callcentrového uživatele
  • CC_STATE stav agenta CC
    • BUSY - zpracovává hovor, je v clericle
    • IDLE - volný

"x" - Tabulka simulatoru PBX

  • Prozatím nedokumentováno ale tabulka je pouzivána

"z" - Tabulka klientských session, které zpracovávají volání

  • ID_CALL - ID volání
  • ID_SESS - ID session


Aplikační rozhraní systému CallChange: Jména zpráv zasílaných v systému

Jména zpráv zasílaných v systému

Kategorie zpráv:

  • OP - zprávy nesoucí požadavek na provedení operace s hovorem např. vytočení čísla
  • LM - zprávy nesoucí požadavek na provedení operace nad linkou ústředny
  • RM - zprávy routeru
  • IM - zprávy pro interprocesovou komunikaci

CS_ - zprávy nesoucí informaci o změně stavu hovoru

  • CS_CREATE_CALL - byl založen nový hovor
  • CS_IDLE - žádný hovor neprobíhá
  • CS_BLOCKED - hovor ukončen ostatními účastníky
  • CS_CONNECTED - hovor je spojen
  • CS_BUSY - volaná protistrana je obsazena
  • CS_NEWCALL - nové odchozí volání na lince byla provedena volba čísla
  • CS_RINGBACK - vyzvánění na vzdálené straně
  • CS_OFFERING - příchozí nespojené volání
  • CS_ONHOLD - hovor je přidržen - není aktivní
  • CS_FAILED - nějaká chyba
  • CS_ERROR - nějaká chyba

SM_ - systemove zprávy

  • SM_DONE - Session je ukončována
  • SM_LIFE_PROBE - Test zda je session aktivni. Session tuto zpravu nijak nezpracovava.

LS_ - zprávy o změně stavu linky

  • LS_ATTACH_OK - Linka byla úspěšně attachnutá
  • LS_ATTACH_ERR - Chyba při attachnutí linky
  • LS_DETACH_OK - Linka byla úspěšně detachnutá
  • LS_DETACH_ERR - Chyba při detachnutí linky

NTF_ - Ohlašovací zprávy o změně stavu agenta, session ...

  • NTF_SESSION_STATE - informace o změne stavu session. Notifikace je posílána z metody ICXSession::SetSessionAttributes()
  • NTF_AGENT_CHANGED - oznámení o změně stavu agenta callcentra. Notifikace je posílána z metody ICXSession::AgentStoreStatus()
  • NTF_AGENT_ASSIGN_GROUP - oznámení o změně přiřazení, nebo připojení agenta callcentra do pracocvní skupiny. Notifikace je posílána z metody ICXSession::AgentAssignGroup()
    • NTF_CHANGE_CONFIG - oznámení o změně konfigurace, upřesnění TABLE=<jméno tabulky, kde došlo ke změně>
    • NTF_OPCHAIN_REGISTER - oznamení o registraci komponenty v řetězu zpracování zpráv
    • NTF_OPCHAIN_DONE - oznamení o ukončení session která byla registrována jako článek řetězu zpracování zpráv

RM_ - Zprávy call routeru

  • RM_OUT_CALL_ENABLE Router povoluje a zakazuje L2 aplikace vytáčet odchozí hovory. V datech zprávy je GROUPID s čísel skupiny a ENABLE s hodnotami 1 nebo 0.
    Zpráva je posílána:
    • při zalogování pro každou skupinu, pro kterou router povolí agentovi odchozí hovory
    • při přihlášení do odchozí skupiny, pro kterou router povolí agentovi odchozí hovory
    • pokud router změní stav povolení

V prvních dvou příležitostech je posíláno pouze kladné povolení, v posledním bodě je možné kladné i záporné povolení.

IM_ - Zprávy meziprocesové komunikace

  • Komunikace s nahrávačem hovorů
    • IM_RECORDER_START - požadavek na spuštění nahrávání hovoru viz. Komunikace s nahrávačem hovorů


Aplikační rozhraní systému CallChange: Komunikace s nahrávačem hovorů

Komunikace s nahrávačem hovorů

Uživatel nebo komponenta Callchange může požádat o spuštění nahráváni hovoru. To vykoná posláním zprávy s požadavkem na spuštění nahrávání nahrávači metodou ICXSession::PostCXMessage().
Parametry naplní takto:
  • messageType "IM_RECORD_REQUEST"
  • recipients "U:CALL_RECORDER"
  • msgData je řetezec ve tvaru položka1=hodnota1|položka2=hodnota2.. který může obsahovat tyto volby:
    • CID - id hovoru, který má být nahrán.
    • PRIORITY - priorita požadavku.
      • 0 - nejvyšší priorita
      • 1 - normální priorita
      • 2 - nízká priorita Protože fyzický počet nahrávacích zařízení může být omezen, je možno v jejich konfiguraci určit, že některá z nich jsou vyhrazena pro prioritní požadavky na nahrávání. Nahrávač se při požadavku o nahrání hovoru snaží najít vhodný nahrávač. Přičemž prefruje nevyhrazená zařízení, při jejich nedostatku v případě že se jedná o prioritní požadavek, hledá hledá vhodé vyhražené zařízení.
    • DESTINATION_EMAIL - seznam emailových adres příjemců nahrané zprávy oddělený znakem ";".
    • ENABLE_ARCHIVE - určení, zda má být nahraný hovor uložen do archivu nahrávek
      • 0 - neukládat nahrávku do archivu
      • 1 - uložit nahrávku do archivu

Nahrávač informuje session, která požadovala nahrávku pomocí těchto zpráv:

  • IM_RECORD_START_OK - nahrávání bylo spuštěno Data zprávy obsahují tyto položky:
    • CID - ID nahravaneho hovoru
    • RID - ID nahrávky
  • IM_RECORD_START_FAIL - nahrávání nebylo spuštěno
    • CID - ID nahravaneho hovoru
    • ERR_CODE - Kód důvodu selhání
      • RR_ALREADY_ACTIVE - Nahravání hovoru na dané lince již probíhá
      • RR_CALL_NOT_CONNECTED - Hovor nebyl spojen, nebylo co nahrávat
      • RR_NO_RESOURCE - Není volný žádný nahrávač
      • RR_FAIL - Selháni HW nebo SW
    • DESC - Text vysvětlující důvod selhání
  • IM_RECORD_FINISH - nahrávání bylo ukončeno
    • CID - ID nahravaneho hovoru
    • RID - ID nahrávky

Navíc jsou pro účely monitoringu a pod. distibuovány tyto notifikační zprávy se stejným obsahem

  • IM_RECORD_REQUEST
  • IM_RECORD_START_OK
  • IM_RECORD_START_FAIL
  • IM_RECORD_FINISH


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ústředny MD110

Dokumentace rozhraní ústředny MD110

Nyní zastarale - pouzivat Dokumentace rozhraní ústředen připojených přes Business Link MD110AgentLib

MD110AgentLib

ProgID: MD110AgentLib.MD110Agent

Konfigurace

Konfigurace je implicitně uložena v registrech HKEY_LOCAL_MACHINE\SOFTWARE\Datasys\CallChange\CSTAAgent. Toto umístění lze změnit použitím parametru "REGISTRY_ROOT" při inicializaci agenta metodou Init.

Jméno položky | Popis | Doporučená hodnota
HostName | Jméno nebo IP adresa Application Linku. |
PortNumber | Číslo portu Application Linku. |
DbgFileName | Cesta a prefix jména souboru logu. |
AgentDbgVerbosity | Úroveň logování agenta. | Normální provoz: 3 Problémy: 3
LayersDbgVerbosity | Úroveň logování komunikačních vrstev. | Normální provoz: 2 Problémy: 3
DbgVerbosity | Úroveň logování všeho ostatního. | Normální provoz: 2 Problémy: 3
FreeAttachingMode | Pokud FreeAttachingMode nemá hodnotu "1", lze monitorovat pouze ty linky, které mají záznam v registru HKEY_LOCAL_MACHINE\SOFTWARE\Datasys\CallChange\CSTAAgent\Lines. |

Úrovně logování

Číslo | Název | Popis
0 | silentVerbosity | nic
1 | criticalVerbosity | kritické, neopravitelné chyby
2 | abnormalVerbosity | nestandardní situace, ale opravitelné (např. ignorované) chyby
3 | standardVerbosity | volání funkcí rozhraní a zpětné volání funkcí
4 | developVerbosity | volání všech (i interních) funkcí
5 | developLowVerbosity | fáze složitějších funkcí
6 | allVerbosity | všechno

Operace

Operace

Parametry

Návratová hodnota (BSTR) Odpovídající CSTA operace Popis
Parametr | Popis
ALTERNATE | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Alternate Call | Prohodí podržený a aktivní hovor. Slučuje funkce HOLD a UNHOLD do jedné.
ACTIVE_CALL | ID aktivního hovoru
ANSWER | CALL | ID hovoru | "0" znamená chybu. | Answer Call | Zvednout vyzvánějící hovor.
CALL_COMPLETION | CALL | ID hovoru | "0" znamená chybu. | Call Completion | Zpracování hovoru, který se nezdařil z důvodu obsazení volaného čísla.
FEATURE | Jedna z hodnot CAMP_ON, CALL_BACK nebo INTRUDE.
CONFERENCE HELD_CALL ID podrženého hovoru (konference) "0" znamená chybu. Conference Call Přidat aktivní hovor do konference.

MD110 podporuje pouze tři účastníky konference.

ACTIVE_CALL | ID aktivního hovoru
CONSULTATION CALL ID aktivního hovoru ID vzniklého hovoru. ID je globálně (i mezi linkami) unikátní.

"0" znamená chybu.

Consultation Call Podržení aktivního hovoru a vytočení konzultačního hovoru. Slučuje funkce HOLD a DIAL do jedné.
NUMBER | číslo volaného
DIAL NUMBER číslo volaného ID vzniklého hovoru. ID musí být globálně (i mezi linkami) unikátní.
"0" znamená chybu. 		Make Call Je vytvořen nový hovor.
DIVERT | CALL | ID hovoru | "0" znamená chybu. | Divert Call | Vyzvánějící hovor je přesměrován.
NUMBER | číslo volaného
MAINTAIN_QUEUE | žádná hodnota (volitelný parametr)
HANGUP | CALL | ID hovoru | "0" znamená chybu. | Clear Connection | Zavěšení hovoru.
HOLD | CALL | ID hovoru | "0" znamená chybu. | Hold Call | Podržení hovoru.
QUERY_DEVICE FEATURE AGENT_STATE, DO_NOT_DISTURB, FORWARD nebo MSG_WAITING. "0" znamená chybu. Query Device Zjistí stav zařízení. Zjištěný stav je oznámen asynchronní událostí LS_???.

Omezení MD110:

  • DO_NOT_DISTURB není podporován
  • FORWARD není podporován
  • MSG_WAITING není podporován
RECONNECT | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Reconnect Call | Zavěšení aktivního hovoru a nárvat k podrženému hovoru. Slučuje funkce HANGUP a UNHOLD do jedné.
ACTIVE_CALL | ID aktivního hovoru
SINGLE_STEP_TRANS CALL ID hovoru "0" znamená chybu. Aktivní hovor je přesměrován. Slučuje funkce CONSULTATION a TRANSFER do jedné.

Omezení MD110:

  • SINGLE_STEP_TRANS není podporován
NUMBER | číslo volaného
MAINTAIN_QUEUE | žádná hodnota (volitelný parametr)
SET_FEATURE DO_NOT_DISTURB ON nebo OFF. "0" znamená chybu. Set Feature Nastavení feature.

Omezení MD110:

  • Jsou podporovány pouze následující typy předávání: IMMEDIATE, BUSY a NO_ANS.
  • Při typu předávání BUSY nebo NO_ANS nesmí být specifikován atribut FORWARD_NUMBER. Bude vždy použit implicitní cíl přesměrování.
  • MSG_WAITING není podporován.
FORWARD_TYPE | IMMEDIATE, BUSY, NO_ANS, BUSY_INT, BUSY_EXT, NO_ANS_INT nebo NO_ANS_EXT.
FORWARD | ON nebo OFF
FORWARD_NUMBER Číslo pro předávání.

(Platná pouze v případě, že FORWARD je ON.)

AGENT_FEATURE | LOGGED_IN, LOGGED_OUT, NOT_READY, READY, WORK_NOT_READY nebo WORK_READY.
AGENT_ID

(Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN nebo LOGGED_OUT.)

AGENT_PASSWORD

Heslo.

(Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN.)

AGENT_GROUP

Číslo ACD skupiny.

(Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN nebo LOGGED_OUT.)

MSG_WAITING | ON nebo OFF
SNAPSHOT_DEVICE | "0" znamená chybu. | Snapshot Device | Zjištění aktivních hovorů na lince.
TRANSFER | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Transfer Call | Přesměrovat podržený hovor na aktivní.
ACTIVE_CALL | ID aktivního hovoru
UNHOLD | CALL | ID hovoru | "0" znamená chybu. | Retrive Call | Návrat k podrženému hovoru.

Pokud se nepodaří operaci úspěšně provést, je vygenerována událost CS_LINE_ERROR (viz kapitolá Události).

Události

Události nad linkou

Událost

Parametry

Popis
Parametr | Popis
LS_AGENT_LOGGED_OFF | AGENT_ID | Nepovinný. | Agent se odhlásil.
AGENT_GROUP | Nepovinný.
LS_AGENT_LOGGED_ON | AGENT_ID | Nepovinný. | Agent se přihlásil.
AGENT_PASSWORD | Nepovinný.
AGENT_GROUP | Nepovinný.
LS_AGENT_STATE | AGENT_STATE | NOT_READY, NULL, READY, WORK_NOT_READY nebo WORK_READY. | Stav agenta.
AGENT_ID | Nepovinný.
LS_ATTACH_ERR | RC | Číselný nebo textový popis chyby. | Chyba při attachnutí linky.
LS_ATTACH_OK | Linka byla úspěšně attachnutá.
LS_DETACH_ERR | RC | Číselný nebo textový popis chyby. | Chyba při detachnutí linky.
LS_DETACH_OK | Linka byla úspěšně detachnutá.
LS_DO_NOT_DISTURB | DO_NOT_DISTURB | ON nebo OFF. | Stav funkce "nerušit".
LS_FORWARD | FORWARD_TYPE | IMMEDIATE, BUSY, NO_ANS, BUSY_INT, BUSY_EXT, NO_ANS_INT nebo NO_ANS_EXT. | Stav přesměrování.
FORWARD | ON nebo OFF
FORWARD_NUMBER | Číslo pro předávání. (Platná pouze v případě, že FORWARD je ON.)
LS_MSG_WAITING | MSG_WAITING | ON nebo OFF. | Stav oznámení o čekající zprávě.
LS_SNAPSHOT index (0, 1, 2, ...) Informace o jednom hovoru:
Parametr | Popis
CALL | ID hovoru
PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
COMPOUND_CALL_STATE
(nepovinný) 		Množina stavů:
Parametr | Popis
index (0, 1, 2, ...) | NULL, INITIATE, ALERTING, CONNECT, HOLD, QUEUED nebo FAIL.
SIMPLE_CALL_STATE
(nepovinný) 		NULL, PENDING, ORIGINATED, DELIVERED, DELIVERED_HELD, RECEIVED, ESTABLISHED, ESTABLISHED_HELD, RECEIVED_ON_HOLD, ESTABLISHED_ON_HOLD, QUEUED, QUEUED_HELD, FAILED, FAILED_HELD.
Seznam aktivních hovorů na daném zařízení.

Události nad hovory

CSTA událost | Událost agenta |  |  |  | Popis
 | Příjemce | Parametry |  |
 |  | Událost | Parametr | Popis
Conferenced | Konzultační hovor na lince provádějící přidání hovoru do konference. | CS_IDLE | CONFERENCE_CALL (nepovinný) | Číslo konferenčního hovoru. | Konzultační hovor byl přidán do konference.
 | Konzultační hovor u zřizovatele a hovory ostatních účastníků. | CS_CONFERENCE | DEVICES | Čísla všech účastníků oddělená znakem "|".
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Connection Cleared | Lince, která byla odpojena. | CS_IDLE |  |  | Zavěšení hovoru.
 | Ostatním linkám, které se na hovoru podíleli. | CS_OTHER_IDLE | NUMBER | Číslo linky, která se odpojila.
Delivered | Volajícímu. | CS_NEWCALL | NUMBER | Číslo volaného. | Volaná linka začala vyzvánět. Vztahuje se i na při přepadnutí vyzvánějícího hovoru z jedné linky na jinou. CN_NEWCALL by měl správně být reakcí na událost Originated, tu ale MD100 neposílá.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
 |  | CS_RINGBACK | NUMBER (nepovinný) | Číslo volaného.
 | Volanému. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Diverted | Původně volané lince. | CS_DIVERTED | NUMBER (nepovinný) | Číslo nově volaného. | Hovor byl přesměrován (ještě před zvednutím). Číslo nového hovoru je shodné s číslem původního hovoru i přesto, že nyní hovor probíhá mezi jinými zařízeními. Volajícímu přijde CSTA událost Delivered (viz víše), jejímž výsledkem je CX událsot CS_RINGBACK.
 |  |  | OTHER_CALL_ID | Číslo nového hovoru.
 |  | CS_IDLE |  |
 | Nově volané lince. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
Established | Volajícímu. | CS_CONNECTED | NUMBER (nepovinný) | Číslo volaného. | Volaný zvedl sluchátko.
 | Volanému. | CS_CONNECTED | NUMBER (nepovinný) | Číslo volajícího.
Failed Event | Lince, na které došlo k chybě. | CS_BUSY (pokud je důvodem obsazení volané linky) |  |  | Na lince došlo k chybě.
 |  | CS_FAILED (pokud je jiný důvod) | CAUSEID | Číslo chyby (hodnota CSTA EventCause).
 |  |  | CAUSE | Popis chyby.
Held | Lince, která podržela hovor. | CS_ONHOLD |  |  | Účastník podržel hovor.
Originated |  |  |  |  | Tuto operaci MD110 neposílá, ale měla by ji posílat ve chvíli, kde je vytočeno číslo, ale volající telefon ještě nezvoní.
Queued | Volajícímu. | CS_RINGBACK | NUMBER (nepovinný) | Číslo volaného. | Nový hovor ve frontě.
 |  |  | QUEUED | Příznak zařazení do fronty.
 | Volanému. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
 |  |  | QUEUED | Příznak zařazení do fronty.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Retrieved | Lince, která obnovila podržený hovor. | CS_RETRIEVED |  |  | Účastník obnovil podržený hovor.
Service Initiated | Lince na které bylo zvednuto sluchátko. | CS_INITIATED | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny. | Bylo zvednuto sluchátko telefonu nebo byl právě probíhající hovor podržen. Na lince je oznamovací tón ústředny. Ústředna vytvořila nový hovor s jedním účastníkem.
Transferred | Lince, která prováděla přesun (pro oba původní hovory). | CS_IDLE | TRANSFERRED_TO (nepovinný) | Číslo druhého hovoru. | Účastník dokončil operaci "transfer". Původní dva hovory se sloučí do jednoho. Čísla hovorů se ale nemění.
 | Linkám, které byly propojeny. | CS_CONNECTEDID (nepovinná) | NUMBER | Číslo druhé strany.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
 | Lince, nad kterou byla operace prováděna. | CS_LINE_ERROR | RC | Číselný nebo textový popis chyby. | Požadovaná operace se nezdařila.
 |  |  | CMD | Požadovaná operace.
 |  |  | PAR | Parametry operace.

Historie

Datum Verze DLL CVS tag Změny
2004-04-07 1.0.0.1
  • Původní verze
2004-05-18 1.0.0.2 MD110_1_0_0_2
  • Úpravy pro přidání kódu pro Siemens do CVS:
    • CSTALink::Layer7 přesunut do prostoru jmen CSTALink::PhaseI.
    • Projekt CSTA přejmenován na PhaseI.
2004-06-15 1.1.0.0 MD110_1_1_0_0
  • Přidána funkce SET_FEATURE.
2004-06-29 1.2.0.0 MD110_1_2_0_0
  • Přidán atribut MAINTAIN_QUEUE pro funkci TRANSWER.
2004-11-30 1.2.0.1 MD110_1_2_0_1
  • Sloučeny větve HEAD a MAINTAIN_QUEUE.
2004-11-30

 1.3.0.0 MD110_1_3_0_0
  • Přidána podpora pro BusinessPhone.
2004-12-08 1.3.1.0 MD110_1_3_1_0
  • Opravena chybová zpráva o nenalezené konfigurační položce PortNumber.
2005-01-04 1.3.1.1 MD110_1_3_1_1
  • Binárky a Boost přidány do CVS.
2005-01-10 2.0.0.0 MD110_2_0_0_0
  • Zpětně nekompatibilní rozhraní ICXAgent2.
  • Konfigurovatelné umístění konfigurace v registrech.
  • Funkce REDIRECT/TRANSFER a TRANSFER2 změněny na DIVERT, SINGLE_STEP_TRANS a TRANSFER.
  • Nové zprávy CS_CONFERENCE a CS_OTHER_IDLE.
2005-01-18 2.0.1.0 MD110_2_0_1_0
  • Opravena chyba v OriginatedEventInfo (callingDevice).
2005-03-04 2.0.2.0 MD110_2_0_2_0
  • Opravena funkce INTRUDE.
2005-04-14 2.1.0 MD110_2_1_0
  • Soubor logu dělený po dnech.
2005-04-19 2.1.1 MD110_2_1_1
  • Opraveny chyby v ASN funkcích isItemSet().
  • Opravena registrace požadavků v invocationsMap.
2005-04-21 2.2.0 MD110_2_2_0
  • Nová funkce QUERY_DEVICE.
  • Nové zprávy:
    • LS_AGENT_LOGGED_OFF
    • LS_AGENT_LOGGED_ON
    • LS_AGENT_STATE
    • LS_DO_NOT_DISTURB
    • LS_FORWARD
    • LS_MSG_WAITING
2005-04-25 2.2.1 MD110_2_2_1
  • onLayer7DivertedEventReceived() - chybné varování v případě, že cílová linka nebyla monitorována.
2004-05-24 2.3.0 MD110_2_3_0
  • Nový parametr PBX_CALL_ID.
  • Změna parametrů CS_CONFERENCE. Seznam účastníků je nyní v parametru DEVICES.
2005-05-27 2.3.1 MD110_2_3_1
  • Oprava chybného dekódování CSTACommonArguments.
2005-05-30 2.3.2 MD110_2_3_2
  • Vylepšeno logování.
2005-05-30 2.3.3 MD110_2_3_3
  • Oprava DetachLine().
2005-06-07 2.5.0 MD110_2_5_0
  • Podpora události Queued.
2005-06-14 2.6.0 MD110_2_6_0
  • Nová funkce SNAPSHOT_DEVICE.
  • Nová konfigurační položka FreeAttachingMode.
2005-07-01 2.6.1 MD110_2_6_1
  • Oprava nestandardního chování QUERY_DEVICE pro feature FORWARD.
2005-08-16 2.7.0 MD110_2_7_0
  • Dynamické ověřování platných linek.
  • Oprava kódování speciálních znaků v parametrech.
2005-08-17 2.7.1 MD110_2_7_1
  • Zasílání CS_NEWCALL i při programovém vytvoření hovoru.
2005-08-18 2.8.0 MD110_2_8_0
  • Nové parametry CONFERENCE_CALL a TRANSFERRED_TO události CS_IDLE.
2005-09-14 2.8.1 MD110_2_8_1
  • Příznak QUEUED má hodnotu 1.
  • Chybné escape sekvence v Params::toString().
2005-10-17 2.9.0 MD110_2_9_0
  • CS_INITIATED
2005-11-23 2.10.0 MD110_2_10_0
  • SET_FEATURE podporuje MSG_WAITING.
  • Oprava konfigurece FreeAttachingMode.
  • Oprava neúspěšného připojení/odpojení linky.
2006-01-16 2.11.0 MD110_2_11_0
  • Přidána vrstva ASNLayer.
2006-01-24 2.11.1 MD110_2_11_1
  • Oprava dekódování parametrů obsahujících escape sekvence.
2006-02-13 2.11.2 MD110_2_11_2
  • ASNLayer - oprava vícenásobného posílání dat.
2006-03-13 2.11.3 MD110_2_11_3
  • Události jsou posílány ze samostatného vlákna. Může řešit problémy se zamrzáním.
2006-03-30 2.11.4 MD110_2_11_4
  • Vylepšeno zamykání na všech vrstvách.
2006-05-03 2.12.0 MD110_2_12_0
  • Do zprávy CS_OFFERING přidán parametr CALLED_NUMBER.
  • Ošetření výjimek v CXAgent::Operate.
2006-05-04 2.12.1 Release-2_12_1
  • Lépe ošetřeno přerušené síťové spojení.


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ústředen připojených přes Business Link

Dokumentace rozhraní ústředen připojených přes Business Link

BLAgentLib

BLAgentLib

ProgID: BLAgentLib.BLAgent

Konfigurace

Konfigurace je implicitně uložena v registrech HKEY_LOCAL_MACHINE\SOFTWARE\Datasys\CallChange\CSTAAgent. Toto umístění lze změnit použitím parametru "REGISTRY_ROOT" při inicializaci agenta metodou Init.

Jméno položky | Popis | Doporučená hodnota
HostName | Jméno nebo IP adresa Application Linku. |
PortNumber | Číslo portu Application Linku. |
DbgFileName | Cesta a prefix jména souboru logu. |
AgentDbgVerbosity | Úroveň logování agenta. | Normální provoz: 3 Problémy: 3
LayersDbgVerbosity | Úroveň logování komunikačních vrstev. | Normální provoz: 2 Problémy: 3
DbgVerbosity | Úroveň logování všeho ostatního. | Normální provoz: 2 Problémy: 3
FreeAttachingMode | Pokud FreeAttachingMode nemá hodnotu "1", lze monitorovat pouze ty linky, které mají záznam v registru HKEY_LOCAL_MACHINE\SOFTWARE\Datasys\CallChange\CSTAAgent\Lines. |

Úrovně logování

Číslo | Název | Popis
0 | silentVerbosity | nic
1 | criticalVerbosity | kritické, neopravitelné chyby
2 | abnormalVerbosity | nestandardní situace, ale opravitelné (např. ignorované) chyby
3 | standardVerbosity | volání funkcí rozhraní a zpětné volání funkcí
4 | developVerbosity | volání všech (i interních) funkcí
5 | developLowVerbosity | fáze složitějších funkcí
6 | allVerbosity | všechno

Operace

Operace | Parametry |  | Návratová hodnota (BSTR) | Odpovídající CSTA operace | Popis
 | Parametr | Popis
ALTERNATE | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Alternate Call | Prohodí podržený a aktivní hovor. Slučuje funkce HOLD a UNHOLD do jedné.
 | ACTIVE_CALL | ID aktivního hovoru
ANSWER | CALL | ID hovoru | "0" znamená chybu. | Answer Call | Zvednout vyzvánějící hovor.
CALL_COMPLETION | CALL | ID hovoru | "0" znamená chybu. | Call Completion | Zpracování hovoru, který se nezdařil z důvodu obsazení volaného čísla.
 | FEATURE | Jedna z hodnot CAMP_ON, CALL_BACK nebo INTRUDE.
CONFERENCE | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Conference Call | Přidat aktivní hovor do konference.
 | ACTIVE_CALL | ID aktivního hovoru
CONSULTATION | CALL | ID aktivního hovoru | ID vzniklého hovoru. ID je globálně (i mezi linkami) unikátní. "0" znamená chybu. | Consultation Call | Podržení aktivního hovoru a vytočení konzultačního hovoru. Slučuje funkce HOLD a DIAL do jedné.
 | NUMBER | číslo volaného
DIAL | NUMBER | číslo volaného | ID vzniklého hovoru. ID musí být globálně (i mezi linkami) unikátní. "0" znamená chybu. | Make Call | Je vytvořen nový hovor.
DIVERT | CALL | ID hovoru | "0" znamená chybu. | Divert Call | Vyzvánějící hovor je přesměrován.
 | NUMBER | číslo volaného
HANGUP | CALL | ID hovoru | "0" znamená chybu. | Clear Connection | Zavěšení hovoru.
HOLD | CALL | ID hovoru | "0" znamená chybu. | Hold Call | Podržení hovoru.
QUERY_DEVICE | FEATURE | AGENT_STATE, DO_NOT_DISTURB, FORWARD nebo MSG_WAITING. | "0" znamená chybu. | Query Device | Zjistí stav zařízení. Zjištěný stav je oznámen asynchronní událostí LS_???. Business Phone podporuje pouze AGENT_STATE a FORWARD.
RECONNECT | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Reconnect Call | Zavěšení aktivního hovoru a nárvat k podrženému hovoru. Slučuje funkce HANGUP a UNHOLD do jedné.
 | ACTIVE_CALL | ID aktivního hovoru
SINGLE_STEP_TRANS | CALL | ID hovoru | "0" znamená chybu. | Divert Call (BusinessPhone používá Divert Call i pro Single Step Trans" z CSTA Phase II) | Aktivní hovor je přesměrován. Slučuje funkce CONSULTATION a TRANSFER do jedné.
 | NUMBER | číslo volaného
SET_FEATURE | DO_NOT_DISTURB | ON nebo OFF. | "0" znamená chybu. | Set Feature | Nastavení feature.
 | FORWARD_TYPE | IMMEDIATE, BUSY, NO_ANS, BUSY_INT, BUSY_EXT, NO_ANS_INT nebo NO_ANS_EXT.
 | FORWARD | ON nebo OFF
 | FORWARD_NUMBER | Číslo pro předávání. (Platná pouze v případě, že FORWARD je ON.)
 | AGENT_FEATURE | LOGGED_IN, LOGGED_OUT, NOT_READY, READY, WORK_NOT_READY nebo WORK_READY.
 | AGENT_ID | (Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN nebo LOGGED_OUT.)
 | AGENT_PASSWORD | Heslo. (Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN.)
 | AGENT_GROUP | Číslo ACD skupiny. (Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN nebo LOGGED_OUT.)
 | MSG_WAITING | ON nebo OFF
SNAPSHOT_DEVICE |  |  | "0" znamená chybu. | Snapshot Device | Zjištění aktivních hovorů na lince.
TRANSFER | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Transfer Call | Přesměrovat podržený hovor na aktivní.
 | ACTIVE_CALL | ID aktivního hovoru
UNHOLD | CALL | ID hovoru | "0" znamená chybu. | Retrive Call | Návrat k podrženému hovoru.

Pokud se nepodaří operaci úspěšně provést, je vygenerována událost CS_LINE_ERROR (viz kapitolá Události).

Události

Události nad linkou

Událost

Parametry

Popis
Parametr | Popis
LS_AGENT_LOGGED_OFF | AGENT_ID | Nepovinný. | Agent se odhlásil.
AGENT_GROUP | Nepovinný.
LS_AGENT_LOGGED_ON | AGENT_ID | Nepovinný. | Agent se přihlásil.
AGENT_PASSWORD | Nepovinný.
AGENT_GROUP | Nepovinný.
LS_AGENT_STATE | AGENT_STATE | NOT_READY, NULL, READY, WORK_NOT_READY nebo WORK_READY. | Stav agenta.
AGENT_ID | Nepovinný.
LS_ATTACH_ERR | RC | Číselný nebo textový popis chyby. | Chyba při attachnutí linky.
LS_ATTACH_OK | Linka byla úspěšně attachnutá.
LS_DETACH_ERR | RC | Číselný nebo textový popis chyby. | Chyba při detachnutí linky.
LS_DETACH_OK | Linka byla úspěšně detachnutá.
LS_DO_NOT_DISTURB | DO_NOT_DISTURB | ON nebo OFF. | Stav funkce "nerušit".
LS_FORWARD | FORWARD_TYPE | IMMEDIATE, BUSY, NO_ANS, BUSY_INT, BUSY_EXT, NO_ANS_INT nebo NO_ANS_EXT. | Stav přesměrování.
FORWARD | ON nebo OFF
FORWARD_NUMBER | Číslo pro předávání. (Platná pouze v případě, že FORWARD je ON.)
LS_MSG_WAITING | MSG_WAITING | ON nebo OFF. | Stav oznámení o čekající zprávě.
LS_SNAPSHOT index (0, 1, 2, ...) Informace o jednom hovoru:
Parametr | Popis
CALL | ID hovoru
PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
COMPOUND_CALL_STATE
(nepovinný) 		Množina stavů:
Parametr | Popis
index (0, 1, 2, ...) | NULL, INITIATE, ALERTING, CONNECT, HOLD, QUEUED nebo FAIL.
SIMPLE_CALL_STATE
(nepovinný) 		NULL, PENDING, ORIGINATED, DELIVERED, DELIVERED_HELD, RECEIVED, ESTABLISHED, ESTABLISHED_HELD, RECEIVED_ON_HOLD, ESTABLISHED_ON_HOLD, QUEUED, QUEUED_HELD, FAILED, FAILED_HELD.
Seznam aktivních hovorů na daném zařízení.

Události nad hovory

CSTA událost | Událost agenta |  |  |  | Popis
 | Příjemce | Parametry |  |
 |  | Událost | Parametr | Popis
Conferenced | Konzultační hovor na lince provádějící přidání hovoru do konference. | CS_IDLE | CONFERENCE_CALL (nepovinný) | Číslo konferenčního hovoru. | Konzultační hovor byl přidán do konference.
 | Konzultační hovor u zřizovatele a hovory ostatních účastníků. | CS_CONFERENCE | DEVICES | Čísla všech účastníků oddělená znakem "|".
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Connection Cleared | Lince, která byla odpojena. | CS_IDLE |  |  | Zavěšení hovoru.
 | Ostatním linkám, které se na hovoru podíleli. | CS_OTHER_IDLE | NUMBER | Číslo linky, která se odpojila.
Delivered | Volajícímu. | CS_NEWCALL | NUMBER | Číslo volaného. | Volaná linka začala vyzvánět. Vztahuje se i na při přepadnutí vyzvánějícího hovoru z jedné linky na jinou. CN_NEWCALL by měl správně být reakcí na událost Originated, tu ale BL neposílá.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
 |  | CS_RINGBACK | NUMBER (nepovinný) | Číslo volaného.
 | Volanému. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Diverted | Původně volané lince. | CS_DIVERTED | NUMBER (nepovinný) | Číslo nově volaného. | Hovor byl přesměrován (ještě před zvednutím). Číslo nového hovoru je shodné s číslem původního hovoru i přesto, že nyní hovor probíhá mezi jinými zařízeními. Volajícímu přijde CSTA událost Delivered (viz víše), jejímž výsledkem je CX událsot CS_RINGBACK.
 |  |  | OTHER_CALL_ID | Číslo nového hovoru.
 |  | CS_IDLE |  |
 | Nově volané lince. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
Established | Volajícímu. | CS_CONNECTED | NUMBER (nepovinný) | Číslo volaného. | Volaný zvedl sluchátko.
 | Volanému. | CS_CONNECTED | NUMBER (nepovinný) | Číslo volajícího.
Failed Event | Lince, na které došlo k chybě. | CS_BUSY (pokud je důvodem obsazení volané linky) |  |  | Na lince došlo k chybě.
 |  | CS_FAILED (pokud je jiný důvod) | CAUSEID | Číslo chyby (hodnota CSTA EventCause).
 |  |  | CAUSE | Popis chyby.
Held | Lince, která podržela hovor. | CS_ONHOLD |  |  | Účastník podržel hovor.
Originated |  |  |  |  | Tuto operaci BL neposílá, ale měla by ji posílat ve chvíli, kde je vytočeno číslo, ale volající telefon ještě nezvoní.
Queued | Volajícímu. | CS_RINGBACK | NUMBER (nepovinný) | Číslo volaného. | Nový hovor ve frontě.
 |  |  | QUEUED | Příznak zařazení do fronty.
 | Volanému. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
 |  |  | QUEUED | Příznak zařazení do fronty.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Retrieved | Lince, která obnovila podržený hovor. | CS_RETRIEVED |  |  | Účastník obnovil podržený hovor.
Service Initiated | Lince na které bylo zvednuto sluchátko. | CS_INITIATED | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny. | Bylo zvednuto sluchátko telefonu nebo byl právě probíhající hovor podržen. Na lince je oznamovací tón ústředny. Ústředna vytvořila nový hovor s jedním účastníkem.
Transferred | Lince, která prováděla přesun (pro oba původní hovory). | CS_IDLE | TRANSFERRED_TO (nepovinný) | Číslo druhého hovoru. | Účastník dokončil operaci "transfer". Původní dva hovory se sloučí do jednoho. Čísla hovorů se ale nemění.
 | Linkám, které byly propojeny. | CS_CONNECTEDID (nepovinná) | NUMBER | Číslo druhé strany.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
 | Lince, nad kterou byla operace prováděna. | CS_LINE_ERROR | RC | Číselný nebo textový popis chyby. | Požadovaná operace se nezdařila.
 |  |  | CMD | Požadovaná operace.
 |  |  | PAR | Parametry operace.

Historie

Datum Verze DLL CVS tag Změny
2004-12-06 1.0.0.0 BL_1_0_0_0
  • První verze vzniklá duplikací MD110AgentLib.
2004-12-08 1.0.1.0 BL_1_0_1_0
  • Opravena chybová zpráva o nenalezené konfigurační položce PortNumber.
2005-04-04 1.0.2.0 BL_1_0_2_0
  • Opravena chybná registrace
2005-01-04 1.2.0.1 BL_1_0_2_1
  • Binárky a Boost přidány do CVS.
2005-01-10 2.0.0.0 BL_2_0_0_0
  • Zpětně nekompatibilní rozhraní ICXAgent2.
  • Konfigurovatelné umístění konfigurace v registrech.
  • Funkce REDIRECT/TRANSFER a TRANSFER2 změněny na DIVERT, SINGLE_STEP_TRANS a TRANSFER.
  • Nové zprávy CS_CONFERENCE a CS_OTHER_IDLE.
2005-01-18 2.0.1.0 BL_2_0_1_0
  • Opravena chyba v OriginatedEventInfo (callingDevice).
2005-03-04 2.0.2.0 BL_2_0_2_0
  • Opravena funkce INTRUDE.
2005-04-14 2.1.0 BL_2_1_0
  • Soubor logu dělený po dnech.
2005-04-19 2.1.1 BL_2_1_1
  • Opraveny chyby v ASN funkcích isItemSet().
  • Opravena registrace požadavků v invocationsMap.
2005-04-21 2.2.0 BL_2_2_0
  • Nová funkce QUERY_DEVICE.
  • Nové zprávy:
    • LS_AGENT_LOGGED_OFF
    • LS_AGENT_LOGGED_ON
    • LS_AGENT_STATE
    • LS_DO_NOT_DISTURB
    • LS_FORWARD
    • LS_MSG_WAITING
2005-04-25 2.2.1 BL_2_2_1
  • onLayer7DivertedEventReceived() - chybné varování v případě, že cílová linka nebyla monitorována.
2004-05-24 2.3.0 BL_2_3_0
  • Nový parametr PBX_CALL_ID.
  • Změna parametrů CS_CONFERENCE. Seznam účastníků je nyní v parametru DEVICES.
2004-05-27 2.3.1 BL_2_3_1
  • Oprava chybného dekódování CSTACommonArguments.
2005-05-30 2.3.2 BL_2_3_2
  • Vylepšeno logování.
2005-06-07 2.5.0 BL_2_5_0
  • Podpora události Queued.
2005-06-14 2.6.0 BL_2_6_0
  • Nová funkce SNAPSHOT_DEVICE.
  • Nová konfigurační položka FreeAttachingMode.
2005-08-16 2.7.0 BL_2_7_0
  • Dynamické ověřování platných linek.
  • Oprava kódování speciálních znaků v parametrech.
2005-08-17 2.7.1 BL_2_7_1
  • Zasílání CS_NEWCALL i při programovém vytvoření hovoru.
2005-08-18 2.8.0 BL_2_8_0
  • Nové parametry CONFERENCE_CALL a TRANSFERRED_TO události CS_IDLE.
2005-09-14 2.8.1 BL_2_8_1
  • Příznak QUEUED má hodnotu 1.
  • Chybné escape sekvence v Params::toString().
2005-10-17 2.9.0 BL_2_9_0
  • CS_INITIATED
2005-11-23 2.10.0 BL_2_10_0
  • SET_FEATURE podporuje MSG_WAITING.
  • Oprava konfigurece FreeAttachingMode.
  • Oprava neúspěšného připojení/odpojení linky.
2006-01-16 2.11.0 BL_2_11_0
  • Přidána vrstva ASNLayer.
2006-01-24 2.11.1 BL_2_11_1
  • Oprava dekódování parametrů obsahujících escape sekvence.
2006-02-13 2.11.2 BL_2_11_2
  • ASNLayer - oprava vícenásobného posílání dat.
2006-03-13 2.11.3 BL_2_11_3
  • Události jsou posílány ze samostatného vlákna. Může řešit problémy se zamrzáním.
2006-03-30 2.11.4 BL_2_11_4
  • Vylepšeno zamykání na všech vrstvách.
2006-05-03 2.12.0 BL_2_12_0
  • Do zprávy CS_OFFERING přidán parametr CALLED_NUMBER.
  • Ošetření výjimek v CXAgent::Operate.
2006-05-04 2.12.1 Release-2_12_1
  • Lépe ošetřeno přerušené síťové spojení.


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ústředen Siemens Hicom

Dokumentace rozhraní ústředen Siemens Hicom

HicomAgentLib

HicomAgentLib

ProgID: HicomAgentLib.HicomAgent

Konfigurace

Konfigurace je implicitně uložena v registrech HKEY_LOCAL_MACHINE\SOFTWARE\Datasys\CallChange\CSTAAgent. Toto umístění lze změnit použitím parametru "REGISTRY_ROOT" při inicializaci agenta metodou Init (uvádí se pouze cesta v klíče HKLM, tj. například "SOFTWARE\Datasys\CallChange\CSTAAgent").

Jméno položky | Popis | Doporučená hodnota
ComName | Jméno sériového portu (např. "com1") |
Layer5Pass | Heslo ústředny pro komunikaci po sériovém portu |
CommBaudRate | Rychlost sériového portu (např. 19200) |
DbgFileName | Cesta a prefix jména souboru logu. |
AgentDbgVerbosity | Úroveň logování agenta. | Normální provoz: 3 Problémy: 3
LayersDbgVerbosity | Úroveň logování komunikačních vrstev. | Normální provoz: 2 Problémy: 3
DbgVerbosity | Úroveň logování všeho ostatního. | Normální provoz: 2 Problémy: 3
FreeAttachingMode | Pokud FreeAttachingMode nemá hodnotu "1", lze monitorovat pouze ty linky, které mají záznam v registru HKEY_LOCAL_MACHINE\SOFTWARE\Datasys\CallChange\CSTAAgent\Lines. |

Úrovně logování

Číslo | Název | Popis
0 | silentVerbosity | nic
1 | criticalVerbosity | kritické, neopravitelné chyby
2 | abnormalVerbosity | nestandardní situace, ale opravitelné (např. ignorované) chyby
3 | standardVerbosity | volání funkcí rozhraní a zpětné volání funkcí
4 | developVerbosity | volání všech (i interních) funkcí
5 | developLowVerbosity | fáze složitějších funkcí
6 | allVerbosity | všechno

Operace

Operace | Parametry |  | Návratová hodnota (BSTR) | Odpovídající CSTA operace | Popis
 | Parametr | Popis
ALTERNATE | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Alternate Call | Prohodí podržený a aktivní hovor. Slučuje funkce HOLD a UNHOLD do jedné.
 | ACTIVE_CALL | ID aktivního hovoru
ANSWER | CALL | ID hovoru | "0" znamená chybu. | Answer Call | Zvednout vyzvánějící hovor.
CALL_COMPLETION | CALL | ID hovoru | "0" znamená chybu. | Call Completion | Zpracování hovoru, který se nezdařil z důvodu obsazení volaného čísla.
 | FEATURE | Jedna z hodnot CAMP_ON, CALL_BACK nebo INTRUDE.
CONFERENCE | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Conference Call | Přidat aktivní hovor do konference.
 | ACTIVE_CALL | ID aktivního hovoru
CONSULTATION | CALL | ID aktivního hovoru | ID vzniklého hovoru. ID je globálně (i mezi linkami) unikátní. "0" znamená chybu. | Consultation Call | Podržení aktivního hovoru a vytočení konzultačního hovoru. Slučuje funkce HOLD a DIAL do jedné.
 | NUMBER | číslo volaného
DIAL | NUMBER | číslo volaného | ID vzniklého hovoru. ID musí být globálně (i mezi linkami) unikátní. "0" znamená chybu. | Make Call | Je vytvořen nový hovor.
DIVERT | CALL | ID hovoru | "0" znamená chybu. | Divert Call | Vyzvánějící hovor je přesměrován.
 | NUMBER | číslo volaného
HANGUP | CALL | ID hovoru | "0" znamená chybu. | Clear Connection | Zavěšení hovoru.
HOLD | CALL | ID hovoru | "0" znamená chybu. | Hold Call | Podržení hovoru. Ústředna tuto funkci podporuje pouze pro externí hovory.
QUERY_DEVICE | FEATURE | AGENT_STATE, DO_NOT_DISTURB, FORWARD nebo MSG_WAITING. | "0" znamená chybu. | Query Device | Zjistí stav zařízení. Zjištěný stav je oznámen asynchronní událostí LS_???.
RECONNECT | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Reconnect Call | Zavěšení aktivního hovoru a nárvat k podrženému hovoru. Slučuje funkce HANGUP a UNHOLD do jedné.
 | ACTIVE_CALL | ID aktivního hovoru
SINGLE_STEP_TRANS | CALL | ID hovoru | "0" znamená chybu. | Single Step Trans | Aktivní hovor je přesměrován. Slučuje funkce CONSULTATION a TRANSFER do jedné.
 | NUMBER | číslo volaného
SET_FEATURE | DO_NOT_DISTURB | ON nebo OFF. | "0" znamená chybu. | Set Feature | Nastavení feature. Ústředna podporuje hodnotu FORWARD_TYPE pouze IMMEDIATE.
 | FORWARD_TYPE | IMMEDIATE, BUSY, NO_ANS, BUSY_INT, BUSY_EXT, NO_ANS_INT, NO_ANS_EXT, IMM_INT nebo IMM_EXT.
 | FORWARD | ON nebo OFF
 | FORWARD_NUMBER | Číslo pro předávání. (Platná pouze v případě, že FORWARD je ON.)
 | AGENT_FEATURE | LOGGED_IN, LOGGED_OUT, NOT_READY, READY, WORK_NOT_READY nebo WORK_READY.
 | AGENT_ID | (Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN nebo LOGGED_OUT.)
 | AGENT_PASSWORD | Heslo. (Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN.)
 | AGENT_GROUP | Číslo ACD skupiny. (Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN nebo LOGGED_OUT.)
 | MSG_WAITING | ON nebo OFF
SNAPSHOT_DEVICE |  |  | "0" znamená chybu. | Snapshot Device | Zjištění aktivních hovorů na lince.
TRANSFER | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Transfer Call | Přesměrovat podržený hovor na aktivní.
 | ACTIVE_CALL | ID aktivního hovoru
UNHOLD | CALL | ID hovoru | "0" znamená chybu. | Retrive Call | Návrat k podrženému hovoru. Ústředna tuto funkci podporuje pouze pro externí hovory.

Pokud se nepodaří operaci úspěšně provést, je vygenerována událost CS_LINE_ERROR (viz kapitolá Události).

Události

Události nad linkou

Událost

Parametry

Popis
Parametr | Popis
LS_AGENT_LOGGED_OFF | AGENT_ID | Nepovinný. | Agent se odhlásil.
AGENT_GROUP | Nepovinný.
LS_AGENT_LOGGED_ON | AGENT_ID | Nepovinný. | Agent se přihlásil.
AGENT_PASSWORD | Nepovinný.
AGENT_GROUP | Nepovinný.
LS_AGENT_STATE | AGENT_STATE | NOT_READY, NULL, READY, WORK_NOT_READY nebo WORK_READY. | Stav agenta.
AGENT_ID | Nepovinný.
LS_ATTACH_ERR | RC | Číselný nebo textový popis chyby. | Chyba při attachnutí linky.
LS_ATTACH_OK | Linka byla úspěšně attachnutá.
LS_DETACH_ERR | RC | Číselný nebo textový popis chyby. | Chyba při detachnutí linky.
LS_DETACH_OK | Linka byla úspěšně detachnutá.
LS_DO_NOT_DISTURB | DO_NOT_DISTURB | ON nebo OFF. | Stav funkce "nerušit".
LS_FORWARD | FORWARD_TYPE | IMMEDIATE, BUSY, NO_ANS, BUSY_INT, BUSY_EXT, NO_ANS_INT, NO_ANS_EXT, IMM_INT nebo IMM_EXT. | Stav přesměrování.
FORWARD | ON nebo OFF
FORWARD_NUMBER | Číslo pro předávání. (Platná pouze v případě, že FORWARD je ON.)
LS_MSG_WAITING | MSG_WAITING | ON nebo OFF. | Stav oznámení o čekající zprávě.
LS_SNAPSHOT index (0, 1, 2, ...) Informace o jednom hovoru:
Parametr | Popis
CALL | ID hovoru
PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
COMPOUND_CALL_STATE
(nepovinný) 		Množina stavů:
Parametr | Popis
index (0, 1, 2, ...) | NULL, INITIATE, ALERTING, CONNECT, HOLD, QUEUED nebo FAIL.
SIMPLE_CALL_STATE
(nepovinný) 		NULL, PENDING, ORIGINATED, DELIVERED, DELIVERED_HELD, RECEIVED, ESTABLISHED, ESTABLISHED_HELD, RECEIVED_ON_HOLD, ESTABLISHED_ON_HOLD, QUEUED, QUEUED_HELD, FAILED, FAILED_HELD.
Seznam aktivních hovorů na daném zařízení.

Události nad hovory

CSTA událost | Událost agenta |  |  |  | Popis
 | Příjemce | Parametry |  |
 |  | Událost | Parametr | Popis
Conferenced | Konzultační hovor na lince provádějící přidání hovoru do konference. | CS_IDLE | CONFERENCE_CALL (nepovinný) | Číslo konferenčního hovoru. | Konzultační hovor byl přidán do konference.
 | Konzultační hovor u zřizovatele a hovory ostatních účastníků. | CS_CONFERENCE | DEVICES | Čísla všech účastníků oddělená znakem "|".
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Connection Cleared | Lince, která byla odpojena. | CS_IDLE |  |  | Zavěšení hovoru.
 | Ostatním linkám, které se na hovoru podíleli. | CS_OTHER_IDLE | NUMBER | Číslo linky, která se odpojila.
Delivered | Volajícímu. | CS_RINGBACK | NUMBER (nepovinný) | Číslo volaného. | Volaná linka začala vyzvánět. Vztahuje se i na při přepadnutí vyzvánějícího hovoru z jedné linky na jinou.
 | Volanému. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Diverted | Původně volané lince. | CS_DIVERTED | NUMBER (nepovinný) | Číslo nově volaného. | Hovor byl přesměrován (ještě před zvednutím). Číslo nového hovoru je shodné s číslem původního hovoru i přesto, že nyní hovor probíhá mezi jinými zařízeními. Volajícímu přijde CSTA událost Delivered (viz víše), jejímž výsledkem je CX událsot CS_RINGBACK.
 |  |  | OTHER_CALL_ID | Číslo nového hovoru.
 |  | CS_IDLE |  |
 | Nově volané lince. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
Established | Volajícímu. | CS_CONNECTED | NUMBER (nepovinný) | Číslo volaného. | Volaný zvedl sluchátko.
 | Volanému. | CS_CONNECTED | NUMBER (nepovinný) | Číslo volajícího.
Failed Event | Lince, na které došlo k chybě. | CS_BUSY (pokud je důvodem obsazení volané linky) |  |  | Na lince došlo k chybě.
 |  | CS_FAILED (pokud je jiný důvod) | CAUSEID | Číslo chyby (hodnota CSTA EventCause).
 |  |  | CAUSE | Popis chyby.
Held | Lince, která podržela hovor. | CS_ONHOLD |  |  | Účastník podržel hovor.
Originated | Volajícímu. | CS_NEWCALL | NUMBER | Číslo volaného. | Bylo vytočeno číslo volaného. Ústředna se snaží připojit volaného účastníka. Volaná linka ještě nevyzvání.
Queued | Volajícímu. | CS_RINGBACK | NUMBER (nepovinný) | Číslo volaného. | Nový hovor ve frontě. Pokud je hovor ve frontě po čase odkloněn na jiné zařízení, hovor přestává být platný, ale ústředna o tomto odklonění neinformuje.
 |  |  | QUEUED | Příznak zařazení do fronty.
 | Volanému. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
 |  |  | QUEUED | Příznak zařazení do fronty.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Retrieved | Lince, která obnovila podržený hovor. | CS_RETRIEVED |  |  | Účastník obnovil podržený hovor.
Service Initiated | Lince na které bylo zvednuto sluchátko. | CS_INITIATED | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny. | Bylo zvednuto sluchátko telefonu nebo byl právě probíhající hovor podržen. Na lince je oznamovací tón ústředny. Ústředna vytvořila nový hovor s jedním účastníkem.
Transferred | Lince, která prováděla přesun (pro oba původní hovory). | CS_IDLE | TRANSFERRED_TO (nepovinný) | Číslo druhého hovoru. | Účastník dokončil operaci "transfer". Původní dva hovory se sloučí do jednoho. Čísla hovorů se ale nemění.
 | Linkám, které byly propojeny. | CS_CONNECTEDID (nepovinná) | NUMBER | Číslo druhé strany.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
 | Lince, nad kterou byla operace prováděna. | CS_LINE_ERROR | RC | Číselný nebo textový popis chyby. | Požadovaná operace se nezdařila.
 |  |  | CMD | Požadovaná operace.
 |  |  | PAR | Parametry operace.

Historie

Datum Verze DLL CVS tag Změny
1.0.0.0
  • První verze.
1.1.0.0
  • Do logu se není zapisuje systémový čas.
1.1.1.0
  • CSTA::ConnectionID - položka "device" opravena na OPTIONAL.
1.2.0.0
  • CCSTAAgent::onLayer7DivertedEventReceived - původnímu účastníkovi hovoru se nyní posílá také událost CS_DIVERTED.
2004-05-18 1.3.0.0 HICOM_1_3_0_0
  • Umístění logu je možné určit nastavením v registrech.
  • První verze v CVS.
  • Úpravy pro přidání kódu do CVS:
    • CSTALink::Layer7 přesunut do prostoru jmen CSTALink::PhaseII.
    • Projekt CSTA přejmenován na PhaseII.
2004-09-16 1.3.1.0 HICOM_1_3_1_0
  • Výjimka v CSTALink::Detail::Layer5::decode() způsobovala zacyklení.
2004-11-30 1.3.1.1 HICOM_1_3_1_1
  • Sloučeny větve HEAD a MAINTAIN_QUEUE.
2004-11-06 1.4.0.0 HICOM_1_4_0_0
  • Přidány funkce ALTERNATE, CALL_COMPLETION, CONFERENCE, CONSULTATION, HOLD, RECONNECT, SET_FEATURE, TRANSFER2, UNHOLD.
2005-01-04 1.4.0.1 HICOM_1_4_0_1
  • Binárky a Boost přidány do CVS.
2005-01-10 2.0.0.0 HICOM_2_0_0_0
  • Zpětně nekompatibilní rozhraní ICXAgent2.
  • Konfigurovatelné umístění konfigurace v registrech.
  • Funkce REDIRECT/TRANSFER a TRANSFER2 změněny na DIVERT, SINGLE_STEP_TRANS a TRANSFER.
  • Nové zprávy CS_CONFERENCE a CS_OTHER_IDLE.
  • Knihovna přejmenována na HicomAgentLib, agent přejmenován na HicomAgent.
2005-03-04 2.0.1.0 HICOM_2_0_1_0
  • Opravena funkce INTRUDE.
2005-04-13 2.1.0 HICOM_2_1_0
  • Soubor logu dělený po dnech.
2005-04-19 2.1.1 HICOM_2_1_1
  • Opraveny chyby v ASN funkcích isItemSet().
  • Opravena registrace požadavků v invocationsMap.
2005-04-21 2.2.0 HICOM_2_2_0
  • Nová funkce QUERY_DEVICE.
  • Nové zprávy:
    • LS_AGENT_LOGGED_OFF
    • LS_AGENT_LOGGED_ON
    • LS_AGENT_STATE
    • LS_DO_NOT_DISTURB
    • LS_FORWARD
    • LS_MSG_WAITING
2005-04-25 2.2.1 HICOM_2_2_1
  • onLayer7DivertedEventReceived() - chybné varování v případě, že cílová linka nebyla monitorována.
2005-05-13 2.3.0 HICOM_2_3_0
  • Přidána podpora pro nový firmware:
    • Rozšířeny hodnoty EventCause.
2004-05-24 2.4.0 HICOM_2_4_0
  • Nový parametr PBX_CALL_ID.
  • Změna parametrů CS_CONFERENCE. Seznam účastníků je nyní v parametru DEVICES.
2005-05-27 2.4.1 HICOM_2_4_1
  • Oprava chybného dekódování CSTACommonArguments.
2005-05-30 2.4.2 HICOM_2_4_2
  • Přidáno dekódování CallInformationEvent.
  • Vylepšeno logování.
2005-06-07 2.5.0 HICOM_2_5_0
  • Podpora události Queued.
2005-06-14 2.6.0 HICOM_2_6_0
  • Nová funkce SNAPSHOT_DEVICE.
  • Nová konfigurační položka FreeAttachingMode.
2005-08-16 2.7.0 HICOM_2_7_0
  • Dynamické ověřování platných linek.
  • Oprava kódování speciálních znaků v parametrech.
2005-08-17 2.7.1 HICOM_2_7_1
  • Zasílání CS_NEWCALL i při programovém vytvoření hovoru.
2005-08-18 2.8.0 HICOM_2_8_0
  • Nové parametry CONFERENCE_CALL a TRANSFERRED_TO události CS_IDLE.
2005-09-14 2.8.1 HICOM_2_8_1
  • Příznak QUEUED má hodnotu 1.
  • Chybné escape sekvence v Params::toString().
2005-10-17 2.9.0 HICOM_2_9_0
  • CS_INITIATED
2005-11-23 2.10.0 HICOM_2_10_0
  • SET_FEATURE podporuje MSG_WAITING.
  • Oprava konfigurece FreeAttachingMode.
  • Oprava neúspěšného připojení/odpojení linky.
2006-01-16 2.11.0 HICOM_2_11_0
  • Přidána vrstva ASNLayer.
2006-01-24 2.11.1 HICOM_2_11_1
  • Oprava dekódování parametrů obsahujících escape sekvence.
2006-02-13 2.11.2 HICOM_2_11_2
  • ASNLayer - oprava vícenásobného posílání dat.
2006-03-13 2.11.3 HICOM_2_11_3
  • Události jsou posílány ze samostatného vlákna. Může řešit problémy se zamrzáním.
2006-03-30 2.11.4 HICOM_2_11_4
  • Vylepšeno zamykání na všech vrstvách.
2006-05-03 2.12.0 HICOM_2_12_0
  • Do zprávy CS_OFFERING přidán parametr CALLED_NUMBER.
  • Ošetření výjimek v CXAgent::Operate.
2006-05-15 2.12.1 HICOM_2_12_1
  • Opraven timeout pro připojení k ústředně.


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ústředen Siemens Cap

Dokumentace rozhraní ústředen Siemens Cap

SiemensCapAgentLib

SiemensCapAgentLib

ProgID: SiemensCapAgentLib.SiemensCapAgent

Konfigurace

Konfigurace je implicitně uložena v registrech HKEY_LOCAL_MACHINE\SOFTWARE\Datasys\CallChange\CSTAAgent. Toto umístění lze změnit použitím parametru "REGISTRY_ROOT" při inicializaci agenta metodou Init.

Jméno položky | Popis | Doporučená hodnota
HostName | Jméno nebo IP adresa Application Linku. |
PortNumber | Číslo portu Application Linku. |
DbgFileName | Cesta a prefix jména souboru logu. |
AgentDbgVerbosity | Úroveň logování agenta. | Normální provoz: 3 Problémy: 3
LayersDbgVerbosity | Úroveň logování komunikačních vrstev. | Normální provoz: 2 Problémy: 3
DbgVerbosity | Úroveň logování všeho ostatního. | Normální provoz: 2 Problémy: 3
FreeAttachingMode | Pokud FreeAttachingMode nemá hodnotu "1", lze monitorovat pouze ty linky, které mají záznam v registru HKEY_LOCAL_MACHINE\SOFTWARE\Datasys\CallChange\CSTAAgent\Lines. |

Úrovně logování

Číslo | Název | Popis
0 | silentVerbosity | nic
1 | criticalVerbosity | kritické, neopravitelné chyby
2 | abnormalVerbosity | nestandardní situace, ale opravitelné (např. ignorované) chyby
3 | standardVerbosity | volání funkcí rozhraní a zpětné volání funkcí
4 | developVerbosity | volání všech (i interních) funkcí
5 | developLowVerbosity | fáze složitějších funkcí
6 | allVerbosity | všechno

Operace

Operace

Parametry

Návratová hodnota (BSTR) Odpovídající CSTA operace Popis
Parametr | Popis
ALTERNATE | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Alternate Call | Prohodí podržený a aktivní hovor. Slučuje funkce HOLD a UNHOLD do jedné.
ACTIVE_CALL | ID aktivního hovoru
ANSWER | CALL | ID hovoru | "0" znamená chybu. | Answer Call | Zvednout vyzvánějící hovor.
CALL_COMPLETION | CALL | ID hovoru | "0" znamená chybu. | Call Completion | Zpracování hovoru, který se nezdařil z důvodu obsazení volaného čísla.
FEATURE | Jedna z hodnot CAMP_ON, CALL_BACK nebo INTRUDE.
CONFERENCE | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Conference Call | Přidat aktivní hovor do konference.
ACTIVE_CALL | ID aktivního hovoru
CONSULTATION CALL ID aktivního hovoru ID vzniklého hovoru. ID je globálně (i mezi linkami) unikátní.

"0" znamená chybu.

Consultation Call Podržení aktivního hovoru a vytočení konzultačního hovoru. Slučuje funkce HOLD a DIAL do jedné.
NUMBER | číslo volaného
DIAL NUMBER číslo volaného ID vzniklého hovoru. ID musí být globálně (i mezi linkami) unikátní.
"0" znamená chybu. 		Make Call Je vytvořen nový hovor.
DIVERT | CALL | ID hovoru | "0" znamená chybu. | Divert Call | Vyzvánějící hovor je přesměrován.
NUMBER | číslo volaného
HANGUP | CALL | ID hovoru | "0" znamená chybu. | Clear Connection | Zavěšení hovoru.
HOLD | CALL | ID hovoru | "0" znamená chybu. | Hold Call | Podržení hovoru.
QUERY_DEVICE FEATURE AGENT_STATE, DO_NOT_DISTURB, FORWARD nebo MSG_WAITING. "0" znamená chybu. Query Device Zjistí stav zařízení. Zjištěný stav je oznámen asynchronní událostí LS_???.

HiPass 4000 nepodporuje:

  • AGENT_STATE
  • MSG_WAITING
RECONNECT | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Reconnect Call | Zavěšení aktivního hovoru a nárvat k podrženému hovoru. Slučuje funkce HANGUP a UNHOLD do jedné.
ACTIVE_CALL | ID aktivního hovoru
SINGLE_STEP_TRANS | CALL | ID hovoru | "0" znamená chybu. | Divert Call (BusinessPhone používá Divert Call i pro Single Step Trans" z CSTA Phase II) | Aktivní hovor je přesměrován. Slučuje funkce CONSULTATION a TRANSFER do jedné.
NUMBER | číslo volaného
SET_FEATURE DO_NOT_DISTURB ON nebo OFF. "0" znamená chybu. Set Feature Nastavení feature.

HiPass 4000 nepodporuje:

  • FORWARD_TYPE: BUSY_INT, BUSY_EXT, NO_ANS_INT, NO_ANS_EXT
  • MSG_WAITING
FORWARD_TYPE | IMMEDIATE, BUSY, NO_ANS, BUSY_INT, BUSY_EXT, NO_ANS_INT nebo NO_ANS_EXT.
FORWARD | ON nebo OFF
FORWARD_NUMBER Číslo pro předávání.

(Platná pouze v případě, že FORWARD je ON.)

AGENT_FEATURE | LOGGED_IN, LOGGED_OUT, NOT_READY, READY, WORK_NOT_READY nebo WORK_READY.
AGENT_ID | (Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN nebo LOGGED_OUT.)
AGENT_PASSWORD Heslo.

(Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN.)

AGENT_GROUP Číslo ACD skupiny.

(Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN nebo LOGGED_OUT.)

MSG_WAITING | ON nebo OFF
SNAPSHOT_DEVICE | "0" znamená chybu. | Snapshot Device | Zjištění aktivních hovorů na lince.
TRANSFER | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Transfer Call | Přesměrovat podržený hovor na aktivní.
ACTIVE_CALL | ID aktivního hovoru
UNHOLD | CALL | ID hovoru | "0" znamená chybu. | Retrive Call | Návrat k podrženému hovoru.

Pokud se nepodaří operaci úspěšně provést, je vygenerována událost CS_LINE_ERROR (viz kapitolá Události).

Události

Události nad linkou

Událost

Parametry

Popis
Parametr | Popis
LS_AGENT_LOGGED_OFF | AGENT_ID | Nepovinný. | Agent se odhlásil.
AGENT_GROUP | Nepovinný.
LS_AGENT_LOGGED_ON | AGENT_ID | Nepovinný. | Agent se přihlásil.
AGENT_PASSWORD | Nepovinný.
AGENT_GROUP | Nepovinný.
LS_AGENT_STATE | AGENT_STATE | NOT_READY, NULL, READY, WORK_NOT_READY nebo WORK_READY. | Stav agenta.
AGENT_ID | Nepovinný.
LS_ATTACH_ERR | RC | Číselný nebo textový popis chyby. | Chyba při attachnutí linky.
LS_ATTACH_OK | Linka byla úspěšně attachnutá.
LS_DETACH_ERR | RC | Číselný nebo textový popis chyby. | Chyba při detachnutí linky.
LS_DETACH_OK | Linka byla úspěšně detachnutá.
LS_DO_NOT_DISTURB | DO_NOT_DISTURB | ON nebo OFF. | Stav funkce "nerušit".
LS_FORWARD | FORWARD_TYPE | IMMEDIATE, BUSY, NO_ANS, BUSY_INT, BUSY_EXT, NO_ANS_INT nebo NO_ANS_EXT. | Stav přesměrování.
FORWARD | ON nebo OFF
FORWARD_NUMBER | Číslo pro předávání. (Platná pouze v případě, že FORWARD je ON.)
LS_MSG_WAITING | MSG_WAITING | ON nebo OFF. | Stav oznámení o čekající zprávě.
LS_SNAPSHOT index (0, 1, 2, ...) Informace o jednom hovoru:
Parametr | Popis
CALL | ID hovoru
PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
COMPOUND_CALL_STATE
(nepovinný) 		Množina stavů:
Parametr | Popis
index (0, 1, 2, ...) | NULL, INITIATE, ALERTING, CONNECT, HOLD, QUEUED nebo FAIL.
SIMPLE_CALL_STATE
(nepovinný) 		NULL, PENDING, ORIGINATED, DELIVERED, DELIVERED_HELD, RECEIVED, ESTABLISHED, ESTABLISHED_HELD, RECEIVED_ON_HOLD, ESTABLISHED_ON_HOLD, QUEUED, QUEUED_HELD, FAILED, FAILED_HELD.
Seznam aktivních hovorů na daném zařízení.

Události nad hovory

CSTA událost | Událost agenta |  |  |  | Popis
 | Příjemce | Parametry |  |
 |  | Událost | Parametr | Popis
Conferenced | Konzultační hovor na lince provádějící přidání hovoru do konference. | CS_IDLE | CONFERENCE_CALL (nepovinný) | Číslo konferenčního hovoru. | Konzultační hovor byl přidán do konference.
 | Konzultační hovor u zřizovatele a hovory ostatních účastníků. | CS_CONFERENCE | DEVICES | Čísla všech účastníků oddělená znakem "|".
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Connection Cleared | Lince, která byla odpojena. | CS_IDLE |  |  | Zavěšení hovoru.
 | Ostatním linkám, které se na hovoru podíleli. | CS_OTHER_IDLE | NUMBER | Číslo linky, která se odpojila.
Delivered | Volajícímu. | CS_NEWCALL | NUMBER | Číslo volaného. | Volaná linka začala vyzvánět. Vztahuje se i na při přepadnutí vyzvánějícího hovoru z jedné linky na jinou. CN_NEWCALL by měl správně být reakcí na událost Originated, tu ale BL neposílá.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
 |  | CS_RINGBACK | NUMBER (nepovinný) | Číslo volaného.
 | Volanému. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Diverted | Původně volané lince. | CS_DIVERTED | NUMBER (nepovinný) | Číslo nově volaného. | Hovor byl přesměrován (ještě před zvednutím). Číslo nového hovoru je shodné s číslem původního hovoru i přesto, že nyní hovor probíhá mezi jinými zařízeními. Volajícímu přijde CSTA událost Delivered (viz víše), jejímž výsledkem je CX událsot CS_RINGBACK.
 |  |  | OTHER_CALL_ID | Číslo nového hovoru.
 |  | CS_IDLE |  |
 | Nově volané lince. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
Established | Volajícímu. | CS_CONNECTED | NUMBER (nepovinný) | Číslo volaného. | Volaný zvedl sluchátko.
 | Volanému. | CS_CONNECTED | NUMBER (nepovinný) | Číslo volajícího.
Failed Event | Lince, na které došlo k chybě. | CS_BUSY (pokud je důvodem obsazení volané linky) |  |  | Na lince došlo k chybě.
 |  | CS_FAILED (pokud je jiný důvod) | CAUSEID | Číslo chyby (hodnota CSTA EventCause).
 |  |  | CAUSE | Popis chyby.
Held | Lince, která podržela hovor. | CS_ONHOLD |  |  | Účastník podržel hovor.
Originated |  |  |  |  | Tuto operaci BL neposílá, ale měla by ji posílat ve chvíli, kde je vytočeno číslo, ale volající telefon ještě nezvoní.
Queued | Volajícímu. | CS_RINGBACK | NUMBER (nepovinný) | Číslo volaného. | Nový hovor ve frontě.
 |  |  | QUEUED | Příznak zařazení do fronty.
 | Volanému. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
 |  |  | QUEUED | Příznak zařazení do fronty.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Retrieved | Lince, která obnovila podržený hovor. | CS_RETRIEVED |  |  | Účastník obnovil podržený hovor.
Service Initiated | Lince na které bylo zvednuto sluchátko. | CS_INITIATED | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny. | Bylo zvednuto sluchátko telefonu nebo byl právě probíhající hovor podržen. Na lince je oznamovací tón ústředny. Ústředna vytvořila nový hovor s jedním účastníkem.
Transferred | Lince, která prováděla přesun (pro oba původní hovory). | CS_IDLE | TRANSFERRED_TO (nepovinný) | Číslo druhého hovoru. | Účastník dokončil operaci "transfer". Původní dva hovory se sloučí do jednoho. Čísla hovorů se ale nemění.
 | Linkám, které byly propojeny. | CS_CONNECTEDID (nepovinná) | NUMBER | Číslo druhé strany.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
 | Lince, nad kterou byla operace prováděna. | CS_LINE_ERROR | RC | Číselný nebo textový popis chyby. | Požadovaná operace se nezdařila.
 |  |  | CMD | Požadovaná operace.
 |  |  | PAR | Parametry operace.

Historie

Datum Verze DLL CVS tag Změny
2006-01-16 2.11.0 SIEMENS_CAP_2_11_0
  • První verze (číslo verze shodné s ostatními CSTA agenty)
2006-01-24 2.11.1 SIEMENS_CAP_2_11_1
  • Oprava dekódování parametrů obsahujících escape sekvence.
2006-02-13 2.11.2 SIEMENS_CAP_2_11_2
  • ASNLayer - oprava vícenásobného posílání dat.
2006-03-13 2.11.3 SIEMENS_CAP_2_11_3
  • Události jsou posílány ze samostatného vlákna. Může řešit problémy se zamrzáním.
2006-03-30 2.11.4 SIEMENS_CAP_2_11_4
  • Vylepšeno zamykání na všech vrstvách.
2006-05-03 2.12.0 SIEMENS_CAP_2_12_0
  • Do zprávy CS_OFFERING přidán parametr CALLED_NUMBER.
  • Ošetření výjimek v CXAgent::Operate.
2006-05-04 2.12.1 Release-2_12_1
  • Lépe ošetřeno přerušené síťové spojení.


Aplikační rozhraní systému CallChange: Dokumentace rozhraní ústředen OmniPCX4400

Dokumentace rozhraní ústředen OmniPCX4400

OmniPCX4400AgentLib

OmniPCX4400AgentLib

ProgID: OmniPCX4400AgentLib.OmniPCX4400Agent

Konfigurace

Konfigurace je implicitně uložena v registrech HKEY_LOCAL_MACHINE\SOFTWARE\Datasys\CallChange\CSTAAgent. Toto umístění lze změnit použitím parametru "REGISTRY_ROOT" při inicializaci agenta metodou Init.

Jméno položky | Popis | Doporučená hodnota
HostName | Jméno nebo IP adresa ústředny. |
PortNumber | Číslo portu ústředny. |
DbgFileName | Cesta a prefix jména souboru logu. |
AgentDbgVerbosity | Úroveň logování agenta. | Normální provoz: 3 Problémy: 3
LayersDbgVerbosity | Úroveň logování komunikačních vrstev. | Normální provoz: 2 Problémy: 3
DbgVerbosity | Úroveň logování všeho ostatního. | Normální provoz: 2 Problémy: 3
FreeAttachingMode | Pokud FreeAttachingMode nemá hodnotu "1", lze monitorovat pouze ty linky, které mají záznam v registru HKEY_LOCAL_MACHINE\SOFTWARE\Datasys\CallChange\CSTAAgent\Lines. |

Úrovně logování

Číslo | Název | Popis
0 | silentVerbosity | nic
1 | criticalVerbosity | kritické, neopravitelné chyby
2 | abnormalVerbosity | nestandardní situace, ale opravitelné (např. ignorované) chyby
3 | standardVerbosity | volání funkcí rozhraní a zpětné volání funkcí
4 | developVerbosity | volání všech (i interních) funkcí
5 | developLowVerbosity | fáze složitějších funkcí
6 | allVerbosity | všechno

Operace

Operace

Parametry

Návratová hodnota (BSTR) Odpovídající CSTA operace Popis
Parametr | Popis
ALTERNATE | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Alternate Call | Prohodí podržený a aktivní hovor. Slučuje funkce HOLD a UNHOLD do jedné.
ACTIVE_CALL | ID aktivního hovoru
ANSWER | CALL | ID hovoru | "0" znamená chybu. | Answer Call | Zvednout vyzvánějící hovor.
CONFERENCE | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Conference Call | Přidat aktivní hovor do konference.
ACTIVE_CALL | ID aktivního hovoru
CONSULTATION CALL ID aktivního hovoru ID vzniklého hovoru. ID je globálně (i mezi linkami) unikátní.

"0" znamená chybu.

Consultation Call Podržení aktivního hovoru a vytočení konzultačního hovoru. Slučuje funkce HOLD a DIAL do jedné.
NUMBER | číslo volaného
DIAL NUMBER číslo volaného ID vzniklého hovoru. ID musí být globálně (i mezi linkami) unikátní.
"0" znamená chybu. 		Make Call Je vytvořen nový hovor.
DIVERT | CALL | ID hovoru | "0" znamená chybu. | Divert Call | Vyzvánějící hovor je přesměrován.
NUMBER | číslo volaného
HANGUP | CALL | ID hovoru | "0" znamená chybu. | Clear Connection | Zavěšení hovoru.
HOLD | CALL | ID hovoru | "0" znamená chybu. | Hold Call | Podržení hovoru.
QUERY_DEVICE FEATURE AGENT_STATE, DO_NOT_DISTURB, FORWARD nebo MSG_WAITING. "0" znamená chybu. Query Device Zjistí stav zařízení. Zjištěný stav je oznámen asynchronní událostí LS_???.

Omezení OmniPCX 4400:

  • DO_NOT_DISTURB není podporován
  • FORWARD není podporován
  • MSG_WAITING není podporován
RECONNECT | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Reconnect Call | Zavěšení aktivního hovoru a nárvat k podrženému hovoru. Slučuje funkce HANGUP a UNHOLD do jedné.
ACTIVE_CALL | ID aktivního hovoru
SET_FEATURE FORWARD_TYPE IMMEDIATE "0" znamená chybu. Set Feature Nastavení feature.

Omezení OmniPCX 4400:

  • DO_NOT_DISTURB není podporován
  • FORWARD není podporován
  • MSG_WAITING není podporován
FORWARD | ON nebo OFF
FORWARD_NUMBER Číslo pro předávání.

(Platná pouze v případě, že FORWARD je ON.)

AGENT_FEATURE | LOGGED_IN, LOGGED_OUT, NOT_READY, READY, WORK_NOT_READY nebo WORK_READY.
AGENT_ID

(Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN nebo LOGGED_OUT.)

AGENT_PASSWORD

Heslo.

(Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN.)

AGENT_GROUP

Číslo ACD skupiny.

(Platná pouze v případě, že AGENT_FEAUTRE je LOGGED_IN nebo LOGGED_OUT.)

MSG_WAITING | ON nebo OFF
SINGLE_STEP_TRANS CALL ID hovoru "0" znamená chybu. Aktivní hovor je přesměrován. Slučuje funkce CONSULTATION a TRANSFER do jedné.

Omezení OmniPCX 4400:

  • SINGLE_STEP_TRANS není podporován
NUMBER | číslo volaného
MAINTAIN_QUEUE | žádná hodnota (volitelný parametr)
SNAPSHOT_DEVICE | "0" znamená chybu. | Snapshot Device | Zjištění aktivních hovorů na lince.
TRANSFER | HELD_CALL | ID podrženého hovoru (konference) | "0" znamená chybu. | Transfer Call | Přesměrovat podržený hovor na aktivní.
ACTIVE_CALL | ID aktivního hovoru
UNHOLD | CALL | ID hovoru | "0" znamená chybu. | Retrive Call | Návrat k podrženému hovoru.

Pokud se nepodaří operaci úspěšně provést, je vygenerována událost CS_LINE_ERROR (viz kapitolá Události).

Události

Události nad linkou

Událost

Parametry

Popis
Parametr | Popis
LS_AGENT_LOGGED_OFF | AGENT_ID | Nepovinný. | Agent se odhlásil.
AGENT_GROUP | Nepovinný.
LS_AGENT_LOGGED_ON | AGENT_ID | Nepovinný. | Agent se přihlásil.
AGENT_PASSWORD | Nepovinný.
AGENT_GROUP | Nepovinný.
LS_AGENT_STATE | AGENT_STATE | NOT_READY, NULL, READY, WORK_NOT_READY nebo WORK_READY. | Stav agenta.
AGENT_ID | Nepovinný.
LS_ATTACH_ERR | RC | Číselný nebo textový popis chyby. | Chyba při attachnutí linky.
LS_ATTACH_OK | Linka byla úspěšně attachnutá.
LS_DETACH_ERR | RC | Číselný nebo textový popis chyby. | Chyba při detachnutí linky.
LS_DETACH_OK | Linka byla úspěšně detachnutá.
LS_DO_NOT_DISTURB | DO_NOT_DISTURB | ON nebo OFF. | Stav funkce "nerušit".
LS_FORWARD | FORWARD_TYPE | IMMEDIATE, BUSY, NO_ANS, BUSY_INT, BUSY_EXT, NO_ANS_INT, NO_ANS_EXT, IMM_INT nebo IMM_EXT. | Stav přesměrování.
FORWARD | ON nebo OFF
FORWARD_NUMBER | Číslo pro předávání. (Platná pouze v případě, že FORWARD je ON.)
LS_MSG_WAITING | MSG_WAITING | ON nebo OFF. | Stav oznámení o čekající zprávě.
LS_SNAPSHOT index (0, 1, 2, ...) Informace o jednom hovoru:
Parametr | Popis
CALL | ID hovoru
PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
COMPOUND_CALL_STATE
(nepovinný) 		Množina stavů:
Parametr | Popis
index (0, 1, 2, ...) | NULL, INITIATE, ALERTING, CONNECT, HOLD, QUEUED nebo FAIL.
SIMPLE_CALL_STATE
(nepovinný) 		NULL, PENDING, ORIGINATED, DELIVERED, DELIVERED_HELD, RECEIVED, ESTABLISHED, ESTABLISHED_HELD, RECEIVED_ON_HOLD, ESTABLISHED_ON_HOLD, QUEUED, QUEUED_HELD, FAILED, FAILED_HELD.
Seznam aktivních hovorů na daném zařízení.

Události nad hovory

CSTA událost | Událost agenta |  |  |  | Popis
 | Příjemce | Parametry |  |
 |  | Událost | Parametr | Popis
Conferenced | Konzultační hovor na lince provádějící přidání hovoru do konference. | CS_IDLE | CONFERENCE_CALL (nepovinný) | Číslo konferenčního hovoru. | Konzultační hovor byl přidán do konference.
 | Konzultační hovor u zřizovatele a hovory ostatních účastníků. | CS_CONFERENCE | DEVICES | Čísla všech účastníků oddělená znakem "|".
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Connection Cleared | Lince, která byla odpojena. | CS_IDLE |  |  | Zavěšení hovoru.
 | Ostatním linkám, které se na hovoru podíleli. | CS_OTHER_IDLE | NUMBER | Číslo linky, která se odpojila.
Delivered | Volajícímu. | CS_RINGBACK | NUMBER (nepovinný) | Číslo volaného. | Volaná linka začala vyzvánět. Vztahuje se i na při přepadnutí vyzvánějícího hovoru z jedné linky na jinou.
 | Volanému. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Diverted | Původně volané lince. | CS_DIVERTED | NUMBER (nepovinný) | Číslo nově volaného. | Hovor byl přesměrován (ještě před zvednutím). Číslo nového hovoru je shodné s číslem původního hovoru i přesto, že nyní hovor probíhá mezi jinými zařízeními. Volajícímu přijde CSTA událost Delivered (viz víše), jejímž výsledkem je CX událsot CS_RINGBACK.
 |  |  | OTHER_CALL_ID | Číslo nového hovoru.
 |  | CS_IDLE |  |
 | Nově volané lince. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
Established | Volajícímu. | CS_CONNECTED | NUMBER (nepovinný) | Číslo volaného. | Volaný zvedl sluchátko.
 | Volanému. | CS_CONNECTED | NUMBER (nepovinný) | Číslo volajícího.
Failed Event | Lince, na které došlo k chybě. | CS_BUSY (pokud je důvodem obsazení volané linky) |  |  | Na lince došlo k chybě.
 |  | CS_FAILED (pokud je jiný důvod) | CAUSEID | Číslo chyby (hodnota CSTA EventCause).
 |  |  | CAUSE | Popis chyby.
Held | Lince, která podržela hovor. | CS_ONHOLD |  |  | Účastník podržel hovor.
Originated | Volajícímu. | CS_NEWCALL | NUMBER | Číslo volaného. | Bylo vytočeno číslo volaného. Ústředna se snaží připojit volaného účastníka. Volaná linka ještě nevyzvání.
Queued | Volajícímu. | CS_RINGBACK | NUMBER (nepovinný) | Číslo volaného. | Nový hovor ve frontě.
 |  |  | QUEUED | Příznak zařazení do fronty.
 | Volanému. | CS_OFFERING | NUMBER (nepovinný) | Číslo volajícího.
 |  |  | QUEUED | Příznak zařazení do fronty.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
Retrieved | Lince, která obnovila podržený hovor. | CS_RETRIEVED |  |  | Účastník obnovil podržený hovor.
Service Initiated | Lince na které bylo zvednuto sluchátko. | CS_INITIATED | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny. | Bylo zvednuto sluchátko telefonu nebo byl právě probíhající hovor podržen. Na lince je oznamovací tón ústředny. Ústředna vytvořila nový hovor s jedním účastníkem.
Transferred | Lince, která prováděla přesun (pro oba původní hovory). | CS_IDLE | TRANSFERRED_TO (nepovinný) | Číslo druhého hovoru. | Účastník dokončil operaci "transfer". Původní dva hovory se sloučí do jednoho. Čísla hovorů se ale nemění.
 | Linkám, které byly propojeny. | CS_CONNECTEDID (nepovinná) | NUMBER | Číslo druhé strany.
 |  |  | PBX_CALL_ID | Interní identifikátor hovoru dle ústředny.
 | Lince, nad kterou byla operace prováděna. | CS_LINE_ERROR | RC | Číselný nebo textový popis chyby. | Požadovaná operace se nezdařila.
 |  |  | CMD | Požadovaná operace.
 |  |  | PAR | Parametry operace.

Historie

Datum Verze DLL CVS tag Změny
2006-01-16 2.11.0 OMNIPCX4400_2_11_0
  • První verze (číslo verze shodné s ostatními CSTA agenty)
2006-01-24 2.11.1 OMNIPCX4400_2_11_1
  • Oprava dekódování parametrů obsahujících escape sekvence.
2006-02-13 2.11.2 OMNIPCX4400_2_11_2
  • ASNLayer - oprava vícenásobného posílání dat.
2006-03-13 2.11.3 OMNIPCX4400_2_11_3
  • Události jsou posílány ze samostatného vlákna. Může řešit problémy se zamrzáním.
2006-03-30 2.11.4 OMNIPCX4400_2_11_4
  • Vylepšeno zamykání na všech vrstvách.
2006-05-03 2.12.0 OMNIPCX4400_2_12_0
  • Do zprávy CS_OFFERING přidán parametr CALLED_NUMBER.
  • Ošetření výjimek v CXAgent::Operate.
  • Oprava ukončování sessionInitLayer.
  • Oprava volitelných položek AARQ_apdu.
2006-05-04 2.12.1 Release-2_12_1
  • Lépe ošetřeno přerušené síťové spojení.


Aplikační rozhraní systému CallChange: Příklady použití rozhraní ústředen

Příklady použití rozhraní ústředen

CSTAAgent - Příklady

CSTAAgent - Příklady

Monitorované zařízení: 601

ALTERNATE | 651 volá 601 | Event: LineId = "601", CallId = "1", MsgType = "CS_OFFERING", Params = "NUMBER=651"
601 zvedne | Event: LineId = "601", CallId = "1", MsgType = "CS_CONNECTED", Params = "NUMBER=651"
601 volá 602 na druhé lince Event: LineId = "601", CallId = "1", MsgType = "CS_ONHOLD", Params = ""
Event: LineId = "601", CallId = "2", MsgType = "CS_NEWCALL", Params = "NUMBER=602"
Event: LineId = "601", CallId = "2", MsgType = "CS_RINGBACK", Params = "NUMBER=602"
602 zvedne | Event: LineId = "601", CallId = "2", MsgType = "CS_CONNECTED", Params = "NUMBER=602"
602 změní aktivní hovor Operate(Line = "601", Command = "ALTERNATE", Params = "HELD_CALL=1|ACTIVE_CALL=2") = { Result = "1", Error = "OK" }
Event: LineId = "601", CallId = "2", MsgType = "CS_ONHOLD", Params = ""
Event: LineId = "601", CallId = "1", MsgType = "CS_RETRIEVED", Params = ""
ANSWER | 651 volá 601 | Event: LineId = "601", CallId = "3", MsgType = "CS_OFFERING", Params = "NUMBER=651"
601 zvedne Operate(Line = "601", Command = "ANSWER", Params = "CALL=3") = { Result = "1", Error = "OK" }
Event: LineId = "601", CallId = "3", MsgType = "CS_CONNECTED", Params = "NUMBER=651"
CALL_COMPLETION 651 volá obsazenou 601 Operate(Line = "601", Command = "DIAL", Params = "NUMBER=602") = { Result = "4", Error = "OK" }
Event: LineId = "601", CallId = "4", MsgType = "CS_BUSY", Params = ""
601 žádá o zpětné zavolání Operate(Line = "601", Command = "CALL_COMPLETION", Params = "CALL=1|FEATURE=CALL_BACK") = { Result = "1", Error = "OK" }
Event: LineId = "601", CallId = "1", MsgType = "CS_IDLE", Params = ""
CONFERENCE | 651 volá 601 | Event: LineId = "601", CallId = "1", MsgType = "CS_OFFERING", Params = "NUMBER=651"
601 zvedne | Event: LineId = "601", CallId = "1", MsgType = "CS_CONNECTED", Params = "NUMBER=651"
601 volá 602 na druhé lince Event: LineId = "601", CallId = "1", MsgType = "CS_ONHOLD", Params = ""
Event: LineId = "601", CallId = "2", MsgType = "CS_NEWCALL", Params = "NUMBER=602"
Event: LineId = "601", CallId = "2", MsgType = "CS_RINGBACK", Params = "NUMBER=602"
602 zvedne | Event: LineId = "601", CallId = "2", MsgType = "CS_CONNECTED", Params = "NUMBER=602"
602 vytvoří konferenci Operate(Line = "601", Command = "CONFERENCE", Params = "HELD_CALL=1|ACTIVE_CALL=2") = { Result = "1", Error = "OK" }
Event: LineId = "601", CallId = "1", MsgType = "CS_CONFERENCE", Params = "601|602|651"
Event: LineId = "601", CallId = "2", MsgType = "CS_IDLE", Params = ""
651 zavěsí | Event: LineId = "601", CallId = "1", MsgType = "CS_OTHER_IDLE", Params = "NUMBER=651"
CONSULTATION | 651 volá 601 | Event: LineId = "601", CallId = "1", MsgType = "CS_OFFERING", Params = "NUMBER=651"
601 zvedne | Event: LineId = "601", CallId = "1", MsgType = "CS_CONNECTED", Params = "NUMBER=651"
601 volá 602 na druhé lince Operate(Line = "601", Command = "CONSULTATION", Params = "CALL=5|NUMBER=602") = { Result = "6", Error = "OK" }
Event: LineId = "601", CallId = "1", MsgType = "CS_ONHOLD", Params = ""
Event: LineId = "601", CallId = "2", MsgType = "CS_RINGBACK", Params = "NUMBER=602"
DIAL 601 volá 602 Operate(Line = "601", Command = "DIAL", Params = "NUMBER=602") = { Result = "7", Error = "OK" }
Event: LineId = "601", CallId = "7", MsgType = "CS_RINGBACK", Params = "NUMBER=602"
HANGUP 601 volá 602 Event: LineId = "601", CallId = "1", MsgType = "CS_NEWCALL", Params = "NUMBER=602"
Event: LineId = "601", CallId = "1", MsgType = "CS_RINGBACK", Params = "NUMBER=602"
601 položí Operate(Line = "601", Command = "HANGUP", Params = "CALL=1") = { Result = "1", Error = "OK" }
Event: LineId = "601", CallId = "1", MsgType = "CS_IDLE", Params = ""
RECONNECT | 651 volá 601 | Event: LineId = "601", CallId = "1", MsgType = "CS_OFFERING", Params = "NUMBER=651"
601 zvedne | Event: LineId = "601", CallId = "1", MsgType = "CS_CONNECTED", Params = "NUMBER=651"
601 volá 602 na druhé lince Event: LineId = "601", CallId = "1", MsgType = "CS_ONHOLD", Params = ""
Event: LineId = "601", CallId = "2", MsgType = "CS_NEWCALL", Params = "NUMBER=602"
Event: LineId = "601", CallId = "2", MsgType = "CS_RINGBACK", Params = "NUMBER=602"
602 zvedne | Event: LineId = "601", CallId = "2", MsgType = "CS_CONNECTED", Params = "NUMBER=602"
601 položí aktivní hovor a vrátí se k podrženému Operate(Line = "601", Command = "RECONNECT", Params = "HELD_CALL=1|ACTIVE_CALL=2") = { Result = "1", Error = "OK" }
Event: LineId = "601", CallId = "2", MsgType = "CS_IDLE", Params = ""
Event: LineId = "601", CallId = "1", MsgType = "CS_RETRIEVED", Params = ""
DIVERT
(MD110 vyžaduje, aby byla monitorována i cílová linka 602) 		651 volá 601 Event: LineId = "601", CallId = "1", MsgType = "CS_OFFERING", Params = "NUMBER=651"
601 přesměrovává na 602 Operate(Line = "601", Command = "DIVERT", Params = "CALL=1|NUMBER=602") = { Result = "1", Error = "OK" }
Event: LineId = "601", CallId = "1", MsgType = "CS_DIVERTED", Params = "NUMBER=602"
Event: LineId = "601", CallId = "1", MsgType = "CS_IDLE", Params = ""
SINGLE_STEP_TRANS | 651 volá 601 | Event: LineId = "601", CallId = "1", MsgType = "CS_OFFERING", Params = "NUMBER=651"
601 zvedne | Event: LineId = "601", CallId = "1", MsgType = "CS_CONNECTED", Params = "NUMBER=651"
601 přesměrovává na 602 Operate(Line = "601", Command = "SINGLE_STEP_TRANS", Params = "CALL=1|NUMBER=602") = { Result = "1", Error = "OK" }
Event: LineId = "601", CallId = "1", MsgType = "CS_DIVERTED", Params = "NUMBER=602"
Event: LineId = "601", CallId = "1", MsgType = "CS_IDLE", Params = ""
SET_FEATURE | 601 zapíná funkci "Do not diturb" | Operate(Line = "601", Command = "SET_FEATURE", Params = "DO_NOT_DISTURB=ON") = { Result = "1", Error = "OK" }
601 vypíná funkci "Do not diturb" | Operate(Line = "601", Command = "SET_FEATURE", Params = "DO_NOT_DISTURB=OFF") = { Result = "1", Error = "OK" }
601 zapíná funkci přešměrování | Operate(Line = "601", Command = "SET_FEATURE", Params = "FORWARD_TYPE=IMMEDIATE|FORWARD=ON|FORWARD_NUMBER=602") = { Result = "1", Error = "OK" }
601 vypíná funkci přešměrování | Operate(Line = "601", Command = "SET_FEATURE", Params = "FORWARD_TYPE=IMMEDIATE|FORWARD=OFF") = { Result = "1", Error = "OK" }
TRANSFER | 651 volá 601 | Event: LineId = "601", CallId = "1", MsgType = "CS_OFFERING", Params = "NUMBER=651"
601 zvedne | Event: LineId = "601", CallId = "1", MsgType = "CS_CONNECTED", Params = "NUMBER=651"
601 volá 602 na druhé lince Event: LineId = "601", CallId = "1", MsgType = "CS_ONHOLD", Params = ""
Event: LineId = "601", CallId = "2", MsgType = "CS_NEWCALL", Params = "NUMBER=602"
Event: LineId = "601", CallId = "2", MsgType = "CS_RINGBACK", Params = "NUMBER=602"
602 zvedne | Event: LineId = "601", CallId = "2", MsgType = "CS_CONNECTED", Params = "NUMBER=602"
602 přepojuje Operate(Line = "601", Command = "TRANSFER", Params = "HELD_CALL=1|ACTIVE_CALL=2") = { Result = "1", Error = "OK" }
Event: LineId = "601", CallId = "1", MsgType = "CS_IDLE", Params = ""
Event: LineId = "601", CallId = "2", MsgType = "CS_IDLE", Params = ""


Aplikační rozhraní systému CallChange: Prohlížeč datového úložiště

Prohlížeč datového úložiště

Pro sledování obsahu datového uložiště, které je publikováno prostřednictvím DCOM a IShareObj, je možno využít aplikace dsmqexp, která je instalována v Program Files\Common Files\Datasys\dsmqexp.exe. Umožňuje prohlížet, modifikovt a mazat údaje uložené v datovém úložišti způsobem jaký je obvyklý při editaci tabulek.
Pro připojení je třeba zadat:
  • jméno share object serveru
  • jméno pod kterým je paměťové úložiště zaregistrováno
  • jméno tabulky ze ketré mají být data vybírána
  • výběrový výraz
  • omezení počtu záznamů pro výběr

Implicitně nastavené hodnoty jsou použitelné pro prohlížení paměťového úložiště CallChange.
Viz. Hlavní vlastnosti datového úložiště


Aplikační rozhraní systému CallChange: Popis konfigurace monitoru CX

Popis konfigurace monitoru CX

Konfigurace stránek monitorovací aplikace "CC Monitor"

CC monitor je aplikace sloužíci k monitorování činnosti a nastavování některých parametrů callchange.

Umístění konfiguračních souborů

V aplikaci jsou zobrazeny stránky (záložky), jejich funkce je dána konfigurací uloženou v konfiguračních XML souborech. Tyto soubory jsou uloženy ve složce pages. Každý konfigurační soubor představuje jednu záložku zobrazovanou v cc monitoru. Soubory jsou pojmenovány page00.xml - page99.xml. Načítany jsou postupně v číselném pořadí. Tzn. pojmenováním souborů je určeno pořadí záložek v aplikaci.

Princip funkce

Pro monitorování činnosti CX je třeba pracovat s daty která jsou uložena ve dvou oddělených prostředích. On-line informace, zahrnující zejména okamžité stavy probíhajících hovorů jsou uloženy v "paměťovém úložišti", konfigurační údaje a archiv hovorů je umístěn v databázi. Oba tyto zdroje dat jsou dostupné prostřednicvím rozhrani CX serveru.
Pro sloučení informací z těchto informačních zdrojů se využívá lokálního databázového stroje SQLite pracujícího v režimu bez uložného souboru. Všechna data jsou umístěna v operační paměti. V konfiguračních souborech jsou mj. uvedena výběrová kriteria která určují jaké údaje mají být z paměťového úložiště a databáze přeneseny do lokální databáze cc monitoru. Pro každou stránku jsou tyto údaje uvedeny zvlášt. Po přenesení předvybraných dat do lokálního SQL serveru jsou data zpracována pomocí SQL dotazů do výsledné tabulky v lokální databázi. Obsah této tabulky je zobrazen uživateli. Je možno konfigurovat různé druhy grafické presentace získaných dat např. formou grafů, obarvením buňek v závislosti na obsahu a možností presentace formou kontingenční tabulky. Načítaní a zpracování dat probíhá v pracovním vlákně na pozadí. V jednom okamžiku je zobrazována a atualizována jedna stránka ccmonitoru.

Připojení k CX serveru

cc monitor pro připojení k CX serveru používá služeb základního klienta pro callcentrum (l2cc.exe), jehož prostřednicvím se též přihlašuje jako agent/manager call centra. Není-li l2cc k dispozici, využije pro připojení služeb level1 klienta. V tom případě se však nepřihlašuje k callcentru, tzn. nemá práva potřebná k provádění zásahů do konfigurace callcentra.

Implicitní substituční proměnné

  • interval_begin - čas a datum počátku intervalu zvoleného v uživatelském rozhraní ve formátu CX serveru
  • interval_end - čas a datum konce intervalu zvoleného v uživatelském rozhraní ve formátu CX serveru
  • interval_name - jméno zvoleného intervalu

Definice stránky

Nejjednodužší příklad konfigurace stránky:

<?xml version="1.0" encoding="windows-1250"?>

<Page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="file:CC_MONITOR.xsd"
name="Triviani test"
contingent_table_mode="false"
raw_mode="true"
update_period="1000"
update_db_period="5000"
>

<PageQuery>
<![CDATA[

select "je to snadne" as konfigurovat;

]]>
</PageQuery>
</Page>

Formát dat pro zobrazení buňky typu CT_CHART

Zobrazovač CT_CHART má jako vstup text buňky, který interpretuje jako jednoduchý graf zobrazený v buňce.

XML schema stránky CC monitoru

XML schema stránky CC monitoru

Table of Contents

  • Schema Document Properties
  • Global Declarations
    • Element: Page
  • Global Definitions
    • Complex Type: CellInfoType
    • Complex Type: CollInfoType
    • Complex Type: ColorAssignmentType
    • Complex Type: CreateContingentTableType
    • Complex Type: DBTransferType
    • Complex Type: LocalDBInitType
    • Complex Type: MemStore2LocDbType
    • Complex Type: PageType
    • Complex Type: ScalarQueryType
    • Simple Type: CELL_TYPE
    • Simple Type: COLOR_DEF
    • Simple Type: local_menu
    • Simple Type: selection_mode
top

Schema Document Properties

Target Namespace None
Element and Attribute Namespaces
  • Global element and attribute declarations belong to this schema's target namespace.
  • By default, local element declarations belong to this schema's target namespace.
  • By default, local attribute declarations have no namespace.

Declared Namespaces

Prefix | Namespace
xml | http://www.w3.org/XML/1998/namespace
xs | http://www.w3.org/2001/XMLSchema
Schema Component Representation
<xs:schema elementFormDefault="qualified" id="CC_MONITOR">
...
</xs:schema>
top

Global Declarations

Element: Page

Name | Page
Type | PageType
Nillable | no
Abstract | no
Documentation | Hlavní element
XML Instance Representation
<Page
name="xs:string [1]
Jméno stránky. Bude zobrazeno jako jméno záložky.'
"
header_col_num="xs:int [0..1]
Počet sloupců tabulky, které budou mít význam a vzhled hlavičky řádku.'
"
raw_mode="xs:boolean [0..1]
Ladící režim. Data jsou zobrazena bez formátování a jsou zobrazeny všechny sloupce cílového dotatzu.'
"
contingent_table_mode="xs:boolean [0..1]
Aktivní režim zobrazení dat jako kontingenční tabulka, slouží jako možnost vypnutí zobrazení pro účely ladění. Předpokladem zobrazení kontingenční tabulky je přítomnost elementu CreateContingentTable.'
"
selection_mode="selection_mode [0..1]
Způsob označování buněk tabulky.'
"
local_menu="local_menu [0..1]
Specializované lokální menu. Jeho funkčnost a obsah je vytvořen v ccmonitor.exe'
"
update_period="xs:int [0..1]
Perioda aktualizace dat získaných z paměťového úložiště.'
"
update_db_period="xs:int [0..1]
Perioda aktualizace dat získaných z databáze.'
"
interval_controls="xs:boolean [0..1]
Zobrazovat na této stránce ovládací prvky pro určení časového intervalu.'
">
<DefaultColumnStyle> CollInfoType </DefaultColumnStyle> [0..1]
Styl sloupců, u kterých není styl explicitně určen.'
<Column> CollInfoType </Column> [0..*]
Specifikace formátu pro zobrazeni sloupce'
<LocalDBInit> LocalDBInitType </LocalDBInit> [0..*]
Inicializace struktur lokální databáze'
<DBTransfer> DBTransferType </DBTransfer> [0..*]
Přenos údajů z databáze do lokální databáze'
<MemStore2LocDb> MemStore2LocDbType </MemStore2LocDb> [0..*]
Přenos údajů z paměťového úložiště CX serveru do lokální databáze'
<ScalarQuery> ScalarQueryType </ScalarQuery> [0..*]
Provedení SQL příkazu se skalárním výstupem v lokální databázi'
<CreateContingentTable> CreateContingentTableType </CreateContingentTable> [0..*]
Předpis pro vytvoření kontingenční tabulky'
<PageQuery> xs:string </PageQuery> [1]
</Page>
Schema Component Representation
<xs:element name="Page" type="PageType"/>
top

Global Definitions

Complex Type: CellInfoType

Parent type: | None
Direct sub-types: | None
Name | CellInfoType
Abstract | no
Documentation | Určení vlastností buňky
XML Instance Representation
<...
cell_type="CELL_TYPE [1]
Základní typ buňky'
"
text="xs:string [0..1]
Statický text buňky. Má využití zejména v popisu sloupců'
"
mask="xs:string [0..1]
Maska provádějící textovou transformaci mezi hodnotou z výsledného databázového dotazu a presentační hodnotou.'Výsledkem je text ve kterém jsou podřetězce %1 - %9 nahrazeny proměnnými získanými parsováním hodnoty pole databázového dotazu ve tvaru A|B.'Jako příklad mějme masku: `%0 skočil %2 přes %1` data: `Karel|Vltavu|hbytě`'Výsledkem bude řetezec: `Karel skočil hbytě přes Vltavu`'
"
joinH="xs:int [0..1]
Kolik buněk směrem doprava má být připojeno k dané buňce'
"
joinV="xs:int [0..1]
Kolik buněk směrem dolů má být připojeno k dané buňce'
"
heigth="xs:int [0..1]
Výška buňky'
"
color_background="COLOR_DEF [0..1]
Barva pozadí'
"
print_text="xs:boolean [0..1]
Je text buňky určen k tisku?'
">
<!-- Mixed content -->
<BackgroundColorAssignment> ColorAssignmentType </BackgroundColorAssignment> [0..*]
Přiřazení barvy podkladu buňky na základě obsahu'
</...>
Schema Component Representation
<xs:complexType name="CellInfoType" mixed="true">
<xs:sequence>
<xs:element name="BackgroundColorAssignment" type="ColorAssignmentType" maxOccurs="unbounded" minOccurs="0"/>
</xs:sequence>
<xs:attribute name="cell_type" type="CELL_TYPE" use="required"/>
<xs:attribute name="text" type="xs:string"/>
<xs:attribute name="mask" type="xs:string"/>
<xs:attribute name="joinH" type="xs:int"/>
<xs:attribute name="joinV" type="xs:int"/>
<xs:attribute name="heigth" type="xs:int"/>
<xs:attribute name="color_background" type="COLOR_DEF"/>
<xs:attribute name="print_text" type="xs:boolean"/>
</xs:complexType>
top

Complex Type: CollInfoType

Parent type: | None
Direct sub-types: | None
Name | CollInfoType
Abstract | no
Documentation | Vlastnosti sloupce tabulky
XML Instance Representation
<...
name="xs:string [0..1]
Interní jméno sloupce'
"
data_name="xs:string [0..1]
Jméno sloupce výsledného SQL dotazu, který se má v tomto sloupci tabulky zobrazovat'
"
width="xs:int [0..1]
Šířka sloupce'
">
<HeaderRow> CellInfoType </HeaderRow> [1..*]
Vlastnosti buňek hlavičky'
<Content> CellInfoType </Content> [1]
Vlastnosti datových buňek'
</...>
Schema Component Representation
<xs:complexType name="CollInfoType">
<xs:sequence>
<xs:element name="HeaderRow" type="CellInfoType" maxOccurs="unbounded" minOccurs="1"/>
<xs:element name="Content" type="CellInfoType" maxOccurs="1" minOccurs="1"/>
</xs:sequence>
<xs:attribute name="name" type="xs:string"/>
<xs:attribute name="data_name" type="xs:string"/>
<xs:attribute name="width" type="xs:int"/>
</xs:complexType>
top

Complex Type: ColorAssignmentType

Parent type: | None
Direct sub-types: | None
Name | ColorAssignmentType
Abstract | no
Documentation | Přiřazení barev hodnotám (číselník barev)
XML Instance Representation
<...
value="xs:string [1]
Hodnota klíče číselníku'
"
color="COLOR_DEF [1]
Hodnota odpovídající barvy'
"/>
Schema Component Representation
<xs:complexType name="ColorAssignmentType">
<xs:attribute name="value" type="xs:string" use="required"/>
<xs:attribute name="color" type="COLOR_DEF" use="required"/>
</xs:complexType>
top

Complex Type: CreateContingentTableType

Parent type: | None
Direct sub-types: | None
Name | CreateContingentTableType
Abstract | no
Documentation | Popis vytváření kontingenční tabulky v lokální databázi. Výsledkem zpracování je nová tabulka (naplněná údaji), jejíž struktura je daná vstupními daty. Definice obsahuje SQL dotaz, který vytváří dlouhou tabulku, která obsahuje tři sloupce: text hlavičky řádků, vlastní data a jméno sloupce do kterého vlastní data přísluší. Zpracováním se tato dlouhá tabulka rozprostře do "šachovnice" kontingenční tabulky.
XML Instance Representation
<...
name="xs:string [1]
Jméno nově vzniklé tabulky v lokální databázi'
"
content_data_type="xs:string [1]
Typ dat uložených v tabulce. Např. varchar(20)'
"
head_data_type="xs:string [1]
Typ dat 1-ho sloupce vystupující jako hlavička řádků. Např. varchar(50)'
"
field_content="xs:string [1]
Jméno sloupce vstupní tabulky, který obsahuje zobrazovanou hodnotu.'
"
field_row_header_text="xs:string [1]
Jméno prvního sloupce (hlavičky)'
"
field_col_header_text="xs:string [1]
Jméno sloupce vstupního dotazu, který obsahuje hodnoty, které budou použity jako jména sloupců.'
"/>
Schema Component Representation
<xs:complexType name="CreateContingentTableType" mixed="true">
<xs:attribute name="name" type="xs:string" use="required"/>
<xs:attribute name="content_data_type" type="xs:string" use="required"/>
<xs:attribute name="head_data_type" type="xs:string" use="required"/>
<xs:attribute name="field_content" type="xs:string" use="required"/>
<xs:attribute name="field_row_header_text" type="xs:string" use="required"/>
<xs:attribute name="field_col_header_text" type="xs:string" use="required"/>
</xs:complexType>
top

Complex Type: DBTransferType

Parent type: | None
Direct sub-types: | None
Name | DBTransferType
Abstract | no
Documentation | Přenos údajů z databáze do lokální databáze. Obsahuje SQL dotaz pro selekci udajů z databáze CX serveru.
XML Instance Representation
<...
name="xs:string [0..1]
Jméno tabulky v lokální databázi do které mají být vybrané údaje uloženy. Tabulka musí být předem vytvořena pomocí LocalDBInit.'
"/>
Schema Component Representation
<xs:complexType name="DBTransferType" mixed="true">
<xs:attribute name="name" type="xs:string"/>
</xs:complexType>
top

Complex Type: LocalDBInitType

Parent type: | None
Direct sub-types: | None
Name | LocalDBInitType
Abstract | no
Documentation | Inicializace struktur lokální databáze. Obsahuje SQL příkazy definující tabulky indexy a pohledy lokální databáze
XML Instance Representation
<...
name="xs:string [0..1]
Interní jméno použité pro oznamování chyb při ladění'
"/>
Schema Component Representation
<xs:complexType name="LocalDBInitType" mixed="true">
<xs:attribute name="name" type="xs:string"/>
</xs:complexType>
top

Complex Type: MemStore2LocDbType

Parent type: | None
Direct sub-types: | None
Name | MemStore2LocDbType
Abstract | no
Documentation | Přenos údajů z paměťového úložiště do lokální databáze. Obsahuje výběrový výraz pro selekci udajů z paměťového úložiště CX serveru.
XML Instance Representation
<...
src_table="xs:string [0..1]
Jméno tabulky paměťového úložiště'
"
dst_table="xs:string [0..1]
Jméno tabulky lokální databáze, do které mají být údaje přeneseny.'
"/>
Schema Component Representation
<xs:complexType name="MemStore2LocDbType" mixed="true">
<xs:attribute name="src_table" type="xs:string"/>
<xs:attribute name="dst_table" type="xs:string"/>
</xs:complexType>
top

Complex Type: PageType

Parent type: | None
Direct sub-types: | None
Name | PageType
Abstract | no
Documentation | Popisuje vzhled a chování stránky
XML Instance Representation
<...
name="xs:string [1]
Jméno stránky. Bude zobrazeno jako jméno záložky.'
"
header_col_num="xs:int [0..1]
Počet sloupců tabulky, které budou mít význam a vzhled hlavičky řádku.'
"
raw_mode="xs:boolean [0..1]
Ladící režim. Data jsou zobrazena bez formátování a jsou zobrazeny všechny sloupce cílového dotatzu.'
"
contingent_table_mode="xs:boolean [0..1]
Aktivní režim zobrazení dat jako kontingenční tabulka, slouží jako možnost vypnutí zobrazení pro účely ladění. Předpokladem zobrazení kontingenční tabulky je přítomnost elementu CreateContingentTable.'
"
selection_mode="selection_mode [0..1]
Způsob označování buněk tabulky.'
"
local_menu="local_menu [0..1]
Specializované lokální menu. Jeho funkčnost a obsah je vytvořen v ccmonitor.exe'
"
update_period="xs:int [0..1]
Perioda aktualizace dat získaných z paměťového úložiště.'
"
update_db_period="xs:int [0..1]
Perioda aktualizace dat získaných z databáze.'
"
interval_controls="xs:boolean [0..1]
Zobrazovat na této stránce ovládací prvky pro určení časového intervalu.'
">
<DefaultColumnStyle> CollInfoType </DefaultColumnStyle> [0..1]
Styl sloupců, u kterých není styl explicitně určen.'
<Column> CollInfoType </Column> [0..*]
Specifikace formátu pro zobrazeni sloupce'
<LocalDBInit> LocalDBInitType </LocalDBInit> [0..*]
Inicializace struktur lokální databáze'
<DBTransfer> DBTransferType </DBTransfer> [0..*]
Přenos údajů z databáze do lokální databáze'
<MemStore2LocDb> MemStore2LocDbType </MemStore2LocDb> [0..*]
Přenos údajů z paměťového úložiště CX serveru do lokální databáze'
<ScalarQuery> ScalarQueryType </ScalarQuery> [0..*]
Provedení SQL příkazu se skalárním výstupem v lokální databázi'
<CreateContingentTable> CreateContingentTableType </CreateContingentTable> [0..*]
Předpis pro vytvoření kontingenční tabulky'
<PageQuery> xs:string </PageQuery> [1]
</...>
Schema Component Representation
<xs:complexType name="PageType">
<xs:sequence>
<xs:element name="DefaultColumnStyle" type="CollInfoType" maxOccurs="1" minOccurs="0"/>
<xs:element name="Column" type="CollInfoType" maxOccurs="unbounded" minOccurs="0"/>
<xs:element name="LocalDBInit" type="LocalDBInitType" maxOccurs="unbounded" minOccurs="0"/>
<xs:element name="DBTransfer" type="DBTransferType" maxOccurs="unbounded" minOccurs="0"/>
<xs:element name="MemStore2LocDb" type="MemStore2LocDbType" maxOccurs="unbounded" minOccurs="0"/>
<xs:element name="ScalarQuery" type="ScalarQueryType" maxOccurs="unbounded" minOccurs="0"/>
<xs:element name="CreateContingentTable" type="CreateContingentTableType" maxOccurs="unbounded" minOccurs="0"/>
<xs:element name="PageQuery" type="xs:string" maxOccurs="1" minOccurs="1"/>
</xs:sequence>
<xs:attribute name="name" type="xs:string" use="required"/>
<xs:attribute name="header_col_num" type="xs:int"/>
<xs:attribute name="raw_mode" type="xs:boolean"/>
<xs:attribute name="contingent_table_mode" type="xs:boolean"/>
<xs:attribute name="selection_mode" type="selection_mode"/>
<xs:attribute name="local_menu" type="local_menu" use="optional"/>
<xs:attribute name="update_period" type="xs:int" use="optional"/>
<xs:attribute name="update_db_period" type="xs:int" use="optional"/>
<xs:attribute name="interval_controls" type="xs:boolean" use="optional"/>
</xs:complexType>
top

Complex Type: ScalarQueryType

Parent type: | None
Direct sub-types: | None
Name | ScalarQueryType
Abstract | no
Documentation | Obsahuje SQL dotaz jehož výslekem je jedna hodnota použitelná v substitučních výrazech.
XML Instance Representation
<...
name="xs:string [0..1]
Jméno substituční proměnné, které má být dotazem naplněno.'
"/>
Schema Component Representation
<xs:complexType name="ScalarQueryType" mixed="true">
<xs:attribute name="name" type="xs:string"/>
</xs:complexType>
top

Simple Type: CELL_TYPE

Parent type: | xs:string (derivation method: restriction)
Direct sub-types: | None
Name CELL_TYPE
Content
  • Base XSD Type: string
  • value comes from list: {'CT_NORMAL'|'CT_CHART'|'CT_DROPLIST'|'CT_URL'|'CT_INTERVALNAME'}
Documentation Typ buňky

CT_NORMAL - obyčejná buňka

CT_CHART - buňka obsahuje graf

CT_DROPLIST - v buňce je zobrazen combobox

CT_URL - v buňce je URL odkaz
Schema Component Representation
<xs:simpleType name="CELL_TYPE">
<xs:restriction base="xs:string">
<xs:enumeration value="CT_NORMAL"/>
<xs:enumeration value="CT_CHART"/>
<xs:enumeration value="CT_DROPLIST"/>
<xs:enumeration value="CT_URL"/>
<xs:enumeration value="CT_INTERVALNAME"/>
</xs:restriction>
</xs:simpleType>
top

Simple Type: COLOR_DEF

Parent type: | xs:string (derivation method: restriction)
Direct sub-types: | None
Name | COLOR_DEF
Content
  • Base XSD Type: string
  • value comes from list: {'CLR_RED'|'CLR_GREEN'|'CLR_BLUE'|'CLR_YELLOW'|'CLR_CYAN'|'CLR_MAGENTA'|'CLR_DKRED'|'CLR_DKGREEN'|'CLR_DKBLUE'|'CLR_DKYELLOW'|'CLR_DKCYAN'|'CLR_DKMAGENTA'|'CLR_BLACK'|'CLR_DKGRAY'|'CLR_LTGRAY'|'CLR_WHITE'}
Documentation | Základní používané barvy
Schema Component Representation
<xs:simpleType name="COLOR_DEF">
<xs:restriction base="xs:string">
<xs:enumeration value="CLR_RED"/>
<xs:enumeration value="CLR_GREEN"/>
<xs:enumeration value="CLR_BLUE"/>
<xs:enumeration value="CLR_YELLOW"/>
<xs:enumeration value="CLR_CYAN"/>
<xs:enumeration value="CLR_MAGENTA"/>
<xs:enumeration value="CLR_DKRED"/>
<xs:enumeration value="CLR_DKGREEN"/>
<xs:enumeration value="CLR_DKBLUE"/>
<xs:enumeration value="CLR_DKYELLOW"/>
<xs:enumeration value="CLR_DKCYAN"/>
<xs:enumeration value="CLR_DKMAGENTA"/>
<xs:enumeration value="CLR_BLACK"/>
<xs:enumeration value="CLR_DKGRAY"/>
<xs:enumeration value="CLR_LTGRAY"/>
<xs:enumeration value="CLR_WHITE"/>
</xs:restriction>
</xs:simpleType>
top

Simple Type: local_menu

Parent type: | xs:string (derivation method: restriction)
Direct sub-types: | None
Name | local_menu
Content
  • Base XSD Type: string
  • value comes from list: {'AGENT_CONNECT'}
Documentation | Specializované lokální menu aktivované stiskem pravého tlačítka myši. Jeho funkčnost a obsah je vytvořen v ccmonitor.exe
Schema Component Representation
<xs:simpleType name="local_menu">
<xs:restriction base="xs:string">
<xs:enumeration value="AGENT_CONNECT"/>
</xs:restriction>
</xs:simpleType>
top

Simple Type: selection_mode

Parent type: | xs:string (derivation method: restriction)
Direct sub-types: | None
Name | selection_mode
Content
  • Base XSD Type: string
  • value comes from list: {'SELECT_NONE'|'SELECT_CELL_SINGLE'|'SELECT_CELL_MULTI'}
Documentation | Režim označování buněk tabulky
Schema Component Representation
<xs:simpleType name="selection_mode">
<xs:restriction base="xs:string">
<xs:enumeration value="SELECT_NONE"/>
<xs:enumeration value="SELECT_CELL_SINGLE"/>
<xs:enumeration value="SELECT_CELL_MULTI"/>
</xs:restriction>
</xs:simpleType>
top

Generated by xs3p.


Aplikační rozhraní systému CallChange: Popis routeru zpráv

Popis routeru zpráv

CXServer

Způsoby použití

  • Virtuální linky
    • Multiplexor
      • Popis: Z jedné fyzické linky dělá několik virtuálních.
      • Příklad použití: Na jedné VX lince může být libovolné množství vstupních linek odlišených číslem volaného.
    • Demultiplexor
      • Popis: Z více fyzických linek dělá jednu virtuální linku.
      • Příklad použití: VX linka je tvořena několika kanály.
    • Virtuální ACD skupina (emulace HW)
      • Popis: Fronta s automatickou distribucí hovorů k přihlášeným agentům.
      • Příklad použití: CC
      • Implementace: Manažer ACD poslouchá příkazy typu AGENT_FEATURE na všech linkách.
    • Virtuální CTI skupina (emulace HW)
      • Popis: Fronta bez jakékoliv funkcionality.
      • Příklad použití: Vstupní linka CC.
    • Vstupní linka CC
      • Popis: Linka, na které jsou vytvořeny CC hovory.
  • Přidané funkce
    • VX funkce
      • Popis: Pro hlasové funkce se hovor dočasně přesměruje do VX.
      • Příklad použití: Vstupní linka CC na HW CTI skupinách.
    • Nahrávání pomocí VX
      • Popis: Pro nahrání hovoru se zřídí konference s VX.

Požadavky na implementaci

  • Směrování:
    • Pokud je zpráva zaslána příjemci _CX_CHAIN, je taková zpráva zpracovávána řetězem komponent.
    • Komponenty jsou seřazeny do vrstev. Nejnižší vrstvou je ovladač fyzických linek. Nejvyšší vrstvou je distributor událostí klientům.
    • Komponenty mají možnost si dynamicky přihlašovat a odhlašovat zprávy podle daných kritérií (hodnota atributů). Komponenta při přihlášení specifikuje, zda chce pouze naslouchat a nebo zda chce zprávy zpracovávat.
    • Směrovač zpráv posílá příkazy seshora dolů, události odspoda nahoru. Pokud dostane zprávu od komponenty, která tvoří nějakou vrstvu, je událost předána následující nižší či vyšší vrstvě. Pokud směrovač dostane zprávu od komponenty, která není vrstvou, dostane zprávu nejvyšší nebo nejnižší vrstva.
    • Pokud komponenta zprávě pouze naslouchá, směrovač jí pošle kopie zprávy a současně předává zprávu dalším vrstvám. Distribuce se zastaví až u první vrstvy, která má danou zprávu přihlášenou s příznakem pro zpracování.
    • Komponenta zpracovávanou událost buď sežere a tím je směrování ukončeno, nebo ji duplikuje a pošle zpět směrovači. Ten ji pak pošle o úroveň víš či níž.
    • Komponenta také může poslat zprávu přímo jiné komponentě, čímž je ze směrování vyloučena, dokud ji někdo nezduplikuje a pošle zpět směrovači.
  • Robustnost
    • Při odstranění session odstranit přidružené záznamy.
  • Distributor událostí klientům
    • Přijímá povely od klientů poslané příjemci "_CX", přidává do nich REQUEST_SESSION_ID a REQUEST_ID a předává je do řetězu (_CX_CHAIN).
    • Předává klientům přihlášené události a odpovědi na jejich požadavky. Pokud má událost vyplněno REQUEST_SESSION_ID, je tato událost poslána pouze tomuto klientovi.
  • Vlastnictví hovorů
    • Počátečním vlastníkem hovoru je session, která hovor vytvořila.
    • Pokud jsou zprávy OP_DIAL a CS_IDLE poslány nějakému článku řetězu, který tyto zprávy zprácovává (režim ROUTE), stává se tento článek vlastníkem hovoru.
    • Message router při ukončení sessiony najde její aktivní hovory a pošle zprávu CS_IDLE, jako by je poslala ukončovaná session - tj. zpráva je přijata i případnými dalšími články řetězu.

Nahrávání

  • Surové nahrání WAVu pomocí OP_START_RECORDING. S výsledkem si žadatel může/musí udělat co chce.
  • CX může žádat o řadu různých činností, jejichž prvním krokem je nahrání hovoru a následné zpracování. Pro zjednodušení implementace takových činností bude na serveru vrstva, která bude implementovat příkaz OP_RECORD_AND_STORE. Parametrem bude jednak ProgId komponenety, která provede zpracování pořízené nahrávky a pak parametry pro tuto komponentu. Zpracovávací komponenty jsou nezávislé na CX a mohou být využity od jinud (třeba z VX).


Aplikační rozhraní systému CallChange: Události a operace nad CX linkami

Události a operace nad CX linkami

Události a operace nad CX linkami

Události

První událost doručená klientům je vždy CS_CREATE_CALL. Tuto zprávu neposílá ovladač, ale generuje ji automaticky CX server. Ovladač jako první posílá "normální" zprávu, např. CS_OFFERING nebo CS_NEWCALL. Poslední zprávou nad hovorem je vždy CS_IDLE, tu musí poslat ovladač, pouze v případě nečekaného pádu ovladače ji za něj může poslat server.

Typ | Popis | Parametry
CS_BUSY | Vytáčení hovoru se nezdařilo z důvodu obsazené volané linky. Nyní je možné buď zavěsit pomocí HANGUP nebo požádat např. o zpětné zavolání pomocí CALL_COMPLETION.
CS_CREATE_CALL | Vždy první zpráva o jakémkoliv hovoru.
CS_CONFERENCE | Hovor se stal součástí konference nebo se změnil seznam účastníků konference. | DEVICES | Seznam účastníků konference. (oddělovačem je svislítko)
CS_CONNECTED | Hovor byl spojen. | NUMBER (nepovinný) | Číslo druhého účastníka hovoru, poukud je známo.
CS_CONNECTEDID | Změna identifikace druhého účastníka hovoru. Nastává po přepojení. | NUMBER (nepovinný) | Číslo druhého účastníka hovoru, poukud je známo.
CS_DIVERTED | Příchozí vyzvánějící hovor byl ještě před zvednutím odkloněn na jiné zařízení. Vzápětí přijde CS_IDLE. | NUMBER (nepovinný) | Číslo, na které byl hovor odkloněn.
CS_FAILED | Vytáčení hovoru se nezdařilo. Nyní je možné buď zavěsit pomocí HANGUP nebo požádat např. o zpětné zavolání pomocí CALL_COMPLETION.
CS_IDLE Hovor byl ukončen. REASON (nepovinný) Důvod ukončení hovoru. Možné hodnoty:
  • NORMAL - normální ukončení hovoru.
  • SHUTDOWN - ovladač byl ukončen.
CS_INITIATED | Bylo zvednuto sluchátko případně probíhající hovor byl podržen. Vzniknul nový hovor s jediným účastníkem. Ve sluchátku je slyšet oznamovací tón ústředny.
CS_NEWCALL | Bylo vytočeno číslo. Ústředna se snaží připojit volaného účastníka. Volaná linka ještě nevyzvání. | NUMBER | Volané číslo.
CS_OFFERING | Na lince vyzvání nový hovor. | NUMBER (nepovinný) | Číslo volajícího.
CALLED_NUMBER (nepovinný) | Původně volané číslo
CS_ONHOLD | Hovor byl podržen.
CS_OTHER_IDLE | Druhá strana zavěsila.
CS_RINGBACK | Vytočený hovor začal vyzvánět. Pokud vyzvánějící hovor po čase přepadne na jiné zařízení je tato zpráva poslána znovu s novým číslem. | NUMBER (nepovinný) | Číslo vyzvánějícího zařízení.
CS_READY | Ukončení některých operací: CALL_COMPLETION, PLAY_WAV, RECORD_WAV a RUN_VX_APP. | RESULT | Výsledek. Používá RUN_VX_APP.
CS_RECORDING_STARTED | Nahrávání hovoru bylo započato.
CS_RECORDING_STOPPED | Nahrávání hovoru bylo ukončeno. | RECORD_ID | Identifikátor nahrávky.
CS_RETRIEVED | Podržený hovor byl obnoven.
CS_TRANSFERRED | Hovor byl přesměrován. | OTHER_CALL_ID | Číslo druhého hovoru, který byl v rámci přesměrování propojen s tímto.
CS_DESCRIPTION | Informace o stavu hovoru (používá VXML) | DESC | Popis stavu hovoru.

Operace

Jména zpráv požadavků mají tvar OP_XXX, kde XXX je jméno operace. Každý požadavek má parametr REQUEST_ID s identifikátorem požadavku. Na každý požadavek musí být odeslána odpověď s vyplněným odpovídajícím REQUEST_ID. V případě úspěchu je jméno zprávy ve tvaru OPRES_RESULT, v případě neúspěchu je jméno zprávy ve tvaru OPRES_ERROR. Parametry OPRES_RESULT jsou závislé na operaci a jsou uvedeny v tabulce. Parametry OPRES_ERROR jsou vždy stejné a to tyto:

Parametr | Popis
REASON Důvod neúspěchu:
  • INVALID_LINE - neznámý identifikátor linky (speciální případ INVALID_ARGUMENTS).
  • INVALID_CALL - neznámý identifikátor hovoru (speciální případ INVALID_ARGUMENTS).
  • INVALID_OPERATION - neznámá nebo nepodporovaná operace.
  • INVALID_ARGUMENTS - chybějící nebo neplatné hodnoty parametrů.
  • INVALID_STATE - v tomto stavu nelze operaci provést.
MESSAGE (volitelný) | Čitelná informace o důvodu chyby.

Na každý požadavek musí být odeslána právě jedna odpověď, buď kladná (úspěch) nebo záporná (chyba). Odpověď nemusí být odeslána okamžitě, ale až po úspěšném provedení operace. Pokud implementace příkaz nepodporuje, musí vrátit OPERROR{REASON: IVALID_OPERATION}.

Operace | Popis | Parametry operace | Parametry odpovědi | Očekávané události
ABORT | Okamžitě přeruší přehrávání nebo nahrávání. | CS_READY.
ALTERNATE | Prohodí podržený a aktivní hovor. Slučuje funkce HOLD a UNHOLD do jedné. | ACTIVE_CALL | Identifikátor aktivního hovoru. | CS_ONHOLD původně aktivnímu hovoru a CS_RETRIEVED nově aktivnímu hovoru.
HELD_CALL | Identifikátor podrženého hovoru.
ANSWER | Zvedne vyzvánějící hovor. | CALL | Identifikátor hovoru. | CS_CONNECTED.
CALL_COMPLETION | Zpracování hovoru, který se nezdařil z důvodu obsazení volaného čísla. | CALL | Identifikátor hovoru. | CS_READY.
FEATURE Jedna z následujících hodnot:
  • CAMP_ON
  • CALL_BACK
  • INTRUDE
CONFERENCE | Propojení hovorů do konference. | ACTIVE_CALL | Identifikátor aktivního hovoru. | CS_CONFERENCE.
HELD_CALL | Identifikátor podrženého hovoru.
CONSULTATION | Podržení aktivního hovoru a vytočení nového konzultačního hovoru. Slučuje funkce HOLD a DIAL do jedné. | CALL | Identifikátor aktivního hovoru. | NEW_CALL | Identifikátor vzniklého konzultačního hovoru. | CS_ONHOLD nově podrženému hovoru a CS_NEWCALL nově vytvořenému hovoru.
NUMBER | Volané číslo.
DIAL | Vytočení nového hovoru. | NUMBER | Volané číslo. | NEW_CALL | Identifikátor vzniklého hovoru. | CS_NEWCALL.
DIVERT | Odklonění vyzvánějícího hovoru na jiné zařízení. | CALL | Identifikátor hovoru. | CS_DIVERTED a CS_IDLE.
NUMBER | Číslo zařízení, na které bude hovor odkloněn.
HANGUP | Zavěšení hovoru | CALL | Identifikátor hovoru. | CS_IDLE.
HOLD | Podržení aktivního hovoru. | CALL | Identifikátor hovoru. | CS_ONHOLD.
PLAY_WAV | Přehrání WAV souboru. | CALL | Identifikátor hovoru. | CS_READY.
WAV_NAME | Jméno WAV souboru.
STOP_CHARS | Znaky, které způsobí okamžité ukončení přehrávání.
RECONNECT | Zavěšení aktivního hovoru a návrat k podrženému hovoru. Slučuje funkce HANGUP a UNHOLD do jedné. | ACTIVE_CALL | Identifikátor aktivního hovoru. | CS_IDLE položenému hovoru a CS_RETRIEVED nově aktivnímu hovoru.
HELD_CALL | Identifikátor podrženého hovoru.
RECORD_WAV | Nahrání WAV souboru. | CALL | Identifikátor hovoru. | CS_RECORDED_WAV (pouze pokud se WAV podaří nahrát) a CS_READY.
WAV_NAME | Jméno WAV souboru.
RUN_VX_APP | Spuštění VX aplikace. | CALL | Identifikátor hovoru. | CS_READY.
APP_NAME | Jméno VX aplikace.
APP_ARGS (nepovinný) | Argumenty pro VX aplikaci.
SINGLE_STEP_TRANS | Aktivní hovor je přesměrován. Slučuje funkce CONSULTATION a TRANSFER do jedné. | CALL | Identifikátor hovoru. | CS_TRANSFERRED a CS_IDLE.
NUMBER | Volané číslo.
START_RECORDING | Začít nahrávání hovoru. | CALL | Identifikátor hovoru. | CS_RECORDING_STARTED.
STOP_RECORDING | Ukončit nahrávání hovoru. | CALL | Identifikátor hovoru. | CS_RECORDING_STOPPED.
TRANSFER | Přesměrovat podržený hovor na aktivní. Oba hovory jsou propojeny a na přesměrovávajícím zařízení ukončeny. | ACTIVE_CALL | Identifikátor aktivního hovoru. | CS_TRANSFERRED a CS_IDLE.
HELD_CALL | Identifikátor podrženého hovoru.
UNHOLD | Podržený hovor byl obnoven. | CALL | Identifikátor hovoru. | CS_RETRIEVED.


Aplikační rozhraní systému CallChange: LineMonitor - tabulka ovladačů

LineMonitor - tabulka ovladačů

LineMonitor - tabulka ovladačů Line monitor se k různým ovladačům chová různým způsobem. Chování je určeno ProgID ovladače.

Tabulka zakompilovaných typů ovladačů ve verzi 1.0.1.146:

ProgID ovladače | Popis | Znak ovladače ve jménu linky | Přenáší seznam linek z databáze do registry
CSTAAgentLib.CSTAAgent | Siemens CSTA | C | ANO
HicomAgentLib.HicomAgent | Siemens Hicom | C | ANO
MD110AgentLib.MD110Agent | Ericson MD110 | M | ANO
SiemensCapAgentLib.SiemensCapAgent | Siemens Cap | H | ANO
BLAgentLib.BLAgent | Business Link | B | ANO
OmniPCX4400AgentLib.OmniPCX4400Agent | OmniPCX4400 | O | ANO
2NAgent.Agent2N | 2N XAPI | X | NE
DSAGENT.CXAGENT | TAPI | T | NE
DSAgent.NMAGENT | Netmeeting COM api | N | NE
cxpbxsim.WSC | Simulátor | S | NE
CxVxDriver.Driver | hybridni CX/VX ovladac | V | NE
ostatni pismena | Náhradní nastavení | F | NE


Aplikační rozhraní systému CallChange: Seznam členů tříd - Výčty

  • DSMQStorageFlags : IDSMQStorage
  • GOB_SpecType : ISysDbConn
  • LogLevel : ICXSession
  • PhoneNormalizerOptions : IPhNormalizer
  • StoreDataOptions : ISysDbConn


Aplikační rozhraní systému CallChange: Seznam členů tříd - Hodnoty výčtu

  • DSMQS_DELETETABLE : IDSMQStorage
  • DSMQS_ENABLE_NEW : IDSMQStorage
  • DSMQS_LIFO : IDSMQStorage
  • DSMQS_LOCK : IDSMQStorage
  • DSMQS_MULTIPLE : IDSMQStorage
  • DSMQS_NODATA : IDSMQStorage
  • DSMQS_NOREMOVE : IDSMQStorage
  • DSMQS_PERSISTENT : IDSMQStorage
  • DSMQS_PUT_FRONT : IDSMQStorage
  • DSMQS_WAIT_50 : IDSMQStorage
  • GOB_MQ_LIKE : ISysDbConn
  • GOB_SQL_FULL : ISysDbConn
  • GOB_SQL_WHERE : ISysDbConn
  • LOG_DATA : ICXSession
  • LOG_DEBUG : ICXSession
  • LOG_ERROR : ICXSession
  • LOG_FETCH : ICXSession
  • LOG_INFO : ICXSession
  • LOG_TRACE : ICXSession
  • LOG_UNIVERSE_END : ICXSession
  • LOG_WARNING : ICXSession
  • NORMALIZER_FORMAT_DIAL : IPhNormalizer
  • NORMALIZER_FORMAT_SHORTEST : IPhNormalizer
  • NORMALIZER_INTERNAL_SHORT : IPhNormalizer
  • NORMALIZER_NUMBER_FROM_PBX : IPhNormalizer
  • SDO_ADD_NEW : ISysDbConn
  • SDO_ERR_NOREPORT : ISysDbConn
  • SDO_UPDATE : ISysDbConn
  • SDO_UPDATE_OR_ADD : ISysDbConn


Aplikační rozhraní systému CallChange: Seznam členů tříd - Funkce

- a -

  • Activate() : IAppActivator
  • ActivateOnCall() : _ILevel2CCEvents
  • AddNumberToBL() : ICXRouter
  • AddProgID() : ICXXMLRPCPlugin
  • AddService() : ICXXMLRPCPlugin
  • AgentAssignGroup() : ICXSession
  • AgentCheckRight() : ICXSession
  • AgentGetApplicationParams() : ICXSession
  • AgentGetGroups() : ICXSession
  • AgentGetRequisiteApps() : ICXSession
  • AgentLogoff() : ICXSession
  • AgentLogon() : ICXSession
  • AgentStoreStatus() : ICXSession
  • AgentStoreStatusEx() : ICXSession
  • AllocID() : ICXSession
  • Answer() : Ilevel1

- b -

  • Busy() : _Ilevel1Events

- c -

  • CallCreated() : _Ilevel1Events
  • CallInfo() : _Ilevel1Events
  • CallXMLRPC() : IDSXMLRPCClient
  • CheckLicence() : ICXSession
  • CheckNumberInBL() : ICXRouter
  • CloseCall() : ILevel2CC
  • CloseCallSession() : Ilevel1
  • COMSessionID() : IDSXMLRPCClient
  • Connected() : _Ilevel1Events
  • ConnectLine() : Ilevel1, ICXSession
  • Consultation() : Ilevel1
  • CreateCOMSession() : IDSXMLRPCClient
  • CreateNewCall() : ICXGlueLine, ICXSession

- d -

  • DeleteNumberFromBL() : ICXRouter
  • DeleteRecords() : IDSMQStorage
  • Dial() : ILevel2CC, Ilevel1
  • Disabled() : _Ilevel1Events
  • DisconnectAll() : IShareObj
  • DisconnectLine() : Ilevel1, ICXSession
  • Done() : ICXXMLRPCPlugin, ICXServer, ICXSession

- e -

  • Enabled() : _Ilevel1Events
  • EndCall() : _Ilevel1Events
  • ExecuteSQL() : ICXSession

- f -

  • Format() : IPhNormalizer

- g -

  • GetActualLineCalls() : ICXSession
  • GetArchive() : Ilevel1, ICXSession
  • GetArchiveCalls() : ICXArchive
  • GetCallEvents() : ICXSession, ICXArchive
  • GetCallState() : ICXSession
  • GetCallStateEx() : ICXSession
  • GetCfgItem() : ICXGlueLine
  • GetConfigItem() : Ilevel1
  • GetConfigItems() : ICXSession
  • GetCXMessage() : ICXSession
  • GetCXMessageEx() : ICXSession
  • GetData() : ISysDbConn
  • GetDatabase() : ICXSession
  • GetDatabaseData() : ICXSession
  • GetDeviceCaps() : ICXSession
  • GetLineFeature() : ICXSession
  • GetLineFromStand() : ICXGlueLine
  • GetLineInfo() : Ilevel1, ICXSession
  • GetLineList() : ICXSession
  • GetLinesConfig() : ICXGlueLine
  • GetLineState() : Ilevel1
  • GetListBlNames() : ICXRouter
  • GetLocalLines() : Ilevel1, ICXSession
  • GetNextID() : IDSMQStorage
  • GetObjData() : ISysDbConn
  • GetObject() : IShareObj
  • GetOperationRequest() : ICXGlueLine
  • GetProxyObject() : IDSXMLRPCClient
  • GetPublicObject() : IShareObj
  • GetRecords() : IDSMQStorage
  • GetRouter() : ICXSession
  • GetServerTime() : ICXSession
  • GetServerTimeString() : ICXSession
  • GetSession() : ICXGlueLine, ILevel2CC, Ilevel1, ICXServer
  • GetSessionAttributes() : ICXSession
  • GetSessionID() : ICXSession
  • GetStandFromLine() : ICXGlueLine
  • GetStandList() : Ilevel1
  • GetStorage() : Ilevel1, ICXSession
  • GetStorePF() : ICore
  • GetTaskStatus() : ISMngr

- h -

  • HangUp() : Ilevel1

- i -

  • InComingCall() : _Ilevel1Events
  • Init() : ICXGlueLine, IDSXMLRPCClient, ICXXMLRPCPlugin, ILevel2CC, Ilevel1, IPhNormalizer, ICXServer, ICXSession
  • InitFromRegistry() : IPhNormalizer
  • InprocQueryInterface() : IDSInprocQI
  • IsNumberInternal() : IPhNormalizer

- l -

  • LineError() : _Ilevel1Events
  • Log() : ICXSession
  • LoginService() : ICXSession
  • LoginUser() : ICXSession
  • LogWrite() : ILevel2CC

- m -

  • MakeNewSession() : ICXServer
  • MakeVariations() : IPhNormalizer

- n -

  • Normalize() : IPhNormalizer
  • Notify() : IAppActivator, _Ilevel1Events

- o -

  • OfferObject() : IShareObj
  • OnCall() : _ILevel2CCEvents
  • OnDial() : _ILevel2CCEvents
  • OnMessage() : _ILevel2CCEvents
  • OperateCall() : Ilevel1, ICXSession
  • OperateCallEx() : ICXSession
  • OperateCallVX() : ICXSession
  • OutGoingCall() : _Ilevel1Events

- p -

  • PhoneUp() : _Ilevel1Events
  • PostCXMessage() : ICXSession
  • PutRecords() : IDSMQStorage

- q -

  • QueryLicence() : ISMngr

- r -

  • Record() : ILevel2CC
  • Redirect() : Ilevel1
  • Register() : IShareObj
  • RegisterAsOperateChainMember() : ICXSession
  • RegisterLine() : ICXGlueLine
  • Revoke() : IShareObj
  • Ringing() : _Ilevel1Events
  • RunCmd() : ISMngr

- s -

  • Search() : ICore
  • SearchEx() : ICore
  • SearchSQL() : ICore
  • SendLineEvent() : ICXGlueLine
  • ServerConnection() : _Ilevel1Events
  • SetAttr() : IDSMQStorage
  • SetCallRc() : ILevel2CC
  • SetCallState() : ICXSession
  • SetData() : ISysDbConn
  • SetDatabaseData() : ICXSession
  • SetIDPersist() : IDSMQStorage
  • SetLineFeature() : ICXSession
  • SetLineInfo() : ICXSession
  • SetSessionAttributes() : ICXSession
  • SetWorkDirectory() : IDSMQStorage
  • SimpleLock() : ICXSession
  • SimpleUnlock() : ICXSession
  • StopAll() : ISMngr
  • StopTaskByID() : ISMngr
  • StoreArchiveCallAttributes() : ICXArchive
  • StoreEvent() : ICXSession
  • SubscribeNotification() : ICXSession

- t -

  • Terminate() : _ILevel2CCEvents, _Ilevel1Events
  • TransferCall() : ILevel2CC


Aplikační rozhraní systému CallChange: Zdrojový soubor CxL2CC.idl

CxL2CC.idl

00001 // DsCssSrv.idl : IDL source for CxL2CC.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (CxL2CC.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009
00010
00021         [
00022                 object,
00023                 uuid(5B445C6E-A4D8-43B2-9BA9-C20DC69A7EB2),
00024                 dual,
00025                 helpstring("ILevel2CC Interface"),
00026                 pointer_default(unique)
00027         ]
00028         interface ILevel2CC : IDispatch
00029         {
00030
00032                 [id(1), helpstring("method Init")] HRESULT Init
00033                         (
00035                         [in] BSTR AppName,
00038                         [out,retval] BOOLEAN *retVal
00039                         );
00040
00042                 [id(2), helpstring("method GetSession")] HRESULT GetSession
00043                         (
00045                         [out,retval] VARIANT *retVal
00046                         );
00047
00049                 [id(3), helpstring("method SetCallRc")] HRESULT SetCallRc
00050                         (
00052                         [in] BSTR CCID,
00054                         [in] BSTR Rc,
00065                         [in] BSTR Rc2,
00067                         [in] BSTR Description,
00069                         [out,retval] VARIANT *retVal
00070                         );
00071
00075                 [id(4), helpstring("method CloseCall")] HRESULT CloseCall
00076                         (
00078                         [in] BSTR CCID,
00080                         [out,retval] VARIANT *retVal
00081                         );
00082
00084                 [id(5), helpstring("method TransferCall")] HRESULT TransferCall
00085                         (
00087                         [in] BSTR callid,
00089                         [in] BSTR LineName,
00091                         [in] BSTR LineNumber,
00093                         [out,retval] VARIANT *retVal
00094                         );
00095
00097                 [id(4), helpstring("method LogWrite")] HRESULT LogWrite
00098                         (
00100                         [in] BSTR Text,
00101                         );
00102
00104                 [id(5), helpstring("method Record")] HRESULT Record
00105                         (
00107                         [out,retval] VARIANT *retVal
00108                         );
00109
00111                 [id(6), helpstring("method Dial")] HRESULT Dial
00112                         (
00114                         [in] BSTR GroupID,
00116                         [in] BSTR NumList,
00118                         [out,retval] VARIANT *retVal
00119                         );
00120
00121         };
00122
00123
00124
00125 [
00126         uuid(27F26B84-7EEC-409D-A119-8B48C78BCB5C),
00127         version(1.0),
00128         helpstring("ILevel2CC 1.0 Type Library")
00129 ]
00130 library ILevel2CCLib
00131 {
00132         importlib("stdole32.tlb");
00133         importlib("stdole2.tlb");
00134
00135         [
00136                 uuid(DAAA4B47-4A66-4284-A9CD-F32ADADDF2DF),
00137                 helpstring("_ILevel2CCEvents Interface")
00138         ]
00139
00141         dispinterface _ILevel2CCEvents
00142         {
00143                 properties:
00144                 methods:
00146                 [id(1), helpstring("method Terminate")] HRESULT Terminate();
00147
00149                 [id(2), helpstring("method OnDial")] HRESULT OnDial(
00151                         [in] BSTR LineName
00152                   );
00153
00155                 [id(3), helpstring("method OnMessage")] HRESULT OnMessage(
00157                         [in] BSTR LineName,
00159                         [in] BSTR callid,
00161                         [in] BSTR cccall,
00163                         [in] BSTR MessageType,
00165                         [in] BSTR Params
00166                   );
00167
00169                 [id(4), helpstring("method OnCall")] HRESULT OnCall(
00171                         [in] BSTR LineName,
00173                         [in] BSTR callid,
00175                         [in] BSTR cccall,
00177                         [in] BSTR Params
00178                   );
00179
00181                 [id(5), helpstring("method ActivateOnCall")] HRESULT ActivateOnCall(
00183                         [in] BSTR LineName,
00185                         [in] BSTR callid,
00187                         [in] BSTR cccall,
00189                         [in] BSTR Params
00190                   );
00191         };
00192
00193         [
00194                 uuid(01467B50-1528-4AAF-BA70-18D40A8F8464),
00195                 helpstring("ILevel2CC Class")
00196         ]
00197         coclass Core
00198         {
00199                 [default] interface ILevel2CC;
00200         };
00201 };


Aplikační rozhraní systému CallChange: Zdrojový soubor cx_xml_stub.idl

cx_xml_stub.idl

00001 // cx_xml_stub.idl : IDL source for cx_xml_stub.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (cx_xml_stub.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009
00010         [
00011                 object,
00012                 uuid(319C3E8D-8E0C-42EF-A0AE-3A8B10C681D7),
00013                 dual,
00014                 helpstring("ICXXMLRPCPlugin Interface"),
00015                 pointer_default(unique)
00016         ]
00018
00034         interface ICXXMLRPCPlugin : IDispatch
00035         {
00037                 [id(1), helpstring("method Init")]
00038                         HRESULT Init(
00040                                 [in] long port
00041                                 );
00043                 [id(2), helpstring("method Done")]
00044                         HRESULT Done();
00046                 [id(3), helpstring("method AddService")]
00047                         HRESULT AddService(
00049                                 [in] BSTR serviceName,
00051                                 [in] IDispatch* service
00052                                 );
00053
00055                 [id(4), helpstring("method AddProgID")]
00056                         HRESULT AddProgID(
00058                                 [in] BSTR ProgID,
00060                                 [in] BSTR options
00061                                 );
00062         };
00063
00064
00066         [
00067                 object,
00068                 uuid(5BAB5EEC-344E-47F6-B1CE-5597C2928A6E),
00069                 dual,
00070                 helpstring("IDSXMLRPCClient Interface"),
00071                 pointer_default(unique)
00072         ]
00073         interface IDSXMLRPCClient : IDispatch
00074         {
00076                 [id(1), helpstring("method Init")]
00077                         HRESULT Init(
00079                                 [in] BSTR url,
00081                                 [in] BSTR options,
00083                                 [out,retval] BSTR *retStat
00084                                 );
00085
00087                 [id(2), helpstring("method CallXMLRPC")]
00088                         HRESULT CallXMLRPC(
00089
00091                                 [in] BSTR methodName,
00092
00094                                 [in] VARIANT paramArray,
00095
00097                                 [in,out] VARIANT *result,
00098
00100                                 [in,out] VARIANT *errMsg,
00101
00103                                 [out,retval] long *errCode
00104                                 );
00105
00107                 [propget, id(3), helpstring("property COMSessionID")]
00108                         HRESULT COMSessionID([out, retval] BSTR *pVal);
00109
00112                 [id(4), helpstring("method GetProxyObject")]
00113                         HRESULT GetProxyObject(
00115                                 [in] BSTR objectName,
00117                                 [out,retval] IDispatch **obj);
00118
00120                 [id(5), helpstring("method CreateCOMSession")]
00121                         HRESULT CreateCOMSession([in] BSTR sessionName);
00122         };
00123
00124
00125
00126 [
00127         uuid(EAD32C70-8850-4684-AF9F-8EB4BE4E9EAA),
00128         version(1.0),
00129         helpstring("cx_xml_stub 1.0 Type Library")
00130 ]
00131 library CX_XML_STUBLib
00132 {
00133         importlib("stdole32.tlb");
00134         importlib("stdole2.tlb");
00135
00136
00137         [
00138                 uuid(E8F793FE-A968-4123-8D4A-8016F3FB3D63),
00139                 helpstring("CXXMLRPCPlugin Class")
00140         ]
00141         coclass CXXMLRPCPlugin
00142         {
00143                 [default] interface ICXXMLRPCPlugin;
00144         };
00145
00146         [
00147                 uuid(031F1A41-1D1A-4FCC-8115-3EFCAFC534E5),
00148                 helpstring("DSXMLRPCClient Class")
00149         ]
00150         coclass DSXMLRPCClient
00151         {
00152                 [default] interface IDSXMLRPCClient;
00153         };
00154
00155         [
00156                 uuid(5139729F-6D41-4B4C-A1B2-231B69DF1435),
00157                 helpstring("DispatchProxy Class"),
00158                 noncreatable
00159
00160         ]
00161         coclass DispatchProxy
00162         {
00163                 [default] interface IDispatch;
00164         };
00165 };


Aplikační rozhraní systému CallChange: Seznam členů třídy

ISysDbConn Seznam členů třídy

Zde naleznete úplný seznam členů třídy ISysDbConn, včetně všech zděděných členů.

ExecuteSQL([in] BSTR sqlCommand,[in] BSTR options,[in] BSTR lockKey,[in, out]VARIANT *numRec,[out, retval] BSTR *retStat) (definován v ISysDbConn) | ISysDbConn
GetData([in] BSTR sqlQuery,[in] long rowMax,[in, out] VARIANT *records,[out, retval] BSTR *retStat) | ISysDbConn
GetObjData([in] BSTR spec,[in] GOB_SpecType spectype,[in] BSTR options,[in] long rowMax,[in, out] VARIANT *records,[out, retval] BSTR *retStat) | ISysDbConn
GOB_MQ_LIKE hodnota výčtu | ISysDbConn
GOB_SpecType jméno výčtu | ISysDbConn
GOB_SQL_FULL hodnota výčtu | ISysDbConn
GOB_SQL_WHERE hodnota výčtu | ISysDbConn
SDO_ADD_NEW hodnota výčtu | ISysDbConn
SDO_ERR_NOREPORT hodnota výčtu | ISysDbConn
SDO_UPDATE hodnota výčtu | ISysDbConn
SDO_UPDATE_OR_ADD hodnota výčtu | ISysDbConn
SetData([in] BSTR tableName,[in] BSTR selCrit,[in] BSTR data,[in] StoreDataOptions options,[in] BSTR lockKey,[in, out] VARIANT *numAffRec,[out, retval] BSTR *retStat) | ISysDbConn
StoreDataOptions jméno výčtu | ISysDbConn


Aplikační rozhraní systému CallChange: Zdrojový soubor DSMQueue.idl

DSMQueue.idl

00001 // DSMQueue.idl : IDL source for DSMQueue.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (DSMQueue.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009
00010
00011
00012
00014
00018         [
00019                 object,
00020                 uuid(D55C4EE5-63E9-49c3-9BAA-D9776CEBF3FA),
00021                 helpstring("IDSInprocQI Interface"),
00022                 oleautomation,
00023                 pointer_default(unique)
00024         ]
00025         interface IDSInprocQI : IUnknown
00026         {
00027                 [helpstring("Query for inproc interface pointer without proxy-stub")]
00028                         HRESULT InprocQueryInterface([in] BSTR iidQ
00029                                                                                 ,[out,retval] long *inprocItfc
00030                                                                                 );
00031         };
00032
00033
00034         [
00035                 object,
00036                 uuid(FCA186B4-F5F4-49e5-96F4-1FA2BBC0C3B8),
00037                 helpstring("IDSMQManage"),
00038                 oleautomation,
00039                 pointer_default(unique)
00040         ]
00041         interface IDSMQManage : IUnknown
00042         {
00043                 [helpstring("method SetMaxWaitTime")] HRESULT SetMaxWaitTime([in] long maxTimeout);
00044         };
00045
00046
00047
00049
00097         [
00098                 object,
00099                 uuid(04A1983C-7DBC-489D-A911-97C356CF6BC2),
00100                 dual,
00101                 helpstring("IDSMQStorage Interface"),
00102                 pointer_default(unique)
00103         ]
00104         interface IDSMQStorage : IDispatch
00105         {
00107         typedef enum
00108                 {
00110                 DSMQS_MULTIPLE=1,
00112                 DSMQS_PERSISTENT=2,
00114                 DSMQS_PUT_FRONT=4,
00116                 DSMQS_NOREMOVE=8,
00118                 DSMQS_NODATA=16,
00120                 DSMQS_LOCK=32,
00122                 DSMQS_ENABLE_NEW=64,
00124                 DSMQS_WAIT_50=128,
00126                 DSMQS_LIFO=256,
00128                 DSMQS_DELETETABLE=512,
00129                 DSMQS_FLAG_BND
00130                 } DSMQStorageFlags;
00131
00142                 [id(1), helpstring("Puts record(s) to storage")]
00143                         HRESULT PutRecords      ([in]   BSTR    tableName
00144                                                                 ,[in]   VARIANT recordAttr
00145                                                                 ,[in]   VARIANT *data
00146                                                                 ,[in,defaultvalue(0)] long flags
00147                                                                 ,[out,retval] VARIANT *recordID
00148                                                                 );
00149
00161                 [id(2), helpstring("Get records specifyed by formula")]
00162                         HRESULT GetRecords      ([in] BSTR      tableName
00163                                                                 ,[in] BSTR attrFormula
00164                                                                 ,[in,out] VARIANT *recordAttr
00165                                                                 ,[in,out] VARIANT *data
00166                                                                 ,[in,defaultvalue(0)] long flags
00167                                                                 ,[in,defaultvalue(0)] long timeout
00168                                                                 ,[in,defaultvalue(1)] long maxcount
00169                                                                 ,[out,retval] long *retCount
00170                                                                 );
00171
00173                 [id(3), helpstring("Delete records from store")]
00174                         HRESULT DeleteRecords([in] BSTR tableName
00175                                                                 ,[in] BSTR attrFormula
00176                                                                 ,[out,retval] long *retCount
00177                                                                 );
00178
00180                 [id(4), helpstring("Set some attributes and/or data of records")]
00181                         HRESULT SetAttr ([in] BSTR      tableName
00182                                                         ,[in] BSTR attrFormula
00183                                                         ,[in] BSTR newAttr
00184                                                         ,[in,defaultvalue(0)] long flags
00185                                                         ,[in,optional] VARIANT *data
00186                                                         ,[out,retval] long *retCount
00187                                                         );
00188
00190                 [id(5), helpstring("Set working directory for persistent records")]
00191                         HRESULT SetWorkDirectory([in] BSTR fileDir
00192                                                                         );
00194                 [id(6), helpstring("Return unique ID (unique for this store only)")]
00195                         HRESULT GetNextID([out,retval] BSTR *retID);
00196
00199                                 [id(7), helpstring("method SetIDPersist")]
00200                         HRESULT SetIDPersist(
00203                                 [in] BSTR regValName
00204                                 );
00205
00206                 [id(8), helpstring("method GetLastFlagImplemented"),hidden]
00207                         HRESULT GetLastFlagImplemented([out, retval] DSMQStorageFlags *flg);
00208         };
00209         [
00210                 object,
00211                 uuid(93EB4CBF-C4A0-4B11-BF94-85B9260F457A),
00212                 dual,
00213                 helpstring("IMQSingleThr Interface"),
00214                 pointer_default(unique)
00215         ]
00216         interface IMQSingleThr : IDispatch
00217         {
00218                 [id(1), helpstring("method GetDirectInterface")] HRESULT GetDirectInterface([in] IDSMQStorage *mq, [out,retval] IDSMQStorage **rv);
00219         };
00220
00221
00222 [
00223         uuid(EE71C2BD-2057-49F1-A9EF-998376D22DA4),
00224         version(1.0),
00225         helpstring("DSMQueue 1.0 Type Library")
00226 ]
00227 library DSMQUEUELib
00228 {
00229         importlib("stdole32.tlb");
00230         importlib("stdole2.tlb");
00231
00232         [
00233                 uuid(D731C4F4-3E88-4CFE-8171-5F7A2B68AC11),
00234                 helpstring("DSMQueue.Storage")
00235         ]
00236         coclass DSMQStorage
00237         {
00238                 [default] interface IDSMQStorage;
00239                 interface IDSInprocQI;
00240                 interface IDSMQManage;
00241         };
00242
00243         [
00244                 uuid(05945E14-D1D7-4B59-B52B-EFF977F8535D),
00245                 helpstring("MQSingleThr class")
00246         ]
00247         coclass MQSingleThr
00248         {
00249                 [default] interface IMQSingleThr;
00250         };
00251
00252
00253
00254 };


Aplikační rozhraní systému CallChange: Zdrojový soubor DsCssSrv.idl

DsCssSrv.idl

00001 // DsCssSrv.idl : IDL source for DsCssSrv.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (DsCssSrv.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009
00010
00012         [
00013                 object,
00014                 uuid(5B445C6E-A4D8-43B2-9BA9-C20DC69A7EB2),
00015                 dual,
00016                 helpstring("ICore Interface"),
00017                 pointer_default(unique)
00018         ]
00019         interface ICore : IDispatch
00020         {
00021
00031                 [id(1), helpstring("method Search")] HRESULT Search
00032                         (
00037                         [in] BSTR SetName,
00039                         [in] BSTR NormTelNum,
00041                         [in] BSTR EntrTelNum,
00042                         [out,retval] VARIANT *retVal
00043                         );
00044
00046                 [id(2), helpstring("method GetStorePF")] HRESULT GetStorePF
00047                         (
00048                         [out,retval] VARIANT *retVal
00049                         );
00050
00058                 [id(3), helpstring("method SearchEx")] HRESULT SearchEx
00059                         (
00064                         [in] BSTR SetName,
00066                         [in] BSTR NormTelNum,
00068                         [in] BSTR EntrTelNum,
00072                         [out,retval] VARIANT *retVal
00073                         );
00074
00076                 [id(4), helpstring("method SearchSQL")] HRESULT SearchSQL
00077                         (
00082                         [in] BSTR SetName,
00088                         [in] BSTR AttrFormula,
00091                         [in,out] VARIANT *retVal,
00093                         [in, defaultvalue(1)] long  maxcount,
00095                         [out,retval] long *retCount
00096                         );
00097         };
00098
00099 [
00100         uuid(27F26B84-7EEC-409D-A119-8B48C78BCB5C),
00101         version(1.0),
00102         helpstring("DsCssSrv 1.0 Type Library")
00103 ]
00104 library DSCSSSRVLib
00105 {
00106         importlib("stdole32.tlb");
00107         importlib("stdole2.tlb");
00108
00109         [
00110                 uuid(01467B50-1528-4AAF-BA70-18D40A8F8464),
00111                 helpstring("Core Class")
00112         ]
00113         coclass Core
00114         {
00115                 [default] interface ICore;
00116         };
00117 };


Aplikační rozhraní systému CallChange: Seznam členů třídy

ICXServer Seznam členů třídy

Zde naleznete úplný seznam členů třídy ICXServer, včetně všech zděděných členů.

Done() | ICXServer
GetSession([in] BSTR sessID,[out, retval] ICXSession **session) | ICXServer
Init() | ICXServer
MakeNewSession([in, defaultvalue("")] BSTR options,[out, retval] ICXSession **session) | ICXServer


Aplikační rozhraní systému CallChange: Zdrojový soubor DSShareObj.idl

DSShareObj.idl

00001 // DSShareObj.idl : IDL source for DSShareObj.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (DSShareObj.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009 import "DSServMngr.idl";
00010
00012         [
00013                 object,
00014                 uuid(0E338102-40F1-4063-9D0B-4293B24520CE),
00015                 dual,
00016                 helpstring("IShareObj Interface"),
00017                 pointer_default(unique)
00018         ]
00019         interface IShareObj : IDispatch
00020         {
00022                 [id(1), helpstring("Offer local object to others. Name of offered service type is identified by typeID string")]
00023                         HRESULT OfferObject([in] IDispatch *obj
00024                                                                 , [in] BSTR typeID
00025                                                                 ,[in,defaultvalue(0)] long timeout
00026                                                                 ,[in,optional] VARIANT param
00027                                                                 ,[out,retval] BOOL *used);
00028
00030                 [id(2), helpstring("Get offered object from manager")]
00031                         HRESULT GetObject(      [in] BSTR typeID
00032                                                                 ,[in] long timeout
00033                                                                 ,[in] long processTimeout
00034                                                                 ,[in,defaultvalue(0)] long taskID
00035                                                                 ,[in,out,optional] VARIANT *param
00036                                                                 ,[out,retval] IDispatch **obj);
00037
00039                 [id(3), helpstring("Disconnect all clients of specified type")]
00040                         HRESULT DisconnectAll([in,defaultvalue("")] BSTR typeID);
00041
00043                 [id(4), helpstring("method Publish")]
00044                         HRESULT Register([in] BSTR pubName, [in] IDispatch *obj);
00045
00047                 [id(5), helpstring("method Revoke")]
00048                         HRESULT Revoke([in] BSTR pubName);
00049
00051                 [id(6), helpstring("method GetPublicObject")]
00052                         HRESULT GetPublicObject([in] BSTR pubName, [in,out] VARIANT *pubObj, [out,retval] BOOL *found);
00053         };
00054         [
00055                 object,
00056                 uuid(965720C8-8FFA-4F08-AC37-CF79422CBB00),
00057
00058                 helpstring("IDispDelegator Interface"),
00059                 pointer_default(unique)
00060         ]
00061         interface IDispDelegator : IUnknown
00062         {
00063         };
00064
00065
00066 [
00067         uuid(B3535BCA-E647-4A06-BA01-AF0F36E0F438),
00068         version(1.0),
00069         helpstring("DSShareObj 1.0 Type Library")
00070 ]
00071 library DSSHAREOBJLib
00072 {
00073         importlib("stdole32.tlb");
00074         importlib("stdole2.tlb");
00075
00076         [
00077                 uuid(C5C0408B-1D3B-4DB2-BDB7-376BFDA88447),
00078                 helpstring("Sharing script objects across machine or network")
00079         ]
00080         coclass ShareObj
00081         {
00082                 [default] interface IShareObj;
00083         };
00084
00085         [
00086                 uuid(B1AFB2F9-9795-43AE-B837-318832E8640F),
00087                 helpstring("DispDelegator Class")
00088         ]
00089         coclass DispDelegator
00090         {
00091                 [default]       interface IDispDelegator;
00092                                         interface IDispatch;
00093         };
00094 };


Aplikační rozhraní systému CallChange: Zdrojový soubor callchange.dcm

callchange.dcm

00001
00143
00144
00204
00205
00256
00257
00264
00265
00266
00272
00273
00279
00280
00286
00287
00293
00294


Aplikační rozhraní systému CallChange: Seznam členů třídy

IShareObj Seznam členů třídy

Zde naleznete úplný seznam členů třídy IShareObj, včetně všech zděděných členů.

DisconnectAll([in, defaultvalue("")] BSTR typeID) | IShareObj
DisconnectAll([in, defaultvalue("")] BSTR typeID) | IShareObj
GetObject([in] BSTR typeID,[in] long timeout,[in] long processTimeout,[in, defaultvalue(0)] long taskID,[in, out, optional] VARIANT *param,[out, retval] IDispatch **obj) | IShareObj
GetObject([in] BSTR typeID,[in] long timeout,[in] long processTimeout,[in, defaultvalue(0)] long taskID,[in, out, optional] VARIANT *param,[out, retval] IDispatch **obj) | IShareObj
GetPublicObject([in] BSTR pubName,[in, out] VARIANT *pubObj,[out, retval] BOOL *found) | IShareObj
GetPublicObject([in] BSTR pubName,[in, out] VARIANT *pubObj,[out, retval] BOOL *found) | IShareObj
OfferObject([in] IDispatch *obj,[in] BSTR typeID,[in, defaultvalue(0)] long timeout,[in, optional] VARIANT param,[out, retval] BOOL *used) | IShareObj
OfferObject([in] IDispatch *obj,[in] BSTR typeID,[in, defaultvalue(0)] long timeout,[in, optional] VARIANT param,[out, retval] BOOL *used) | IShareObj
Register([in] BSTR pubName,[in] IDispatch *obj) | IShareObj
Register([in] BSTR pubName,[in] IDispatch *obj) | IShareObj
Revoke([in] BSTR pubName) | IShareObj
Revoke([in] BSTR pubName) | IShareObj


Aplikační rozhraní systému CallChange: Zdrojový soubor CxClient2.idl

CxClient2.idl

00001 // CxClient2.idl : IDL source for CxClient2.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (CxClient2.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009 //import "DsCssSrv.idl";
00010
00012         [
00013                 object,
00014                 uuid(73880C55-7A97-4361-B3D8-A93FC9138923),
00015                 dual,
00016                 helpstring("Ilevel1 Interface"),
00017                 pointer_default(unique)
00018         ]
00019         interface Ilevel1 : IDispatch
00020         {
00024                 [id(1), helpstring("method Init")] HRESULT Init
00025                         (
00027                         [in] BSTR AppName,
00029                         [in] long AppLicenseBit
00030                         );
00032                 [id(2), helpstring("method ConnectLine")] HRESULT ConnectLine
00033                         (
00035                         [in] BSTR lineName,
00037                         [out, retval] BSTR *retStat
00038                         );
00040                 [id(3), helpstring("method DisconnectLine")] HRESULT DisconnectLine
00041                         (
00043                         [in] BSTR lineName,
00045                         [out, retval] BSTR *retStat
00046                         );
00048                 [id(4), helpstring("method Dial")] HRESULT Dial
00049                         (
00051                         [in] BSTR LineName,
00053                         [in] BSTR  Number,
00055                         [out,retval] BSTR *retStat
00056                         );
00058                 [id(5), helpstring("method Redirect")] HRESULT Redirect
00059                         (
00061                         [in] BSTR CallID,
00063                         [in] BSTR  Number,
00065                         [out,retval] BSTR *retStat
00066                         );
00068                 [id(6), helpstring("method HangUp")] HRESULT HangUp
00069                         (
00071                         [in] BSTR CallID,
00073                         [out,retval] BSTR *retStat
00074                         );
00076                 [id(7), helpstring("method Answer")] HRESULT Answer
00077                         (
00079                         [in] BSTR CallID,
00081                         [out,retval] BSTR *retStat
00082                         );
00084                 [id(8), helpstring("method OperateCall")] HRESULT OperateCall
00085                         (
00087                         [in] BSTR CallID,
00089                         [in] BSTR OperationName,
00091                         [in] BSTR Params,
00093                         [out,retval] BSTR *retStat
00094                         );
00096                 [id(9), helpstring("method CloseCallSession")] HRESULT CloseCallSession
00097                         (
00099                         [in] BSTR CallID
00100                         );
00102                 [id(10), helpstring("method GetStandList")] HRESULT GetStandList
00103                         (
00105                         [out] VARIANT *LineNames,
00107                         [out] VARIANT *Numbers
00108                         );
00110                 [id(11), helpstring("method GetLocalLines")] HRESULT GetLocalLines
00111                         (
00113                         [out,retval] VARIANT *LineNames
00114                         );
00116                 [id(12), helpstring("method GetLineState")] HRESULT GetLineState
00117                         (
00119                         [in] BSTR LineName,
00120                         [out,retval] BSTR *State
00121                         );
00123                 [id(13), helpstring("method GetConfigItem")] HRESULT GetConfigItem
00124                         (
00127                         [in] BSTR ItemName,
00129                         [out,retval] BSTR *Value
00130                         );
00132                 [id(14), helpstring("method GetArchive")] HRESULT GetArchive
00133                         (
00134                         [out, retval] VARIANT *pVal
00135                         );
00137                 [id(15), helpstring("method GetLineInfo")] HRESULT GetLineInfo
00138                         (
00140                         [in] BSTR LineName,
00141                         [out, retval] BSTR *retInfo
00142                         );
00144                 [id(16), helpstring("method GetStorage")] HRESULT GetStorage([out,retval] VARIANT *pVal);
00146                 [id(17), helpstring("method GetSession")]
00147                         HRESULT GetSession([out,retval] VARIANT *pVal);
00149                 [id(18), helpstring("method Consultation")] HRESULT Consultation
00150                         (
00152                         [in] BSTR CallID,
00154                         [in] BSTR number,
00156                         [in,out] VARIANT *consultCallID,
00158                         [out,retval] BSTR *retStat
00159                         );
00160                 [id(19), helpstring("method GetContactSearchServer")] HRESULT GetContactSearchServer([out,retval] VARIANT *pVar);
00161
00162         };
00163
00164 [
00165         uuid(997B7322-C787-4BC9-9C0B-8732CCCB995F),
00166         version(1.0),
00167         helpstring("CxClient 1.0 Type Library")
00168 ]
00169 library CXCLIENT2Lib
00170 {
00171         importlib("stdole32.tlb");
00172         importlib("stdole2.tlb");
00173
00174         [
00175                 uuid(DAAA4B47-4A66-4284-A9CD-F32ADADDF2DC),
00176                 helpstring("_Ilevel1Events Interface")
00177         ]
00178
00180         dispinterface _Ilevel1Events
00181         {
00182                 properties:
00183                 methods:
00185                 [id(1), helpstring("method Terminate")] HRESULT Terminate();
00187                 [id(2), helpstring("method Enabled")] HRESULT Enabled();
00189                 [id(3), helpstring("method Disabled")] HRESULT Disabled();
00191                 [id(4), helpstring("method InComingCall")] HRESULT InComingCall([in] BSTR CallID);
00193                 [id(5), helpstring("method PhoneUp")] HRESULT PhoneUp([in] BSTR CallID);
00195                 [id(6), helpstring("method OutGoingCall")] HRESULT OutGoingCall([in] BSTR CallID);
00197                 [id(7), helpstring("method Connected")] HRESULT Connected([in] BSTR CallID);
00199                 [id(8), helpstring("method Busy")] HRESULT Busy([in] BSTR CallID);
00201                 [id(9), helpstring("method EndCall")] HRESULT EndCall([in] BSTR CallID);
00203                 [id(10), helpstring("method Ringing")] HRESULT Ringing([in] BSTR CallID);
00205                 [id(11), helpstring("method CallCreated")] HRESULT CallCreated(BSTR CallID, BSTR LineID, BSTR Number, BSTR Cause);
00207                 [id(12), helpstring("method CallInfo")] HRESULT CallInfo(BSTR CallID, BSTR LocalNumber, BSTR RemoteNumber, BSTR Direction, BSTR State, BSTR OtherParams);
00209                 [id(13), helpstring("method LineError")] HRESULT LineError([in] BSTR CallID, [in] BSTR ErrCode, [in] BSTR OtherParams);
00211                 [id(14), helpstring("method ServerConnection")] HRESULT ServerConnection([in] BSTR Connected);
00213                 [id(15), helpstring("method Notify")] HRESULT Notify([in] BSTR msgType,[in] BSTR msgData);
00214         };
00215
00216         [
00217                 uuid(7C43B021-8D6D-4969-A8C3-F69076025D36),
00218                 helpstring("level1 Class")
00219         ]
00220         coclass level1
00221         {
00222                 [default] interface Ilevel1;
00223                 [default, source] dispinterface _Ilevel1Events;
00224         };
00225 };


Aplikační rozhraní systému CallChange: Zdrojový soubor cxglueline.idl

cxglueline.idl

00001 // cxglueline.idl : IDL source for cxglueline.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (cxglueline.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009
00010
00020         [
00021                 object,
00022                 uuid(754CFCC8-B3DC-42E0-ABCF-B0EDD5E3CE1F),
00023                 dual,
00024                 helpstring("ICXGlueLine Interface"),
00025                 pointer_default(unique)
00026         ]
00027         interface ICXGlueLine : IDispatch
00028         {
00030                 [id(1), helpstring("method Init")]
00031                         HRESULT Init(
00033                                 [in] BSTR instanceNumber,
00035                                 [out,retval] BSTR *retStat);
00036
00038                 [id(2), helpstring("method GetLinesConfig")]
00039                         HRESULT GetLinesConfig(
00044                                 [in,out] VARIANT *linesCfg,
00048                                 [out,retval] BSTR *retStat);
00058                 [id(3), helpstring("method RegisterLine")]
00059                         HRESULT RegisterLine(
00061                                 [in] BSTR lineName,
00066                                 [in] BSTR enabled,
00070                                 [in] BSTR attStat,
00072                                 [out, retval] BSTR *retStat);
00073
00074
00076                 [id(4), helpstring("method SendLineEvent")]
00077                         HRESULT SendLineEvent(
00079                                 [in] BSTR lineName,
00081                                 [in] BSTR driverCallid,
00083                                 [in] BSTR mtype,
00085                                 [in] BSTR params,
00089                                 [out,retval] BSTR *retStat
00090                                 );
00091
00092
00094                 [id(5), helpstring("method GetOperationRequest")]
00095                         HRESULT GetOperationRequest(
00097                                 [in] long timeout,
00099                                 [in,out] VARIANT *line,
00101                                 [in,out] VARIANT *action,
00103                                 [in,out] VARIANT *attrs,
00105                                 [in,out] VARIANT *data,
00113                                 [out,retval] BSTR *retStat);
00114
00116                 [id(6), helpstring("method GetCfgItem")]
00117                         HRESULT GetCfgItem(
00118                         [in] BSTR itemName,
00119                         [out,retval] VARIANT *itemValue);
00120
00122                 [id(7), helpstring("method CreateNewCall")]
00123                         HRESULT CreateNewCall(
00125                                 [in] BSTR lineName,
00127                                 [in,out] VARIANT *id,
00131                                 [out,retval] BSTR *retStat
00132                                 );
00134                 [id(8), helpstring("method GetLineFromStand")]
00135                         HRESULT GetLineFromStand(
00137                                 [in] BSTR stand,
00139                                 [out,retval] BSTR *line
00140                                 );
00141
00143                 [id(9), helpstring("method GetStandFromLine")]
00144                         HRESULT GetStandFromLine(
00146                                 [in] BSTR line,
00148                                 [out,retval] BSTR *stand
00149                                 );
00151                 [id(10), helpstring("method GetSession")]
00152                         HRESULT GetSession(
00154                                 [in,out] VARIANT *session,
00158                                 [out,retval] BSTR *retStat);
00159         };
00160
00161 [
00162         uuid(F3AD7DB9-87D0-4EDF-B313-901926EB1735),
00163         version(1.0),
00164         helpstring("cxglueline 1.0 Type Library")
00165 ]
00166 library CXGLUELINELib
00167 {
00168         importlib("stdole32.tlb");
00169         importlib("stdole2.tlb");
00170
00171
00172         [
00173                 uuid(4DEE6FBF-B174-47FA-BDEA-C4D575CAFD57),
00174                 helpstring("CXGlueLine Class")
00175         ]
00176         coclass CXGlueLine
00177         {
00178                 [default] interface ICXGlueLine;
00179         };
00180 };


Aplikační rozhraní systému CallChange: Zdrojový soubor PhoneNormalizer.idl

PhoneNormalizer.idl

00001 // PhoneNormalizer.idl : IDL source for PhoneNormalizer.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (PhoneNormalizer.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009
00011         [
00012                 object,
00013                 uuid(180AA8F1-6C1F-4F6E-A3A3-2C936CA1599D),
00014                 dual,
00015                 helpstring("IPhNormalizer Interface"),
00016                 pointer_default(unique)
00017         ]
00018         interface IPhNormalizer : IDispatch
00019         {
00021                 typedef enum
00022                         {
00024                         NORMALIZER_NUMBER_FROM_PBX=1,
00026                         NORMALIZER_INTERNAL_SHORT=2,
00028                         NORMALIZER_FORMAT_DIAL=4,
00030                         NORMALIZER_FORMAT_SHORTEST=8
00031                         } PhoneNormalizerOptions;
00032
00036                 [id(1), helpstring("method Normalize")]
00037                         HRESULT Normalize(
00039                                 [in] BSTR phoneNum,
00041                                 [in] long options,
00042                                 [out,retval] BSTR *result
00043                                 );
00044
00046                 [id(2), helpstring("method MakeVariations")]
00047                         HRESULT MakeVariations(
00049                                 [in] BSTR phoneNum,
00051                                 [in] long options,
00053                                 [out,retval] BSTR *result
00054                                 );
00055
00057                 [id(3), helpstring("method Init")]
00058                         HRESULT Init(
00060
00073                                 [in] BSTR paramList
00074                                 );
00076                 [id(4), helpstring("method Format")]
00077                         HRESULT Format(
00079                                 [in] BSTR num,
00084                                 [in] long options,
00085                                 [out,retval] BSTR *result);
00086                 [propget, id(5), helpstring("property InternationalAccessCode")] HRESULT InternationalAccessCode([out, retval] BSTR *pVal);
00087                 [propput, id(5), helpstring("property InternationalAccessCode")] HRESULT InternationalAccessCode([in] BSTR newVal);
00088                 [propget, id(6), helpstring("property LocalCountryCode")] HRESULT LocalCountryCode([out, retval] BSTR *pVal);
00089                 [propput, id(6), helpstring("property LocalCountryCode")] HRESULT LocalCountryCode([in] BSTR newVal);
00090                 [propget, id(7), helpstring("property AreaCodeEscape")] HRESULT AreaCodeEscape([out, retval] BSTR *pVal);
00091                 [propput, id(7), helpstring("property AreaCodeEscape")] HRESULT AreaCodeEscape([in] BSTR newVal);
00092                 [propget, id(8), helpstring("property AreaCode")] HRESULT AreaCode([out, retval] BSTR *pVal);
00093                 [propput, id(8), helpstring("property AreaCode")] HRESULT AreaCode([in] BSTR newVal);
00094                 [propget, id(9), helpstring("property PBXdigits")] HRESULT PBXdigits([out, retval] long *pVal);
00095                 [propput, id(9), helpstring("property PBXdigits")] HRESULT PBXdigits([in] long newVal);
00096                 [propget, id(10), helpstring("property PBXCommonPart")] HRESULT PBXCommonPart([out, retval] BSTR *pVal);
00097                 [propput, id(10), helpstring("property PBXCommonPart")] HRESULT PBXCommonPart([in] BSTR newVal);
00098                 [propget, id(11), helpstring("property PBXOutsideAccessCode")] HRESULT PBXOutsideAccessCode([out, retval] BSTR *pVal);
00099                 [propput, id(11), helpstring("property PBXOutsideAccessCode")] HRESULT PBXOutsideAccessCode([in] BSTR newVal);
00100                 [propget, id(12), helpstring("property PBXIncommingPrefix")] HRESULT PBXIncommingPrefix([out, retval] BSTR *pVal);
00101                 [propput, id(12), helpstring("property PBXIncommingPrefix")] HRESULT PBXIncommingPrefix([in] BSTR newVal);
00103                 [id(13), helpstring("method IsNumberInternal")]
00104                         HRESULT IsNumberInternal([in] BSTR num,[out, retval] VARIANT_BOOL *result);
00105                 [propget, id(14), helpstring("property TrunkWildcard")]
00106                         HRESULT TrunkWildcard([out, retval] BSTR *pVal);
00107                 [propput, id(14), helpstring("property TrunkWildcard")]
00108                         HRESULT TrunkWildcard([in] BSTR newVal);
00109
00111                 [id(15), helpstring("method InitFromRegistry")]
00112                         HRESULT InitFromRegistry(
00116                                 [in] BSTR regKeyName
00117                                 ,[out,retval] BSTR *retStat
00118                                 );
00119         };
00120
00121 [
00122         uuid(2128FCCF-AFC9-4800-A115-6D411B3EF1F8),
00123         version(1.0),
00124         helpstring("PhoneNormalizer 1.0 Type Library")
00125 ]
00126 library PHONENORMALIZERLib
00127 {
00128         importlib("stdole32.tlb");
00129         importlib("stdole2.tlb");
00130
00131         [
00132                 uuid(FC2A4C3E-623C-4712-9486-D7D9E145FCC9),
00133                 helpstring("PhNormalizer Class")
00134         ]
00135         coclass PhNormalizer
00136         {
00137                 [default] interface IPhNormalizer;
00138         };
00139 };


Aplikační rozhraní systému CallChange: Seznam členů třídy

IDSMQStorage Seznam členů třídy

Zde naleznete úplný seznam členů třídy IDSMQStorage, včetně všech zděděných členů.

DeleteRecords([in] BSTR tableName,[in] BSTR attrFormula,[out, retval] long *retCount) | IDSMQStorage
DeleteRecords([in] BSTR tableName,[in] BSTR attrFormula,[out, retval] long *retCount) | IDSMQStorage
DSMQS_DELETETABLE hodnota výčtu | IDSMQStorage
DSMQS_ENABLE_NEW hodnota výčtu | IDSMQStorage
DSMQS_FLAG_BND hodnota výčtu (definován v IDSMQStorage) | IDSMQStorage
DSMQS_LIFO hodnota výčtu | IDSMQStorage
DSMQS_LOCK hodnota výčtu | IDSMQStorage
DSMQS_MULTIPLE hodnota výčtu | IDSMQStorage
DSMQS_NODATA hodnota výčtu | IDSMQStorage
DSMQS_NOREMOVE hodnota výčtu | IDSMQStorage
DSMQS_PERSISTENT hodnota výčtu | IDSMQStorage
DSMQS_PUT_FRONT hodnota výčtu | IDSMQStorage
DSMQS_WAIT_50 hodnota výčtu | IDSMQStorage
DSMQStorageFlags jméno výčtu | IDSMQStorage
DSMQStorageFlags jméno výčtu | IDSMQStorage
GetLastFlagImplemented([out, retval] DSMQStorageFlags *flg) (definován v IDSMQStorage) | IDSMQStorage
GetLastFlagImplemented([out, retval] DSMQStorageFlags *flg) (definován v IDSMQStorage) | IDSMQStorage
GetNextID([out, retval] BSTR *retID) | IDSMQStorage
GetNextID([out, retval] BSTR *retID) | IDSMQStorage
GetRecords([in] BSTR tableName,[in] BSTR attrFormula,[in, out] VARIANT *recordAttr,[in, out] VARIANT *data,[in, defaultvalue(0)] long flags,[in, defaultvalue(0)] long timeout,[in, defaultvalue(1)] long maxcount,[out, retval] long *retCount) | IDSMQStorage
GetRecords([in] BSTR tableName,[in] BSTR attrFormula,[in, out] VARIANT *recordAttr,[in, out] VARIANT *data,[in, defaultvalue(0)] long flags,[in, defaultvalue(0)] long timeout,[in, defaultvalue(1)] long maxcount,[out, retval] long *retCount) | IDSMQStorage
PutRecords([in] BSTR tableName,[in] VARIANT recordAttr,[in] VARIANT *data,[in, defaultvalue(0)] long flags,[out, retval] VARIANT *recordID) | IDSMQStorage
PutRecords([in] BSTR tableName,[in] VARIANT recordAttr,[in] VARIANT *data,[in, defaultvalue(0)] long flags,[out, retval] VARIANT *recordID) | IDSMQStorage
SetAttr([in] BSTR tableName,[in] BSTR attrFormula,[in] BSTR newAttr,[in, defaultvalue(0)] long flags,[in, optional] VARIANT *data,[out, retval] long *retCount) | IDSMQStorage
SetAttr([in] BSTR tableName,[in] BSTR attrFormula,[in] BSTR newAttr,[in, defaultvalue(0)] long flags,[in, optional] VARIANT *data,[out, retval] long *retCount) | IDSMQStorage
SetIDPersist([in] BSTR regValName) | IDSMQStorage
SetIDPersist([in] BSTR regValName) | IDSMQStorage
SetWorkDirectory([in] BSTR fileDir) | IDSMQStorage
SetWorkDirectory([in] BSTR fileDir) | IDSMQStorage


Aplikační rozhraní systému CallChange: Seznam členů třídy

IDSInprocQI Seznam členů třídy

Zde naleznete úplný seznam členů třídy IDSInprocQI, včetně všech zděděných členů.

InprocQueryInterface([in] BSTR iidQ,[out, retval] long *inprocItfc) | IDSInprocQI
InprocQueryInterface([in] BSTR iidQ,[out, retval] long *inprocItfc) | IDSInprocQI


Aplikační rozhraní systému CallChange: Seznam členů třídy

Ilevel1 Seznam členů třídy

Zde naleznete úplný seznam členů třídy Ilevel1, včetně všech zděděných členů.

Answer([in] BSTR CallID,[out, retval] BSTR *retStat) | Ilevel1
CloseCallSession([in] BSTR CallID) | Ilevel1
ConnectLine([in] BSTR lineName,[out, retval] BSTR *retStat) | Ilevel1
Consultation([in] BSTR CallID,[in] BSTR number,[in, out] VARIANT *consultCallID,[out, retval] BSTR *retStat) | Ilevel1
Dial([in] BSTR LineName,[in] BSTR Number,[out, retval] BSTR *retStat) | Ilevel1
DisconnectLine([in] BSTR lineName,[out, retval] BSTR *retStat) | Ilevel1
GetArchive([out, retval] VARIANT *pVal) | Ilevel1
GetConfigItem([in] BSTR ItemName,[out, retval] BSTR *Value) | Ilevel1
GetContactSearchServer([out, retval] VARIANT *pVar) (definován v Ilevel1) | Ilevel1
GetLineInfo([in] BSTR LineName,[out, retval] BSTR *retInfo) | Ilevel1
GetLineState([in] BSTR LineName,[out, retval] BSTR *State) | Ilevel1
GetLocalLines([out, retval] VARIANT *LineNames) | Ilevel1
GetSession([out, retval] VARIANT *pVal) | Ilevel1
GetStandList([out] VARIANT *LineNames,[out] VARIANT *Numbers) | Ilevel1
GetStorage([out, retval] VARIANT *pVal) | Ilevel1
HangUp([in] BSTR CallID,[out, retval] BSTR *retStat) | Ilevel1
Init([in] BSTR AppName,[in] long AppLicenseBit) | Ilevel1
OperateCall([in] BSTR CallID,[in] BSTR OperationName,[in] BSTR Params,[out, retval] BSTR *retStat) | Ilevel1
Redirect([in] BSTR CallID,[in] BSTR Number,[out, retval] BSTR *retStat) | Ilevel1


Aplikační rozhraní systému CallChange: Seznam členů třídy

ICXRouter Seznam členů třídy

Zde naleznete úplný seznam členů třídy ICXRouter, včetně všech zděděných členů.

AddNumberToBL([in] BSTR lname,[in] BSTR phnumber,[in] double expirationDays,[in, defaultvalue("")] BSTR agentID,[in, defaultvalue("")] BSTR description,[out, retval] BSTR *retStat) | ICXRouter
CheckNumberInBL([in] BSTR phoneNum,[in] BSTR listName,[in, out] VARIANT *blStat,[out, retval] BSTR *retStat) | ICXRouter
DeleteNumberFromBL([in] BSTR phoneNumber,[in] BSTR listName,[out, retval] BSTR *retStat) | ICXRouter
GetListBlNames([in, out] VARIANT *listNames,[out, retval] BSTR *retStat) | ICXRouter


Aplikační rozhraní systému CallChange: Zdrojový soubor DSServMngr.idl

DSServMngr.idl

00001 // DSServMngr.idl : IDL source for DSServMngr.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (DSServMngr.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009
00011 typedef enum
00012 {
00014         TSUnknown=0,
00016         TSRunning=1,
00018         TSShutdown=2,
00020         TSStop=3
00021 } TaskStatus;
00022
00023
00025         [
00026                 object,
00027                 uuid(8A5A6311-BD0E-11D2-830A-00105A2F4B4E),
00028                 dual,
00029                 helpstring("ISMngr Interface"),
00030                 pointer_default(unique)
00031         ]
00032         interface ISMngr : IDispatch
00033         {
00035                 [id(1), helpstring("Start new task")]
00036                         HRESULT RunCmd([in] BSTR CmdLine
00037                                                 ,[in,defaultvalue(0)] BSTR WorkDir
00038                                                 ,[in,defaultvalue(0)] long StopTimeout
00039                                                 ,[out,retval] BOOL *status
00040                                                 );
00042                 [id(2), helpstring("StopTask identifyed by Task ID")]
00043                         HRESULT StopTaskByID(
00044                                                                 [in] long taskID
00045                                                                 ,[out,retval] BOOL *result
00046                                                                 );
00047                 [id(3), helpstring("StopTask identifyed by name")]
00048                         HRESULT StopTaskByName([in] BSTR taskName,[out,retval] BOOL *status);
00049
00051                 [id(4), helpstring("Stop all managed tasks")]
00052                         HRESULT StopAll ([out,retval] BOOL *result
00053                                                         );
00054
00055
00065                 [id(5), helpstring("Question for new task state")]
00066                         HRESULT GetTaskStatus([in] long taskID
00067                                                                 ,[in] BSTR cmdLine
00068                                                                 ,[out,retval] TaskStatus *status
00069                                                                 );
00070
00072                 [id(6), helpstring("Question if available licences are there")]
00073                         HRESULT QueryLicence([in] long cls
00074                                                                 ,[in] long ProcessID
00075                                                                 ,[in] long instNum
00076                                                                 ,[out,retval] BOOL *retVal
00077                                                                 );
00078         };
00079
00080
00081
00082
00083 [
00084         uuid(43C0E048-BCD8-11D2-830A-00105A2F4B4E),
00085         version(1.0),
00086         helpstring("DSServMngr 1.0 Type Library")
00087 ]
00088 library DSSERVMNGRLib
00089 {
00090         importlib("stdole32.tlb");
00091         importlib("stdole2.tlb");
00100         [
00101                 uuid(8A5A6312-BD0E-11D2-830A-00105A2F4B4E),
00102                 helpstring("DSServMngr.SMngr")
00103         ]
00104         coclass SMngr
00105         {
00106                 [default] interface ISMngr;
00107         };
00108 };
00109
00110 //
00111 // $Log: DSServMngr.idl,v $
00112 // Revision 1.1  2006/04/21 08:08:19  matejka
00113 // zmenena struktura adresaru podle navrhu VV s prihlednutim k CVS
00114 //
00115 // Revision 1.1  2003/08/26 13:32:49  honza
00116 // import do cvs
00117 //
00118 //


Aplikační rozhraní systému CallChange: Seznam členů třídy

IFxExt Seznam členů třídy

Zde naleznete úplný seznam členů třídy IFxExt, včetně všech zděděných členů.

CloseWin32Handle([in] long handle) (definován v IFxExt) | IFxExt
CopyFile([in] BSTR existingFile,[in] BSTR newName,[out, retval] BOOL *result) (definován v IFxExt) | IFxExt
CreateConsole() (definován v IFxExt) | IFxExt
CreateGUID([out, retval] BSTR *retVal) (definován v IFxExt) | IFxExt
CreateMutex([in] BSTR NameOfObject,[out, retval] long *handle) (definován v IFxExt) | IFxExt
CreateSemaphore([in] BSTR NameOfObject,[in, out] VARIANT *handle,[out, retval] BOOL *firstInstance) (definován v IFxExt) | IFxExt
CreateTemporaryFilePath([in] BSTR ext,[out, retval] BSTR *FilePath) (definován v IFxExt) | IFxExt
DeleteFile([in]BSTR file,[out, retval] long *pRet) (definován v IFxExt) | IFxExt
GetCurrentProcessId([out, retval] long *id) (definován v IFxExt) | IFxExt
GetItemFromList([in] BSTR itemName,[in] BSTR itemList,[in, defaultvalue("=")] BSTR ass,[in, defaultvalue("|")] BSTR sep,[in, defaultvalue("\\")] BSTR esc,[out, retval] VARIANT *itemValue) (definován v IFxExt) | IFxExt
GetItemNames([in] BSTR itemList,[in, defaultvalue("=")] BSTR ass,[in, defaultvalue("|")] BSTR sep,[in, defaultvalue("\\")] BSTR esc,[out, retval] VARIANT *itemNames) (definován v IFxExt) | IFxExt
GetLocalTime([out, retval] long *locT) (definován v IFxExt) | IFxExt
GetShortPathName([in] BSTR LongPathName,[out, retval] BSTR *result) (definován v IFxExt) | IFxExt
GetTempFileName([in] BSTR dir,[out, retval] BSTR *fileName) (definován v IFxExt) | IFxExt
GetTempPath([out, retval] BSTR *path) (definován v IFxExt) | IFxExt
InitializeSecurity([in, defaultvalue("")] BSTR params) (definován v IFxExt) | IFxExt
Loc([in] BSTR refStr,[out, optional] VARIANT *accl,[out, retval] BSTR *local) (definován v IFxExt) | IFxExt
Localize2([in] BSTR refStr,[in] BSTR LocFile,[in, out, optional] VARIANT *accl,[out, retval] BSTR *local) (definován v IFxExt) | IFxExt
MergeLists([in] BSTR firstList,[in] BSTR secondList,[in, defaultvalue("=")] BSTR ass,[in, defaultvalue("|")] BSTR sep,[out, retval] BSTR *newList) (definován v IFxExt) | IFxExt
MoveFile([in] BSTR existingFile,[in] BSTR newName,[out, retval] BOOL *result) (definován v IFxExt) | IFxExt
PutItemToList([in] BSTR itemName,[in] BSTR itemValue,[in] BSTR oldParamList,[in, defaultvalue("=")] BSTR ass,[in, defaultvalue("|")] BSTR sep,[in, defaultvalue("\\")] BSTR esc,[out, retval] BSTR *newList) (definován v IFxExt) | IFxExt
ReleaseMutex([in] long handle,[out, retval] BOOL *result) (definován v IFxExt) | IFxExt
RemoveItemFromList([in] BSTR itemName,[in] BSTR paramList,[in, defaultvalue("=")] BSTR ass,[in, defaultvalue("|")] BSTR sep,[in, defaultvalue("\\")] BSTR esc,[out, retval] BSTR *newList) (definován v IFxExt) | IFxExt
RunCmd([in] BSTR cmdLine, long mode,[out, retval] long *pVal) (definován v IFxExt) | IFxExt
SyncFolders([in] BSTR srcFld,[in] BSTR dstFld,[in] BOOL updateOpenedFiles,[in] BOOL deleteExtraFiles,[in] BOOL doRegistrations,[in] BOOL overwriteNew,[in, out] VARIANT *restartRq,[out, retval] BSTR *errState) (definován v IFxExt) | IFxExt
WaitForSingleObject([in] long handle,[in, defaultvalue(0xffffffff)] long timeout,[in, defaultvalue(0)] BOOL prosessWinMsgs,[out, retval] long *retCode) (definován v IFxExt) | IFxExt


Aplikační rozhraní systému CallChange: Seznam členů třídy

ILevel2CC Seznam členů třídy

Zde naleznete úplný seznam členů třídy ILevel2CC, včetně všech zděděných členů.

CloseCall([in] BSTR CCID,[out, retval] VARIANT *retVal) | ILevel2CC
Dial([in] BSTR GroupID,[in] BSTR NumList,[out, retval] VARIANT *retVal) | ILevel2CC
GetSession([out, retval] VARIANT *retVal) | ILevel2CC
Init([in] BSTR AppName,[out, retval] BOOLEAN *retVal) | ILevel2CC
LogWrite([in] BSTR Text,) | ILevel2CC
Record([out, retval] VARIANT *retVal) | ILevel2CC
SetCallRc([in] BSTR CCID,[in] BSTR Rc,[in] BSTR Rc2,[in] BSTR Description,[out, retval] VARIANT *retVal) | ILevel2CC
TransferCall([in] BSTR callid,[in] BSTR LineName,[in] BSTR LineNumber,[out, retval] VARIANT *retVal) | ILevel2CC


Aplikační rozhraní systému CallChange: Zdrojový soubor DsCssSrv.idl

DsCssSrv.idl

00001 // DsCssSrv.idl : IDL source for DsCssSrv.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (DsCssSrv.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009
00010
00012         [
00013                 object,
00014                 uuid(5B445C6E-A4D8-43B2-9BA9-C20DC69A7EB2),
00015                 dual,
00016                 helpstring("ICore Interface"),
00017                 pointer_default(unique)
00018         ]
00019         interface ICore : IDispatch
00020         {
00021
00031                 [id(1), helpstring("method Search")] HRESULT Search
00032                         (
00037                         [in] BSTR SetName,
00039                         [in] BSTR NormTelNum,
00041                         [in] BSTR EntrTelNum,
00042                         [out,retval] VARIANT *retVal
00043                         );
00044
00046                 [id(2), helpstring("method GetStorePF")] HRESULT GetStorePF
00047                         (
00048                         [out,retval] VARIANT *retVal
00049                         );
00050
00058                 [id(3), helpstring("method SearchEx")] HRESULT SearchEx
00059                         (
00064                         [in] BSTR SetName,
00066                         [in] BSTR NormTelNum,
00068                         [in] BSTR EntrTelNum,
00072                         [out,retval] VARIANT *retVal
00073                         );
00074
00076                 [id(4), helpstring("method SearchSQL")] HRESULT SearchSQL
00077                         (
00082                         [in] BSTR SetName,
00088                         [in] BSTR AttrFormula,
00091                         [out] VARIANT *retVal,
00093                         [in, defaultvalue(1)] long  maxcount,
00095                         [out,retval] long *retCount
00096                         );
00097         };
00098
00099 [
00100         uuid(27F26B84-7EEC-409D-A119-8B48C78BCB5C),
00101         version(1.0),
00102         helpstring("DsCssSrv 1.0 Type Library")
00103 ]
00104 library DSCSSSRVLib
00105 {
00106         importlib("stdole32.tlb");
00107         importlib("stdole2.tlb");
00108
00109         [
00110                 uuid(01467B50-1528-4AAF-BA70-18D40A8F8464),
00111                 helpstring("Core Class")
00112         ]
00113         coclass Core
00114         {
00115                 [default] interface ICore;
00116         };
00117 };


Aplikační rozhraní systému CallChange: Seznam členů třídy

ICXXMLRPCPlugin Seznam členů třídy

Zde naleznete úplný seznam členů třídy ICXXMLRPCPlugin, včetně všech zděděných členů.

AddProgID([in] BSTR ProgID,[in] BSTR options) | ICXXMLRPCPlugin
AddService([in] BSTR serviceName,[in] IDispatch *service) | ICXXMLRPCPlugin
Done() | ICXXMLRPCPlugin
Init([in] long port) | ICXXMLRPCPlugin


Aplikační rozhraní systému CallChange: Zdrojový soubor delegate.idl

delegate.idl

00001
00002 // delegate.idl - Universal Delegator Component
00003 //
00004 // Copyright 1998, Keith Brown
00006 import "unknwn.idl";
00007
00008 [
00009     uuid(9b8c32f1-249a-11d2-a7bb-006008d25ccf),
00010     object,
00011     local
00012 ]
00013 interface IDelegatorHookMethods : IUnknown
00014 {
00015     void DelegatorPreprocess( [in] DWORD nVtblIndex,
00016                               [in] void* pArgs,
00017                               [out] DWORD* pnCookie );
00018     HRESULT DelegatorPostprocess( [in] DWORD nVtblIndex,
00019                                   [in] HRESULT hrFromInner,
00020                                   [in] DWORD nCookie );
00021 }
00022
00023 [
00024     uuid(5f8bea30-60ce-11d2-a7ea-006008d25ccf),
00025     object,
00026     local
00027 ]
00028 interface IDelegatorHookMethods2 : IUnknown
00029 {
00030     HRESULT DelegatorPreprocess( [in] DWORD nVtblIndex,
00031                                  [in] void* pArgs,
00032                                  [out] void** ppv );
00033     HRESULT DelegatorPostprocess( [in] DWORD nVtblIndex,
00034                                   [in] HRESULT hrFromInner,
00035                                   [in] void* pv );
00036 }
00037
00038 [
00039     uuid(bd8f05b0-9145-11d2-a802-006008d25ccf),
00040     object,
00041     local
00042 ]
00043 interface IDelegatorGetCallContext : IUnknown
00044 {
00045         HRESULT GetCallContext( [out, retval] void** ppv );
00046 }
00047
00048 [
00049     uuid(9b8c32f9-249a-11d2-a7bb-006008d25ccf),
00050     object,
00051     local
00052 ]
00053 interface IDelegatorHookQI : IUnknown
00054 {
00055     typedef enum _DelegatorHookOptions
00056     {
00057         DHO_PREPROCESS_METHODS  = 0x00000001,
00058         DHO_POSTPROCESS_METHODS = 0x00000002,
00059         DHO_MAY_BLOCK_CALLS     = 0x00000004
00060     } DelegatorHookOptions;
00061
00062     HRESULT Init( [in] IUnknown* pUnkInner );
00063     HRESULT OnFirstDelegatorQIFor( [in] REFIID iid,
00064                                    [in, iid_is(iid)] IUnknown* pItfInner,
00065                                    [out] DWORD* pgrfDelegatorHookOptions,
00066                                    [in] REFIID iidMethodHook,
00067                                    [out, iid_is(iidMethodHook)] void** ppMethodHook );
00068 }
00069
00070 [
00071     uuid(6bf39960-7173-11d2-a7fa-006008d25ccf),
00072     object,
00073     local
00074 ]
00075 interface IDelegatorSplitIdentity : IUnknown
00076 {
00077     HRESULT DelegatorSafeRef( [in] REFIID iid, [out, iid_is(iid)] void** ppv );
00078     HRESULT GetHook         ( [in] REFIID iid, [out, iid_is(iid)] void** ppv );
00079 }
00080
00081 [
00082     uuid(6bf39961-7173-11d2-a7fa-006008d25ccf),
00083     object,
00084     local
00085 ]
00086 interface IDelegatorConnection : IUnknown
00087 {
00088     HRESULT DelegatorConnect( [in] IDelegatorSplitIdentity* pdsi );
00089     HRESULT DelegatorDisconnect();
00090 }
00091
00092 [
00093     uuid(9b8c32f3-249a-11d2-a7bb-006008d25ccf),
00094     object,
00095     local
00096 ]
00097 interface IDelegatorFactory : IUnknown
00098 {
00099     typedef enum _DelegatorOptions
00100     {
00101         DO_MBV_INPROC                           = 0x00000001,
00102         DO_MBV_LOCAL                            = 0x00000002,
00103         DO_MBV_DIFFERENTMACHINE         = 0x00000004,
00104         DO_MBV_ALL                                      = 0x00000007,
00105         DO_MAINTAIN_IDENTITY            = 0x00000008,
00106                 DO_CACHE_INTERFACES                     = 0x00000010,
00107                 DO_CONNECTION_NOTIFICATION  = 0x00000020
00108     } DelegatorOptions;
00109
00110     HRESULT CreateDelegator( [in] IUnknown* pUnkOuter,
00111                              [in] IUnknown* pUnkInner,
00112                              [in] CLSID* pclsidHook,
00113                              [in] IUnknown* pHook,
00114                              [in] DWORD grfOptions,
00115                              [in] REFIID iid,
00116                              [out, iid_is(iid)] void** ppv );
00117 }
00118
00119 [
00120     uuid(9b8c32f8-249a-11d2-a7bb-006008d25ccf),
00121     object,
00122     local
00123 ]
00124 interface IAlternateCredentialDelegatorHook : IUnknown
00125 {
00126     typedef enum _ACDH_OPTIONS
00127     {
00128         ACDH_AUTHNSVC        = 0x00000001,
00129         ACDH_AUTHZSVC        = 0x00000002,
00130         ACDH_SERVERPRINCIPAL = 0x00000004,
00131         ACDH_AUTHNLEVEL      = 0x00000008,
00132         ACDH_IMPLEVEL        = 0x00000010,
00133         ACDH_CREDENTIALS     = 0x00000020,
00134         ACDH_CAPS            = 0x00000040
00135     } ACDH_OPTIONS;
00136
00137     HRESULT Init( [in] DWORD grfOptions,
00138                   [in] DWORD nAuthnSvc,
00139                   [in] DWORD nAuthzSvc,
00140                   [in] const OLECHAR* pszServerPrincipal,
00141                   [in] DWORD nAuthnLevel,
00142                   [in] DWORD nImpLevel,
00143                   [in] const OLECHAR* pszAuthority,
00144                   [in] const OLECHAR* pszPrincipal,
00145                   [in] const OLECHAR* pszPassword,
00146                   [in] DWORD grfCaps );
00147 }
00148
00149 [
00150         uuid(CE8555A1-977B-11d0-B33A-00400530E4E8),
00151         object,
00152         local,
00153         restricted, hidden
00154 ]
00155 interface IDelegatorFactory0 : IUnknown
00156 {
00157     HRESULT CreateDelegator( [in] IUnknown* pUnkOuter,
00158                              [in] IUnknown* pUnkInner,
00159                              [in] REFIID iid,
00160                              [out, iid_is(iid)] void** ppv );
00161 }
00162
00163 // This typelib is not registered, nor useful.
00164 // It is provided mainly as documentation, and to show
00165 // the CLSIDs exposed from this server.
00166 [
00167     uuid(9b8c32f5-249a-11d2-a7bb-006008d25ccf),
00168     version(1.0), lcid(0)
00169 ]
00170 library DelegatorLib
00171 {
00172     importlib( "stdole32.tlb" );
00173
00174     [uuid(5f8bea31-60ce-11d2-a7ea-006008d25ccf)]
00175     coclass CoDelegator21
00176     {
00177         interface IUnknown;
00178     }
00179     [uuid(9b8c32f0-249a-11d2-a7bb-006008d25ccf), hidden, restricted]
00180     coclass CoDelegator20
00181     {
00182         interface IUnknown;
00183     }
00184     [uuid(CE8555A0-977B-11d0-B33A-00400530E4E8), hidden, restricted]
00185     coclass CoDelegator10
00186     {
00187         interface IUnknown;
00188     }
00189     [uuid(bd8f05b1-9145-11d2-a802-006008d25ccf)]
00190     coclass CoDelegatorGetCallContext
00191     {
00192         interface IDelegatorGetCallContext;
00193     }
00194     [uuid(9b8c32f6-249a-11d2-a7bb-006008d25ccf)]
00195     coclass CoAnonymousDelegatorHook
00196     {
00197         interface IUnknown;
00198         interface IDelegatorHookQI;
00199         interface IPersist;
00200     }
00201     [uuid(9b8c32f7-249a-11d2-a7bb-006008d25ccf)]
00202     coclass CoAlternateCredentialDelegatorHook
00203     {
00204         interface IUnknown;
00205         interface IDelegatorHookQI;
00206         interface IAlternateCredentialDelegatorHook;
00207         interface IPersistStream;
00208     }
00209 }


Aplikační rozhraní systému CallChange: Seznam členů třídy

ICore Seznam členů třídy

Zde naleznete úplný seznam členů třídy ICore, včetně všech zděděných členů.

GetStorePF([out, retval] VARIANT *retVal) | ICore
GetStorePF([out, retval] VARIANT *retVal) | ICore
Search([in] BSTR SetName,[in] BSTR NormTelNum,[in] BSTR EntrTelNum,[out, retval] VARIANT *retVal) | ICore
Search([in] BSTR SetName,[in] BSTR NormTelNum,[in] BSTR EntrTelNum,[out, retval] VARIANT *retVal) | ICore
SearchEx([in] BSTR SetName,[in] BSTR NormTelNum,[in] BSTR EntrTelNum,[out, retval] VARIANT *retVal) | ICore
SearchEx([in] BSTR SetName,[in] BSTR NormTelNum,[in] BSTR EntrTelNum,[out, retval] VARIANT *retVal) | ICore
SearchSQL([in] BSTR SetName,[in] BSTR AttrFormula,[out] VARIANT *retVal,[in, defaultvalue(1)] long maxcount,[out, retval] long *retCount) | ICore
SearchSQL([in] BSTR SetName,[in] BSTR AttrFormula,[in, out] VARIANT *retVal,[in, defaultvalue(1)] long maxcount,[out, retval] long *retCount) | ICore


Aplikační rozhraní systému CallChange: Zdrojový soubor fxExtObj.idl

fxExtObj.idl

00001 // fxExtObj.idl : IDL source for fxExtObj.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (fxExtObj.tlb) and marshalling code.
00006
00007 #define NO_XML_SAVE
00008
00009
00010 import "oaidl.idl";
00011 import "ocidl.idl";
00012
00014         [
00015                 object,
00016                 uuid(4E73E844-4B9F-11D2-BEDB-0060972F3133),
00017                 dual,
00018                 helpstring("IFxExt Interface"),
00019                 pointer_default(unique)
00020         ]
00021         interface IFxExt : IDispatch
00022         {
00023                 [id(1), helpstring("Execute external command")] HRESULT RunCmd([in] BSTR cmdLine,long mode, [out, retval] long *pVal);
00024                 [id(2), helpstring("DeleteFile")] HRESULT DeleteFile([in]BSTR file,[out,retval] long *pRet);
00025                 [id(3), helpstring("GetTempPath")] HRESULT GetTempPath([out,retval] BSTR *path);
00026                 [id(4), helpstring("Create unique file name in spec. directory")] HRESULT GetTempFileName([in] BSTR dir,[out,retval] BSTR *fileName);
00027                 [id(5), helpstring("Create unique file name with spec. file extension")] HRESULT CreateTemporaryFilePath([in] BSTR ext,[out,retval] BSTR *FilePath);
00028                 [id(6), helpstring("Localize string and accelerator key")] HRESULT Loc([in] BSTR refStr, [out,optional] VARIANT *accl,[out,retval] BSTR * local);
00029                 [id(7), helpstring("CreateGUID")] HRESULT CreateGUID([out,retval] BSTR *retVal);
00030                 [id(8), helpstring("Create console window for text output")] HRESULT CreateConsole();
00031                 [id(9), helpstring("method MoveFile")] HRESULT MoveFile([in] BSTR existingFile, [in] BSTR newName, [out,retval] BOOL *result);
00032
00033                 [id(10), helpstring("method GetCurrentProcessId")]
00034                         HRESULT GetCurrentProcessId([out,retval] long *id);
00035
00036                 [id(11), helpstring("method PutItemToList")]
00037                         HRESULT PutItemToList([in] BSTR itemName
00038                                                                 , [in] BSTR itemValue
00039                                                                 , [in] BSTR oldParamList
00040                                                                 , [in,defaultvalue("=")] BSTR ass
00041                                                                 , [in,defaultvalue("|")] BSTR sep
00042                                                                 ,[in,defaultvalue("\\")] BSTR esc
00043                                                                 , [out,retval] BSTR *newList
00044                                                                 );
00045
00046                 [id(12), helpstring("method GetItemFromList")]
00047                         HRESULT GetItemFromList(
00048                                                                         [in] BSTR itemName
00049                                                                         ,[in] BSTR itemList
00050                                                                         ,[in,defaultvalue("=")] BSTR ass
00051                                                                         ,[in,defaultvalue("|")] BSTR sep
00052                                                                         ,[in,defaultvalue("\\")] BSTR esc
00053                                                                         ,[out,retval] VARIANT *itemValue
00054                                                                         );
00055
00056                 [id(13), helpstring("method RemoveItemFromList")]
00057                         HRESULT RemoveItemFromList(     [in] BSTR itemName
00058                                                                                 ,[in] BSTR paramList
00059                                                                                 ,[in,defaultvalue("=")] BSTR ass
00060                                                                                 ,[in,defaultvalue("|")] BSTR sep
00061                                                                                 ,[in,defaultvalue("\\")] BSTR esc
00062                                                                                 ,[out,retval] BSTR *newList
00063                                                                                 );
00064
00065                 [id(14), helpstring("method InitializeSecurity")]
00066                         HRESULT InitializeSecurity([in,defaultvalue("")] BSTR params);
00067
00068                 [id(15), helpstring("method MergeLists")]
00069                         HRESULT MergeLists(
00070                                                                 [in] BSTR firstList
00071                                                                 ,[in] BSTR secondList
00072                                                                 ,[in,defaultvalue("=")] BSTR ass
00073                                                                 ,[in,defaultvalue("|")] BSTR sep
00074                                                                 ,[out,retval] BSTR *newList
00075                                                                 );
00076                 [id(16), helpstring("method GetItemNames")]
00077                         HRESULT GetItemNames(
00078                                                                 [in] BSTR itemList
00079                                                                 ,[in,defaultvalue("=")] BSTR ass
00080                                                                 ,[in,defaultvalue("|")] BSTR sep
00081                                                                 ,[in,defaultvalue("\\")] BSTR esc
00082                                                                 ,[out,retval] VARIANT *itemNames
00083                                                                 );
00084
00085                 [id(17), helpstring("Synchronizes content of folders")]
00086                         HRESULT SyncFolders (
00087                                                                 [in] BSTR srcFld
00088                                                                 ,[in] BSTR dstFld
00089                                                                 ,[in] BOOL updateOpenedFiles
00090                                                                 ,[in] BOOL deleteExtraFiles
00091                                                                 ,[in] BOOL doRegistrations
00092                                                                 ,[in] BOOL overwriteNew
00093                                                                 ,[in,out] VARIANT *restartRq
00094                                                                 ,[out,retval] BSTR *errState
00095                                                                 );
00096                 [id(18), helpstring("method CreateSemaphore")] HRESULT CreateSemaphore([in] BSTR NameOfObject, [in,out] VARIANT *handle, [out,retval] BOOL *firstInstance);
00097                 [id(19), helpstring("method CloseWin32Handle")] HRESULT CloseWin32Handle([in] long handle);
00098                 [id(20), helpstring("method GetShortPathName")] HRESULT GetShortPathName([in] BSTR LongPathName, [out,retval] BSTR *result);
00099                 [id(21), helpstring("method CopyFile")] HRESULT CopyFile([in] BSTR existingFile, [in] BSTR newName, [out,retval] BOOL *result);
00100                 [id(22), helpstring("method Localize2")] HRESULT Localize2([in] BSTR refStr, [in] BSTR LocFile, [in,out,optional] VARIANT *accl, [out,retval] BSTR * local);
00101                 [id(23), helpstring("method CreateMutex")] HRESULT CreateMutex([in] BSTR NameOfObject, [out,retval] long *handle);
00102                 [id(24), helpstring("method WaitForSingleObject")] HRESULT WaitForSingleObject([in] long handle,[in,defaultvalue(0xffffffff)] long timeout, [in,defaultvalue(0)] BOOL prosessWinMsgs,[out,retval] long *retCode);
00103                 [id(25), helpstring("method ReleaseMutex")] HRESULT ReleaseMutex([in] long handle, [out,retval] BOOL *result);
00104                 [id(26), helpstring("method GetLocalTime")] HRESULT GetLocalTime([out,retval] long *locT);
00105         };
00106
00107
00109         [
00110                 object,
00111                 uuid(2835F3D5-64FF-11D2-BEF8-0060972F3133),
00112                 dual,
00113                 helpstring("IFxFile Interface"),
00114                 pointer_default(unique)
00115         ]
00116         interface IFxFile : IDispatch
00117         {
00118                 [id(1), helpstring("method Open")] HRESULT Open([in] BSTR filename,[in] BSTR flags);
00119                 [id(2), helpstring("method Write")] HRESULT Write([in]BSTR str,[out,retval] int *cnt);
00120                 [id(3), helpstring("method fscanf")] HRESULT fscanf([in] BSTR format,[out,retval] BSTR *str);
00121                 [id(4), helpstring("method Close")] HRESULT Close();
00122                 [id(5), helpstring("method Flush")] HRESULT Flush();
00123                 [id(6), helpstring("method ReadBase64")] HRESULT ReadBase64([out,retval] BSTR *dataEncoded);
00124         };
00125
00127         [
00128                 object,
00129                 uuid(773B9A16-14CB-11D3-8393-00105A2F4B4E),
00130                 dual,
00131                 helpstring("IDSVariantCol Interface"),
00132                 pointer_default(unique)
00133         ]
00134         interface IDSVariantCol : IDispatch
00135         {
00136                 [propget, id(0), helpstring("Gets value idetified by property name or index")]
00137                         HRESULT Item([in] VARIANT Index,[out,retval] VARIANT *val);
00138                 [propput, id(0), helpstring("Sets value idetified by property name or index")]
00139                         HRESULT Item([in] VARIANT Index,[in] VARIANT val);
00140                 [propget, id(1), helpstring("Actual count of values in collection")]
00141                         HRESULT Count([out, retval] long *pVal);
00142                 [propput, id(1), helpstring("Sets size of collection")]
00143                         HRESULT Count([in] long size);
00144
00145                 [id(2), helpstring("Store new value")]
00146                         HRESULT Add([in] BSTR valueName,[in] VARIANT val,[out,retval] long *idx);
00147
00148                 [id(3), helpstring("Delete existing value(s). Return count of deleted values")]
00149                         HRESULT Delete([in] VARIANT Index,[out, retval] long *cnt);
00150
00151                 [propget, id(4), helpstring("property uniq")]
00152                         HRESULT uniq([out, retval] BOOL *pVal);
00153                 [propput, id(4), helpstring("property uniq")]
00154                         HRESULT uniq([in] BOOL newVal);
00155                 [id(5), helpstring("method Find")]
00156                         HRESULT Find([in] BSTR Key, [out,retval] long *idx);
00157                 [propget, id(6), helpstring("Enable automatic use of Add if Key does not exist")]
00158                         HRESULT AutoAdd([out, retval] BOOL *pVal);
00159                 [propput, id(6), helpstring("Enable automatic use of Add if Key does not exist")]
00160                         HRESULT AutoAdd([in] BOOL newVal);
00161                 [id(7), helpstring("Index to Key conversion")]
00162                         HRESULT Key([in] long Idx, [out,retval] BSTR *Key);
00163                 [id(8), helpstring("Create new collection (faster than CreateObject)")]
00164                         HRESULT CreateNew([out,retval ] IDSVariantCol **retVal);
00165                 [id(9), helpstring("Sort collection on Key or Value property")]
00166                         HRESULT Sort([in,defaultvalue(0)] BOOL onValue);
00167                 [id(10), helpstring("Add item=values from string")]
00168                         HRESULT AddFromString([in]BSTR String,[in,defaultvalue("")] BSTR Delimiter,[out,retval] long *idx);
00169
00170                 [propget, id(11), helpstring("property AsString")]
00171                         HRESULT AsString([in,defaultvalue("")] BSTR Delimiter,[out, retval] BSTR *pVal);
00172
00173                 [id(12), helpstring("method Clear")] HRESULT Clear();
00174                 [id(13), helpstring("method ReadVXIni")]
00175                         HRESULT ReadVXIni([in] BSTR iniFile, [out,retval] BOOL *retVal);
00176                 [id(18), helpstring("method WriteVXIni")]
00177                         HRESULT WriteVXIni([in] BSTR iniFile, [out,retval] BOOL *retVal);
00178                 [id(19), helpstring("method AddParamList")]
00179                         HRESULT AddParamList([in] BSTR String);
00180                 [propget, id(20), helpstring("property AsParamList")] HRESULT AsParamList([out, retval] BSTR *pVal);
00182                 [propget, restricted, id(DISPID_NEWENUM),helpstring("returns an enumerator for the collection.")]
00183                         HRESULT _NewEnum([out, retval] IUnknown** pVal);
00184                 [propput, id(11), helpstring("property AsString")]
00185                         HRESULT AsString([in,defaultvalue("")] BSTR Delimiter, [in] BSTR newVal);
00187 #ifndef NO_XML_SAVE
00188                 [id(14), helpstring("method SaveXMLDoc")]
00189                         HRESULT SaveXMLDoc([in] VARIANT fileName,[in,defaultvalue(1)] BOOL recursive, [in,defaultvalue(1)] BOOL saveObjects);
00190                 [id(15), helpstring("method LoadXMLDoc")]
00191                         HRESULT LoadXMLDoc([in] VARIANT fileName,[in,defaultvalue(1)] BOOL recursive, [in,defaultvalue(1)] BOOL loadObjects);
00192                 [id(16), helpstring("method SaveToXMLElement")]
00193                         HRESULT SaveToXMLElement([in] IXMLDOMDocument *doc,[in] IXMLDOMElement *element, [in,defaultvalue(1)] BOOL recursive, [in,defaultvalue(1)] BOOL saveObjects);
00194                 [id(17), helpstring("method LoadFromXMLElement")]
00195                         HRESULT LoadFromXMLElement([in] IXMLDOMElement *element, [in,defaultvalue(1)] BOOL recursive, [in,defaultvalue(1)] BOOL loadObjects);
00196 #endif
00197         };
00198 [
00199         uuid(4E73E837-4B9F-11D2-BEDB-0060972F3133),
00200         version(1.0),
00201         helpstring("fxExtObj 1.0 Type Library")
00202 ]
00203 library FXEXTOBJLib
00204 {
00205         importlib("stdole32.tlb");
00206         importlib("stdole2.tlb");
00207
00208         [
00209                 uuid(4E73E845-4B9F-11D2-BEDB-0060972F3133),
00210                 helpstring("FxExt Class")
00211         ]
00212         coclass FxExt
00213         {
00214                 [default] interface IFxExt;
00215         };
00216         [
00217                 uuid(2835F3D6-64FF-11D2-BEF8-0060972F3133),
00218                 helpstring("FxFile Class")
00219         ]
00220         coclass FxFile
00221         {
00222                 [default] interface IFxFile;
00223         };
00224         [
00225                 uuid(773B9A18-14CB-11D3-8393-00105A2F4B4E),
00226                 helpstring("_IDSVariantColEvents Interface")
00227         ]
00228         dispinterface _IDSVariantColEvents
00229         {
00230                 properties:
00231                 methods:
00232         };
00233
00234         [
00235                 uuid(773B9A17-14CB-11D3-8393-00105A2F4B4E),
00236                 helpstring("DSVariantCol Class")
00237         ]
00238         coclass DSVariantCol
00239         {
00240                 [default] interface IDSVariantCol;
00241                 [default, source] dispinterface _IDSVariantColEvents;
00242         };
00243 };


Aplikační rozhraní systému CallChange: Seznam členů třídy

IDSXMLRPCClient Seznam členů třídy

Zde naleznete úplný seznam členů třídy IDSXMLRPCClient, včetně všech zděděných členů.

CallXMLRPC([in] BSTR methodName,[in] VARIANT paramArray,[in, out] VARIANT *result,[in, out] VARIANT *errMsg,[out, retval] long *errCode) | IDSXMLRPCClient
COMSessionID([out, retval] BSTR *pVal) | IDSXMLRPCClient
CreateCOMSession([in] BSTR sessionName) | IDSXMLRPCClient
GetProxyObject([in] BSTR objectName,[out, retval] IDispatch **obj) | IDSXMLRPCClient
Init([in] BSTR url,[in] BSTR options,[out, retval] BSTR *retStat) | IDSXMLRPCClient


Aplikační rozhraní systému CallChange: Seznam členů třídy

IAppActivator Seznam členů třídy

Zde naleznete úplný seznam členů třídy IAppActivator, včetně všech zděděných členů.

Activate([in] BSTR parameters,[in] BSTR envVariables,[out, retval] BSTR *retStat) | IAppActivator
Notify([in] BSTR event,[in] VARIANT params,[out, retval] BSTR *retStat) | IAppActivator


Aplikační rozhraní systému CallChange: Zdrojový soubor CXServer2.idl

CXServer2.idl

00001 // CXServer2.idl : IDL source for CXServer2.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (CXServer2.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009 import "DSServMngr.idl";
00010 import "DSShareObj.idl";
00011 import "DSMQueue.idl";
00012 import "DsCssSrv.idl";
00013
00014
00016         [
00017                 object,
00018                 uuid(F9C04FD8-D1F8-4279-8B7F-0A909EDE8383),
00019                 dual,
00020                 helpstring("ICXArchive Interface"),
00021                 pointer_default(unique)
00022         ]
00023         interface ICXArchive : IDispatch
00024         {
00026                 [id(1), helpstring("method GetArchiveCalls")]
00027                         HRESULT GetArchiveCalls
00028                                 (
00030                                 [in] BSTR lines,
00033                                 [in] BSTR extraItemList,
00036                                 [in] BSTR selection,
00038                                 [in] BSTR orderBy,
00040                                 [in] long rowMax,
00042                                 [in,out] VARIANT *records,
00043                                 [out,retval] BSTR *retStat
00044                                 );
00045
00047                 [id(2), helpstring("method StoreArchiveCallAttributes")]
00048                         HRESULT StoreArchiveCallAttributes(
00050                                 [in] BSTR callID,
00063                                 [in] BSTR attributeList,
00064                                 [out,retval] BSTR *retStat);
00065
00067                 [id(3), helpstring("method GetCallEvents")]
00068                         HRESULT GetCallEvents(
00070                                 [in] BSTR callID,
00078                                 [in,out] VARIANT *records,
00079                                 [out,retval] BSTR *retstat);
00080         };
00081
00083         [
00084                 object,
00085                 uuid(78B3A783-FEF5-46AB-9A67-A07575A25A8F),
00086                 dual,
00087                 helpstring("ICXRouter Interface"),
00088                 pointer_default(unique)
00089         ]
00090         interface ICXRouter : IDispatch
00091         {
00093                 [id(1), helpstring("method CheckNumberInBL")]
00094                         HRESULT CheckNumberInBL(
00096                                 [in] BSTR phoneNum,
00098                                 [in] BSTR listName,
00107                                 [in,out] VARIANT *blStat,
00112                                 [out,retval] BSTR *retStat
00113                                 );
00115                 [id(2), helpstring("method AddNumberToBL")]
00116                         HRESULT AddNumberToBL(
00118                                 [in] BSTR lname,
00120                                 [in] BSTR phnumber,
00122                                 [in] double expirationDays,
00124                                 [in,defaultvalue("")] BSTR agentID,
00126                                 [in,defaultvalue("")] BSTR description,
00127                                 [out,retval] BSTR *retStat
00128                                 );
00130                 [id(3), helpstring("method DeleteNumberFromBL")] HRESULT DeleteNumberFromBL([in] BSTR phoneNumber, [in] BSTR listName, [out, retval] BSTR *retStat);
00132                 [id(4), helpstring("method GetBLlist")]
00133                         HRESULT GetListBlNames
00134                                 (
00138                                 [in,out] VARIANT *listNames,
00139                                 [out,retval] BSTR *retStat
00140                                 );
00141         };
00142
00143
00145         [
00146                 object,
00147                 uuid(A5474D9E-BC6D-48CB-8DA3-3E2A44CDAEFB),
00148                 dual,
00149                 helpstring("ISysDbConn Interface"),
00150                 pointer_default(unique)
00151         ]
00152         interface ISysDbConn : IDispatch
00153         {
00155         typedef enum
00156                 {
00158                 SDO_ADD_NEW=0,
00160                 SDO_UPDATE=1,
00162                 SDO_UPDATE_OR_ADD=2,
00164                 SDO_ERR_NOREPORT=4
00165                 } StoreDataOptions;
00166
00167         typedef enum
00168                 {
00170                 GOB_MQ_LIKE=0,
00172                 GOB_SQL_FULL=1,
00174                 GOB_SQL_WHERE=2
00175                 } GOB_SpecType;
00176
00177 //              [id(1), helpstring("method Open")]
00178 //                      HRESULT Open([in,defaultvalue("")] BSTR options,[out,retval] BSTR *retStat);
00179
00180 /*
00181                 [id(2), helpstring("method Close")]
00182                         HRESULT Close([out,retval] BSTR *retStat);
00183 */
00185                 [id(3), helpstring("method GetData")]
00186                         HRESULT GetData(
00188                                 [in] BSTR sqlQuery,
00190                                 [in] long rowMax,
00192                                 [in,out] VARIANT *records,
00193                                 [out,retval] BSTR *retStat);
00194
00196                 [id(4), helpstring("method SetData")]
00197                         HRESULT SetData(
00199                                 [in] BSTR tableName,
00201                                 [in] BSTR selCrit,
00203                                 [in] BSTR data,
00204                                 [in] StoreDataOptions options,
00206                         [in] BSTR lockKey,
00207                         [in,out] VARIANT *numAffRec, [out,retval] BSTR *retStat);
00208
00211                 [id(5), helpstring("method GetObjData")]
00212                         HRESULT GetObjData(
00214                         [in] BSTR spec,
00216                         [in] GOB_SpecType spectype,
00222                         [in] BSTR options,
00224                          [in] long rowMax,
00227                          [in,out] VARIANT *records,
00228                          [out,retval] BSTR *retStat);
00229                 [id(6), helpstring("method ExecuteSQL")] HRESULT ExecuteSQL([in] BSTR sqlCommand,[in] BSTR options,[in] BSTR lockKey, [in,out]VARIANT *numRec, [out,retval] BSTR *retStat);
00230         };
00231
00233
00241         [
00242                 object,
00243                 uuid(F84C702C-E332-460A-951D-79BB5DF57FED),
00244                 dual,
00245                 helpstring("ICXSession Interface"),
00246                 pointer_default(unique)
00247         ]
00248         interface ICXSession : IDispatch
00249         {
00251                 typedef enum
00252                 {
00254                 LOG_UNIVERSE_END=0,
00256                 LOG_ERROR=1,
00258                 LOG_WARNING=2,
00260                 LOG_INFO=3,
00262                 LOG_DEBUG=4,
00264                 LOG_TRACE=5,
00266                 LOG_DATA=6,
00268                 LOG_FETCH=7
00269                 } LogLevel;
00270
00273                 [id(10), helpstring("property Storage")]
00274                         HRESULT GetStorage([out, retval] IDSMQStorage * *pVal);
00275
00277                 [id(11), helpstring("property Archive")]
00278                         HRESULT GetArchive([out, retval] ICXArchive * *pVal);
00279
00281                 [id(12), helpstring("property Router")]
00282                         HRESULT GetRouter([out, retval] ICXRouter * *pVal);
00283
00286                 [id(13), helpstring("method Init")]
00287                         HRESULT Init(
00289                                 [out,retval] BSTR *sessionID
00290                                 );
00291
00293                 [id(14), helpstring("method Done")]
00294                         HRESULT Done();
00295
00302                 [id(15), helpstring("method Log")]
00303                         HRESULT Log([in] long level, [in] BSTR category, [in] BSTR value, [in] BSTR text);
00304
00306                 [id(16), helpstring("method AllocID")]
00307                         HRESULT AllocID([in,defaultvalue("")] BSTR specChar,[out,retval] BSTR *newID);
00309                 [id(17), helpstring("method GetServerTimeString")]
00310                         HRESULT GetServerTimeString([out,retval] BSTR *time);
00311
00313                 [id(18), helpstring("method GetServerTime")]
00314                         HRESULT GetServerTime([out,retval] VARIANT *_time);
00315
00317                 [id(19), helpstring("method SimpleLock")]
00318                         HRESULT SimpleLock(
00320                                 [in] BSTR lockName,
00322                                 [in] long waitTimeout,
00324                                 [in] long lockTimeout,
00329                                 [in,out] VARIANT *retStat,
00331                                 [out,retval] BSTR *lockHandle
00332                                 );
00333
00335                 [id(20), helpstring("method SimpleUnlock")]
00336                         HRESULT SimpleUnlock
00337                                 (
00339                                 [in] BSTR lockHandle,
00340                                 [out,retval] BSTR *retStat
00341                                 );
00342
00344                 [id(21), helpstring("method GetConfigItems")]
00345                         HRESULT GetConfigItems(
00347                                 [in] BSTR itemNameList,
00348
00354                                 [in,out] VARIANT *resultList,
00355                                 [out,retval] BSTR *retStat
00356                                 );
00357
00359                 [id(22), helpstring("method LoginUser")]
00360                         HRESULT LoginUser(
00362                                 [in] BSTR userName,
00364                                 [in] BSTR machineName,
00365                                 [out,retval] BSTR *retStat
00366                                 );
00367
00369                 [id(23), helpstring("method LoginService")]
00370                         HRESULT LoginService(
00372                                 [in] BSTR serviceName,
00374                                 [in] BSTR machineName,
00375                                 [out,retval] BSTR *retStat
00376                                 );
00377
00379                 [id(24), helpstring("method CheckLicence")]
00380                         HRESULT CheckLicence(
00382                                 [in] long licenceBit,
00388                                 [out,retval] BSTR *retStat
00389                                 );
00390
00392                 [id(25), helpstring("method PostCXMessage")]
00393                         HRESULT PostCXMessage(
00395                                         [in] BSTR messageType,
00405                                         [in] BSTR recipients,
00407                                         [in] VARIANT msgData,
00409                                         [in,defaultvalue("")] BSTR options,
00414                                         [out,retval] BSTR *retStat
00415                                         );
00417                 [id(26), helpstring("method GetCXMessage")]
00418                         HRESULT GetCXMessage (
00425                                 [in] long waitTimeout,
00428                                 [in,out] VARIANT *msgAttributes,
00430                                 [in,out] VARIANT *msgData,
00431                                 [out,retval] BSTR *retStat
00432                                 );
00434                 [id(27), helpstring("method GetLineList")]
00435                         HRESULT GetLineList(
00438                                 [out,retval] BSTR * lineList
00439                                 );
00440
00442                 [id(28), helpstring("method GetLocalLines")]
00443                         HRESULT GetLocalLines(
00445                                 [out,retval] BSTR *localLines
00446                                 );
00448                 [id(29), helpstring("method ConnectLine")]
00449                         HRESULT ConnectLine(
00451                                 [in] BSTR lineName,
00452                                 [out,retval] BSTR *retStat
00453                                 );
00455                 [id(30), helpstring("method DisconnectLine")]
00456                         HRESULT DisconnectLine(
00458                                 [in] BSTR lineName,
00459                                 [out,retval] BSTR *retStat
00460                                 );
00461
00462
00464                 [id(31), helpstring("method GetLineInfo")]
00465                         HRESULT GetLineInfo(
00467                                 [in] BSTR lineName,
00471                                 [in,out] VARIANT *lineInfo,
00472                                 [out,retval] BSTR *retStat
00473                                 );
00474
00475
00477                 [id(32), helpstring("method GetActualLineCalls")]
00478                         HRESULT GetActualLineCalls(
00480                                 [in] BSTR lineName,
00483                                 [in,out] VARIANT *callList,
00484                                 [out,retval] BSTR *retStat
00485                                 );
00487                 [id(33), helpstring("method GetSessionAttributes")]
00488                         HRESULT GetSessionAttributes(
00491                                 [in,out] VARIANT *attributes,
00493                                 [in,defaultvalue("")] BSTR sessionID,
00494                                 [out,retval] BSTR *retStat
00495                                 );
00496
00500                 [id(34), helpstring("method SetSessionAttributes")]
00501                         HRESULT SetSessionAttributes(
00509                                 [in] BSTR attributes,
00511                                 [in,defaultvalue("")] BSTR sessionID,
00512                                 [out,retval] BSTR *retStat
00513                                 );
00514
00516                 [id(35), helpstring("method GetCallState")]
00517                         HRESULT GetCallState(
00519                                 [in] BSTR callID,
00523                                 [in,out] VARIANT *callAttributes,
00524                                 [out,retval] BSTR *retStat
00525                                 );
00526
00527
00529                 [id(36), helpstring("method SetCallState")]
00530                         HRESULT SetCallState(
00532                                 [in] BSTR callID,
00536                                 [in] BSTR attributes,
00544                                 [in,defaultvalue("")] BSTR options,
00545                                 [out,retval] BSTR *retStat
00546                                 );
00547
00548
00550                 [id(37), helpstring("method CreateNewCall")]
00551                         HRESULT CreateNewCall(
00553                         [in] BSTR lineName,
00555                         [in,out] VARIANT *callID,
00556                         [out,retval] BSTR *retStat
00557                         );
00559                 [id(38), helpstring("method OperateCall")]
00560                         HRESULT OperateCall(
00576                                 [in] BSTR parameters,
00577                                 [out,retval] BSTR *retStat
00578                                 );
00579
00587                 [id(39), helpstring("method StoreEvent")]
00588                         HRESULT StoreEvent(
00590                                 [in] BSTR obj_id,
00592                                 [in] BSTR ev_type,
00594                                 [in] BSTR ev_val,
00596                                 [in] BSTR ev_descr,
00597                                 [out,retval] BSTR *retStat
00598                                 );
00599
00601                 [id(40), helpstring("method GetCallEvents")]
00602                         HRESULT GetCallEvents(
00604                                 [in] BSTR callID,
00606                                 [in,out] VARIANT *eventList,
00607                                 [out,retval] BSTR *retStat
00608                                 );
00609
00611                 [id(41), helpstring("method SetLineFeature")]
00612                         HRESULT SetLineFeature(
00614                                                 [in] BSTR lineName,
00616                                                 [in] BSTR operation,
00617                                                 [out,retval] BSTR *retStat
00618                                                 );
00619
00621                 [id(42), helpstring("method GetLineFeature")]
00622                         HRESULT GetLineFeature(
00624                                                 [in] BSTR lineName,
00626                                                 [in] BSTR feature,
00627                                                 [out,retval] BSTR *retStat
00628                                                 );
00630                 [id(43), helpstring("method SetLineInfo")]
00631                         HRESULT SetLineInfo(
00633                                 [in] BSTR lineName,
00637                                 [in] BSTR lineInfo,
00638                                 [out,retval] BSTR *retstat);
00639
00641                 [id(44), helpstring("method UpdateDatabaseData")]
00642                         HRESULT SetDatabaseData(
00645                                 [in] BSTR tableName,
00647                                 [in] BSTR selCrit,
00650                                 [in] BSTR data,
00652                                 [in] StoreDataOptions options,
00654                                 [in,out] VARIANT *numAffRec,
00655                                 [out,retval] BSTR *retStat
00656                                 );
00657
00659                 [id(45), helpstring("method GetDatabaseData")]
00660                         HRESULT GetDatabaseData(
00662                                 [in] BSTR sqlQuery,
00664                                 [in] long rowMax,
00668                                 [in,out] VARIANT *records,
00669                                 [out,retval] BSTR *retStat);
00671                 [id(46), helpstring("method GetDatabase")]
00672                         HRESULT GetDatabase([out, retval] ISysDbConn **db);
00674                 [id(47), helpstring("method GetSessionID")]
00675                         HRESULT GetSessionID([out,retval] BSTR *retV);
00678                 [id(48), helpstring("method GetCallStateEx")]
00679                         HRESULT GetCallStateEx
00680                                 (
00682                                 [in] BSTR callID,
00686                                 [in] BSTR options,
00690                                 [in,out] VARIANT *callAttributes,
00695                                 [out,retval] BSTR *retStat
00696                                 );
00702                 [id(49), helpstring("method SubscribeNotification")]
00703                         HRESULT SubscribeNotification
00704                                 (
00706                                 [in] BSTR NotifyType,
00708                                 [out,retval] BSTR *retStat
00709                                 );
00711                 [id(50), helpstring("method AgentLogon")]
00712                         HRESULT AgentLogon(
00713                                 [in] BSTR loginName,
00714                                 [in] BSTR password,
00722                                 [in,defaultvalue("")] BSTR options,
00724                                 [in,out] VARIANT *userID,
00730
00731                                 [out,retval] BSTR *retStat);
00732
00734                 [id(51), helpstring("method AgentLogoff")]
00735                         HRESULT AgentLogoff([out,retval] BSTR *retStat);
00736
00738                 [id(52), helpstring("method AgentCheckRight")]
00739                         HRESULT AgentCheckRight
00740                                 (
00747                                 [in] BSTR role,
00749                                 [in,out] VARIANT *enabled,
00750                                 [out,retval] BSTR *stat
00751                                 );
00757                 [id(53), helpstring("method AgentStoreStatus")]
00758                         HRESULT AgentStoreStatus(
00764                                 [in] BSTR actionCode,
00766                                 [in] BSTR actionSubcode,
00767                                 [out,retval] BSTR *retStat);
00768
00769
00771                 [id(54), helpstring("method AgentGetGroups")]
00772                         HRESULT AgentGetGroups(
00773
00778                                 [in] BOOL enrol,
00781                                 [in,out] VARIANT *groupInfo,
00783                                 [out,retval] BSTR *retStat
00784                                 );
00785
00786
00788                 [id(55), helpstring("method AgentAssignGroup")]
00789                         HRESULT AgentAssignGroup(
00791                                 [in] BSTR groupID,
00792
00802                                 [in,defaultvalue("")] BSTR options,
00804                                 [out, retval] BSTR *retStat
00805                                 );
00806
00807
00809                 [id(56), helpstring("method ExecuteSQL")]
00810                         HRESULT ExecuteSQL(
00812                                 [in] BSTR sqlCommand,
00814                                 [in]  BSTR options,
00816                                 [in]  BSTR lockKey,
00818                                 [in,out]  VARIANT *numRec,
00820                                 [out,retval]  BSTR *retStat
00821                                 );
00822
00824                 [id(57), helpstring("method AgentGetRequisiteApps")]
00825                         HRESULT AgentGetRequisiteApps
00826                                 (
00828                                 [in,defaultvalue("")] BSTR options,
00831                                 [in,out] VARIANT *appList,
00833                                 [out,retval] BSTR *retStat
00834                                 );
00835
00837                 [id(58), helpstring("method AgentGetApplicationParams")]
00838                         HRESULT AgentGetApplicationParams
00839                                 (
00841                                 [in] BSTR appName,
00849                                 [in,out] VARIANT *appData,
00851                                 [out,retval] BSTR *retStat
00852                                 );
00853                 [id(59), helpstring("method GetCXMessageEx")]
00854                         HRESULT GetCXMessageEx
00855                                 (
00862                                 [in] long waitTimeout,
00864                                 [in] long flags,
00866                                 [in,defaultvalue("")] BSTR selection,
00869
00870                                 [in,out] VARIANT *msgAttributes,
00871                                 [in,out] VARIANT *msgData,
00872                                 [out,retval] BSTR *retStat
00873                                 );
00874
00876                 [id(60), helpstring("method GetDeviceCaps")]
00877                         HRESULT GetDeviceCaps
00878                                 (
00880                                 [in] BSTR deviceType
00882                                 ,[in] BSTR deviceName
00884                                 ,[in,defaultvalue("")] BSTR caps
00886                                 ,[in,out] VARIANT *capsList
00888                                 ,[out,retval] BSTR *retStat
00889                                 );
00890
00900
00901                 [id(61), helpstring("method OperateCallVX")]
00902                         HRESULT OperateCallVX
00903                                 (
00905                                 [in] BSTR operateParams,
00907                                 [in] BSTR vxAppName,
00909                                 [in] BSTR vxAction,
00911                                 [in] BSTR vxAppParams,
00916                                 [in,defaultvalue("")] BSTR options,
00918                                 [out,retval] BSTR *retStat
00919                                 );
00920
00921
00922
00925                 [id(62), helpstring("method OperateCallEx")]
00926                         HRESULT OperateCallEx
00927                                 (
00929                                 [in] BSTR parameters,
00931                                 [in,defaultvalue("")] BSTR queueName,
00933                                 [in,out,defaultvalue("")] VARIANT *requestID,
00935                                 [out,retval] BSTR *retStat
00936                                 );
00937
00940
00941                 [id(63), helpstring("method RegisterAsOperateChainMember")]
00942                         HRESULT RegisterAsOperateChainMember
00943                                 (
00955
00956                                 [in] BSTR msgFilterFormulas,
00958                                 [out,retval] BSTR *retStat
00959                                 );
00960
00961                 [id(64), helpstring("method AgentStoreStatusEx")]
00962                         HRESULT AgentStoreStatusEx(
00968                                 [in] BSTR actionCode,
00970                                 [in] BSTR actionSubcode,
00972                                 [in,defaultvalue("")] BSTR agentSession,
00973                                 [out,retval] BSTR *retStat);
00974         };
00975
00977
00981         [
00982                 object,
00983                 uuid(C014D5CB-8AE8-4C11-8B76-AA641171FFFD),
00984                 dual,
00985                 helpstring("ICXServer Interface"),
00986                 pointer_default(unique)
00987         ]
00988         interface ICXServer : IDispatch
00989         {
00991                 [id(1), helpstring("Je volán ihned po vytvoření")]
00992                         HRESULT Init();
00994                 [id(2), helpstring("method Done")]
00995                         HRESULT Done();
00997                 [id(3), helpstring("method MakeNewSession")]
00998                         HRESULT MakeNewSession(
01000                                 [in,defaultvalue("")] BSTR options,
01002                                 [out,retval] ICXSession** session
01003                                 );
01006                 [id(4), helpstring("method GetSession")]
01007                         HRESULT GetSession(
01008                                 [in] BSTR sessID
01009                                 ,[out,retval] ICXSession** session);
01010         };
01011         [
01012                 object,
01013                 uuid(3FCEF8DF-9818-45DE-A526-88E077D32120),
01014                 dual,
01015                 helpstring("ICXSessionProxy Interface"),
01016                 pointer_default(unique)
01017         ]
01018         interface ICXSessionProxy : IDispatch
01019         {
01020         };
01021         [
01022                 object,
01023                 uuid(40EF080C-B539-4FB4-B580-193CD3C8A369),
01024                 dual,
01025                 helpstring("IHelper Interface"),
01026                 pointer_default(unique)
01027         ]
01028         interface IHelper : IDispatch
01029         {
01030                 [id(1), helpstring("method WrapCXSession")] HRESULT WrapCXSession([in] ICXSession *base, [in, defaultvalue("")] BSTR options, [out,retval] ICXSession **wrapped);
01031                 [id(2), helpstring("method GetCXServerRPCproxy")] HRESULT GetCXServerRPCproxy([in] BSTR serverURL, [in] BSTR options, [in,out] VARIANT *cxserver, [out,retval] BSTR *retStat);
01032                 [id(3), helpstring("method GetCSS_RPCproxy")] HRESULT GetCSS_RPCproxy([in] BSTR serverURL, [in] BSTR options, [in,out] VARIANT *cxserver, [out,retval] BSTR *retStat);
01033         };
01034
01035         [
01036                 object,
01037                 uuid(A4D4C59F-6E35-4319-8848-830C4D6B248C),
01038                 helpstring("ICXrpcPROXY Interface"),
01039                 pointer_default(unique)
01040         ]
01041         interface ICXrpcPROXY : IUnknown
01042         {
01043                 [helpstring("method SetRpcDispatch")] HRESULT SetRpcDispatch([in] IDispatch *rpc);
01044         };
01045
01046         [
01047                 object,
01048                 uuid(08F88E17-4DF3-491D-B7E6-99985177EB31),
01049                 helpstring("ISessDSMQProxy Interface"),
01050                 pointer_default(unique)
01051         ]
01052         interface ISessDSMQProxy : IUnknown
01053         {
01054                 [helpstring("method Init")] HRESULT Init(IDSMQStorage *stg, ICXSession *sess);
01055         };
01056
01057
01058 [
01059         uuid(923A0483-F0DA-43D2-8460-7DE77C784F6C),
01060         version(1.0),
01061         helpstring("CXServer2 1.0 Type Library")
01062 ]
01063 library CXSERVER2Lib
01064 {
01065         importlib("stdole32.tlb");
01066         importlib("stdole2.tlb");
01067
01068
01069         [
01070                 uuid(7F5CC6EF-4047-45F7-B669-E37E59067C96),
01071                 helpstring("CXServer Class")
01072         ]
01073         coclass CXServer
01074         {
01075                 [default] interface ICXServer;
01076         };
01077         [
01078                 uuid(550E97A4-AAC3-4624-BD8A-088497D4146B),
01079                 helpstring("CXSession Class")
01080         ]
01081         coclass CXSession
01082         {
01083                 [default] interface ICXSession;
01084         };
01085         [
01086                 uuid(927F86F4-0AA6-4001-8ACA-CBD1441A51E0),
01087                 helpstring("CXArchive Class")
01088         ]
01089         coclass CXArchive
01090         {
01091                 [default] interface ICXArchive;
01092         };
01093         [
01094                 uuid(7931BB49-E6D1-4B2B-BAF1-089AF6370C58),
01095                 helpstring("CXRouter Class")
01096         ]
01097         coclass CXRouter
01098         {
01099                 [default] interface ICXRouter;
01100         };
01101         [
01102                 uuid(7D61E277-1BBB-45BE-9CAE-419F767E8BBC),
01103                 helpstring("SysDbConn Class"),
01104                 hidden
01105         ]
01106         coclass SysDbConn
01107         {
01108                 [default] interface ISysDbConn;
01109         };
01110         [
01111                 uuid(5304066C-7230-42A7-9A41-287246852016),
01112                 helpstring("CXSessionProxy Class")
01113         ]
01114         coclass CXSessionProxy
01115         {
01116                 [default] interface ICXSessionProxy;
01117         };
01118         [
01119                 uuid(1A76A1E1-C8B1-43D1-A8AF-21FC7AB42A09),
01120                 helpstring("Helper Class")
01121         ]
01122         coclass Helper
01123         {
01124                 [default] interface IHelper;
01125         };
01126
01127         [
01128                 uuid(B110896E-BD68-4734-B05A-8C51A9022BA8),
01129                 helpstring("CXServerRPCproxy Class"),
01130                 noncreatable
01131         ]
01132         coclass CXServerRPCproxy
01133         {
01134                 [default] interface ICXServer;
01135                 interface ICXrpcPROXY;
01136         };
01137
01138         [
01139                 uuid(18EB7DC2-D36E-4769-A430-F41571BC1B2C),
01140                 helpstring("CXSessionRPCproxy Class"),
01141                 noncreatable
01142         ]
01143         coclass CXSessionRPCproxy
01144         {
01145                 [default] interface ICXSession;
01146                 interface ICXrpcPROXY;
01147         };
01148
01149         [
01150                 uuid(F9C3E7B3-0B11-443F-A148-68BF1069E0E5),
01151                 noncreatable,
01152                 helpstring("SysDbConnRPCProxy Class")
01153         ]
01154         coclass SysDbConnRPCProxy
01155         {
01156                 [default] interface ISysDbConn;
01157                 interface ICXrpcPROXY;
01158         };
01159
01160         [
01161                 uuid(1D4A8D00-BA04-4727-A7A4-8CAA84BFB102),
01162                 helpstring("CXRouterRPCProxy Class")
01163         ]
01164         coclass CXRouterRPCProxy
01165         {
01166                 [default] interface ICXRouter;
01167                 interface ICXrpcPROXY;
01168         };
01169
01170         [
01171                 uuid(7F3EC53F-E524-483C-9F91-1A87B05D00B3),
01172                 noncreatable,
01173                 helpstring("CXArchiveRPCproxy Class")
01174         ]
01175         coclass CXArchiveRPCproxy
01176         {
01177                 [default] interface ICXArchive;
01178                 interface ICXrpcPROXY;
01179         };
01180
01181         [
01182                 uuid(9DFE58D7-CAF1-4642-A716-68ED346A2527),
01183                 noncreatable,
01184                 helpstring("StorageRPCproxy Class")
01185         ]
01186         coclass StorageRPCproxy
01187         {
01188                 [default] interface IDSMQStorage;
01189                 interface ICXrpcPROXY;
01190         };
01191
01192         [
01193                 uuid(4A425382-2184-4EB4-B2E3-A8816D5E9D8F),
01194                 noncreatable,
01195                 helpstring("CoreRPCproxy Class")
01196         ]
01197         coclass CoreRPCproxy
01198         {
01199                 [default] interface ICore;
01200                 interface ICXrpcPROXY;
01201         };
01202         [
01203                 uuid(39F52F85-7B22-49A5-BE23-4F3099D83C99),
01204                 helpstring("SessDSMQProxy Class")
01205         ]
01206         coclass SessDSMQProxy
01207         {
01208                 [default] interface IDSMQStorage;
01209                 interface ISessDSMQProxy;
01210         };
01211 };


Aplikační rozhraní systému CallChange: Seznam členů třídy

ICXSession Seznam členů třídy

Zde naleznete úplný seznam členů třídy ICXSession, včetně všech zděděných členů.

AgentAssignGroup([in] BSTR groupID,[in, defaultvalue("")] BSTR options,[out, retval] BSTR *retStat) | ICXSession
AgentCheckRight([in] BSTR role,[in, out] VARIANT *enabled,[out, retval] BSTR *stat) | ICXSession
AgentGetApplicationParams([in] BSTR appName,[in, out] VARIANT *appData,[out, retval] BSTR *retStat) | ICXSession
AgentGetGroups([in] BOOL enrol,[in, out] VARIANT *groupInfo,[out, retval] BSTR *retStat) | ICXSession
AgentGetRequisiteApps([in, defaultvalue("")] BSTR options,[in, out] VARIANT *appList,[out, retval] BSTR *retStat) | ICXSession
AgentLogoff([out, retval] BSTR *retStat) | ICXSession
AgentLogon([in] BSTR loginName,[in] BSTR password,[in, defaultvalue("")] BSTR options,[in, out] VARIANT *userID,[out, retval] BSTR *retStat) | ICXSession
AgentStoreStatus([in] BSTR actionCode,[in] BSTR actionSubcode,[out, retval] BSTR *retStat) | ICXSession
AgentStoreStatusEx([in] BSTR actionCode,[in] BSTR actionSubcode,[in, defaultvalue("")] BSTR agentSession,[out, retval] BSTR *retStat) | ICXSession
AllocID([in, defaultvalue("")] BSTR specChar,[out, retval] BSTR *newID) | ICXSession
CheckLicence([in] long licenceBit,[out, retval] BSTR *retStat) | ICXSession
ConnectLine([in] BSTR lineName,[out, retval] BSTR *retStat) | ICXSession
CreateNewCall([in] BSTR lineName,[in, out] VARIANT *callID,[out, retval] BSTR *retStat) | ICXSession
DisconnectLine([in] BSTR lineName,[out, retval] BSTR *retStat) | ICXSession
Done() | ICXSession
ExecuteSQL([in] BSTR sqlCommand,[in] BSTR options,[in] BSTR lockKey,[in, out] VARIANT *numRec,[out, retval] BSTR *retStat) | ICXSession
GetActualLineCalls([in] BSTR lineName,[in, out] VARIANT *callList,[out, retval] BSTR *retStat) | ICXSession
GetArchive([out, retval] ICXArchive **pVal) | ICXSession
GetCallEvents([in] BSTR callID,[in, out] VARIANT *eventList,[out, retval] BSTR *retStat) | ICXSession
GetCallState([in] BSTR callID,[in, out] VARIANT *callAttributes,[out, retval] BSTR *retStat) | ICXSession
GetCallStateEx([in] BSTR callID,[in] BSTR options,[in, out] VARIANT *callAttributes,[out, retval] BSTR *retStat) | ICXSession
GetConfigItems([in] BSTR itemNameList,[in, out] VARIANT *resultList,[out, retval] BSTR *retStat) | ICXSession
GetCXMessage([in] long waitTimeout,[in, out] VARIANT *msgAttributes,[in, out] VARIANT *msgData,[out, retval] BSTR *retStat) | ICXSession
GetCXMessageEx([in] long waitTimeout,[in] long flags,[in, defaultvalue("")] BSTR selection,[in, out] VARIANT *msgAttributes,[in, out] VARIANT *msgData,[out, retval] BSTR *retStat) | ICXSession
GetDatabase([out, retval] ISysDbConn **db) | ICXSession
GetDatabaseData([in] BSTR sqlQuery,[in] long rowMax,[in, out] VARIANT *records,[out, retval] BSTR *retStat) | ICXSession
GetDeviceCaps([in] BSTR deviceType,[in] BSTR deviceName,[in, defaultvalue("")] BSTR caps,[in, out] VARIANT *capsList,[out, retval] BSTR *retStat) | ICXSession
GetLineFeature([in] BSTR lineName,[in] BSTR feature,[out, retval] BSTR *retStat) | ICXSession
GetLineInfo([in] BSTR lineName,[in, out] VARIANT *lineInfo,[out, retval] BSTR *retStat) | ICXSession
GetLineList([out, retval] BSTR *lineList) | ICXSession
GetLocalLines([out, retval] BSTR *localLines) | ICXSession
GetRouter([out, retval] ICXRouter **pVal) | ICXSession
GetServerTime([out, retval] VARIANT *_time) | ICXSession
GetServerTimeString([out, retval] BSTR *time) | ICXSession
GetSessionAttributes([in, out] VARIANT *attributes,[in, defaultvalue("")] BSTR sessionID,[out, retval] BSTR *retStat) | ICXSession
GetSessionID([out, retval] BSTR *retV) | ICXSession
GetStorage([out, retval] IDSMQStorage **pVal) | ICXSession
Init([out, retval] BSTR *sessionID) | ICXSession
Log([in] long level,[in] BSTR category,[in] BSTR value,[in] BSTR text) | ICXSession
LOG_DATA hodnota výčtu | ICXSession
LOG_DEBUG hodnota výčtu | ICXSession
LOG_ERROR hodnota výčtu | ICXSession
LOG_FETCH hodnota výčtu | ICXSession
LOG_INFO hodnota výčtu | ICXSession
LOG_TRACE hodnota výčtu | ICXSession
LOG_UNIVERSE_END hodnota výčtu | ICXSession
LOG_WARNING hodnota výčtu | ICXSession
LoginService([in] BSTR serviceName,[in] BSTR machineName,[out, retval] BSTR *retStat) | ICXSession
LoginUser([in] BSTR userName,[in] BSTR machineName,[out, retval] BSTR *retStat) | ICXSession
LogLevel jméno výčtu | ICXSession
OperateCall([in] BSTR parameters,[out, retval] BSTR *retStat) | ICXSession
OperateCallEx([in] BSTR parameters,[in, defaultvalue("")] BSTR queueName,[in, out, defaultvalue("")] VARIANT *requestID,[out, retval] BSTR *retStat) | ICXSession
OperateCallVX([in] BSTR operateParams,[in] BSTR vxAppName,[in] BSTR vxAction,[in] BSTR vxAppParams,[in, defaultvalue("")] BSTR options,[out, retval] BSTR *retStat) | ICXSession
PostCXMessage([in] BSTR messageType,[in] BSTR recipients,[in] VARIANT msgData,[in, defaultvalue("")] BSTR options,[out, retval] BSTR *retStat) | ICXSession
RegisterAsOperateChainMember([in] BSTR msgFilterFormulas,[out, retval] BSTR *retStat) | ICXSession
SetCallState([in] BSTR callID,[in] BSTR attributes,[in, defaultvalue("")] BSTR options,[out, retval] BSTR *retStat) | ICXSession
SetDatabaseData([in] BSTR tableName,[in] BSTR selCrit,[in] BSTR data,[in] StoreDataOptions options,[in, out] VARIANT *numAffRec,[out, retval] BSTR *retStat) | ICXSession
SetLineFeature([in] BSTR lineName,[in] BSTR operation,[out, retval] BSTR *retStat) | ICXSession
SetLineInfo([in] BSTR lineName,[in] BSTR lineInfo,[out, retval] BSTR *retstat) | ICXSession
SetSessionAttributes([in] BSTR attributes,[in, defaultvalue("")] BSTR sessionID,[out, retval] BSTR *retStat) | ICXSession
SimpleLock([in] BSTR lockName,[in] long waitTimeout,[in] long lockTimeout,[in, out] VARIANT *retStat,[out, retval] BSTR *lockHandle) | ICXSession
SimpleUnlock([in] BSTR lockHandle,[out, retval] BSTR *retStat) | ICXSession
StoreEvent([in] BSTR obj_id,[in] BSTR ev_type,[in] BSTR ev_val,[in] BSTR ev_descr,[out, retval] BSTR *retStat) | ICXSession
SubscribeNotification([in] BSTR NotifyType,[out, retval] BSTR *retStat) | ICXSession


Aplikační rozhraní systému CallChange: Seznam členů třídy

ICXGlueLine Seznam členů třídy

Zde naleznete úplný seznam členů třídy ICXGlueLine, včetně všech zděděných členů.

CreateNewCall([in] BSTR lineName,[in, out] VARIANT *id,[out, retval] BSTR *retStat) | ICXGlueLine
GetCfgItem([in] BSTR itemName,[out, retval] VARIANT *itemValue) | ICXGlueLine
GetLineFromStand([in] BSTR stand,[out, retval] BSTR *line) | ICXGlueLine
GetLinesConfig([in, out] VARIANT *linesCfg,[out, retval] BSTR *retStat) | ICXGlueLine
GetOperationRequest([in] long timeout,[in, out] VARIANT *line,[in, out] VARIANT *action,[in, out] VARIANT *attrs,[in, out] VARIANT *data,[out, retval] BSTR *retStat) | ICXGlueLine
GetSession([in, out] VARIANT *session,[out, retval] BSTR *retStat) | ICXGlueLine
GetStandFromLine([in] BSTR line,[out, retval] BSTR *stand) | ICXGlueLine
Init([in] BSTR instanceNumber,[out, retval] BSTR *retStat) | ICXGlueLine
RegisterLine([in] BSTR lineName,[in] BSTR enabled,[in] BSTR attStat,[out, retval] BSTR *retStat) | ICXGlueLine
SendLineEvent([in] BSTR lineName,[in] BSTR driverCallid,[in] BSTR mtype,[in] BSTR params,[out, retval] BSTR *retStat) | ICXGlueLine


Aplikační rozhraní systému CallChange: Seznam členů třídy

ICXArchive Seznam členů třídy

Zde naleznete úplný seznam členů třídy ICXArchive, včetně všech zděděných členů.

GetArchiveCalls([in] BSTR lines,[in] BSTR extraItemList,[in] BSTR selection,[in] BSTR orderBy,[in] long rowMax,[in, out] VARIANT *records,[out, retval] BSTR *retStat) | ICXArchive
GetCallEvents([in] BSTR callID,[in, out] VARIANT *records,[out, retval] BSTR *retstat) | ICXArchive
StoreArchiveCallAttributes([in] BSTR callID,[in] BSTR attributeList,[out, retval] BSTR *retStat) | ICXArchive


Aplikační rozhraní systému CallChange: Seznam členů třídy

_Ilevel1Events Seznam členů třídy

Zde naleznete úplný seznam členů třídy _Ilevel1Events, včetně všech zděděných členů.

Busy([in] BSTR CallID) | _Ilevel1Events
CallCreated(BSTR CallID, BSTR LineID, BSTR Number, BSTR Cause) | _Ilevel1Events
CallInfo(BSTR CallID, BSTR LocalNumber, BSTR RemoteNumber, BSTR Direction, BSTR State, BSTR OtherParams) | _Ilevel1Events
Connected([in] BSTR CallID) | _Ilevel1Events
Disabled() _Ilevel1Events
Enabled() _Ilevel1Events
EndCall([in] BSTR CallID) | _Ilevel1Events
InComingCall([in] BSTR CallID) | _Ilevel1Events
LineError([in] BSTR CallID,[in] BSTR ErrCode,[in] BSTR OtherParams) | _Ilevel1Events
Notify([in] BSTR msgType,[in] BSTR msgData) | _Ilevel1Events
OutGoingCall([in] BSTR CallID) | _Ilevel1Events
PhoneUp([in] BSTR CallID) | _Ilevel1Events
Ringing([in] BSTR CallID) | _Ilevel1Events
ServerConnection([in] BSTR Connected) | _Ilevel1Events


Aplikační rozhraní systému CallChange: Seznam členů třídy

IPhNormalizer Seznam členů třídy

Zde naleznete úplný seznam členů třídy IPhNormalizer, včetně všech zděděných členů.

AreaCode([out, retval] BSTR *pVal) (definován v IPhNormalizer) | IPhNormalizer
AreaCode([in] BSTR newVal) (definován v IPhNormalizer) | IPhNormalizer
AreaCodeEscape([out, retval] BSTR *pVal) (definován v IPhNormalizer) | IPhNormalizer
AreaCodeEscape([in] BSTR newVal) (definován v IPhNormalizer) | IPhNormalizer
Format([in] BSTR num,[in] long options,[out, retval] BSTR *result) | IPhNormalizer
Init([in] BSTR paramList) | IPhNormalizer
InitFromRegistry([in] BSTR regKeyName,[out, retval] BSTR *retStat) | IPhNormalizer
InternationalAccessCode([out, retval] BSTR *pVal) (definován v IPhNormalizer) | IPhNormalizer
InternationalAccessCode([in] BSTR newVal) (definován v IPhNormalizer) | IPhNormalizer
IsNumberInternal([in] BSTR num,[out, retval] VARIANT_BOOL *result) | IPhNormalizer
LocalCountryCode([out, retval] BSTR *pVal) (definován v IPhNormalizer) | IPhNormalizer
LocalCountryCode([in] BSTR newVal) (definován v IPhNormalizer) | IPhNormalizer
MakeVariations([in] BSTR phoneNum,[in] long options,[out, retval] BSTR *result) | IPhNormalizer
Normalize([in] BSTR phoneNum,[in] long options,[out, retval] BSTR *result) | IPhNormalizer
NORMALIZER_FORMAT_DIAL hodnota výčtu | IPhNormalizer
NORMALIZER_FORMAT_SHORTEST hodnota výčtu | IPhNormalizer
NORMALIZER_INTERNAL_SHORT hodnota výčtu | IPhNormalizer
NORMALIZER_NUMBER_FROM_PBX hodnota výčtu | IPhNormalizer
PBXCommonPart([out, retval] BSTR *pVal) (definován v IPhNormalizer) | IPhNormalizer
PBXCommonPart([in] BSTR newVal) (definován v IPhNormalizer) | IPhNormalizer
PBXdigits([out, retval] long *pVal) (definován v IPhNormalizer) | IPhNormalizer
PBXdigits([in] long newVal) (definován v IPhNormalizer) | IPhNormalizer
PBXIncommingPrefix([out, retval] BSTR *pVal) (definován v IPhNormalizer) | IPhNormalizer
PBXIncommingPrefix([in] BSTR newVal) (definován v IPhNormalizer) | IPhNormalizer
PBXOutsideAccessCode([out, retval] BSTR *pVal) (definován v IPhNormalizer) | IPhNormalizer
PBXOutsideAccessCode([in] BSTR newVal) (definován v IPhNormalizer) | IPhNormalizer
PhoneNormalizerOptions jméno výčtu | IPhNormalizer
TrunkWildcard([out, retval] BSTR *pVal) (definován v IPhNormalizer) | IPhNormalizer
TrunkWildcard([in] BSTR newVal) (definován v IPhNormalizer) | IPhNormalizer


Aplikační rozhraní systému CallChange: Zdrojový soubor DSAppActivator.idl

DSAppActivator.idl

00001 // DSAppActivator.idl : IDL source for DSAppActivator.dll
00002 //
00003
00004 // This file will be processed by the MIDL tool to
00005 // produce the type library (DSAppActivator.tlb) and marshalling code.
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00010         [
00011                 object,
00012                 uuid(AC818917-C962-44DA-9289-8D6A54CC6D82),
00013                 dual,
00014                 helpstring("IAppActivator Interface"),
00015                 pointer_default(unique)
00016         ]
00017         interface IAppActivator : IDispatch
00018         {
00020                 [id(1), helpstring("method Activate")]
00021                         HRESULT Activate(
00023                                 [in] BSTR parameters,
00025                                 [in] BSTR envVariables,
00026                                 [out,retval] BSTR *retStat);
00027
00029                 [id(2), helpstring("method Notify")]
00030                         HRESULT Notify(
00032                                 [in] BSTR event,
00034                                 [in] VARIANT params,
00036                                 [out,retval] BSTR *retStat
00037                                 );
00038
00039         };
00040         [
00041                 object,
00042                 uuid(AF46DD44-A7A3-4655-B79E-B537C5014737),
00043                 dual,
00044                 helpstring("IScriptExecutor Interface"),
00045                 pointer_default(unique)
00046         ]
00047         interface IScriptExecutor : IDispatch
00048         {
00049                 [id(1), helpstring("method Execute")] HRESULT Execute([in] BSTR code,[in,defaultvalue("")] BSTR options, [out,retval] BSTR *result);
00050                 [id(2), helpstring("method CallMethod")] HRESULT CallMethod([in] BSTR methodName,[in,out] VARIANT *params,[in,out] VARIANT *retV ,[out,retval] BSTR *retStat);
00051                 [id(3), helpstring("method RegisterGlobalObject")] HRESULT RegisterGlobalObject([in] BSTR name, [in] IDispatch *obj);
00052         };
00053
00054 [
00055         uuid(B7E981B2-589F-429C-AF3F-A5D4769DA88E),
00056         version(1.0),
00057         helpstring("DSAppActivator 1.0 Type Library")
00058 ]
00059 library DSAPPACTIVATORLib
00060 {
00061         importlib("stdole32.tlb");
00062         importlib("stdole2.tlb");
00063
00064         [
00065                 uuid(DECEBBA0-FCAC-4C5C-99EF-473191279317),
00066                 helpstring("AppActivator Class")
00067         ]
00068         coclass AppActivator
00069         {
00070                 [default] interface IAppActivator;
00071         };
00072         [
00073                 uuid(190BF073-9CC5-47BF-992A-AC2D6440D3F9),
00074                 helpstring("ScriptExecutor Class")
00075         ]
00076         coclass ScriptExecutor
00077         {
00078                 [default] interface IScriptExecutor;
00079         };
00080 };


Aplikační rozhraní systému CallChange: Seznam členů třídy

IDSVariantCol Seznam členů třídy

Zde naleznete úplný seznam členů třídy IDSVariantCol, včetně všech zděděných členů.

_NewEnum([out, retval] IUnknown **pVal) (definován v IDSVariantCol) | IDSVariantCol
Add([in] BSTR valueName,[in] VARIANT val,[out, retval] long *idx) (definován v IDSVariantCol) | IDSVariantCol
AddFromString([in]BSTR String,[in, defaultvalue("")] BSTR Delimiter,[out, retval] long *idx) (definován v IDSVariantCol) | IDSVariantCol
AddParamList([in] BSTR String) (definován v IDSVariantCol) | IDSVariantCol
AsParamList([out, retval] BSTR *pVal) (definován v IDSVariantCol) | IDSVariantCol
AsString([in, defaultvalue("")] BSTR Delimiter,[out, retval] BSTR *pVal) (definován v IDSVariantCol) | IDSVariantCol
AsString([in, defaultvalue("")] BSTR Delimiter,[in] BSTR newVal) (definován v IDSVariantCol) | IDSVariantCol
AutoAdd([out, retval] BOOL *pVal) (definován v IDSVariantCol) | IDSVariantCol
AutoAdd([in] BOOL newVal) (definován v IDSVariantCol) | IDSVariantCol
Clear() (definován v IDSVariantCol) | IDSVariantCol
Count([out, retval] long *pVal) (definován v IDSVariantCol) | IDSVariantCol
Count([in] long size) (definován v IDSVariantCol) | IDSVariantCol
CreateNew([out, retval] IDSVariantCol **retVal) (definován v IDSVariantCol) | IDSVariantCol
Delete([in] VARIANT Index,[out, retval] long *cnt) (definován v IDSVariantCol) | IDSVariantCol
Find([in] BSTR Key,[out, retval] long *idx) (definován v IDSVariantCol) | IDSVariantCol
Item([in] VARIANT Index,[out, retval] VARIANT *val) (definován v IDSVariantCol) | IDSVariantCol
Item([in] VARIANT Index,[in] VARIANT val) (definován v IDSVariantCol) | IDSVariantCol
Key([in] long Idx,[out, retval] BSTR *Key) (definován v IDSVariantCol) | IDSVariantCol
ReadVXIni([in] BSTR iniFile,[out, retval] BOOL *retVal) (definován v IDSVariantCol) | IDSVariantCol
Sort([in, defaultvalue(0)] BOOL onValue) (definován v IDSVariantCol) | IDSVariantCol
uniq([out, retval] BOOL *pVal) (definován v IDSVariantCol) | IDSVariantCol
uniq([in] BOOL newVal) (definován v IDSVariantCol) | IDSVariantCol
WriteVXIni([in] BSTR iniFile,[out, retval] BOOL *retVal) (definován v IDSVariantCol) | IDSVariantCol


Aplikační rozhraní systému CallChange: Seznam členů třídy

IFxFile Seznam členů třídy

Zde naleznete úplný seznam členů třídy IFxFile, včetně všech zděděných členů.

Close() (definován v IFxFile) | IFxFile
Flush() (definován v IFxFile) | IFxFile
fscanf([in] BSTR format,[out, retval] BSTR *str) (definován v IFxFile) | IFxFile
Open([in] BSTR filename,[in] BSTR flags) (definován v IFxFile) | IFxFile
ReadBase64([out, retval] BSTR *dataEncoded) (definován v IFxFile) | IFxFile
Write([in]BSTR str,[out, retval] int *cnt) (definován v IFxFile) | IFxFile


Aplikační rozhraní systému CallChange: Seznam členů třídy

_ILevel2CCEvents Seznam členů třídy

Zde naleznete úplný seznam členů třídy _ILevel2CCEvents, včetně všech zděděných členů.

ActivateOnCall([in] BSTR LineName,[in] BSTR callid,[in] BSTR cccall,[in] BSTR Params) | _ILevel2CCEvents
OnCall([in] BSTR LineName,[in] BSTR callid,[in] BSTR cccall,[in] BSTR Params) | _ILevel2CCEvents
OnDial([in] BSTR LineName) | _ILevel2CCEvents
OnMessage([in] BSTR LineName,[in] BSTR callid,[in] BSTR cccall,[in] BSTR MessageType,[in] BSTR Params) | _ILevel2CCEvents


Aplikační rozhraní systému CallChange: Seznam členů třídy

ISMngr Seznam členů třídy

Zde naleznete úplný seznam členů třídy ISMngr, včetně všech zděděných členů.

GetTaskStatus([in] long taskID,[in] BSTR cmdLine,[out, retval] TaskStatus *status) | ISMngr
QueryLicence([in] long cls,[in] long ProcessID,[in] long instNum,[out, retval] BOOL *retVal) | ISMngr
RunCmd([in] BSTR CmdLine,[in, defaultvalue(0)] BSTR WorkDir,[in, defaultvalue(0)] long StopTimeout,[out, retval] BOOL *status) | ISMngr
StopAll([out, retval] BOOL *result) | ISMngr
StopTaskByID([in] long taskID,[out, retval] BOOL *result) | ISMngr
StopTaskByName([in] BSTR taskName,[out, retval] BOOL *status) (definován v ISMngr) | ISMngr